import grafana-pcp-3.0.1-1.el8
This commit is contained in:
parent
1ef4fdb829
commit
396d010b26
6
.gitignore
vendored
6
.gitignore
vendored
@ -1,3 +1,3 @@
|
||||
SOURCES/grafana-pcp-3.0.0.tar.gz
|
||||
SOURCES/grafana-pcp-vendor-3.0.0.tar.xz
|
||||
SOURCES/grafana-pcp-webpack-3.0.0.tar.gz
|
||||
SOURCES/grafana-pcp-3.0.1.tar.gz
|
||||
SOURCES/grafana-pcp-vendor-3.0.1.tar.xz
|
||||
SOURCES/grafana-pcp-webpack-3.0.1.tar.gz
|
||||
|
@ -1,3 +1,3 @@
|
||||
c0f6c30248360c48f13b81632646f4c0f8ce8c93 SOURCES/grafana-pcp-3.0.0.tar.gz
|
||||
9aca560138ce650a9517c012211eb2fec40ade34 SOURCES/grafana-pcp-vendor-3.0.0.tar.xz
|
||||
7c8ded839342abcc9bf098c1987f35905502a751 SOURCES/grafana-pcp-webpack-3.0.0.tar.gz
|
||||
df45f63a697b6d473719c147d69792eb2e3377fd SOURCES/grafana-pcp-3.0.1.tar.gz
|
||||
188a679178e1c0b3bcba30babe4c964e95437011 SOURCES/grafana-pcp-vendor-3.0.1.tar.xz
|
||||
cba1f8f742bd8d63c7f2dd3b6b7674ac8c2fa925 SOURCES/grafana-pcp-webpack-3.0.1.tar.gz
|
||||
|
@ -1,13 +0,0 @@
|
||||
diff --git a/pkg/datasources/redis/datasource_test.go b/pkg/datasources/redis/datasource_test.go
|
||||
index d677825..1ff9fd7 100644
|
||||
--- a/pkg/datasources/redis/datasource_test.go
|
||||
+++ b/pkg/datasources/redis/datasource_test.go
|
||||
@@ -107,7 +107,7 @@ func TestDatasource(t *testing.T) {
|
||||
So(response.Responses["A"].Frames, ShouldHaveLength, 1)
|
||||
So(response.Responses["A"].Frames[0].Fields, ShouldHaveLength, 3)
|
||||
So(response.Responses["A"].Frames[0].Fields[0].Len(), ShouldEqual, 1) // it's a counter metric with two values
|
||||
- So(response.Responses["A"].Frames[0].Fields[0].At(0).(time.Time).UnixNano(), ShouldEqual, 1599320692309872128)
|
||||
+ So(response.Responses["A"].Frames[0].Fields[0].At(0).(time.Time).UnixNano(), ShouldEqual, int64(1599320692309872128))
|
||||
So(response.Responses["A"].Frames[0].Fields[1].Name, ShouldEqual, "disk.dev.read[nvme0n1]")
|
||||
So(*response.Responses["A"].Frames[0].Fields[1].At(0).(*float64), ShouldEqual, 200)
|
||||
So(response.Responses["A"].Frames[0].Fields[2].Name, ShouldEqual, "disk.dev.read[sda]")
|
@ -1,11 +1,3 @@
|
||||
%if 0%{?rhel}
|
||||
# emulate macros defined by the go-rpm-macros package
|
||||
# https://pagure.io/go-rpm-macros/blob/master/f/rpm/macros.d/macros.go-compilers-golang
|
||||
%define gobuild(o:) go build -buildmode pie -compiler gc -tags="rpm_crashtraceback ${BUILDTAGS:-}" -ldflags "${LDFLAGS:-}%{?currentgoldflags} -B 0x$(head -c20 /dev/urandom|od -An -tx1|tr -d ' \\n') -extldflags '%__global_ldflags %{?__golang_extldflags}'" -a -v -x %{?**};
|
||||
%define gotestextldflags %__global_ldflags %{?__golang_extldflags}
|
||||
%define gotest() GO111MODULE=off go test -buildmode pie -compiler gc -ldflags "${LDFLAGS:-}%{?currentgoldflags} -extldflags '%{gotestextldflags}'" %{?**};
|
||||
%endif
|
||||
|
||||
# https://bugzilla.redhat.com/show_bug.cgi?id=1752991
|
||||
# unfortunately the go_arches macro doesn't reflect that change yet
|
||||
ExcludeArch: i686
|
||||
@ -20,12 +12,21 @@ ExcludeArch: i686
|
||||
end
|
||||
end}
|
||||
|
||||
# Specify if the frontend and dashboards will be compiled as part of the build or
|
||||
# are attached as a webpack tarball (in case of an unsuitable nodejs or jsonnet version on the build system)
|
||||
# gobuild and gotest macros are defined in go-rpm-macros, which is not available on RHEL
|
||||
# definitions lifted from Fedora 34 podman.spec
|
||||
%if ! 0%{?gobuild:1}
|
||||
%define gobuild(o:) GO111MODULE=off go build -buildmode pie -compiler gc -tags="rpm_crashtraceback ${BUILDTAGS:-}" -ldflags "${LDFLAGS:-} -B 0x$(head -c20 /dev/urandom|od -An -tx1|tr -d ' \\n') -extldflags '-Wl,-z,relro -Wl,-z,now -specs=/usr/lib/rpm/redhat/redhat-hardened-ld '" -a -v -x %{?**};
|
||||
%endif
|
||||
%if ! 0%{?gotest:1}
|
||||
%define gotest() GO111MODULE=off go test -buildmode pie -compiler gc -ldflags "${LDFLAGS:-} -extldflags '-Wl,-z,relro -Wl,-z,now -specs=/usr/lib/rpm/redhat/redhat-hardened-ld '" %{?**};
|
||||
%endif
|
||||
|
||||
# Specify if the frontend and dashboards will be compiled as part of the build or are attached
|
||||
# as a webpack tarball (in case of an unsuitable nodejs or jsonnet version on the build system)
|
||||
%define compile_frontend 0
|
||||
|
||||
Name: grafana-pcp
|
||||
Version: 3.0.0
|
||||
Version: 3.0.1
|
||||
Release: 1%{?dist}
|
||||
Summary: Performance Co-Pilot Grafana Plugin
|
||||
License: ASL 2.0
|
||||
@ -40,13 +41,11 @@ Source2: grafana-pcp-webpack-%{version}.tar.gz
|
||||
Source3: Makefile
|
||||
Source4: list_bundled_nodejs_packages.py
|
||||
|
||||
Patch1: 001-fix-test-on-32bit.patch
|
||||
|
||||
# Intersection of go_arches and nodejs_arches
|
||||
ExclusiveArch: %{grafanapcp_arches}
|
||||
|
||||
BuildRequires: systemd-rpm-macros, golang, go-srpm-macros
|
||||
%if 0%{?fedora}
|
||||
%if 0%{?fedora} >= 31
|
||||
BuildRequires: go-rpm-macros
|
||||
%endif
|
||||
%if %{compile_frontend}
|
||||
@ -59,7 +58,7 @@ BuildRequires: nodejs >= 1:12, nodejs < 1:13, yarnpkg, golang-github-google-jso
|
||||
|
||||
%global install_dir %{_sharedstatedir}/grafana/plugins/performancecopilot-pcp-app
|
||||
|
||||
Requires: grafana >= 7.3.3
|
||||
Requires: grafana >= 7.3.6
|
||||
Suggests: pcp >= 5.2.2
|
||||
Suggests: redis >= 5.0.0
|
||||
Suggests: bpftrace >= 0.9.2
|
||||
@ -78,21 +77,21 @@ Obsoletes: pcp-webapp-vector <= 4.3.4
|
||||
Provides: bundled(golang(github.com/grafana/grafana-plugin-sdk-go)) = 0.79.0
|
||||
Provides: bundled(golang(github.com/smartystreets/goconvey)) = 1.6.4
|
||||
Provides: bundled(npm(@babel/plugin-transform-modules-commonjs)) = 7.12.1
|
||||
Provides: bundled(npm(@grafana/data)) = 7.3.3
|
||||
Provides: bundled(npm(@grafana/runtime)) = 7.3.3
|
||||
Provides: bundled(npm(@grafana/toolkit)) = 7.3.3
|
||||
Provides: bundled(npm(@grafana/ui)) = 7.3.3
|
||||
Provides: bundled(npm(@grafana/data)) = 7.3.6
|
||||
Provides: bundled(npm(@grafana/runtime)) = 7.3.6
|
||||
Provides: bundled(npm(@grafana/toolkit)) = 7.3.6
|
||||
Provides: bundled(npm(@grafana/ui)) = 7.3.6
|
||||
Provides: bundled(npm(@types/blueimp-md5)) = 2.7.0
|
||||
Provides: bundled(npm(@types/d3-selection)) = 1.4.3
|
||||
Provides: bundled(npm(@types/enzyme)) = 3.10.5
|
||||
Provides: bundled(npm(@types/enzyme-adapter-react-16)) = 1.0.6
|
||||
Provides: bundled(npm(@types/expect-puppeteer)) = 3.3.1
|
||||
Provides: bundled(npm(@types/jest)) = 24.0.13
|
||||
Provides: bundled(npm(@types/jest-environment-puppeteer)) = 4.4.0
|
||||
Provides: bundled(npm(@types/jest-environment-puppeteer)) = 4.4.1
|
||||
Provides: bundled(npm(@types/lodash)) = 4.14.165
|
||||
Provides: bundled(npm(@types/memoize-one)) = 5.1.2
|
||||
Provides: bundled(npm(@types/react-autosuggest)) = 9.3.14
|
||||
Provides: bundled(npm(@types/react-redux)) = 7.1.11
|
||||
Provides: bundled(npm(@types/react-redux)) = 7.1.12
|
||||
Provides: bundled(npm(@types/redux)) = 3.6.0
|
||||
Provides: bundled(npm(@types/redux-persist)) = 4.3.1
|
||||
Provides: bundled(npm(@types/redux-persist-transform-filter)) = 0.0.4
|
||||
@ -109,15 +108,15 @@ Provides: bundled(npm(jest)) = 25.5.4
|
||||
Provides: bundled(npm(jest-date-mock)) = 1.0.8
|
||||
Provides: bundled(npm(jest-puppeteer)) = 4.4.0
|
||||
Provides: bundled(npm(lodash)) = 4.17.19
|
||||
Provides: bundled(npm(loglevel)) = 1.7.0
|
||||
Provides: bundled(npm(loglevel)) = 1.7.1
|
||||
Provides: bundled(npm(loglevel-plugin-prefix)) = 0.8.4
|
||||
Provides: bundled(npm(memoize-one)) = 4.1.0
|
||||
Provides: bundled(npm(monaco-editor)) = 0.20.0
|
||||
Provides: bundled(npm(monaco-editor-webpack-plugin)) = 2.0.0
|
||||
Provides: bundled(npm(monaco-editor-webpack-plugin)) = 1.9.0
|
||||
Provides: bundled(npm(prettier)) = 1.19.1
|
||||
Provides: bundled(npm(prettier-plugin-organize-imports)) = 1.1.1
|
||||
Provides: bundled(npm(puppeteer)) = 5.5.0
|
||||
Provides: bundled(npm(react-autosuggest)) = 10.0.3
|
||||
Provides: bundled(npm(react-autosuggest)) = 10.0.4
|
||||
Provides: bundled(npm(react-monaco-editor)) = 0.36.0
|
||||
Provides: bundled(npm(react-redux)) = 7.2.2
|
||||
Provides: bundled(npm(react-use)) = 15.3.4
|
||||
@ -140,8 +139,6 @@ bpftrace scripts from pmdabpftrace(1), as well as several dashboards.
|
||||
%setup -q -T -D -b 2
|
||||
%endif
|
||||
|
||||
%patch1 -p1
|
||||
|
||||
# Set up Go build subdir and links
|
||||
mkdir -p %{_builddir}/src/github.com/performancecopilot
|
||||
ln -s %{_builddir}/%{name}-%{version} \
|
||||
@ -197,6 +194,9 @@ export GOPATH=%{_builddir}
|
||||
|
||||
|
||||
%changelog
|
||||
* Wed Dec 23 2020 Andreas Gerstmayr <agerstmayr@redhat.com> 3.0.1-1
|
||||
- update to 3.0.1 tagged upstream community sources, see CHANGELOG
|
||||
|
||||
* Thu Nov 26 2020 Andreas Gerstmayr <agerstmayr@redhat.com> 3.0.0-1
|
||||
- update to 3.0.0 tagged upstream community sources, see CHANGELOG
|
||||
- bundle golang dependencies and (optionally) node.js dependencies
|
||||
|
Loading…
Reference in New Issue
Block a user