Update to Firefox 28
This commit is contained in:
parent
40c26d1c07
commit
d0a850fb23
2
.gitignore
vendored
2
.gitignore
vendored
@ -94,3 +94,5 @@ firefox-3.6.4.source.tar.bz2
|
||||
/firefox-langpacks-27.0-20140203.tar.xz
|
||||
/firefox-27.0.1.source.tar.bz2
|
||||
/firefox-langpacks-27.0.1-20140224.tar.xz
|
||||
/firefox-28.0.source.tar.bz2
|
||||
/firefox-langpacks-28.0-20140318.tar.xz
|
||||
|
@ -1,15 +0,0 @@
|
||||
Patch from: Bill Nottingham <notting@redhat.com>
|
||||
|
||||
diff -up mozilla-release/browser/base/Makefile.in.fu mozilla-release/browser/base/Makefile.in
|
||||
--- mozilla-release/browser/base/Makefile.in.fu 2011-06-24 16:50:23.802042086 -0400
|
||||
+++ mozilla-release/browser/base/Makefile.in 2011-06-24 16:50:42.324042096 -0400
|
||||
@@ -62,7 +62,7 @@ EXTRA_JS_MODULES = \
|
||||
|
||||
include $(topsrcdir)/config/rules.mk
|
||||
|
||||
-PRE_RELEASE_SUFFIX := ""
|
||||
+PRE_RELEASE_SUFFIX :=
|
||||
|
||||
DEFINES += \
|
||||
-DMOZ_APP_VERSION=$(MOZ_APP_VERSION) \
|
||||
|
17
firefox.spec
17
firefox.spec
@ -85,14 +85,14 @@
|
||||
|
||||
Summary: Mozilla Firefox Web browser
|
||||
Name: firefox
|
||||
Version: 27.0.1
|
||||
Release: 2%{?pre_tag}%{?dist}
|
||||
Version: 28.0
|
||||
Release: 1%{?pre_tag}%{?dist}
|
||||
URL: http://www.mozilla.org/projects/firefox/
|
||||
License: MPLv1.1 or GPLv2+ or LGPLv2+
|
||||
Group: Applications/Internet
|
||||
Source0: ftp://ftp.mozilla.org/pub/firefox/releases/%{version}%{?pre_version}/source/firefox-%{version}%{?pre_version}.source.tar.bz2
|
||||
%if %{build_langpacks}
|
||||
Source1: firefox-langpacks-%{version}%{?pre_version}-20140224.tar.xz
|
||||
Source1: firefox-langpacks-%{version}%{?pre_version}-20140318.tar.xz
|
||||
%endif
|
||||
Source10: firefox-mozconfig
|
||||
Source11: firefox-mozconfig-branded
|
||||
@ -114,14 +114,10 @@ Patch19: xulrunner-24.0-s390-inlines.patch
|
||||
# Fedora specific patches
|
||||
# Unable to install addons from https pages
|
||||
Patch204: rhbz-966424.patch
|
||||
Patch214: firefox-5.0-asciidel.patch
|
||||
Patch215: firefox-15.0-enable-addons.patch
|
||||
Patch216: firefox-duckduckgo.patch
|
||||
|
||||
# Upstream patches
|
||||
Patch300: mozilla-837563.patch
|
||||
Patch301: mozilla-938730.patch
|
||||
Patch302: mozilla-885002.patch
|
||||
|
||||
%if %{official_branding}
|
||||
# Required by Mozilla Corporation
|
||||
@ -229,14 +225,10 @@ cd %{tarballdir}
|
||||
|
||||
# Fedora patches
|
||||
%patch204 -p1 -b .966424
|
||||
%patch214 -p1 -b .asciidel
|
||||
%patch215 -p2 -b .addons
|
||||
%patch216 -p1 -b .duckduckgo
|
||||
|
||||
# Upstream patches
|
||||
%patch300 -p1 -b .837563
|
||||
%patch301 -p1 -b .938730
|
||||
%patch302 -p1 -b .885002
|
||||
|
||||
%if %{official_branding}
|
||||
# Required by Mozilla Corporation
|
||||
@ -635,6 +627,9 @@ gtk-update-icon-cache %{_datadir}/icons/hicolor &>/dev/null || :
|
||||
#---------------------------------------------------------------------
|
||||
|
||||
%changelog
|
||||
* Tue Mar 18 2014 Martin Stransky <stransky@redhat.com> - 28.0-1
|
||||
- Update to 28.0
|
||||
|
||||
* Thu Mar 6 2014 Martin Stransky <stransky@redhat.com> - 27.0.1-2
|
||||
- Removed needless build patch
|
||||
|
||||
|
@ -1,144 +0,0 @@
|
||||
# HG changeset patch
|
||||
# User Matthew Gregan <kinetik@flim.org>
|
||||
# Date 1383172648 -46800
|
||||
# Thu Oct 31 11:37:28 2013 +1300
|
||||
# Node ID 2f6bd7da0756edaad53b601b18cf0c0e27f5f676
|
||||
# Parent 0f6219c6fb61f3f5e6775d269a6cf52305021024
|
||||
Bug 837563 - Enable libcubeb's PulseAudio backend. r=glandium
|
||||
|
||||
diff --git a/configure.in b/configure.in
|
||||
--- a/configure.in
|
||||
+++ b/configure.in
|
||||
@@ -5522,65 +5522,68 @@ fi
|
||||
if test -n "$MOZ_TREMOR"; then
|
||||
AC_DEFINE(MOZ_TREMOR)
|
||||
fi
|
||||
|
||||
if test -n "$MOZ_OPUS"; then
|
||||
AC_DEFINE(MOZ_OPUS)
|
||||
fi
|
||||
|
||||
-dnl ========================================================
|
||||
-dnl = Check alsa availability on Linux if using sydneyaudio
|
||||
-dnl ========================================================
|
||||
-
|
||||
-dnl If using sydneyaudio with Linux, ensure that the alsa library is available
|
||||
+dnl ====================================================
|
||||
+dnl = Check alsa availability on Linux if using libcubeb
|
||||
+dnl ====================================================
|
||||
+
|
||||
+dnl If using libcubeb with Linux, ensure that the alsa library is available
|
||||
if test -n "$MOZ_CUBEB" -a "$OS_TARGET" = "Linux"; then
|
||||
MOZ_ALSA=1
|
||||
fi
|
||||
|
||||
MOZ_ARG_ENABLE_BOOL(alsa,
|
||||
[ --enable-alsa Enable Alsa support (default on Linux)],
|
||||
-MOZ_ALSA=1,
|
||||
-MOZ_ALSA=)
|
||||
+ MOZ_ALSA=1,
|
||||
+ MOZ_ALSA=)
|
||||
|
||||
if test -n "$MOZ_ALSA"; then
|
||||
AC_DEFINE(MOZ_CUBEB)
|
||||
PKG_CHECK_MODULES(MOZ_ALSA, alsa, ,
|
||||
[echo "$MOZ_ALSA_PKG_ERRORS"
|
||||
AC_MSG_ERROR([Need alsa for Ogg, Wave or WebM decoding on Linux. Disable with --disable-ogg --disable-wave --disable-webm. (On Ubuntu, you might try installing the package libasound2-dev.)])])
|
||||
fi
|
||||
|
||||
AC_SUBST(MOZ_ALSA)
|
||||
AC_SUBST(MOZ_ALSA_CFLAGS)
|
||||
AC_SUBST(MOZ_ALSA_LIBS)
|
||||
|
||||
dnl ========================================================
|
||||
-dnl = Enable PulseAudio
|
||||
-dnl ========================================================
|
||||
-
|
||||
-MOZ_ARG_ENABLE_BOOL(pulseaudio,
|
||||
-[ --enable-pulseaudio Enable PulseAudio support (experimental)],
|
||||
-MOZ_PULSEAUDIO=1,
|
||||
-MOZ_PULSEAUDIO=)
|
||||
+dnl = Disable PulseAudio
|
||||
+dnl ========================================================
|
||||
+
|
||||
+dnl If using libcubeb with Linux, ensure that the PA library is available
|
||||
+if test -n "$MOZ_CUBEB" -a "$OS_TARGET" = "Linux" -a -z "$MOZ_B2G"; then
|
||||
+ MOZ_PULSEAUDIO=1
|
||||
+fi
|
||||
+
|
||||
+MOZ_ARG_DISABLE_BOOL(pulseaudio,
|
||||
+[ --disable-pulseaudio Disable PulseAudio support],
|
||||
+ MOZ_PULSEAUDIO=,
|
||||
+ MOZ_PULSEAUDIO=1)
|
||||
|
||||
if test -n "$MOZ_PULSEAUDIO"; then
|
||||
AC_DEFINE(MOZ_CUBEB)
|
||||
if test -z "$gonkdir"; then
|
||||
PKG_CHECK_MODULES(MOZ_PULSEAUDIO, libpulse, ,
|
||||
[echo "$MOZ_PULSEAUDIO_PKG_ERRORS"
|
||||
AC_MSG_ERROR([pulseaudio audio backend requires libpulse development package])])
|
||||
else
|
||||
MOZ_PULSEAUDIO_CFLAGS="-I$gonkdir/external/pulseaudio/pulseaudio/src"
|
||||
- MOZ_PULSEAUDIO_LIBS="-lpulse"
|
||||
fi
|
||||
fi
|
||||
|
||||
AC_SUBST(MOZ_PULSEAUDIO)
|
||||
AC_SUBST(MOZ_PULSEAUDIO_CFLAGS)
|
||||
-AC_SUBST(MOZ_PULSEAUDIO_LIBS)
|
||||
|
||||
dnl ========================================================
|
||||
dnl = Enable GStreamer
|
||||
dnl ========================================================
|
||||
if test "$OS_TARGET" = "Linux"; then
|
||||
MOZ_GSTREAMER=1
|
||||
fi
|
||||
|
||||
diff --git a/media/webrtc/signaling/test/Makefile.in b/media/webrtc/signaling/test/Makefile.in
|
||||
--- a/media/webrtc/signaling/test/Makefile.in
|
||||
+++ b/media/webrtc/signaling/test/Makefile.in
|
||||
@@ -18,21 +18,16 @@ LIBS = \
|
||||
$(NULL)
|
||||
|
||||
ifdef MOZ_CUBEB
|
||||
ifdef MOZ_ALSA
|
||||
LIBS += \
|
||||
$(MOZ_ALSA_LIBS) \
|
||||
$(NULL)
|
||||
endif
|
||||
-ifdef MOZ_PULSEAUDIO
|
||||
-LIBS += \
|
||||
- $(MOZ_PULSEAUDIO_LIBS) \
|
||||
- $(NULL)
|
||||
-endif
|
||||
endif
|
||||
|
||||
ifeq ($(OS_TARGET),Android)
|
||||
LIBS += \
|
||||
$(STLPORT_LDFLAGS) \
|
||||
$(STLPORT_LIBS) \
|
||||
$(NULL)
|
||||
CPPFLAGS += \
|
||||
diff --git a/toolkit/library/Makefile.in b/toolkit/library/Makefile.in
|
||||
--- a/toolkit/library/Makefile.in
|
||||
+++ b/toolkit/library/Makefile.in
|
||||
@@ -428,19 +428,16 @@ OS_LIBS += $(call EXPAND_LIBNAME,secur32
|
||||
endif
|
||||
endif
|
||||
|
||||
|
||||
ifdef MOZ_CUBEB
|
||||
ifdef MOZ_ALSA
|
||||
EXTRA_DSO_LDOPTS += $(MOZ_ALSA_LIBS)
|
||||
endif
|
||||
-ifdef MOZ_PULSEAUDIO
|
||||
-EXTRA_DSO_LDOPTS += $(MOZ_PULSEAUDIO_LIBS)
|
||||
-endif
|
||||
endif
|
||||
|
||||
ifdef HAVE_CLOCK_MONOTONIC
|
||||
EXTRA_DSO_LDOPTS += $(REALTIME_LIBS)
|
||||
endif
|
||||
|
||||
ifeq (android,$(MOZ_WIDGET_TOOLKIT))
|
||||
OS_LIBS += -lGLESv2
|
@ -1,30 +0,0 @@
|
||||
# HG changeset patch
|
||||
# Parent d8fd5706493e19bcb85443316a4c180849f5d247
|
||||
# User Steve Singer <steve@ssinger.info>
|
||||
Bug 885002 - Fix casting on 64 bit Big Endian platforms.
|
||||
|
||||
|
||||
diff --git a/content/media/FileBlockCache.h b/content/media/FileBlockCache.h
|
||||
--- a/content/media/FileBlockCache.h
|
||||
+++ b/content/media/FileBlockCache.h
|
||||
@@ -138,19 +138,17 @@ public:
|
||||
|
||||
bool IsEmpty() {
|
||||
return nsDeque::GetSize() == 0;
|
||||
}
|
||||
|
||||
private:
|
||||
int32_t ObjectAt(int32_t aIndex) {
|
||||
void* v = nsDeque::ObjectAt(aIndex);
|
||||
- // Ugly hack to work around "casting 64bit void* to 32bit int loses precision"
|
||||
- // error on 64bit Linux.
|
||||
- return *(reinterpret_cast<int32_t*>(&v));
|
||||
+ return reinterpret_cast<uintptr_t>(v);
|
||||
}
|
||||
};
|
||||
|
||||
private:
|
||||
int64_t BlockIndexToOffset(int32_t aBlockIndex) {
|
||||
return static_cast<int64_t>(aBlockIndex) * BLOCK_SIZE;
|
||||
}
|
||||
|
@ -1,27 +0,0 @@
|
||||
diff -up mozilla-release/storage/src/Makefile.in.938730 mozilla-release/storage/src/Makefile.in
|
||||
--- mozilla-release/storage/src/Makefile.in.938730 2013-12-09 15:15:44.708527295 +0100
|
||||
+++ mozilla-release/storage/src/Makefile.in 2013-12-09 15:17:16.119682503 +0100
|
||||
@@ -6,14 +6,23 @@
|
||||
# Don't use the jemalloc allocator on Android, because we can't guarantee
|
||||
# that Gecko will configure sqlite before it is first used (bug 730495).
|
||||
#
|
||||
+# Don't use the jemalloc allocator when using system NSS. Linked in libraries
|
||||
+# (such as NSS) might trigger an initialization of sqlite and allocation
|
||||
+# of memory using the default allocator, prior to the storage service
|
||||
+# registering its allocator, causing memory management failures (bug 938730).
|
||||
+#
|
||||
# Note: On Windows our sqlite build assumes we use jemalloc. If you disable
|
||||
# MOZ_STORAGE_MEMORY on Windows, you will also need to change the "ifdef
|
||||
# MOZ_MEMORY" options in db/sqlite3/src/Makefile.in.
|
||||
+
|
||||
+ifndef _USE_SYSTEM_NSS
|
||||
ifdef MOZ_MEMORY
|
||||
ifneq ($(OS_TARGET), Android)
|
||||
DEFINES += -DMOZ_STORAGE_MEMORY
|
||||
endif
|
||||
endif
|
||||
+endif
|
||||
+
|
||||
|
||||
# For nsDependentJSString
|
||||
LOCAL_INCLUDES = \
|
4
sources
4
sources
@ -1,2 +1,2 @@
|
||||
c8feb2c55294aa679e8755ac24844933 firefox-27.0.1.source.tar.bz2
|
||||
cb4686a984be5503cdfe34fd25cb2217 firefox-langpacks-27.0.1-20140224.tar.xz
|
||||
db06b6da6b826cfc6a49c15bca115a6b firefox-28.0.source.tar.bz2
|
||||
6b8a78488747b8949c6d4ff575452319 firefox-langpacks-28.0-20140318.tar.xz
|
||||
|
Loading…
Reference in New Issue
Block a user