removing unused patches
This commit is contained in:
parent
3d33e32144
commit
5ac0ddab3b
@ -1,29 +0,0 @@
|
||||
diff -up firefox-78.2.0/security/nss/lib/freebl/freebl.gyp.rhel6-abiv2-mozbz1642174 firefox-78.2.0/security/nss/lib/freebl/freebl.gyp
|
||||
--- firefox-78.2.0/security/nss/lib/freebl/freebl.gyp.rhel6-abiv2-mozbz1642174 2020-09-12 08:29:08.527410514 +0200
|
||||
+++ firefox-78.2.0/security/nss/lib/freebl/freebl.gyp 2020-09-12 08:42:26.279064334 +0200
|
||||
@@ -259,7 +259,7 @@
|
||||
'type': 'static_library',
|
||||
'sources': [
|
||||
'gcm-ppc.c',
|
||||
- 'sha512-p8.s',
|
||||
+ #'sha512-p8.s',
|
||||
],
|
||||
'dependencies': [
|
||||
'<(DEPTH)/exports.gyp:nss_exports'
|
||||
diff -up firefox-78.2.0/security/nss/lib/freebl/Makefile.rhel6-abiv2-mozbz1642174 firefox-78.2.0/security/nss/lib/freebl/Makefile
|
||||
--- firefox-78.2.0/security/nss/lib/freebl/Makefile.rhel6-abiv2-mozbz1642174 2020-08-17 20:34:06.000000000 +0200
|
||||
+++ firefox-78.2.0/security/nss/lib/freebl/Makefile 2020-09-12 08:28:08.089142990 +0200
|
||||
@@ -267,9 +267,12 @@ ifeq ($(CPU_ARCH),arm)
|
||||
endif
|
||||
ifeq ($(CPU_ARCH),ppc)
|
||||
EXTRA_SRCS += gcm-ppc.c
|
||||
- ASFILES += sha512-p8.s
|
||||
ifdef USE_64
|
||||
DEFINES += -DNSS_NO_INIT_SUPPORT
|
||||
+ #PPC_ABI := $(shell $(CC) -dM -E - < /dev/null | awk '$$2 == "_CALL_ELF" {print $$3}')
|
||||
+ # ifeq ($(PPC_ABI),2)
|
||||
+ # ASFILES += sha512-p8.s
|
||||
+ # endif
|
||||
endif # USE_64
|
||||
endif # ppc
|
||||
endif # Linux
|
@ -1,27 +0,0 @@
|
||||
diff -ru firefox-78.3.0/security/sandbox/linux/SandboxFilter.cpp firefox-78.4.0/security/sandbox/linux/SandboxFilter.cpp
|
||||
--- firefox-78.3.0/security/sandbox/linux/SandboxFilter.cpp 2020-09-14 21:21:02.000000000 +0200
|
||||
+++ firefox-78.4.0/security/sandbox/linux/SandboxFilter.cpp 2020-10-14 11:34:48.000000000 +0200
|
||||
@@ -243,14 +243,21 @@
|
||||
auto path = reinterpret_cast<const char*>(aArgs.args[1]);
|
||||
auto buf = reinterpret_cast<statstruct*>(aArgs.args[2]);
|
||||
auto flags = static_cast<int>(aArgs.args[3]);
|
||||
+
|
||||
+ if (fd != AT_FDCWD && (flags & AT_EMPTY_PATH) != 0 &&
|
||||
+ strcmp(path, "") == 0) {
|
||||
+ return ConvertError(fstatsyscall(fd, buf));
|
||||
+ }
|
||||
+
|
||||
if (fd != AT_FDCWD && path[0] != '/') {
|
||||
SANDBOX_LOG_ERROR("unsupported fd-relative fstatat(%d, \"%s\", %p, %d)",
|
||||
fd, path, buf, flags);
|
||||
return BlockedSyscallTrap(aArgs, nullptr);
|
||||
}
|
||||
- if ((flags & ~AT_SYMLINK_NOFOLLOW) != 0) {
|
||||
+ if ((flags & ~(AT_SYMLINK_NOFOLLOW | AT_NO_AUTOMOUNT)) != 0) {
|
||||
SANDBOX_LOG_ERROR("unsupported flags %d in fstatat(%d, \"%s\", %p, %d)",
|
||||
- (flags & ~AT_SYMLINK_NOFOLLOW), fd, path, buf, flags);
|
||||
+ (flags & ~(AT_SYMLINK_NOFOLLOW | AT_NO_AUTOMOUNT)), fd,
|
||||
+ path, buf, flags);
|
||||
return BlockedSyscallTrap(aArgs, nullptr);
|
||||
}
|
||||
return (flags & AT_SYMLINK_NOFOLLOW) == 0 ? broker->Stat(path, buf)
|
@ -1,39 +0,0 @@
|
||||
diff -up firefox-78.2.0/mozglue/build/ppc.cpp.ppc-vsx firefox-78.2.0/mozglue/build/ppc.cpp
|
||||
--- firefox-78.2.0/mozglue/build/ppc.cpp.ppc-vsx 2020-09-11 07:07:05.850864720 +0200
|
||||
+++ firefox-78.2.0/mozglue/build/ppc.cpp 2020-09-11 07:08:48.884202679 +0200
|
||||
@@ -14,10 +14,6 @@
|
||||
#if defined(XP_LINUX)
|
||||
// Use the getauxval() function if available.
|
||||
// ARCH_3_00 wasn't defined until glibc 2.23, so include just in case.
|
||||
-# include <sys/auxv.h>
|
||||
-# ifndef PPC_FEATURE2_ARCH_3_00
|
||||
-# define PPC_FEATURE2_ARCH_3_00 0x00800000
|
||||
-# endif
|
||||
#endif
|
||||
|
||||
const unsigned PPC_FLAG_VMX = 1;
|
||||
@@ -33,24 +29,8 @@ static signed get_ppc_cpu_flags(void) {
|
||||
}
|
||||
cpu_flags = 0;
|
||||
|
||||
-#if defined(XP_LINUX)
|
||||
- // Try getauxval().
|
||||
- unsigned long int cap = getauxval(AT_HWCAP);
|
||||
- unsigned long int cap2 = getauxval(AT_HWCAP2);
|
||||
-
|
||||
- if (cap & PPC_FEATURE_HAS_ALTIVEC) {
|
||||
- cpu_flags |= PPC_FLAG_VMX;
|
||||
- }
|
||||
- if (cap & PPC_FEATURE_HAS_VSX) {
|
||||
- cpu_flags |= PPC_FLAG_VSX;
|
||||
- }
|
||||
- if (cap2 & PPC_FEATURE2_ARCH_3_00) {
|
||||
- cpu_flags |= PPC_FLAG_VSX3;
|
||||
- }
|
||||
-#else
|
||||
// Non-Linux detection here. Currently, on systems other than Linux,
|
||||
// no CPU SIMD features will be detected.
|
||||
-#endif
|
||||
|
||||
return cpu_flags;
|
||||
}
|
@ -1,41 +0,0 @@
|
||||
diff -up firefox-78.2.0/third_party/rust/libdbus-sys/build.rs.rhel6-dbusver firefox-78.2.0/third_party/rust/libdbus-sys/build.rs
|
||||
--- firefox-78.2.0/third_party/rust/libdbus-sys/build.rs.rhel6-dbusver 2020-08-17 20:34:46.000000000 +0200
|
||||
+++ firefox-78.2.0/third_party/rust/libdbus-sys/build.rs 2020-09-09 21:06:34.932374254 +0200
|
||||
@@ -3,5 +3,5 @@ extern crate pkg_config;
|
||||
fn main() {
|
||||
// See https://github.com/joshtriplett/metadeps/issues/9 for why we don't use
|
||||
// metadeps here, but instead keep this manually in sync with Cargo.toml.
|
||||
- pkg_config::Config::new().atleast_version("1.6").probe("dbus-1").unwrap();
|
||||
+ pkg_config::Config::new().atleast_version("1.2").probe("dbus-1").unwrap();
|
||||
}
|
||||
diff -up firefox-78.2.0/third_party/rust/libdbus-sys/.cargo-checksum.json.rhel6-dbusver firefox-78.2.0/third_party/rust/libdbus-sys/.cargo-checksum.json
|
||||
--- firefox-78.2.0/third_party/rust/libdbus-sys/.cargo-checksum.json.rhel6-dbusver 2020-08-17 20:35:05.000000000 +0200
|
||||
+++ firefox-78.2.0/third_party/rust/libdbus-sys/.cargo-checksum.json 2020-09-09 21:11:37.045287830 +0200
|
||||
@@ -1 +1 @@
|
||||
-{"files":{"Cargo.toml":"7054b852a13a318562f3ef791e69802f234c9f3d943f2de2d1cef8b31fd0939a","LICENSE-APACHE":"453745410e3be8cf25d56872ea2aec975a78e6c9f217443d0bf908a5bce7c8ff","LICENSE-MIT":"de3911c2d98c8bd2d701ee721347053d9b55995a11f9a8c955e44d3ca1b376bf","build.rs":"9fbc218277d76a570c01c5795a7c8008f5458317cc036d7c88b1dc1a4af22fb7","src/lib.rs":"c8a0d43a3b7e9c8828d4946437379f1985492bd6b04fdd5e967bbcace2197c3d"},"package":"18cb88963258d00f4962205dbb5933d82780d9962c8c8a064b651d2ad7189210"}
|
||||
\ No newline at end of file
|
||||
+{"files":{"Cargo.toml":"7054b852a13a318562f3ef791e69802f234c9f3d943f2de2d1cef8b31fd0939a","LICENSE-APACHE":"453745410e3be8cf25d56872ea2aec975a78e6c9f217443d0bf908a5bce7c8ff","LICENSE-MIT":"de3911c2d98c8bd2d701ee721347053d9b55995a11f9a8c955e44d3ca1b376bf","build.rs":"41d24ea34bd37eb7a47253ac0681da2dde73e52caf04bbcecf795965e5d36466","src/lib.rs":"31e939a4a7f537265a84c91ba940ac31ac0f66c53a49971f1b21bbd2e4a7b5e9"},"package":"18cb88963258d00f4962205dbb5933d82780d9962c8c8a064b651d2ad7189210"}
|
||||
diff -up firefox-78.2.0/third_party/rust/libdbus-sys/src/lib.rs.rhel6-dbusver firefox-78.2.0/third_party/rust/libdbus-sys/src/lib.rs
|
||||
--- firefox-78.2.0/third_party/rust/libdbus-sys/src/lib.rs.rhel6-dbusver 2020-08-17 20:34:38.000000000 +0200
|
||||
+++ firefox-78.2.0/third_party/rust/libdbus-sys/src/lib.rs 2020-09-09 21:06:34.933374260 +0200
|
||||
@@ -252,13 +252,14 @@ extern "C" {
|
||||
pub fn dbus_signature_validate_single(signature: *const c_char, error: *mut DBusError) -> u32;
|
||||
|
||||
pub fn dbus_threads_init_default() -> c_int;
|
||||
+}
|
||||
+ pub fn dbus_validate_bus_name(busname: *const c_char, error: *mut DBusError) -> u32 {return 1;}
|
||||
+ pub fn dbus_validate_error_name(errorname: *const c_char, error: *mut DBusError) -> u32 {return 1;}
|
||||
+ pub fn dbus_validate_interface(interface: *const c_char, error: *mut DBusError) -> u32 {return 1;}
|
||||
+ pub fn dbus_validate_member(member: *const c_char, error: *mut DBusError) -> u32 {return 1;}
|
||||
+ pub fn dbus_validate_path(path: *const c_char, error: *mut DBusError) -> u32 {return 1;}
|
||||
|
||||
- pub fn dbus_validate_bus_name(busname: *const c_char, error: *mut DBusError) -> u32;
|
||||
- pub fn dbus_validate_error_name(errorname: *const c_char, error: *mut DBusError) -> u32;
|
||||
- pub fn dbus_validate_interface(interface: *const c_char, error: *mut DBusError) -> u32;
|
||||
- pub fn dbus_validate_member(member: *const c_char, error: *mut DBusError) -> u32;
|
||||
- pub fn dbus_validate_path(path: *const c_char, error: *mut DBusError) -> u32;
|
||||
-
|
||||
+extern "C" {
|
||||
pub fn dbus_watch_get_enabled(watch: *mut DBusWatch) -> u32;
|
||||
pub fn dbus_watch_get_flags(watch: *mut DBusWatch) -> c_uint;
|
||||
pub fn dbus_watch_get_unix_fd(watch: *mut DBusWatch) -> c_int;
|
@ -1,16 +0,0 @@
|
||||
diff -up firefox-78.2.0/media/webrtc/trunk/webrtc/modules/video_capture/linux/device_info_linux.cc.rhel6-kernel firefox-78.2.0/media/webrtc/trunk/webrtc/modules/video_capture/linux/device_info_linux.cc
|
||||
--- firefox-78.2.0/media/webrtc/trunk/webrtc/modules/video_capture/linux/device_info_linux.cc.rhel6-kernel 2020-09-09 19:56:13.159597467 +0200
|
||||
+++ firefox-78.2.0/media/webrtc/trunk/webrtc/modules/video_capture/linux/device_info_linux.cc 2020-09-09 19:56:31.457712629 +0200
|
||||
@@ -385,11 +385,7 @@ bool DeviceInfoLinux::IsDeviceNameMatche
|
||||
|
||||
bool DeviceInfoLinux::IsVideoCaptureDevice(struct v4l2_capability* cap)
|
||||
{
|
||||
- if (cap->capabilities & V4L2_CAP_DEVICE_CAPS) {
|
||||
- return cap->device_caps & V4L2_CAP_VIDEO_CAPTURE;
|
||||
- } else {
|
||||
- return cap->capabilities & V4L2_CAP_VIDEO_CAPTURE;
|
||||
- }
|
||||
+ return false;
|
||||
}
|
||||
|
||||
int32_t DeviceInfoLinux::FillCapabilities(int fd) {
|
@ -1,12 +0,0 @@
|
||||
diff -up firefox-78.2.0/python/mozbuild/mozbuild/controller/building.py.mach-fail firefox-78.2.0/python/mozbuild/mozbuild/controller/building.py
|
||||
--- firefox-78.2.0/python/mozbuild/mozbuild/controller/building.py.mach-fail 2020-09-09 19:25:18.552930506 +0200
|
||||
+++ firefox-78.2.0/python/mozbuild/mozbuild/controller/building.py 2020-09-09 19:25:31.081010223 +0200
|
||||
@@ -591,7 +591,7 @@ class TerminalLoggingHandler(logging.Han
|
||||
if self.footer:
|
||||
self.footer.clear()
|
||||
|
||||
- self.fh.write(msg.encode("utf-8"))
|
||||
+ self.fh.write(msg)
|
||||
self.fh.write('\n')
|
||||
|
||||
if self.footer:
|
@ -1,12 +0,0 @@
|
||||
diff -up firefox-78.2.0/tools/profiler/gecko/nsProfiler.cpp.zconst firefox-78.2.0/tools/profiler/gecko/nsProfiler.cpp
|
||||
--- firefox-78.2.0/tools/profiler/gecko/nsProfiler.cpp.zconst 2020-09-09 20:29:17.489123431 +0200
|
||||
+++ firefox-78.2.0/tools/profiler/gecko/nsProfiler.cpp 2020-09-09 20:30:09.544457350 +0200
|
||||
@@ -523,7 +523,7 @@ nsProfiler::GetProfileDataAsGzippedArray
|
||||
stream.opaque = nullptr;
|
||||
stream.next_out = (Bytef*)outBuff.Elements();
|
||||
stream.avail_out = outBuff.Length();
|
||||
- stream.next_in = (z_const Bytef*)aResult.Data();
|
||||
+ stream.next_in = (Bytef*)aResult.Data();
|
||||
stream.avail_in = aResult.Length();
|
||||
|
||||
// A windowBits of 31 is the default (15) plus 16 for emitting a
|
Loading…
Reference in New Issue
Block a user