30 lines
1.3 KiB
Diff
30 lines
1.3 KiB
Diff
diff -up firefox-78.2.0/security/nss/lib/freebl/freebl.gyp.rhel6-abiv2-mozbz1642174 firefox-78.2.0/security/nss/lib/freebl/freebl.gyp
|
|
--- firefox-78.2.0/security/nss/lib/freebl/freebl.gyp.rhel6-abiv2-mozbz1642174 2020-09-12 08:29:08.527410514 +0200
|
|
+++ firefox-78.2.0/security/nss/lib/freebl/freebl.gyp 2020-09-12 08:42:26.279064334 +0200
|
|
@@ -259,7 +259,7 @@
|
|
'type': 'static_library',
|
|
'sources': [
|
|
'gcm-ppc.c',
|
|
- 'sha512-p8.s',
|
|
+ #'sha512-p8.s',
|
|
],
|
|
'dependencies': [
|
|
'<(DEPTH)/exports.gyp:nss_exports'
|
|
diff -up firefox-78.2.0/security/nss/lib/freebl/Makefile.rhel6-abiv2-mozbz1642174 firefox-78.2.0/security/nss/lib/freebl/Makefile
|
|
--- firefox-78.2.0/security/nss/lib/freebl/Makefile.rhel6-abiv2-mozbz1642174 2020-08-17 20:34:06.000000000 +0200
|
|
+++ firefox-78.2.0/security/nss/lib/freebl/Makefile 2020-09-12 08:28:08.089142990 +0200
|
|
@@ -267,9 +267,12 @@ ifeq ($(CPU_ARCH),arm)
|
|
endif
|
|
ifeq ($(CPU_ARCH),ppc)
|
|
EXTRA_SRCS += gcm-ppc.c
|
|
- ASFILES += sha512-p8.s
|
|
ifdef USE_64
|
|
DEFINES += -DNSS_NO_INIT_SUPPORT
|
|
+ #PPC_ABI := $(shell $(CC) -dM -E - < /dev/null | awk '$$2 == "_CALL_ELF" {print $$3}')
|
|
+ # ifeq ($(PPC_ABI),2)
|
|
+ # ASFILES += sha512-p8.s
|
|
+ # endif
|
|
endif # USE_64
|
|
endif # ppc
|
|
endif # Linux
|