Initial import of XBean

This commit is contained in:
Stanislav Ochotnicky 2010-07-13 08:21:01 +00:00
parent dee65b37b2
commit e9ea39468d
6 changed files with 328 additions and 0 deletions

View File

@ -0,0 +1 @@
xbean-3.7.tar.xz

1
import.log Normal file
View File

@ -0,0 +1 @@
xbean-3_7-2_fc13:HEAD:xbean-3.7-2.fc13.src.rpm:1279009217

129
pom-3.7.patch Normal file
View File

@ -0,0 +1,129 @@
diff --git a/pom.xml b/pom.xml
index 569995c..3631ba4 100644
--- a/pom.xml
+++ b/pom.xml
@@ -24,12 +24,6 @@
<modelVersion>4.0.0</modelVersion>
- <parent>
- <groupId>org.apache.geronimo.genesis</groupId>
- <artifactId>genesis-java5-flava</artifactId>
- <version>2.0</version>
- </parent>
-
<groupId>org.apache.xbean</groupId>
<artifactId>xbean</artifactId>
<name>Apache XBean</name>
@@ -265,33 +259,15 @@
</dependency>
<dependency>
- <groupId>org.springframework</groupId>
- <artifactId>spring-beans</artifactId>
- <version>2.5.6</version>
- </dependency>
-
- <dependency>
- <groupId>org.springframework</groupId>
- <artifactId>spring-context</artifactId>
- <version>2.5.6</version>
- </dependency>
-
- <dependency>
- <groupId>org.springframework</groupId>
- <artifactId>spring-web</artifactId>
- <version>2.5.6</version>
- </dependency>
-
- <dependency>
<groupId>com.thoughtworks.qdox</groupId>
<artifactId>qdox</artifactId>
<version>1.6.3</version>
</dependency>
-
+
<dependency>
<groupId>org.slf4j</groupId>
<artifactId>slf4j-api</artifactId>
- <version>1.5.11</version>
+ <version>1.5.11</version>
</dependency>
</dependencies>
</dependencyManagement>
@@ -327,13 +303,13 @@
<artifactId>maven-bundle-plugin</artifactId>
<version>2.0.0</version>
<extensions>true</extensions>
- <configuration>
- <instructions>
- <Bundle-DocURL>${project.url}</Bundle-DocURL>
- <Export-Package>org.apache.xbean.*;version=${pom.version}</Export-Package>
- <Private-Package />
- </instructions>
- </configuration>
+ <configuration>
+- <instructions>
+- <Bundle-DocURL>${project.url}</Bundle-DocURL>
+- <Export-Package>org.apache.xbean.*;version=${pom.version}</Export-Package>
+- <Private-Package />
+- </instructions>
+- </configuration>
</plugin>
</plugins>
</pluginManagement>
@@ -343,22 +319,21 @@
<groupId>org.apache.felix</groupId>
<artifactId>maven-bundle-plugin</artifactId>
</plugin>
+ <plugin>
+ <artifactId>maven-compiler-plugin</artifactId>
+ <configuration>
+ <source>1.5</source>
+ <target>1.5</target>
+ </configuration>
+ </plugin>
</plugins>
</build>
<modules>
- <module>xbean-classloader</module>
<module>xbean-classpath</module>
<module>xbean-bundleutils</module>
- <module>xbean-finder</module>
<module>xbean-naming</module>
<module>xbean-reflect</module>
- <module>xbean-blueprint</module>
- <module>xbean-spring</module>
- <module>xbean-telnet</module>
- <module>maven-xbean-plugin</module>
- <module>xbean-asm-shaded</module>
- <module>xbean-finder-shaded</module>
</modules>
<reporting>
@@ -422,4 +397,4 @@
</plugins>
</reporting>
-</project>
\ No newline at end of file
+</project>
diff --git a/xbean-reflect/pom.xml b/xbean-reflect/pom.xml
index 5ea1864..288ec1d 100644
--- a/xbean-reflect/pom.xml
+++ b/xbean-reflect/pom.xml
@@ -47,13 +47,6 @@
<optional>true</optional>
</dependency>
<dependency>
- <groupId>org.apache.xbean</groupId>
- <artifactId>xbean-asm-shaded</artifactId>
- <version>3.7</version>
- <scope>provided</scope>
- <optional>true</optional>
- </dependency>
- <dependency>
<groupId>log4j</groupId>
<artifactId>log4j</artifactId>
<version>1.2.12</version>

View File

@ -0,0 +1 @@
987f14094e03d803e948d6c09ad8a2d4 xbean-3.7.tar.xz

50
xbean.depmap Normal file
View File

@ -0,0 +1,50 @@
<dependencies>
<dependency>
<maven>
<groupId>org.osgi</groupId>
<artifactId>org.osgi.core</artifactId>
<version>4.2.0</version>
</maven>
<jpp>
<groupId>JPP/felix</groupId>
<artifactId>org.osgi.core</artifactId>
<version>1.2.0</version>
</jpp>
</dependency>
<dependency>
<maven>
<groupId>asm</groupId>
<artifactId>asm-commons</artifactId>
<version>3.1</version>
</maven>
<jpp>
<groupId>JPP/objectweb-asm</groupId>
<artifactId>asm-commons</artifactId>
<version>3.2</version>
</jpp>
</dependency>
<dependency>
<maven>
<groupId>asm</groupId>
<artifactId>asm</artifactId>
<version>3.1</version>
</maven>
<jpp>
<groupId>JPP/objectweb-asm</groupId>
<artifactId>asm</artifactId>
<version>3.2</version>
</jpp>
</dependency>
<dependency>
<maven>
<groupId>asm</groupId>
<artifactId>asm-tree</artifactId>
<version>3.1</version>
</maven>
<jpp>
<groupId>JPP/objectweb-asm</groupId>
<artifactId>asm-tree</artifactId>
<version>3.2</version>
</jpp>
</dependency>
</dependencies>

146
xbean.spec Normal file
View File

@ -0,0 +1,146 @@
Name: xbean
Version: 3.7
BuildArch: noarch
Release: 2%{?dist}
Summary: Java plugin based web server
Group: Development/Libraries
License: ASL 2.0
URL: http://geronimo.apache.org/xbean/
# unfortunately no source/binary releases are being made lately, just
# tags in repos and binary releases in maven repositories
# svn export http://svn.apache.org/repos/asf/geronimo/xbean/tags/xbean-3.7
# tar caf xbean-3.7.tar.xz xbean-3.7
Source0: xbean-%{version}.tar.xz
Source1: xbean.depmap
BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
Patch0: pom-%{version}.patch
BuildRequires: java-devel
BuildRequires: apache-commons-beanutils
BuildRequires: apache-commons-logging
BuildRequires: mx4j
BuildRequires: objectweb-asm
BuildRequires: ant
BuildRequires: qdox
BuildRequires: slf4j
BuildRequires: felix-osgi-core >= 1.4.0
BuildRequires: maven-plugin-bundle
BuildRequires: maven-antrun-plugin
BuildRequires: maven-compiler-plugin
BuildRequires: maven-idea-plugin
BuildRequires: maven-install-plugin
BuildRequires: maven-javadoc-plugin
BuildRequires: maven-resources-plugin
BuildRequires: maven-surefire-maven-plugin
BuildRequires: maven-site-plugin
BuildRequires: maven2-plugin-shade
Requires: java
Requires: objectweb-asm
Requires: apache-commons-logging
%description
The goal of XBean project is to create a plugin based server
analogous to Eclipse being a plugin based IDE. XBean will be able to
discover, download and install server plugins from an Internet based
repository. In addition, we include support for multiple IoC systems,
support for running with no IoC system, JMX without JMX code,
lifecycle and class loader management, and a rock solid Spring
integration.
%package javadoc
Summary: API documentation for %{name}
Group: Documentation
Requires: jpackage-utils
%description javadoc
%{summary}.
%prep
%setup -q
# build failing on this due to doxia-sitetools problems
rm src/site/site.xml
# removes dependency on springframework and prevents building of
# modules depending on it. If other modules are required,
# springframework will have to be brought in first
%patch0 -p1
# Fix dependency on xbean-asm-shaded to original objectweb-asm
sed -i 's/org.apache.xbean.asm/org.objectweb.asm/' \
xbean-reflect/src/main/java/org/apache/xbean/recipe/XbeanAsmParameterNameLoader.java
%build
export MAVEN_REPO_LOCAL=$(pwd)/.m2/repository
mvn-jpp -e \
-Dmaven.repo.local=$MAVEN_REPO_LOCAL \
-Dmaven2.jpp.depmap.file="%{SOURCE1}" \
install javadoc:javadoc
%install
rm -rf $RPM_BUILD_ROOT
# for every module we want to be built
for sub in reflect naming classpath; do
# install jar
install -Dpm 644 %{name}-${sub}/target/%{name}-${sub}-%{version}.jar \
$RPM_BUILD_ROOT/%{_javadir}/xbean/%{name}-${sub}-%{version}.jar;
# intall pom
install -Dpm 644 %{name}-${sub}/pom.xml $RPM_BUILD_ROOT/%{_mavenpomdir}/JPP-%{name}-${sub}.pom
# maven depmap
%add_to_maven_depmap org.apache.xbean %{name}-${sub} %{version} JPP/xbean %{name}-${sub}
# javadoc
install -d -m 755 $RPM_BUILD_ROOT%{_javadocdir}/%{name}-%{version}/%{name}-${sub}-%{version}
cp -pr %{name}-${sub}/target/site/apidocs/* $RPM_BUILD_ROOT%{_javadocdir}/%{name}-%{version}/%{name}-${sub}-%{version}
done
ln -sf %{name}-%{version} $RPM_BUILD_ROOT%{_javadocdir}/%{name}
# unversioned symlinks
pushd $RPM_BUILD_ROOT%{_javadir}/%{name}
for jar in *-%{version}*; do
ln -sf ${jar} `echo $jar| sed "s|-%{version}||g"`
done
popd # come back from javadir
# parent pom
install -pm 644 pom.xml $RPM_BUILD_ROOT/%{_mavenpomdir}/JPP-%{name}.pom
%clean
rm -rf $RPM_BUILD_ROOT
%post
%update_maven_depmap
%postun
%update_maven_depmap
%files
%defattr(-,root,root,-)
%doc LICENSE NOTICE
%{_mavenpomdir}/JPP-*.pom
%{_mavendepmapfragdir}/%{name}
%{_javadir}/%{name}
%files javadoc
%defattr(-,root,root,-)
%doc LICENSE
%{_javadocdir}/%{name}
%{_javadocdir}/%{name}-%{version}
%changelog
* Fri Jul 9 2010 Stanislav Ochotnicky <sochotnicky@redhat.com> - 3.7-2
- Add license to javadoc subpackage
* Mon Jun 21 2010 Stanislav Ochotnicky <sochotnicky@redhat.com> - 3.7-1
- First release