diff --git a/.cvsignore b/.cvsignore
index e69de29..7594e46 100644
--- a/.cvsignore
+++ b/.cvsignore
@@ -0,0 +1 @@
+xbean-3.7.tar.xz
diff --git a/import.log b/import.log
new file mode 100644
index 0000000..7984c81
--- /dev/null
+++ b/import.log
@@ -0,0 +1 @@
+xbean-3_7-2_fc13:HEAD:xbean-3.7-2.fc13.src.rpm:1279009217
diff --git a/pom-3.7.patch b/pom-3.7.patch
new file mode 100644
index 0000000..bb431d4
--- /dev/null
+++ b/pom-3.7.patch
@@ -0,0 +1,129 @@
+diff --git a/pom.xml b/pom.xml
+index 569995c..3631ba4 100644
+--- a/pom.xml
++++ b/pom.xml
+@@ -24,12 +24,6 @@
+
+ 4.0.0
+
+-
+- org.apache.geronimo.genesis
+- genesis-java5-flava
+- 2.0
+-
+-
+ org.apache.xbean
+ xbean
+ Apache XBean
+@@ -265,33 +259,15 @@
+
+
+
+- org.springframework
+- spring-beans
+- 2.5.6
+-
+-
+-
+- org.springframework
+- spring-context
+- 2.5.6
+-
+-
+-
+- org.springframework
+- spring-web
+- 2.5.6
+-
+-
+-
+ com.thoughtworks.qdox
+ qdox
+ 1.6.3
+
+-
++
+
+ org.slf4j
+ slf4j-api
+- 1.5.11
++ 1.5.11
+
+
+
+@@ -327,13 +303,13 @@
+ maven-bundle-plugin
+ 2.0.0
+ true
+-
+-
+- ${project.url}
+- org.apache.xbean.*;version=${pom.version}
+-
+-
+-
++
++-
++- ${project.url}
++- org.apache.xbean.*;version=${pom.version}
++-
++-
++-
+
+
+
+@@ -343,22 +319,21 @@
+ org.apache.felix
+ maven-bundle-plugin
+
++
++ maven-compiler-plugin
++
++ 1.5
++ 1.5
++
++
+
+
+
+
+- xbean-classloader
+ xbean-classpath
+ xbean-bundleutils
+- xbean-finder
+ xbean-naming
+ xbean-reflect
+- xbean-blueprint
+- xbean-spring
+- xbean-telnet
+- maven-xbean-plugin
+- xbean-asm-shaded
+- xbean-finder-shaded
+
+
+
+@@ -422,4 +397,4 @@
+
+
+
+-
+\ No newline at end of file
++
+diff --git a/xbean-reflect/pom.xml b/xbean-reflect/pom.xml
+index 5ea1864..288ec1d 100644
+--- a/xbean-reflect/pom.xml
++++ b/xbean-reflect/pom.xml
+@@ -47,13 +47,6 @@
+ true
+
+
+- org.apache.xbean
+- xbean-asm-shaded
+- 3.7
+- provided
+- true
+-
+-
+ log4j
+ log4j
+ 1.2.12
diff --git a/sources b/sources
index e69de29..9f53590 100644
--- a/sources
+++ b/sources
@@ -0,0 +1 @@
+987f14094e03d803e948d6c09ad8a2d4 xbean-3.7.tar.xz
diff --git a/xbean.depmap b/xbean.depmap
new file mode 100644
index 0000000..25ffb7f
--- /dev/null
+++ b/xbean.depmap
@@ -0,0 +1,50 @@
+
+
+
+ org.osgi
+ org.osgi.core
+ 4.2.0
+
+
+ JPP/felix
+ org.osgi.core
+ 1.2.0
+
+
+
+
+ asm
+ asm-commons
+ 3.1
+
+
+ JPP/objectweb-asm
+ asm-commons
+ 3.2
+
+
+
+
+ asm
+ asm
+ 3.1
+
+
+ JPP/objectweb-asm
+ asm
+ 3.2
+
+
+
+
+ asm
+ asm-tree
+ 3.1
+
+
+ JPP/objectweb-asm
+ asm-tree
+ 3.2
+
+
+
diff --git a/xbean.spec b/xbean.spec
new file mode 100644
index 0000000..23dbc75
--- /dev/null
+++ b/xbean.spec
@@ -0,0 +1,146 @@
+Name: xbean
+Version: 3.7
+BuildArch: noarch
+
+Release: 2%{?dist}
+Summary: Java plugin based web server
+
+Group: Development/Libraries
+License: ASL 2.0
+URL: http://geronimo.apache.org/xbean/
+
+# unfortunately no source/binary releases are being made lately, just
+# tags in repos and binary releases in maven repositories
+# svn export http://svn.apache.org/repos/asf/geronimo/xbean/tags/xbean-3.7
+# tar caf xbean-3.7.tar.xz xbean-3.7
+Source0: xbean-%{version}.tar.xz
+Source1: xbean.depmap
+
+BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
+
+Patch0: pom-%{version}.patch
+
+BuildRequires: java-devel
+BuildRequires: apache-commons-beanutils
+BuildRequires: apache-commons-logging
+BuildRequires: mx4j
+BuildRequires: objectweb-asm
+BuildRequires: ant
+BuildRequires: qdox
+BuildRequires: slf4j
+BuildRequires: felix-osgi-core >= 1.4.0
+BuildRequires: maven-plugin-bundle
+BuildRequires: maven-antrun-plugin
+BuildRequires: maven-compiler-plugin
+BuildRequires: maven-idea-plugin
+BuildRequires: maven-install-plugin
+BuildRequires: maven-javadoc-plugin
+BuildRequires: maven-resources-plugin
+BuildRequires: maven-surefire-maven-plugin
+BuildRequires: maven-site-plugin
+BuildRequires: maven2-plugin-shade
+
+Requires: java
+Requires: objectweb-asm
+Requires: apache-commons-logging
+
+
+%description
+The goal of XBean project is to create a plugin based server
+analogous to Eclipse being a plugin based IDE. XBean will be able to
+discover, download and install server plugins from an Internet based
+repository. In addition, we include support for multiple IoC systems,
+support for running with no IoC system, JMX without JMX code,
+lifecycle and class loader management, and a rock solid Spring
+integration.
+
+%package javadoc
+Summary: API documentation for %{name}
+Group: Documentation
+Requires: jpackage-utils
+
+%description javadoc
+%{summary}.
+
+%prep
+%setup -q
+# build failing on this due to doxia-sitetools problems
+rm src/site/site.xml
+
+# removes dependency on springframework and prevents building of
+# modules depending on it. If other modules are required,
+# springframework will have to be brought in first
+%patch0 -p1
+
+# Fix dependency on xbean-asm-shaded to original objectweb-asm
+sed -i 's/org.apache.xbean.asm/org.objectweb.asm/' \
+ xbean-reflect/src/main/java/org/apache/xbean/recipe/XbeanAsmParameterNameLoader.java
+
+%build
+export MAVEN_REPO_LOCAL=$(pwd)/.m2/repository
+mvn-jpp -e \
+ -Dmaven.repo.local=$MAVEN_REPO_LOCAL \
+ -Dmaven2.jpp.depmap.file="%{SOURCE1}" \
+ install javadoc:javadoc
+
+
+%install
+rm -rf $RPM_BUILD_ROOT
+
+# for every module we want to be built
+for sub in reflect naming classpath; do
+ # install jar
+ install -Dpm 644 %{name}-${sub}/target/%{name}-${sub}-%{version}.jar \
+ $RPM_BUILD_ROOT/%{_javadir}/xbean/%{name}-${sub}-%{version}.jar;
+
+ # intall pom
+ install -Dpm 644 %{name}-${sub}/pom.xml $RPM_BUILD_ROOT/%{_mavenpomdir}/JPP-%{name}-${sub}.pom
+
+ # maven depmap
+ %add_to_maven_depmap org.apache.xbean %{name}-${sub} %{version} JPP/xbean %{name}-${sub}
+
+ # javadoc
+ install -d -m 755 $RPM_BUILD_ROOT%{_javadocdir}/%{name}-%{version}/%{name}-${sub}-%{version}
+ cp -pr %{name}-${sub}/target/site/apidocs/* $RPM_BUILD_ROOT%{_javadocdir}/%{name}-%{version}/%{name}-${sub}-%{version}
+done
+ln -sf %{name}-%{version} $RPM_BUILD_ROOT%{_javadocdir}/%{name}
+
+# unversioned symlinks
+pushd $RPM_BUILD_ROOT%{_javadir}/%{name}
+for jar in *-%{version}*; do
+ ln -sf ${jar} `echo $jar| sed "s|-%{version}||g"`
+done
+popd # come back from javadir
+
+# parent pom
+install -pm 644 pom.xml $RPM_BUILD_ROOT/%{_mavenpomdir}/JPP-%{name}.pom
+
+%clean
+rm -rf $RPM_BUILD_ROOT
+
+%post
+%update_maven_depmap
+
+%postun
+%update_maven_depmap
+
+%files
+%defattr(-,root,root,-)
+%doc LICENSE NOTICE
+%{_mavenpomdir}/JPP-*.pom
+%{_mavendepmapfragdir}/%{name}
+%{_javadir}/%{name}
+
+%files javadoc
+%defattr(-,root,root,-)
+%doc LICENSE
+%{_javadocdir}/%{name}
+%{_javadocdir}/%{name}-%{version}
+
+%changelog
+* Fri Jul 9 2010 Stanislav Ochotnicky - 3.7-2
+- Add license to javadoc subpackage
+
+* Mon Jun 21 2010 Stanislav Ochotnicky - 3.7-1
+- First release
+