3.12.0-8 - Add valgrind-3.12.0-ppc64-isa-3_00.patch
This commit is contained in:
parent
27f6306ee9
commit
05a0f7b232
54
valgrind-3.12.0-ppc64-isa-3_00.patch
Normal file
54
valgrind-3.12.0-ppc64-isa-3_00.patch
Normal file
@ -0,0 +1,54 @@
|
||||
PPC64: ISA 3.0 setup fixes.
|
||||
|
||||
There is a typo in the configure.ac file that causes the HAS_ISA_3_00
|
||||
variable to not be set.
|
||||
|
||||
The mask64 value is missing the HWCAPS bit for ISA3.0.
|
||||
bugzilla
|
||||
---
|
||||
VEX/priv/guest_ppc_toIR.c | 2 +-
|
||||
configure.ac | 2 +-
|
||||
2 files changed, 2 insertions(+), 2 deletions(-)
|
||||
|
||||
diff --git a/VEX/priv/guest_ppc_toIR.c b/VEX/priv/guest_ppc_toIR.c
|
||||
index 0d27389..6fede61 100644
|
||||
--- a/VEX/priv/guest_ppc_toIR.c
|
||||
+++ b/VEX/priv/guest_ppc_toIR.c
|
||||
@@ -29122,7 +29122,7 @@ DisResult disInstr_PPC ( IRSB* irsb_IN,
|
||||
|
||||
mask64 = VEX_HWCAPS_PPC64_V | VEX_HWCAPS_PPC64_FX
|
||||
| VEX_HWCAPS_PPC64_GX | VEX_HWCAPS_PPC64_VX | VEX_HWCAPS_PPC64_DFP
|
||||
- | VEX_HWCAPS_PPC64_ISA2_07;
|
||||
+ | VEX_HWCAPS_PPC64_ISA2_07 | VEX_HWCAPS_PPC64_ISA3_0;
|
||||
|
||||
if (mode64) {
|
||||
vassert((hwcaps_guest & mask32) == 0);
|
||||
diff --git a/configure.ac b/configure.ac
|
||||
index 587917b..4c3cc58 100644
|
||||
--- a/configure.ac
|
||||
+++ b/configure.ac
|
||||
@@ -1537,7 +1537,7 @@ ac_asm_have_isa_3_00=no
|
||||
AC_MSG_RESULT([no])
|
||||
])
|
||||
|
||||
-AM_CONDITIONAL(HAS_ISA_3_00, test x$ac_asm_have_isa_3_00 = xyes \
|
||||
+AM_CONDITIONAL(HAS_ISA_3_00, [test x$ac_asm_have_isa_3_00 = xyes \
|
||||
-a x$HWCAP_HAS_ISA_3_00 = xyes])
|
||||
|
||||
# Check for pthread_create@GLIBC2.0
|
||||
--
|
||||
1.8.3.1
|
||||
|
||||
Only in valgrind-3.12.0: autom4te.cache
|
||||
diff -ur valgrind-3.12.0.orig/configure valgrind-3.12.0/configure
|
||||
--- valgrind-3.12.0.orig/configure 2016-12-16 16:52:17.101832444 +0100
|
||||
+++ valgrind-3.12.0/configure 2017-03-28 23:38:32.997776458 +0200
|
||||
@@ -8122,7 +8122,7 @@
|
||||
rm -f core conftest.err conftest.$ac_objext conftest.$ac_ext
|
||||
|
||||
if test x$ac_asm_have_isa_3_00 = xyes \
|
||||
- -a x$HWCAP_HAS_ISA_3_00 = xyes]; then
|
||||
+ -a x$HWCAP_HAS_ISA_3_00 = xyes; then
|
||||
HAS_ISA_3_00_TRUE=
|
||||
HAS_ISA_3_00_FALSE='#'
|
||||
else
|
@ -3,7 +3,7 @@
|
||||
Summary: Tool for finding memory management bugs in programs
|
||||
Name: %{?scl_prefix}valgrind
|
||||
Version: 3.12.0
|
||||
Release: 7%{?dist}
|
||||
Release: 8%{?dist}
|
||||
Epoch: 1
|
||||
License: GPLv2+
|
||||
URL: http://www.valgrind.org/
|
||||
@ -130,6 +130,9 @@ Patch18: valgrind-3.12.0-aarch64-syscalls.patch
|
||||
# stxssp, lxsd, lxssp instructions
|
||||
Patch19: valgrind-3.12.0-powerpc-register-pair.patch
|
||||
|
||||
# KDE#377478 PPC64: ISA 3.0 setup fixes
|
||||
Patch20: valgrind-3.12.0-ppc64-isa-3_00.patch
|
||||
|
||||
%if %{build_multilib}
|
||||
# Ensure glibc{,-devel} is installed for both multilib arches
|
||||
BuildRequires: /lib/libc.so.6 /usr/lib/libc.so /lib64/libc.so.6 /usr/lib64/libc.so
|
||||
@ -258,6 +261,7 @@ Valgrind User Manual for details.
|
||||
%patch17 -p1
|
||||
%patch18 -p1
|
||||
%patch19 -p1
|
||||
%patch20 -p1
|
||||
|
||||
%build
|
||||
# We need to use the software collection compiler and binutils if available.
|
||||
@ -451,8 +455,9 @@ echo ===============END TESTING===============
|
||||
%endif
|
||||
|
||||
%changelog
|
||||
* Tue Mar 28 2017 Mark Wielaard <mjw@redhat.com>
|
||||
* Tue Mar 28 2017 Mark Wielaard <mjw@redhat.com> - 3.12.0-8
|
||||
- Add valgrind-3.12.0-powerpc-register-pair.patch
|
||||
- Add valgrind-3.12.0-ppc64-isa-3_00.patch
|
||||
|
||||
* Sat Feb 18 2017 Mark Wielaard <mjw@redhat.com> - 3.12.0-7
|
||||
- Add valgrind-3.12.0-aarch64-syscalls.patch
|
||||
|
Loading…
Reference in New Issue
Block a user