55 lines
1.8 KiB
Diff
55 lines
1.8 KiB
Diff
PPC64: ISA 3.0 setup fixes.
|
|
|
|
There is a typo in the configure.ac file that causes the HAS_ISA_3_00
|
|
variable to not be set.
|
|
|
|
The mask64 value is missing the HWCAPS bit for ISA3.0.
|
|
bugzilla
|
|
---
|
|
VEX/priv/guest_ppc_toIR.c | 2 +-
|
|
configure.ac | 2 +-
|
|
2 files changed, 2 insertions(+), 2 deletions(-)
|
|
|
|
diff --git a/VEX/priv/guest_ppc_toIR.c b/VEX/priv/guest_ppc_toIR.c
|
|
index 0d27389..6fede61 100644
|
|
--- a/VEX/priv/guest_ppc_toIR.c
|
|
+++ b/VEX/priv/guest_ppc_toIR.c
|
|
@@ -29122,7 +29122,7 @@ DisResult disInstr_PPC ( IRSB* irsb_IN,
|
|
|
|
mask64 = VEX_HWCAPS_PPC64_V | VEX_HWCAPS_PPC64_FX
|
|
| VEX_HWCAPS_PPC64_GX | VEX_HWCAPS_PPC64_VX | VEX_HWCAPS_PPC64_DFP
|
|
- | VEX_HWCAPS_PPC64_ISA2_07;
|
|
+ | VEX_HWCAPS_PPC64_ISA2_07 | VEX_HWCAPS_PPC64_ISA3_0;
|
|
|
|
if (mode64) {
|
|
vassert((hwcaps_guest & mask32) == 0);
|
|
diff --git a/configure.ac b/configure.ac
|
|
index 587917b..4c3cc58 100644
|
|
--- a/configure.ac
|
|
+++ b/configure.ac
|
|
@@ -1537,7 +1537,7 @@ ac_asm_have_isa_3_00=no
|
|
AC_MSG_RESULT([no])
|
|
])
|
|
|
|
-AM_CONDITIONAL(HAS_ISA_3_00, test x$ac_asm_have_isa_3_00 = xyes \
|
|
+AM_CONDITIONAL(HAS_ISA_3_00, [test x$ac_asm_have_isa_3_00 = xyes \
|
|
-a x$HWCAP_HAS_ISA_3_00 = xyes])
|
|
|
|
# Check for pthread_create@GLIBC2.0
|
|
--
|
|
1.8.3.1
|
|
|
|
Only in valgrind-3.12.0: autom4te.cache
|
|
diff -ur valgrind-3.12.0.orig/configure valgrind-3.12.0/configure
|
|
--- valgrind-3.12.0.orig/configure 2016-12-16 16:52:17.101832444 +0100
|
|
+++ valgrind-3.12.0/configure 2017-03-28 23:38:32.997776458 +0200
|
|
@@ -8122,7 +8122,7 @@
|
|
rm -f core conftest.err conftest.$ac_objext conftest.$ac_ext
|
|
|
|
if test x$ac_asm_have_isa_3_00 = xyes \
|
|
- -a x$HWCAP_HAS_ISA_3_00 = xyes]; then
|
|
+ -a x$HWCAP_HAS_ISA_3_00 = xyes; then
|
|
HAS_ISA_3_00_TRUE=
|
|
HAS_ISA_3_00_FALSE='#'
|
|
else
|