894b42f522
- fix #218915 - fdisk -b 4K - upgrade to -pre7 release - fix building problem with raw0 patch - fix #217186 - /bin/sh: @MKINSTALLDIRS@: No such file or directory (port po/Makefile.in.in from gettext-0.16) - sync with FC6 and RHEL5: - fix #216489 - SCHED_BATCH option missing in chrt - fix #216712 - issues with raw device support ("raw0" is wrong device name) - fix #216760 - mount with context or fscontext option fails (temporarily disabled the support for additional contexts -- not supported by kernel yet) - fix #211827 - Can't mount with additional contexts - fix #213127 - mount --make-unbindable does not work - fix #211749 - add -r option to losetup to create a read-only loop - Resolves: rhbz#218915 rhbz#217186 rhbz#216489 rhbz#216712 rhbz#216760 rhbz#211827 rhbz#213127 rhbz#211749
16 lines
561 B
Diff
16 lines
561 B
Diff
|
|
The "-b" option allows to manually define size of sector size. We need to support
|
|
4096 bytes for really huge disks. [kzak 12/14/2006]
|
|
|
|
--- util-linux-2.13-pre7/fdisk/fdisk.c.kzak 2006-12-14 10:21:57.000000000 +0100
|
|
+++ util-linux-2.13-pre7/fdisk/fdisk.c 2006-12-14 10:22:21.000000000 +0100
|
|
@@ -2491,7 +2491,7 @@
|
|
*/
|
|
sector_size = atoi(optarg);
|
|
if (sector_size != 512 && sector_size != 1024 &&
|
|
- sector_size != 2048)
|
|
+ sector_size != 2048 && sector_size != 4096)
|
|
fatal(usage);
|
|
sector_offset = 2;
|
|
user_set_sector_size = 1;
|