894b42f522
- fix #218915 - fdisk -b 4K - upgrade to -pre7 release - fix building problem with raw0 patch - fix #217186 - /bin/sh: @MKINSTALLDIRS@: No such file or directory (port po/Makefile.in.in from gettext-0.16) - sync with FC6 and RHEL5: - fix #216489 - SCHED_BATCH option missing in chrt - fix #216712 - issues with raw device support ("raw0" is wrong device name) - fix #216760 - mount with context or fscontext option fails (temporarily disabled the support for additional contexts -- not supported by kernel yet) - fix #211827 - Can't mount with additional contexts - fix #213127 - mount --make-unbindable does not work - fix #211749 - add -r option to losetup to create a read-only loop - Resolves: rhbz#218915 rhbz#217186 rhbz#216489 rhbz#216712 rhbz#216760 rhbz#211827 rhbz#213127 rhbz#211749
123 lines
4.2 KiB
Diff
123 lines
4.2 KiB
Diff
--- util-linux-2.13-pre6/po/Makefile.in.in.mkdir_p 2005-10-14 22:22:14.000000000 +0200
|
|
+++ util-linux-2.13-pre6/po/Makefile.in.in 2006-10-24 22:48:30.000000000 +0200
|
|
@@ -1,5 +1,5 @@
|
|
# Makefile for PO directory in any package using GNU gettext.
|
|
-# Copyright (C) 1995-1997, 2000-2005 by Ulrich Drepper <drepper@gnu.ai.mit.edu>
|
|
+# Copyright (C) 1995-1997, 2000-2006 by Ulrich Drepper <drepper@gnu.ai.mit.edu>
|
|
#
|
|
# This file can be copied and used freely without restrictions. It can
|
|
# be used in projects which are not available under the GNU General Public
|
|
@@ -8,7 +8,7 @@
|
|
# Please note that the actual code of GNU gettext is covered by the GNU
|
|
# General Public License and is *not* in the public domain.
|
|
#
|
|
-# Origin: gettext-0.14.4
|
|
+# Origin: gettext-0.16
|
|
|
|
PACKAGE = @PACKAGE@
|
|
VERSION = @VERSION@
|
|
@@ -23,18 +23,38 @@
|
|
|
|
prefix = @prefix@
|
|
exec_prefix = @exec_prefix@
|
|
-datadir = $(prefix)/usr/share
|
|
-localedir = $(datadir)/locale
|
|
+datarootdir = @datarootdir@
|
|
+datadir = @datadir@
|
|
+localedir = @localedir@
|
|
gettextsrcdir = $(datadir)/gettext/po
|
|
|
|
INSTALL = @INSTALL@
|
|
INSTALL_DATA = @INSTALL_DATA@
|
|
-MKINSTALLDIRS = @MKINSTALLDIRS@
|
|
-mkinstalldirs = $(SHELL) $(MKINSTALLDIRS)
|
|
|
|
-GMSGFMT = @GMSGFMT@
|
|
-MSGFMT = @MSGFMT@
|
|
-XGETTEXT = @XGETTEXT@
|
|
+# We use $(mkdir_p).
|
|
+# In automake <= 1.9.x, $(mkdir_p) is defined either as "mkdir -p --" or as
|
|
+# "$(mkinstalldirs)" or as "$(install_sh) -d". For these automake versions,
|
|
+# @install_sh@ does not start with $(SHELL), so we add it.
|
|
+# In automake >= 1.10, @mkdir_p@ is derived from ${MKDIR_P}, which is defined
|
|
+# either as "/path/to/mkdir -p" or ".../install-sh -c -d". For these automake
|
|
+# versions, $(mkinstalldirs) and $(install_sh) are unused.
|
|
+mkinstalldirs = $(SHELL) @install_sh@ -d
|
|
+install_sh = $(SHELL) @install_sh@
|
|
+MKDIR_P = @MKDIR_P@
|
|
+mkdir_p = @mkdir_p@
|
|
+
|
|
+GMSGFMT_ = @GMSGFMT@
|
|
+GMSGFMT_no = @GMSGFMT@
|
|
+GMSGFMT_yes = @GMSGFMT_015@
|
|
+GMSGFMT = $(GMSGFMT_$(USE_MSGCTXT))
|
|
+MSGFMT_ = @MSGFMT@
|
|
+MSGFMT_no = @MSGFMT@
|
|
+MSGFMT_yes = @MSGFMT_015@
|
|
+MSGFMT = $(MSGFMT_$(USE_MSGCTXT))
|
|
+XGETTEXT_ = @XGETTEXT@
|
|
+XGETTEXT_no = @XGETTEXT@
|
|
+XGETTEXT_yes = @XGETTEXT_015@
|
|
+XGETTEXT = $(XGETTEXT_$(USE_MSGCTXT))
|
|
MSGMERGE = msgmerge
|
|
MSGMERGE_UPDATE = @MSGMERGE@ --update
|
|
MSGINIT = msginit
|
|
@@ -158,7 +178,7 @@
|
|
install-exec:
|
|
install-data: install-data-@USE_NLS@
|
|
if test "$(PACKAGE)" = "gettext-tools"; then \
|
|
- $(mkinstalldirs) $(DESTDIR)$(gettextsrcdir); \
|
|
+ $(mkdir_p) $(DESTDIR)$(gettextsrcdir); \
|
|
for file in $(DISTFILES.common) Makevars.template; do \
|
|
$(INSTALL_DATA) $(srcdir)/$$file \
|
|
$(DESTDIR)$(gettextsrcdir)/$$file; \
|
|
@@ -171,13 +191,13 @@
|
|
fi
|
|
install-data-no: all
|
|
install-data-yes: all
|
|
- $(mkinstalldirs) $(DESTDIR)$(datadir)
|
|
+ $(mkdir_p) $(DESTDIR)$(datadir)
|
|
@catalogs='$(CATALOGS)'; \
|
|
for cat in $$catalogs; do \
|
|
cat=`basename $$cat`; \
|
|
lang=`echo $$cat | sed -e 's/\.gmo$$//'`; \
|
|
dir=$(localedir)/$$lang/LC_MESSAGES; \
|
|
- $(mkinstalldirs) $(DESTDIR)$$dir; \
|
|
+ $(mkdir_p) $(DESTDIR)$$dir; \
|
|
if test -r $$cat; then realcat=$$cat; else realcat=$(srcdir)/$$cat; fi; \
|
|
$(INSTALL_DATA) $$realcat $(DESTDIR)$$dir/$(DOMAIN).mo; \
|
|
echo "installing $$realcat as $(DESTDIR)$$dir/$(DOMAIN).mo"; \
|
|
@@ -217,19 +237,19 @@
|
|
installdirs-exec:
|
|
installdirs-data: installdirs-data-@USE_NLS@
|
|
if test "$(PACKAGE)" = "gettext-tools"; then \
|
|
- $(mkinstalldirs) $(DESTDIR)$(gettextsrcdir); \
|
|
+ $(mkdir_p) $(DESTDIR)$(gettextsrcdir); \
|
|
else \
|
|
: ; \
|
|
fi
|
|
installdirs-data-no:
|
|
installdirs-data-yes:
|
|
- $(mkinstalldirs) $(DESTDIR)$(datadir)
|
|
+ $(mkdir_p) $(DESTDIR)$(datadir)
|
|
@catalogs='$(CATALOGS)'; \
|
|
for cat in $$catalogs; do \
|
|
cat=`basename $$cat`; \
|
|
lang=`echo $$cat | sed -e 's/\.gmo$$//'`; \
|
|
dir=$(localedir)/$$lang/LC_MESSAGES; \
|
|
- $(mkinstalldirs) $(DESTDIR)$$dir; \
|
|
+ $(mkdir_p) $(DESTDIR)$$dir; \
|
|
for lc in '' $(EXTRA_LOCALE_CATEGORIES); do \
|
|
if test -n "$$lc"; then \
|
|
if (cd $(DESTDIR)$(localedir)/$$lang && LC_ALL=C ls -l -d $$lc 2>/dev/null) | grep ' -> ' >/dev/null; then \
|
|
@@ -374,8 +394,7 @@
|
|
|
|
Makefile: Makefile.in.in Makevars $(top_builddir)/config.status @POMAKEFILEDEPS@
|
|
cd $(top_builddir) \
|
|
- && CONFIG_FILES=$(subdir)/$@.in CONFIG_HEADERS= \
|
|
- $(SHELL) ./config.status
|
|
+ && $(SHELL) ./config.status $(subdir)/$@.in po-directories
|
|
|
|
force:
|
|
|