2.39-0.1: upgrade to -rc1
This commit is contained in:
parent
a04c11370c
commit
a228e53a4b
1
.gitignore
vendored
1
.gitignore
vendored
@ -87,3 +87,4 @@
|
|||||||
/util-linux-2.38-rc3.tar.xz
|
/util-linux-2.38-rc3.tar.xz
|
||||||
/util-linux-2.38.tar.xz
|
/util-linux-2.38.tar.xz
|
||||||
/util-linux-2.38.1.tar.xz
|
/util-linux-2.38.1.tar.xz
|
||||||
|
/util-linux-2.39-rc1.tar.xz
|
||||||
|
2
sources
2
sources
@ -1 +1 @@
|
|||||||
SHA512 (util-linux-2.38.1.tar.xz) = 07f11147f67dfc6c8bc766dfc83266054e6ede776feada0566b447d13276b6882ee85c6fe53e8d94a17c03332106fc0549deca3cf5f2e92dda554e9bc0551957
|
SHA512 (util-linux-2.39-rc1.tar.xz) = e9981d7c65eed7cd3f96f590e2190c7c804b1767464c821cd9277c72aaf38b8407f324cf9e8f3b96eb96359a0746f21a01dfb6baa504f49c8c7e1aff2dc956b3
|
||||||
|
@ -1,46 +0,0 @@
|
|||||||
commit 84732a8849a08d42a9a95dcbee9005116be78eb8
|
|
||||||
Author: Khem Raj <raj.khem@gmail.com>
|
|
||||||
Date: Sun Aug 7 14:39:19 2022 -0700
|
|
||||||
|
|
||||||
check for sys/pidfd.h
|
|
||||||
|
|
||||||
This header in newer glibc defines the signatures of functions
|
|
||||||
pidfd_send_signal() and pidfd_open() and when these functions are
|
|
||||||
defined by libc then we need to include the relevant header to get
|
|
||||||
the definitions. Clang 15+ has started to error out when function
|
|
||||||
signatures are missing.
|
|
||||||
|
|
||||||
Fixes errors like
|
|
||||||
misc-utils/kill.c:402:6: error: call to undeclared function 'pidfd_send_signal'; ISO C99 and later do not support implicit function declarations [-Wimplicit-function-declaration]
|
|
||||||
if (pidfd_send_signal(pfd, ctl->numsig, &info, 0) < 0)
|
|
||||||
|
|
||||||
Signed-off-by: Khem Raj <raj.khem@gmail.com>
|
|
||||||
|
|
||||||
diff --git a/configure.ac b/configure.ac
|
|
||||||
index d8b4d475103c2bab..4a35d17f81375c29 100644
|
|
||||||
--- a/configure.ac
|
|
||||||
+++ b/configure.ac
|
|
||||||
@@ -339,6 +339,7 @@ AC_CHECK_HEADERS([ \
|
|
||||||
sys/mkdev.h \
|
|
||||||
sys/mount.h \
|
|
||||||
sys/param.h \
|
|
||||||
+ sys/pidfd.h \
|
|
||||||
sys/prctl.h \
|
|
||||||
sys/resource.h \
|
|
||||||
sys/sendfile.h \
|
|
||||||
diff --git a/include/pidfd-utils.h b/include/pidfd-utils.h
|
|
||||||
index eddede9767478be2..d9e33cbc57ae38c8 100644
|
|
||||||
--- a/include/pidfd-utils.h
|
|
||||||
+++ b/include/pidfd-utils.h
|
|
||||||
@@ -4,8 +4,10 @@
|
|
||||||
#ifdef HAVE_SYS_SYSCALL_H
|
|
||||||
# include <sys/syscall.h>
|
|
||||||
# if defined(SYS_pidfd_send_signal) && defined(SYS_pidfd_open)
|
|
||||||
+# ifdef HAVE_SYS_PIDFD_H
|
|
||||||
+# include <sys/pidfd.h>
|
|
||||||
+# endif
|
|
||||||
# include <sys/types.h>
|
|
||||||
-
|
|
||||||
# ifndef HAVE_PIDFD_SEND_SIGNAL
|
|
||||||
static inline int pidfd_send_signal(int pidfd, int sig, siginfo_t *info,
|
|
||||||
unsigned int flags)
|
|
@ -1,13 +1,13 @@
|
|||||||
### Header
|
### Header
|
||||||
Summary: Collection of basic system utilities
|
Summary: Collection of basic system utilities
|
||||||
Name: util-linux
|
Name: util-linux
|
||||||
Version: 2.38.1
|
Version: 2.39
|
||||||
Release: 4%{?dist}
|
Release: 0.1%{?dist}
|
||||||
License: GPLv2 and GPLv2+ and LGPLv2+ and BSD with advertising and Public Domain
|
License: GPLv2 and GPLv2+ and LGPLv2+ and BSD with advertising and Public Domain
|
||||||
URL: https://en.wikipedia.org/wiki/Util-linux
|
URL: https://en.wikipedia.org/wiki/Util-linux
|
||||||
|
|
||||||
### Macros
|
### Macros
|
||||||
%global upstream_version %{version}
|
%global upstream_version %{version}-rc1
|
||||||
%global upstream_major %(eval echo %{version} | sed -e 's/\([[:digit:]]*\)\.\([[:digit:]]*\)\.[[:digit:]]*$/\1.\2/')
|
%global upstream_major %(eval echo %{version} | sed -e 's/\([[:digit:]]*\)\.\([[:digit:]]*\)\.[[:digit:]]*$/\1.\2/')
|
||||||
|
|
||||||
%global compldir %{_datadir}/bash-completion/completions/
|
%global compldir %{_datadir}/bash-completion/completions/
|
||||||
@ -93,7 +93,10 @@ Patch0: login-lastlog-create.patch
|
|||||||
# Add `/run/motd.d` to the hardcoded MOTD_FILE
|
# Add `/run/motd.d` to the hardcoded MOTD_FILE
|
||||||
# https://github.com/coreos/console-login-helper-messages/issues/60
|
# https://github.com/coreos/console-login-helper-messages/issues/60
|
||||||
Patch1: login-default-motd-file.patch
|
Patch1: login-default-motd-file.patch
|
||||||
Patch2: util-linux-kill-c99.patch
|
# upstream, already in >= v2.39-rc2
|
||||||
|
Patch2: libmount-dont-ignore-autofs-mounts-by-default.patch
|
||||||
|
Patch3: mount-ignore-autofs-entries-in-mount-listing.patch
|
||||||
|
|
||||||
|
|
||||||
%description
|
%description
|
||||||
The util-linux package contains a large variety of low-level system
|
The util-linux package contains a large variety of low-level system
|
||||||
@ -289,7 +292,7 @@ chfn and chsh utilities with dependence on libuser.
|
|||||||
unset LINGUAS || :
|
unset LINGUAS || :
|
||||||
|
|
||||||
# enable only when make a change to the build-system
|
# enable only when make a change to the build-system
|
||||||
./autogen.sh
|
#./autogen.sh
|
||||||
|
|
||||||
|
|
||||||
export CFLAGS="-D_LARGEFILE_SOURCE -D_LARGEFILE64_SOURCE -D_FILE_OFFSET_BITS=64 $RPM_OPT_FLAGS"
|
export CFLAGS="-D_LARGEFILE_SOURCE -D_LARGEFILE64_SOURCE -D_FILE_OFFSET_BITS=64 $RPM_OPT_FLAGS"
|
||||||
@ -491,6 +494,7 @@ fi
|
|||||||
%{_bindir}/eject
|
%{_bindir}/eject
|
||||||
%{_bindir}/fallocate
|
%{_bindir}/fallocate
|
||||||
%{_bindir}/fincore
|
%{_bindir}/fincore
|
||||||
|
%{_bindir}/fadvise
|
||||||
%{_bindir}/getopt
|
%{_bindir}/getopt
|
||||||
%{_bindir}/hexdump
|
%{_bindir}/hexdump
|
||||||
%{_bindir}/irqtop
|
%{_bindir}/irqtop
|
||||||
@ -510,6 +514,7 @@ fi
|
|||||||
%{_bindir}/mcookie
|
%{_bindir}/mcookie
|
||||||
%{_bindir}/mesg
|
%{_bindir}/mesg
|
||||||
%{_bindir}/namei
|
%{_bindir}/namei
|
||||||
|
%{_bindir}/pipesz
|
||||||
%{_bindir}/prlimit
|
%{_bindir}/prlimit
|
||||||
%{_bindir}/rename
|
%{_bindir}/rename
|
||||||
%{_bindir}/rev
|
%{_bindir}/rev
|
||||||
@ -524,6 +529,7 @@ fi
|
|||||||
%{_bindir}/utmpdump
|
%{_bindir}/utmpdump
|
||||||
%{_bindir}/uuidgen
|
%{_bindir}/uuidgen
|
||||||
%{_bindir}/uuidparse
|
%{_bindir}/uuidparse
|
||||||
|
%{_bindir}/waitpid
|
||||||
%{_bindir}/wall
|
%{_bindir}/wall
|
||||||
%{_bindir}/wdctl
|
%{_bindir}/wdctl
|
||||||
%{_bindir}/whereis
|
%{_bindir}/whereis
|
||||||
@ -534,6 +540,7 @@ fi
|
|||||||
%{_mandir}/man1/colrm.1*
|
%{_mandir}/man1/colrm.1*
|
||||||
%{_mandir}/man1/column.1*
|
%{_mandir}/man1/column.1*
|
||||||
%{_mandir}/man1/eject.1*
|
%{_mandir}/man1/eject.1*
|
||||||
|
%{_mandir}/man1/fadvise.1.*
|
||||||
%{_mandir}/man1/fallocate.1*
|
%{_mandir}/man1/fallocate.1*
|
||||||
%{_mandir}/man1/fincore.1*
|
%{_mandir}/man1/fincore.1*
|
||||||
%{_mandir}/man1/getopt.1*
|
%{_mandir}/man1/getopt.1*
|
||||||
@ -552,6 +559,7 @@ fi
|
|||||||
%{_mandir}/man1/mcookie.1*
|
%{_mandir}/man1/mcookie.1*
|
||||||
%{_mandir}/man1/mesg.1*
|
%{_mandir}/man1/mesg.1*
|
||||||
%{_mandir}/man1/namei.1*
|
%{_mandir}/man1/namei.1*
|
||||||
|
%{_mandir}/man1/pipesz.1.*
|
||||||
%{_mandir}/man1/prlimit.1*
|
%{_mandir}/man1/prlimit.1*
|
||||||
%{_mandir}/man1/rename.1*
|
%{_mandir}/man1/rename.1*
|
||||||
%{_mandir}/man1/rev.1*
|
%{_mandir}/man1/rev.1*
|
||||||
@ -567,6 +575,7 @@ fi
|
|||||||
%{_mandir}/man1/utmpdump.1.gz
|
%{_mandir}/man1/utmpdump.1.gz
|
||||||
%{_mandir}/man1/uuidgen.1*
|
%{_mandir}/man1/uuidgen.1*
|
||||||
%{_mandir}/man1/uuidparse.1*
|
%{_mandir}/man1/uuidparse.1*
|
||||||
|
%{_mandir}/man1/waitpid.1.*
|
||||||
%{_mandir}/man1/wall.1*
|
%{_mandir}/man1/wall.1*
|
||||||
%{_mandir}/man1/whereis.1*
|
%{_mandir}/man1/whereis.1*
|
||||||
%{_mandir}/man1/write.1*
|
%{_mandir}/man1/write.1*
|
||||||
@ -574,6 +583,7 @@ fi
|
|||||||
%{_mandir}/man5/terminal-colors.d.5*
|
%{_mandir}/man5/terminal-colors.d.5*
|
||||||
%{_mandir}/man8/addpart.8*
|
%{_mandir}/man8/addpart.8*
|
||||||
%{_mandir}/man8/blkdiscard.8*
|
%{_mandir}/man8/blkdiscard.8*
|
||||||
|
%{_mandir}/man8/blkpr.8.*
|
||||||
%{_mandir}/man8/blkzone.8*
|
%{_mandir}/man8/blkzone.8*
|
||||||
%{_mandir}/man8/chcpu.8*
|
%{_mandir}/man8/chcpu.8*
|
||||||
%{_mandir}/man8/chmem.8*
|
%{_mandir}/man8/chmem.8*
|
||||||
@ -607,6 +617,7 @@ fi
|
|||||||
%{_mandir}/man8/zramctl.8*
|
%{_mandir}/man8/zramctl.8*
|
||||||
%{_sbindir}/addpart
|
%{_sbindir}/addpart
|
||||||
%{_sbindir}/blkdiscard
|
%{_sbindir}/blkdiscard
|
||||||
|
%{_sbindir}/blkpr
|
||||||
%{_sbindir}/blkzone
|
%{_sbindir}/blkzone
|
||||||
%{_sbindir}/chcpu
|
%{_sbindir}/chcpu
|
||||||
%{_sbindir}/ctrlaltdel
|
%{_sbindir}/ctrlaltdel
|
||||||
@ -676,6 +687,7 @@ fi
|
|||||||
%{compldir}/mkfs.cramfs
|
%{compldir}/mkfs.cramfs
|
||||||
%{compldir}/mkfs.minix
|
%{compldir}/mkfs.minix
|
||||||
%{compldir}/namei
|
%{compldir}/namei
|
||||||
|
%{compldir}/pipesz
|
||||||
%{compldir}/pivot_root
|
%{compldir}/pivot_root
|
||||||
%{compldir}/prlimit
|
%{compldir}/prlimit
|
||||||
%{compldir}/readprofile
|
%{compldir}/readprofile
|
||||||
@ -910,6 +922,10 @@ fi
|
|||||||
%{_libdir}/python*/site-packages/libmount/
|
%{_libdir}/python*/site-packages/libmount/
|
||||||
|
|
||||||
%changelog
|
%changelog
|
||||||
|
* Mon Mar 20 2023 Karel Zak <kzak@redhat.com> - 2.39-0.1
|
||||||
|
- upgrade to v2.39-rc1
|
||||||
|
https://kernel.org/pub/linux/utils/util-linux/v2.39/v2.39-ReleaseNotes
|
||||||
|
|
||||||
* Sat Jan 21 2023 Fedora Release Engineering <releng@fedoraproject.org> - 2.38.1-4
|
* Sat Jan 21 2023 Fedora Release Engineering <releng@fedoraproject.org> - 2.38.1-4
|
||||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_38_Mass_Rebuild
|
- Rebuilt for https://fedoraproject.org/wiki/Fedora_38_Mass_Rebuild
|
||||||
|
|
||||||
|
Loading…
Reference in New Issue
Block a user