auto-import changelog data from util-linux-2.11y-9.src.rpm
Mon Feb 24 2003 Elliot Lee <sopwith@redhat.com> - rebuilt Wed Feb 19 2003 Elliot Lee <sopwith@redhat.com> 2.11y-8 - ipcs-84243.patch to fix #84243 Thu Feb 13 2003 Yukihiro Nakai <ynakai@redhat.com> 2.11y-7 - Update moremisc patch to fix swprintf()'s minimum field (bug #83361). Mon Feb 03 2003 Elliot Lee <sopwith@redhat.com> 2.11y-6 - Fix mcookie segfault on many 64-bit architectures (bug #83345). Mon Feb 03 2003 Tim Waugh <twaugh@redhat.com> 2.11y-5 - Fix underlined multibyte characters (bug #83376). Sun Feb 02 2003 Florian La Roche <Florian.LaRoche@redhat.de> - rebuild to have again a s390 rpm - disable some more apps for mainframe Wed Jan 29 2003 Elliot Lee <sopwith@redhat.com> 2.11y-4 - util-linux-2.11y-umask-82552.patch Wed Jan 22 2003 Tim Powers <timp@redhat.com> - rebuilt Mon Jan 13 2003 Elliot Lee <sopwith@redhat.com> 2.11y-2 - Fix #81069, #75421 Mon Jan 13 2003 Elliot Lee <sopwith@redhat.com> 2.11y-1 - Update to 2.11y - Fix #80953 - Update patch0, patch107, patch117, patch120 for 2.11y - Remove patch60, patch61, patch207, patch211, patch212, patch119, patch121 - Remove patch122, patch200 Wed Oct 30 2002 Elliot Lee <sopwith@redhat.com> 2.11w-2 - Remove some crack/unnecessary patches while submitting stuff upstream. - Build with -D_FILE_OFFSET_BITS=64 Tue Oct 29 2002 Elliot Lee <sopwith@redhat.com> 2.11w-1 - Update to 2.11w, resolve patch conflicts Tue Oct 08 2002 Phil Knirsch <pknirsch@redhat.com> 2.11r-10hammer.3 - Extended util-linux-2.11b-s390x patch to work again. Thu Oct 03 2002 Elliot Lee <sopwith@redhat.com> 2.11r-10hammer.2 - Add patch122 for hwclock on x86_64 Thu Sep 12 2002 Than Ngo <than@redhat.com> 2.11r-10hammer.1 - Fixed pam config files Wed Sep 11 2002 Bernhard Rosenkraenzer <bero@redhat.com> 2.11r-10hammer - Port to hammer
This commit is contained in:
parent
cc64ef48b0
commit
67c293319c
@ -1,2 +1,3 @@
|
||||
floppy-0.12.tar.gz
|
||||
kbdrate.tar.gz
|
||||
util-linux-2.11r.tar.gz
|
||||
util-linux-2.11y.tar.bz2
|
||||
|
3
sources
3
sources
@ -1,2 +1,3 @@
|
||||
7d3ac81855e26687dada6a31d2677875 floppy-0.12.tar.gz
|
||||
555e4bd2a23347fddac4268cbf4e1fe4 kbdrate.tar.gz
|
||||
939c11a899f9e4f3cfc3ec83b736d3ad util-linux-2.11r.tar.gz
|
||||
9431ced07a1bb2713f4ae9b8b9e208f2 util-linux-2.11y.tar.bz2
|
||||
|
26
util-linux-2.11y-multibyte.patch
Normal file
26
util-linux-2.11y-multibyte.patch
Normal file
@ -0,0 +1,26 @@
|
||||
--- util-linux-2.11y/text-utils/more.c.multibyte 2003-02-03 16:22:32.000000000 +0000
|
||||
+++ util-linux-2.11y/text-utils/more.c 2003-02-03 17:03:45.000000000 +0000
|
||||
@@ -1163,7 +1163,23 @@
|
||||
my_putstring(state ? ULenter : ULexit);
|
||||
}
|
||||
if (c != ' ' || pstate == 0 || state != 0 || ulglitch == 0)
|
||||
+#ifdef ENABLE_WIDECHAR
|
||||
+ {
|
||||
+ wchar_t wc;
|
||||
+ size_t mblength;
|
||||
+ mbstate_t state;
|
||||
+ memset (&state, '\0', sizeof (mbstate_t));
|
||||
+ s--; n++;
|
||||
+ mblength = mbrtowc (&wc, s, n, &state);
|
||||
+ if (mblength == (size_t) -2 || mblength == (size_t) -1)
|
||||
+ mblength = 1;
|
||||
+ while (mblength--)
|
||||
+ putchar (*s++);
|
||||
+ n += mblength;
|
||||
+ }
|
||||
+#else
|
||||
putchar(c);
|
||||
+#endif /* ENABLE_WIDECHAR */
|
||||
if (state && *chUL) {
|
||||
pr(chBS);
|
||||
my_putstring(chUL);
|
70
util-linux-2.11y-procpartitions-37436.patch
Normal file
70
util-linux-2.11y-procpartitions-37436.patch
Normal file
@ -0,0 +1,70 @@
|
||||
--- util-linux-2.11y/disk-utils/blockdev.c.procpartitions 2002-03-08 17:57:02.000000000 -0500
|
||||
+++ util-linux-2.11y/disk-utils/blockdev.c 2003-01-13 14:28:41.000000000 -0500
|
||||
@@ -290,6 +290,7 @@
|
||||
char ptname[200];
|
||||
char device[210];
|
||||
int ma, mi, sz;
|
||||
+ char iobuf[32*1024];
|
||||
|
||||
procpt = fopen(PROC_PARTITIONS, "r");
|
||||
if (!procpt) {
|
||||
@@ -297,6 +298,7 @@
|
||||
progname, PROC_PARTITIONS);
|
||||
exit(1);
|
||||
}
|
||||
+ setvbuf(procpt, iobuf, _IOFBF, sizeof(iobuf));
|
||||
|
||||
while (fgets(line, sizeof(line), procpt)) {
|
||||
if (sscanf (line, " %d %d %d %[^\n ]",
|
||||
--- util-linux-2.11y/fdisk/fdisk.c.procpartitions 2003-01-13 14:28:41.000000000 -0500
|
||||
+++ util-linux-2.11y/fdisk/fdisk.c 2003-01-13 14:28:41.000000000 -0500
|
||||
@@ -2371,12 +2371,14 @@
|
||||
FILE *procpt;
|
||||
char line[100], ptname[100], devname[120], *s;
|
||||
int ma, mi, sz;
|
||||
+ char iobuf[32*1024];
|
||||
|
||||
procpt = fopen(PROC_PARTITIONS, "r");
|
||||
if (procpt == NULL) {
|
||||
fprintf(stderr, _("cannot open %s\n"), PROC_PARTITIONS);
|
||||
return;
|
||||
}
|
||||
+ setvbuf(procpt, iobuf, _IOFBF, sizeof(iobuf));
|
||||
|
||||
while (fgets(line, sizeof(line), procpt)) {
|
||||
if (sscanf (line, " %d %d %d %[^\n ]",
|
||||
--- util-linux-2.11y/mount/mount_by_label.c.procpartitions 2002-11-26 04:23:49.000000000 -0500
|
||||
+++ util-linux-2.11y/mount/mount_by_label.c 2003-01-13 14:31:53.000000000 -0500
|
||||
@@ -136,9 +136,7 @@
|
||||
char device[110];
|
||||
int firstPass;
|
||||
int handleOnFirst;
|
||||
-#if 0
|
||||
char iobuf[32*1024]; /* For setvbuf */
|
||||
-#endif
|
||||
|
||||
if (uuidCache)
|
||||
return;
|
||||
@@ -155,7 +153,6 @@
|
||||
PROC_PARTITIONS);
|
||||
return;
|
||||
}
|
||||
-#if 0
|
||||
/* Ugly kludge - the contents of /proc/partitions change in time,
|
||||
and this causes failures when the file is not read in one go.
|
||||
In particular, one cannot use stdio on /proc/partitions.
|
||||
@@ -166,9 +163,12 @@
|
||||
to keep statistics in /proc/partitions. Of course, statistics belong
|
||||
in some /proc/diskstats, not in some /proc file that happened to
|
||||
exist already. */
|
||||
-
|
||||
+/* Until someone actually implements something else, /proc/partitions _IS_
|
||||
+ /proc/diskstats. And no matter what file we are reading, we will still
|
||||
+ need to increase the buffer size, because 8k is just not Enough For
|
||||
+ Everyone even if stats aren't in /proc/partitions.
|
||||
+*/
|
||||
setvbuf(procpt, iobuf, _IOFBF, sizeof(iobuf));
|
||||
-#endif
|
||||
|
||||
for (firstPass = 1; firstPass >= 0; firstPass--) {
|
||||
fseek(procpt, 0, SEEK_SET);
|
109
util-linux-2.11y-skipraid2.patch
Normal file
109
util-linux-2.11y-skipraid2.patch
Normal file
@ -0,0 +1,109 @@
|
||||
--- util-linux-2.11y/mount/linux_fs.h.skipraid2 2002-10-07 09:08:22.000000000 -0400
|
||||
+++ util-linux-2.11y/mount/linux_fs.h 2003-01-13 14:42:57.000000000 -0500
|
||||
@@ -13,6 +13,12 @@
|
||||
#endif
|
||||
#endif
|
||||
|
||||
+#include <inttypes.h>
|
||||
+#ifndef BLKGETSIZE64
|
||||
+#include <sys/ioctl.h>
|
||||
+#define BLKGETSIZE64 _IOR(0x12,114,sizeof(uint64_t))
|
||||
+#endif
|
||||
+
|
||||
#define MINIX_SUPER_MAGIC 0x137F /* minix v1, 14 char names */
|
||||
#define MINIX_SUPER_MAGIC2 0x138F /* minix v1, 30 char names */
|
||||
#define MINIX2_SUPER_MAGIC 0x2468 /* minix v2, 14 char names */
|
||||
--- util-linux-2.11y/mount/get_label_uuid.c.skipraid2 2003-01-13 14:44:04.000000000 -0500
|
||||
+++ util-linux-2.11y/mount/get_label_uuid.c 2003-01-13 14:46:34.000000000 -0500
|
||||
@@ -6,6 +6,8 @@
|
||||
#include <unistd.h>
|
||||
#include <stdlib.h>
|
||||
#include <string.h>
|
||||
+#include <endian.h>
|
||||
+#include <sys/stat.h>
|
||||
|
||||
#include "linux_fs.h"
|
||||
#include "get_label_uuid.h"
|
||||
@@ -19,28 +21,62 @@
|
||||
* not on the disks that form the raid array. This test causes a lot of
|
||||
* problems when run on my striped promise fasttrak 100 array."
|
||||
*/
|
||||
-static inline int
|
||||
-is_raid_partition(int fd) {
|
||||
-#if 0
|
||||
- struct mdp_super_block mdsb;
|
||||
- int n;
|
||||
-
|
||||
- /* hardcode 4096 here in various places, because that's
|
||||
- what it's defined to be. Note that even if we used
|
||||
- the actual kernel headers, sizeof(mdp_super_t) is
|
||||
- slightly larger in the 2.2 kernel on 64-bit archs,
|
||||
- so using that wouldn't work. */
|
||||
- lseek(fd, -4096, SEEK_END); /* Ignore possible error
|
||||
- about return value overflow */
|
||||
- n = 4096;
|
||||
- if (sizeof(mdsb) < n)
|
||||
- n = sizeof(mdsb);
|
||||
- if (read(fd, &mdsb, n) != n)
|
||||
- return 1; /* error */
|
||||
- return (mdsbmagic(mdsb) == MD_SB_MAGIC);
|
||||
+
|
||||
+#if BYTE_ORDER == BIG_ENDIAN
|
||||
+#define INT32_FROM_LE(val) ((unsigned int) ( \
|
||||
+ (((unsigned int) (val) & (unsigned int) 0x000000ffU) << 24) | \
|
||||
+ (((unsigned int) (val) & (unsigned int) 0x0000ff00U) << 8) | \
|
||||
+ (((unsigned int) (val) & (unsigned int) 0x00ff0000U) >> 8) | \
|
||||
+ (((unsigned int) (val) & (unsigned int) 0xff000000U) >> 24)))
|
||||
#else
|
||||
- return 0;
|
||||
+#define INT32_FROM_LE(val) (val)
|
||||
+#endif
|
||||
+
|
||||
+typedef struct {
|
||||
+ unsigned int md_magic;
|
||||
+} mdp_super_t;
|
||||
+#ifndef MD_SB_MAGIC
|
||||
+#define MD_SB_MAGIC 0xa92b4efc
|
||||
+#endif
|
||||
+#ifndef MD_RESERVED_BYTES
|
||||
+#define MD_RESERVED_BYTES 65536L
|
||||
#endif
|
||||
+#ifndef MD_NEW_SIZE_BYTES
|
||||
+#define MD_NEW_SIZE_BYTES(x) ((x & ~(MD_RESERVED_BYTES - 1L)) - MD_RESERVED_BYTES)
|
||||
+#endif
|
||||
+
|
||||
+static int
|
||||
+is_raid_partition(int fd)
|
||||
+{
|
||||
+ mdp_super_t mdsb;
|
||||
+ int n;
|
||||
+ struct stat sbuf;
|
||||
+ if(fstat(fd, &sbuf))
|
||||
+ return 2;
|
||||
+ if(!sbuf.st_size) {
|
||||
+ uint64_t bsize64;
|
||||
+ unsigned int bsize32;
|
||||
+ if(!ioctl(fd, BLKGETSIZE64, &bsize64))
|
||||
+ sbuf.st_size = bsize64;
|
||||
+ else if(!ioctl(fd, BLKGETSIZE, &bsize32))
|
||||
+ sbuf.st_size = bsize32;
|
||||
+ }
|
||||
+ if(!sbuf.st_size) return 3;
|
||||
+ /* hardcode 4096 here in various places,
|
||||
+ because that's what it's defined to be.
|
||||
+ Note that even if we used the actual kernel headers,
|
||||
+ sizeof(mdp_super_t) is slightly larger in the 2.2 kernel on 64-bit
|
||||
+ archs, so using that wouldn't work. */
|
||||
+ lseek(fd, MD_NEW_SIZE_BYTES(sbuf.st_size), SEEK_SET);
|
||||
+ n = 4096; if(sizeof(mdsb) < n) n = sizeof(mdsb);
|
||||
+ if(read(fd, &mdsb, n) != n)
|
||||
+ return 4; /* error */
|
||||
+ mdsb.md_magic = INT32_FROM_LE(mdsb.md_magic);
|
||||
+ return (mdsb.md_magic == MD_SB_MAGIC); /* If this device has a
|
||||
+ RAID superblock at
|
||||
+ the end, it must be
|
||||
+ part of a RAID
|
||||
+ array. */
|
||||
}
|
||||
|
||||
/* for now, only ext2, ext3, xfs, ocfs are supported */
|
284
util-linux.spec
284
util-linux.spec
@ -1,11 +1,15 @@
|
||||
# Upstream maintainer util-linux@math.uio.no
|
||||
|
||||
%define with_kbdrate 0
|
||||
%define floppyver 0.12
|
||||
%define no_sfdisk_archs ppc ppc64
|
||||
%define no_hwclock_archs s390 s390x
|
||||
%define cytune_archs %{ix86} alpha armv4l
|
||||
|
||||
Summary: A collection of basic system utilities.
|
||||
Name: util-linux
|
||||
Version: 2.11r
|
||||
Release: 10
|
||||
Version: 2.11y
|
||||
Release: 9
|
||||
License: distributable
|
||||
Group: System Environment/Base
|
||||
|
||||
@ -14,8 +18,9 @@ BuildRequires: pam-devel
|
||||
BuildRequires: ncurses-devel
|
||||
BuildRequires: libtermcap-devel
|
||||
BuildRequires: zlib-devel
|
||||
BuildRequires: slang-devel
|
||||
|
||||
Source0: ftp://ftp.kernel.org/pub/linux/utils/util-linux/util-linux-%{version}.tar.gz
|
||||
Source0: ftp://ftp.kernel.org/pub/linux/utils/util-linux/util-linux-%{version}.tar.bz2
|
||||
Source1: util-linux-2.7-login.pamd
|
||||
Source2: util-linux-2.7-chfn.pamd
|
||||
Source3: util-linux-2.7-chsh.pamd
|
||||
@ -24,61 +29,71 @@ Source7: cramfs.h
|
||||
Source8: nologin.c
|
||||
Source9: nologin.8
|
||||
Source10: kbdrate.tar.gz
|
||||
Source11: http://download.sourceforge.net/floppyutil/floppy-%{floppyver}.tar.gz
|
||||
|
||||
Patch0: util-linux-2.11a-rhconfig.patch
|
||||
##### Red Hat Linux-specific patches
|
||||
# Changes to MCONFIG build-time configuration
|
||||
Patch0: util-linux-2.11y-rhconfig.patch
|
||||
# Don't install the chkdupexe perl script
|
||||
Patch1: util-linux-2.11r-nochkdupexe.patch
|
||||
# This patch is here because gafton put it here five years ago
|
||||
Patch2: util-linux-2.11a-gecossize.patch
|
||||
|
||||
# No clue why this patch is here
|
||||
Patch4: util-linux-2.11n-mount.patch
|
||||
|
||||
# Helps allow building/installing as non-root
|
||||
Patch21: util-linux-2.9v-nonroot.patch
|
||||
|
||||
Patch27: util-linux-2.11r-moretc.patch
|
||||
|
||||
Patch35: util-linux-2.10m-loginpath.patch
|
||||
Patch60: util-linux-2.10s-s390x.patch
|
||||
Patch61: util-linux-2.11b-s390x.patch
|
||||
# Force 'more' to link against libtermcap so that we don't have a
|
||||
# /bin binary depending on a /usr/lib library (ncurses)
|
||||
Patch27: util-linux-2.11w-moretc.patch
|
||||
|
||||
# 1. Reduce MAX_PARTS to 16 (upstream reasonably won't take it)
|
||||
# 2. Use O_LARGEFILE (I have no idea whether this has any effect given
|
||||
# -D_FILE_OFFSET_BITS=64)
|
||||
# 3. Use the standard syscall() function instead of some bad hacks.
|
||||
Patch70: util-linux-2.11r-miscfixes.patch
|
||||
|
||||
# Because we have our own mkcramfs, because the copyright/license is unclear
|
||||
Patch100: mkcramfs.patch
|
||||
Patch101: mkcramfs-quiet.patch
|
||||
|
||||
########
|
||||
# Mount patches
|
||||
Patch201: mount-2.10m-nolock-docs.patch
|
||||
Patch202: mount-2.10o-nfsman.patch
|
||||
Patch204: mount-2.10r-2gb.patch
|
||||
Patch206: mount-2.10r-kudzu.patch
|
||||
Patch207: mount-2.11r-swapon.patch
|
||||
Patch209: mount-2.11b-swapoff.patch
|
||||
Patch210: util-linux-2.11b-largefile.patch
|
||||
Patch211: mount-2.11e-user_label_umount.patch
|
||||
Patch212: mount-2.11r-netdev.patch
|
||||
Patch220: util-linux-2.11n-makej.patch
|
||||
|
||||
########### START UNSUBMITTED
|
||||
Patch103: util-linux-2.11r-ownerumount.patch
|
||||
Patch106: util-linux-2.11g-swaponsymlink-57300.patch
|
||||
Patch107: util-linux-2.11r-procpartitions-37436.patch
|
||||
Patch108: util-linux-2.11n-autosmb-32132.patch
|
||||
# Note on how to set up raw device mappings using RHL /etc/sysconfig/rawdevices
|
||||
Patch109: util-linux-2.11f-rawman.patch
|
||||
Patch111: util-linux-2.11n-mkfsman.patch
|
||||
|
||||
######## Patches that should be upstream eventually
|
||||
Patch206: mount-2.10r-kudzu.patch
|
||||
#Patch207: util-linux-2.11w-swapon.patch
|
||||
#Patch211: mount-2.11e-user_label_umount.patch
|
||||
#Patch212: util-linux-2.11w-netdev.patch
|
||||
|
||||
#Patch60: util-linux-2.10s-s390x.patch
|
||||
#Patch61: util-linux-2.11b-s390x.patch
|
||||
|
||||
Patch103: util-linux-2.11r-ownerumount.patch
|
||||
Patch106: util-linux-2.11w-swaponsymlink-57300.patch
|
||||
Patch107: util-linux-2.11y-procpartitions-37436.patch
|
||||
Patch113: util-linux-2.11r-ctty3.patch
|
||||
Patch114: util-linux-2.11n-dumboctal.patch
|
||||
Patch115: util-linux-2.11n-fstabperm-61868.patch
|
||||
Patch116: util-linux-2.11n-loginutmp-66950.patch
|
||||
Patch117: util-linux-2.11r-moremisc.patch
|
||||
Patch300: util-linux-2.11n-ia64mkswap.patch
|
||||
Patch301: util-linux-2.11r-swapondetect.patch
|
||||
Patch302: util-linux-2.11r-largeswap.patch
|
||||
Patch117: util-linux-2.11y-moremisc.patch
|
||||
|
||||
Patch118: util-linux-2.11r-gptsize-69603.patch
|
||||
Patch119: fdisk-add-primary.patch
|
||||
#Patch119: fdisk-add-primary.patch
|
||||
|
||||
Patch120: util-linux-2.11r-skipraid2.patch
|
||||
Patch121: util-linux-2.11r-hwclock-72140.patch
|
||||
########### END UNSUBMITTED
|
||||
Patch120: util-linux-2.11y-skipraid2.patch
|
||||
#Patch121: util-linux-2.11r-hwclock-72140.patch
|
||||
#Patch122: util-linux-2.11r-hwclock_hammer.patch
|
||||
|
||||
#Patch200: util-linux-2.11w-hammer.patch
|
||||
Patch123: util-linux-2.11y-blkgetsize-81069.patch
|
||||
Patch124: util-linux-2.11y-umount-75421.patch
|
||||
Patch125: util-linux-2.11y-umask-82552.patch
|
||||
Patch126: util-linux-2.11y-multibyte.patch
|
||||
Patch127: util-linux-2.11y-mcookie-83345.patch
|
||||
Patch128: util-linux-2.11y-ipcs-84243.patch
|
||||
|
||||
# When adding patches, please make sure that it is easy to find out what bug # the
|
||||
# patch fixes.
|
||||
########### END upstreamable
|
||||
|
||||
Obsoletes: fdisk tunelp
|
||||
%ifarch alpha sparc sparc64 sparcv9 s390
|
||||
@ -105,7 +120,6 @@ program.
|
||||
Group: System Environment/Base
|
||||
Summary: Programs for mounting and unmounting filesystems.
|
||||
ExclusiveOS: Linux
|
||||
Prereq: mktemp /bin/awk /usr/bin/cmp textutils fileutils
|
||||
|
||||
%description -n mount
|
||||
The mount package contains the mount, umount, swapon, and swapoff
|
||||
@ -130,7 +144,7 @@ device.
|
||||
|
||||
%prep
|
||||
|
||||
%setup -q -a 10
|
||||
%setup -q -a 10 -a 11
|
||||
|
||||
%patch0 -p1 -b .rhconfig
|
||||
|
||||
@ -147,12 +161,8 @@ device.
|
||||
# is under /usr and won't be accessable if / is mounted but /usr is not
|
||||
%patch27 -p1 -b .moretc
|
||||
|
||||
%patch35 -p1 -b .loginpath
|
||||
|
||||
%ifarch s390 s390x
|
||||
%patch60 -p1 -b .s390x2
|
||||
%patch61 -p1 -b .s390x
|
||||
%endif
|
||||
#patch60 -p1 -b .s390x2
|
||||
#patch61 -p1 -b .s390x
|
||||
|
||||
# No support for large numbers of cylinders in fdisk{sgi,sun}label.*
|
||||
# Too many places in those files assume that it is an unsigned short,
|
||||
@ -167,16 +177,10 @@ cp %{SOURCE7} %{SOURCE6} .
|
||||
# nologin
|
||||
cp %{SOURCE8} %{SOURCE9} .
|
||||
|
||||
%patch201 -p1 -b .docbug
|
||||
%patch202 -p1 -b .nfsman
|
||||
%patch204 -p1 -b .2gb
|
||||
%patch206 -p1 -b .kudzu
|
||||
%patch207 -p1 -b .swapon
|
||||
%patch209 -p2 -b .swapoff
|
||||
%patch210 -p1 -b .largefile
|
||||
%patch211 -p2 -b .userumount
|
||||
%patch212 -p1 -b .netdev
|
||||
%patch220 -p1 -b .makej
|
||||
#patch207 -p1 -b .swapon
|
||||
#patch211 -p2 -b .userumount
|
||||
#patch212 -p1 -b .netdev
|
||||
|
||||
sed -e 's:^MAN_DIR=.*:MAN_DIR=%{_mandir}:' -e 's:^INFO_DIR=.*:INFO_DIR=%{_infodir}:' MCONFIG > MCONFIG.new
|
||||
mv MCONFIG.new MCONFIG
|
||||
@ -184,34 +188,34 @@ mv MCONFIG.new MCONFIG
|
||||
%patch103 -p1 -b .ownerumount
|
||||
%patch106 -p1 -b .swaponsymlink
|
||||
%patch107 -p1 -b .procpartitions
|
||||
%patch108 -p1 -b .autosmb
|
||||
%patch109 -p1 -b .rawman
|
||||
%patch111 -p1 -b .mkfsman
|
||||
|
||||
%patch113 -p1 -b .ctty3
|
||||
%patch114 -p1 -b .dumboctal
|
||||
%patch115 -p1 -b .fstabperm
|
||||
%patch116 -p1 -b .loginutmp
|
||||
%patch117 -p1 -b .moremisc
|
||||
%patch118 -p1 -b .gptsize
|
||||
cd fdisk
|
||||
%patch119 -p0 -b .addprimary
|
||||
cd ..
|
||||
#cd fdisk
|
||||
#patch119 -p0 -b .addprimary
|
||||
#cd ..
|
||||
%patch120 -p1 -b .skipraid2
|
||||
%patch121 -p1 -b .hwclock
|
||||
#patch121 -p1 -b .hwclock
|
||||
#patch122 -p1 -b .hammer_rtc
|
||||
|
||||
#patch200 -p1 -b .hammer
|
||||
%patch123 -p1 -b .blkgetsize
|
||||
%patch124 -p1 -b .umount
|
||||
%patch125 -p1 -b .umask
|
||||
%patch126 -p1 -b .multibyte
|
||||
%patch127 -p1 -b .mcookie-dumbness
|
||||
|
||||
# All of this patch is in except a 'max swap size' change, which
|
||||
# doesn't seem to be needed
|
||||
#%patch300 -p1 -b .offtmkswap
|
||||
#%patch301 -p1 -b .detectswap
|
||||
%patch302 -p1 -b .largeswap
|
||||
|
||||
%build
|
||||
unset LINGUAS || :
|
||||
|
||||
%configure
|
||||
|
||||
make "OPT=$RPM_OPT_FLAGS -D_LARGEFILE_SOURCE -D_LARGEFILE64_SOURCE" \
|
||||
make "OPT=$RPM_OPT_FLAGS -D_LARGEFILE_SOURCE -D_LARGEFILE64_SOURCE -D_FILE_OFFSET_BITS=64" \
|
||||
LDFLAGS="" \
|
||||
HAVE_PIVOT_ROOT=yes \
|
||||
%{?_smp_mflags}
|
||||
@ -226,6 +230,12 @@ pushd kbdrate
|
||||
popd
|
||||
%endif
|
||||
|
||||
pushd floppy-%{floppyver}
|
||||
# We have to disable floppygtk somehow...
|
||||
%configure --with-gtk-prefix=/asfd/jkl
|
||||
make %{?_smp_mflags}
|
||||
popd
|
||||
|
||||
gcc $RPM_OPT_FLAGS -o mkcramfs mkcramfs.c -I. -lz
|
||||
|
||||
gcc $RPM_OPT_FLAGS -o nologin nologin.c
|
||||
@ -249,6 +259,9 @@ make \
|
||||
INSTALLBIN="install -m 755" \
|
||||
INSTALLMAN="install -m 644" \
|
||||
install DESTDIR=${RPM_BUILD_ROOT}
|
||||
pushd floppy-%{floppyver}
|
||||
%makeinstall
|
||||
popd
|
||||
|
||||
install -m 755 mount/pivot_root ${RPM_BUILD_ROOT}/sbin
|
||||
install -m 644 mount/pivot_root.8 ${RPM_BUILD_ROOT}%{_mandir}/man8
|
||||
@ -315,6 +328,35 @@ ln -sf hwclock ${RPM_BUILD_ROOT}/sbin/clock
|
||||
chmod 644 ${RPM_BUILD_ROOT}%{_datadir}/misc/getopt/*
|
||||
rm -f fdisk/README.cfdisk
|
||||
|
||||
mkdir -p $RPM_BUILD_ROOT%{_datadir}/misc
|
||||
install text-utils/more.help $RPM_BUILD_ROOT%{_datadir}/misc/
|
||||
|
||||
# Final cleanup
|
||||
%ifnarch %cytune_archs
|
||||
rm -f $RPM_BUILD_ROOT%{_bindir}/cytune $RPM_BUILD_ROOT%{_mandir}/man8/cytune.8*
|
||||
%endif
|
||||
%ifarch %no_sfdisk_archs
|
||||
rm -f $RPM_BUILD_ROOT/sbin/sfdisk $RPM_BUILD_ROOT%{_mandir}/man8/sfdisk.8*
|
||||
%endif
|
||||
%ifarch %no_hwclock_archs
|
||||
rm -f $RPM_BUILD_ROOT/sbin/{hwclock,clock} $RPM_BUILD_ROOT%{_mandir}/man8/hwclock.8*
|
||||
%endif
|
||||
%ifarch s390 s390x
|
||||
rm -f $RPM_BUILD_ROOT/usr/{bin,sbin}/{fdformat,tunelp,floppy,setfdprm} $RPM_BUILD_ROOT%{_mandir}/man8/{fdformat,tunelp,floppy,setfdprm}.8*
|
||||
rm -f $RPM_BUILD_ROOT/%{_sysconfdir}/fdprm
|
||||
%endif
|
||||
|
||||
for I in /sbin/cfdisk /sbin/fsck.minix /sbin/mkfs.{bfs,minix} /sbin/sln %{_bindir}/line %{_bindir}/pg; do
|
||||
rm -f $RPM_BUILD_ROOT$I
|
||||
done
|
||||
|
||||
rm -f $RPM_BUILD_ROOT%{_mandir}/man1/line.1*
|
||||
rm -f $RPM_BUILD_ROOT%{_mandir}/man1/pg.1*
|
||||
rm -f $RPM_BUILD_ROOT%{_mandir}/man8/cfdisk.8*
|
||||
rm -f $RPM_BUILD_ROOT%{_mandir}/man8/fsck.minix.8*
|
||||
rm -f $RPM_BUILD_ROOT%{_mandir}/man8/mkfs.minix.8*
|
||||
rm -f $RPM_BUILD_ROOT%{_mandir}/man8/mkfs.bfs.8*
|
||||
|
||||
%find_lang %{name}
|
||||
|
||||
%clean
|
||||
@ -338,7 +380,9 @@ fi
|
||||
%attr(755,root,root) /bin/login
|
||||
/bin/more
|
||||
|
||||
%ifnarch s390 s390x
|
||||
%config %{_sysconfdir}/fdprm
|
||||
%endif
|
||||
%config %{_sysconfdir}/pam.d/chfn
|
||||
%config %{_sysconfdir}/pam.d/chsh
|
||||
%config %{_sysconfdir}/pam.d/login
|
||||
@ -346,37 +390,29 @@ fi
|
||||
/sbin/agetty
|
||||
/sbin/blockdev
|
||||
/sbin/pivot_root
|
||||
%ifnarch s390 s390x
|
||||
/sbin/clock
|
||||
/sbin/fdisk
|
||||
%endif
|
||||
/sbin/ctrlaltdel
|
||||
/sbin/elvtune
|
||||
/sbin/addpart
|
||||
/sbin/delpart
|
||||
/sbin/partx
|
||||
|
||||
%ifarch %{ix86} alpha ia64 s390 s390x
|
||||
/sbin/fsck.minix
|
||||
/sbin/mkfs.minix
|
||||
/sbin/mkfs.bfs
|
||||
%{_mandir}/man8/fsck.minix.8*
|
||||
%{_mandir}/man8/mkfs.minix.8*
|
||||
%{_mandir}/man8/mkfs.bfs.8*
|
||||
%ifnarch %no_sfdisk_archs
|
||||
/sbin/sfdisk
|
||||
%{_mandir}/man8/sfdisk.8*
|
||||
%doc fdisk/sfdisk.examples
|
||||
%endif
|
||||
|
||||
%ifnarch s390 s390x
|
||||
/sbin/fdisk
|
||||
%{_mandir}/man8/fdisk.8*
|
||||
%ifnarch %no_hwclock_archs
|
||||
/sbin/clock
|
||||
/sbin/hwclock
|
||||
/usr/sbin/hwclock
|
||||
%{_mandir}/man8/hwclock.8*
|
||||
%endif
|
||||
/sbin/mkfs
|
||||
/sbin/mkswap
|
||||
#/sbin/mkfs.bfs
|
||||
/sbin/rescuept
|
||||
#/sbin/sln
|
||||
/sbin/nologin
|
||||
%{_mandir}/man8/nologin.8*
|
||||
|
||||
@ -396,12 +432,14 @@ fi
|
||||
%{_bindir}/colcrt
|
||||
%{_bindir}/colrm
|
||||
%{_bindir}/column
|
||||
%ifarch %{ix86} alpha armv4l
|
||||
%ifarch %cytune_archs
|
||||
%{_bindir}/cytune
|
||||
%{_mandir}/man8/cytune.8*
|
||||
%endif
|
||||
%{_bindir}/ddate
|
||||
%ifnarch s390 s390x
|
||||
%{_bindir}/fdformat
|
||||
%endif
|
||||
%{_bindir}/getopt
|
||||
%{_bindir}/hexdump
|
||||
%{_bindir}/ipcrm
|
||||
@ -411,6 +449,12 @@ fi
|
||||
%{_bindir}/look
|
||||
%{_bindir}/mcookie
|
||||
%{_bindir}/mkcramfs
|
||||
/sbin/fsck.cramfs
|
||||
/sbin/mkfs.cramfs
|
||||
%ifnarch s390 s390x
|
||||
%{_bindir}/floppy
|
||||
%{_mandir}/man8/floppy.8*
|
||||
%endif
|
||||
%{_bindir}/namei
|
||||
%attr(4711,root,root) %{_bindir}/newgrp
|
||||
%{_bindir}/raw
|
||||
@ -418,13 +462,14 @@ fi
|
||||
%{_bindir}/renice
|
||||
%{_bindir}/rev
|
||||
%{_bindir}/script
|
||||
%ifnarch s390 s390x
|
||||
%{_bindir}/setfdprm
|
||||
%endif
|
||||
%{_bindir}/setsid
|
||||
%{_bindir}/setterm
|
||||
%ifarch sparc sparc64 sparcv9
|
||||
%{_bindir}/sunhostid
|
||||
%endif
|
||||
#%{_bindir}/tsort
|
||||
%{_bindir}/ul
|
||||
%{_bindir}/whereis
|
||||
%attr(2755,root,tty) %{_bindir}/write
|
||||
@ -440,7 +485,7 @@ fi
|
||||
%{_mandir}/man8/vidmode.8*
|
||||
%endif
|
||||
%{_sbindir}/readprofile
|
||||
%ifnarch s390
|
||||
%ifnarch s390 s390x
|
||||
%{_sbindir}/tunelp
|
||||
%endif
|
||||
%{_sbindir}/vipw
|
||||
@ -459,7 +504,6 @@ fi
|
||||
%{_mandir}/man1/ddate.1*
|
||||
%{_mandir}/man1/getopt.1*
|
||||
%{_mandir}/man1/hexdump.1*
|
||||
#%{_mandir}/man1/hostid.1*
|
||||
%{_mandir}/man1/kill.1*
|
||||
%{_mandir}/man1/logger.1*
|
||||
%{_mandir}/man1/login.1*
|
||||
@ -473,7 +517,6 @@ fi
|
||||
%{_mandir}/man1/rev.1*
|
||||
%{_mandir}/man1/script.1*
|
||||
%{_mandir}/man1/setterm.1*
|
||||
#%{_mandir}/man1/tsort.1*
|
||||
%{_mandir}/man1/ul.1*
|
||||
%{_mandir}/man1/whereis.1*
|
||||
%{_mandir}/man1/write.1*
|
||||
@ -483,26 +526,27 @@ fi
|
||||
%{_mandir}/man8/ctrlaltdel.8*
|
||||
%{_mandir}/man8/dmesg.8*
|
||||
%{_mandir}/man8/elvtune.8*
|
||||
%{_mandir}/man8/fdformat.8*
|
||||
%ifnarch s390 s390x
|
||||
%{_mandir}/man8/fdisk.8*
|
||||
%{_mandir}/man8/hwclock.8*
|
||||
%{_mandir}/man8/fdformat.8*
|
||||
%endif
|
||||
%{_mandir}/man8/ipcrm.8*
|
||||
%{_mandir}/man8/ipcs.8*
|
||||
%{_mandir}/man8/isosize.8*
|
||||
%{_mandir}/man8/mkfs.8*
|
||||
#%{_mandir}/man8/mkfs.bfs.8*
|
||||
%{_mandir}/man8/mkswap.8*
|
||||
%{_mandir}/man8/pivot_root.8*
|
||||
%{_mandir}/man8/raw.8*
|
||||
%{_mandir}/man8/rawdevices.8*
|
||||
%{_mandir}/man8/renice.8*
|
||||
%ifnarch s390 s390x
|
||||
%{_mandir}/man8/setfdprm.8*
|
||||
%endif
|
||||
%{_mandir}/man8/setsid.8*
|
||||
# XXX this man page should be moved to glibc.
|
||||
%{_mandir}/man8/sln.8*
|
||||
%ifnarch s390 s390x
|
||||
%{_mandir}/man8/tunelp.8*
|
||||
%endif
|
||||
%{_mandir}/man8/vigr.8*
|
||||
%{_mandir}/man8/vipw.8*
|
||||
|
||||
@ -528,6 +572,60 @@ fi
|
||||
/sbin/losetup
|
||||
|
||||
%changelog
|
||||
* Mon Feb 24 2003 Elliot Lee <sopwith@redhat.com>
|
||||
- rebuilt
|
||||
|
||||
* Wed Feb 19 2003 Elliot Lee <sopwith@redhat.com> 2.11y-8
|
||||
- ipcs-84243.patch to fix #84243
|
||||
|
||||
* Thu Feb 13 2003 Yukihiro Nakai <ynakai@redhat.com> 2.11y-7
|
||||
- Update moremisc patch to fix swprintf()'s minimum field (bug #83361).
|
||||
|
||||
* Mon Feb 03 2003 Elliot Lee <sopwith@redhat.com> 2.11y-6
|
||||
- Fix mcookie segfault on many 64-bit architectures (bug #83345).
|
||||
|
||||
* Mon Feb 03 2003 Tim Waugh <twaugh@redhat.com> 2.11y-5
|
||||
- Fix underlined multibyte characters (bug #83376).
|
||||
|
||||
* Sun Feb 02 2003 Florian La Roche <Florian.LaRoche@redhat.de>
|
||||
- rebuild to have again a s390 rpm
|
||||
- disable some more apps for mainframe
|
||||
|
||||
* Wed Jan 29 2003 Elliot Lee <sopwith@redhat.com> 2.11y-4
|
||||
- util-linux-2.11y-umask-82552.patch
|
||||
|
||||
* Wed Jan 22 2003 Tim Powers <timp@redhat.com>
|
||||
- rebuilt
|
||||
|
||||
* Mon Jan 13 2003 Elliot Lee <sopwith@redhat.com> 2.11y-2
|
||||
- Fix #81069, #75421
|
||||
|
||||
* Mon Jan 13 2003 Elliot Lee <sopwith@redhat.com> 2.11y-1
|
||||
- Update to 2.11y
|
||||
- Fix #80953
|
||||
- Update patch0, patch107, patch117, patch120 for 2.11y
|
||||
- Remove patch60, patch61, patch207, patch211, patch212, patch119, patch121
|
||||
- Remove patch122, patch200
|
||||
|
||||
* Wed Oct 30 2002 Elliot Lee <sopwith@redhat.com> 2.11w-2
|
||||
- Remove some crack/unnecessary patches while submitting stuff upstream.
|
||||
- Build with -D_FILE_OFFSET_BITS=64
|
||||
|
||||
* Tue Oct 29 2002 Elliot Lee <sopwith@redhat.com> 2.11w-1
|
||||
- Update to 2.11w, resolve patch conflicts
|
||||
|
||||
* Tue Oct 08 2002 Phil Knirsch <pknirsch@redhat.com> 2.11r-10hammer.3
|
||||
- Extended util-linux-2.11b-s390x patch to work again.
|
||||
|
||||
* Thu Oct 03 2002 Elliot Lee <sopwith@redhat.com> 2.11r-10hammer.2
|
||||
- Add patch122 for hwclock on x86_64
|
||||
|
||||
* Thu Sep 12 2002 Than Ngo <than@redhat.com> 2.11r-10hammer.1
|
||||
- Fixed pam config files
|
||||
|
||||
* Wed Sep 11 2002 Bernhard Rosenkraenzer <bero@redhat.com> 2.11r-10hammer
|
||||
- Port to hammer
|
||||
|
||||
* Fri Aug 30 2002 Elliot Lee <sopwith@redhat.com> 2.11r-10
|
||||
- Patch120 (hwclock) to fix #72140
|
||||
- Include isosize util
|
||||
|
Loading…
Reference in New Issue
Block a user