parent
7bbea84c42
commit
3aff07c3c7
@ -1,5 +1,5 @@
|
|||||||
--- util-linux-2.13-pre1/hwclock/hwclock.c.audit 2005-07-31 22:15:18.000000000 +0200
|
--- util-linux-2.13-pre2/hwclock/hwclock.c.audit 2005-07-31 22:15:18.000000000 +0200
|
||||||
+++ util-linux-2.13-pre1/hwclock/hwclock.c 2005-08-12 14:36:57.000000000 +0200
|
+++ util-linux-2.13-pre2/hwclock/hwclock.c 2005-08-30 11:11:11.000000000 +0200
|
||||||
@@ -81,9 +81,11 @@
|
@@ -81,9 +81,11 @@
|
||||||
#include <stdarg.h>
|
#include <stdarg.h>
|
||||||
#include <getopt.h>
|
#include <getopt.h>
|
||||||
@ -21,12 +21,15 @@
|
|||||||
}
|
}
|
||||||
|
|
||||||
static const struct option longopts[] = {
|
static const struct option longopts[] = {
|
||||||
@@ -1298,6 +1300,12 @@
|
@@ -1298,6 +1300,15 @@
|
||||||
/* Remember what time we were invoked */
|
/* Remember what time we were invoked */
|
||||||
gettimeofday(&startup_time, NULL);
|
gettimeofday(&startup_time, NULL);
|
||||||
|
|
||||||
+ audit_fd = audit_open();
|
+ audit_fd = audit_open();
|
||||||
+ if (audit_fd < 0) {
|
+ if (audit_fd < 0 && !(errno == EINVAL || errno == EPROTONOSUPPORT ||
|
||||||
|
+ errno == EAFNOSUPPORT)) {
|
||||||
|
+ /* You get these error codes only when the kernel doesn't have
|
||||||
|
+ * audit compiled in. */
|
||||||
+ fprintf(stderr, "Error - unable to connect to audit system\n");
|
+ fprintf(stderr, "Error - unable to connect to audit system\n");
|
||||||
+ return EX_NOPERM;
|
+ return EX_NOPERM;
|
||||||
+ }
|
+ }
|
||||||
@ -34,7 +37,7 @@
|
|||||||
setlocale(LC_ALL, "");
|
setlocale(LC_ALL, "");
|
||||||
#ifdef LC_NUMERIC
|
#ifdef LC_NUMERIC
|
||||||
/* We need LC_CTYPE and LC_TIME and LC_MESSAGES, but must avoid
|
/* We need LC_CTYPE and LC_TIME and LC_MESSAGES, but must avoid
|
||||||
@@ -1393,6 +1401,13 @@
|
@@ -1393,6 +1404,13 @@
|
||||||
argc -= optind;
|
argc -= optind;
|
||||||
argv += optind;
|
argv += optind;
|
||||||
|
|
||||||
@ -48,7 +51,7 @@
|
|||||||
if (argc > 0) {
|
if (argc > 0) {
|
||||||
usage(_("%s takes no non-option arguments. "
|
usage(_("%s takes no non-option arguments. "
|
||||||
"You supplied %d.\n"),
|
"You supplied %d.\n"),
|
||||||
@@ -1403,27 +1418,27 @@
|
@@ -1403,27 +1421,27 @@
|
||||||
fprintf(stderr, _("You have specified multiple functions.\n"
|
fprintf(stderr, _("You have specified multiple functions.\n"
|
||||||
"You can only perform one function "
|
"You can only perform one function "
|
||||||
"at a time.\n"));
|
"at a time.\n"));
|
||||||
@ -80,7 +83,7 @@
|
|||||||
}
|
}
|
||||||
|
|
||||||
#ifdef __alpha__
|
#ifdef __alpha__
|
||||||
@@ -1437,7 +1452,7 @@
|
@@ -1437,7 +1455,7 @@
|
||||||
if (rc != 0) {
|
if (rc != 0) {
|
||||||
fprintf(stderr, _("No usable set-to time. "
|
fprintf(stderr, _("No usable set-to time. "
|
||||||
"Cannot set clock.\n"));
|
"Cannot set clock.\n"));
|
||||||
@ -89,7 +92,7 @@
|
|||||||
}
|
}
|
||||||
}
|
}
|
||||||
|
|
||||||
@@ -1469,11 +1484,11 @@
|
@@ -1469,11 +1487,11 @@
|
||||||
}
|
}
|
||||||
|
|
||||||
if (!permitted)
|
if (!permitted)
|
||||||
@ -103,7 +106,7 @@
|
|||||||
}
|
}
|
||||||
|
|
||||||
if (debug)
|
if (debug)
|
||||||
@@ -1487,12 +1502,14 @@
|
@@ -1487,12 +1505,14 @@
|
||||||
fprintf(stderr,
|
fprintf(stderr,
|
||||||
_("Use the --debug option to see the details "
|
_("Use the --debug option to see the details "
|
||||||
"of our search for an access method.\n"));
|
"of our search for an access method.\n"));
|
||||||
@ -120,9 +123,9 @@
|
|||||||
}
|
}
|
||||||
|
|
||||||
/* A single routine for greater uniformity */
|
/* A single routine for greater uniformity */
|
||||||
--- /dev/null 2005-08-10 15:18:23.129961080 +0200
|
--- /dev/null 2005-08-29 11:11:19.415613608 +0200
|
||||||
+++ util-linux-2.13-pre1/hwclock/audit.c 2005-08-12 14:36:57.000000000 +0200
|
+++ util-linux-2.13-pre2/hwclock/audit.c 2005-08-30 11:10:38.000000000 +0200
|
||||||
@@ -0,0 +1,70 @@
|
@@ -0,0 +1,73 @@
|
||||||
+/* audit.c -- This file contains the audit system extensions
|
+/* audit.c -- This file contains the audit system extensions
|
||||||
+ *
|
+ *
|
||||||
+ * Copyright 2005 Red Hat Inc., Durham, North Carolina.
|
+ * Copyright 2005 Red Hat Inc., Durham, North Carolina.
|
||||||
@ -168,6 +171,9 @@
|
|||||||
+ const char *success;
|
+ const char *success;
|
||||||
+ extern char *progname;
|
+ extern char *progname;
|
||||||
+
|
+
|
||||||
|
+ if (audit_fd < 0)
|
||||||
|
+ return; /* kernel without audit support */
|
||||||
|
+
|
||||||
+ if (!result)
|
+ if (!result)
|
||||||
+ success = "success";
|
+ success = "success";
|
||||||
+ else
|
+ else
|
||||||
@ -193,8 +199,8 @@
|
|||||||
+ exit(status);
|
+ exit(status);
|
||||||
+}
|
+}
|
||||||
+
|
+
|
||||||
--- util-linux-2.13-pre1/hwclock/kd.c.audit 2005-07-31 18:01:20.000000000 +0200
|
--- util-linux-2.13-pre2/hwclock/kd.c.audit 2005-07-31 18:01:20.000000000 +0200
|
||||||
+++ util-linux-2.13-pre1/hwclock/kd.c 2005-08-12 14:36:57.000000000 +0200
|
+++ util-linux-2.13-pre2/hwclock/kd.c 2005-08-30 11:06:38.000000000 +0200
|
||||||
@@ -19,6 +19,7 @@
|
@@ -19,6 +19,7 @@
|
||||||
|
|
||||||
#include "clock.h"
|
#include "clock.h"
|
||||||
@ -221,19 +227,19 @@
|
|||||||
}
|
}
|
||||||
return 0;
|
return 0;
|
||||||
}
|
}
|
||||||
--- util-linux-2.13-pre1/hwclock/Makefile.am.audit 2005-08-12 14:37:27.000000000 +0200
|
--- util-linux-2.13-pre2/hwclock/Makefile.am.audit 2005-01-30 00:18:46.000000000 +0100
|
||||||
+++ util-linux-2.13-pre1/hwclock/Makefile.am 2005-08-12 14:50:39.000000000 +0200
|
+++ util-linux-2.13-pre2/hwclock/Makefile.am 2005-08-30 11:06:38.000000000 +0200
|
||||||
@@ -4,4 +4,5 @@
|
@@ -4,4 +4,5 @@
|
||||||
|
|
||||||
sbin_PROGRAMS = hwclock
|
sbin_PROGRAMS = hwclock
|
||||||
|
|
||||||
-hwclock_SOURCES = hwclock.c cmos.c rtc.c kd.c
|
-hwclock_SOURCES = hwclock.c cmos.c rtc.c kd.c
|
||||||
\ No newline at end of file
|
\ Chybí znak konce řádku na konci souboru
|
||||||
+hwclock_SOURCES = hwclock.c cmos.c rtc.c kd.c audit.c
|
+hwclock_SOURCES = hwclock.c cmos.c rtc.c kd.c audit.c
|
||||||
+hwclock_LDADD = -laudit
|
+hwclock_LDADD = -laudit
|
||||||
\ No newline at end of file
|
\ Chybí znak konce řádku na konci souboru
|
||||||
--- /dev/null 2005-08-10 15:18:23.129961080 +0200
|
--- /dev/null 2005-08-29 11:11:19.415613608 +0200
|
||||||
+++ util-linux-2.13-pre1/hwclock/audit.h 2005-08-12 14:36:57.000000000 +0200
|
+++ util-linux-2.13-pre2/hwclock/audit.h 2005-08-30 11:06:38.000000000 +0200
|
||||||
@@ -0,0 +1,34 @@
|
@@ -0,0 +1,34 @@
|
||||||
+/* audit.h -- This file contains the function prototypes for audit calls
|
+/* audit.h -- This file contains the function prototypes for audit calls
|
||||||
+ * Copyright 2005 Red Hat Inc., Durham, North Carolina.
|
+ * Copyright 2005 Red Hat Inc., Durham, North Carolina.
|
||||||
@ -269,8 +275,8 @@
|
|||||||
+void audit_exit(int status);
|
+void audit_exit(int status);
|
||||||
+
|
+
|
||||||
+#endif
|
+#endif
|
||||||
--- util-linux-2.13-pre1/hwclock/clock.h.audit 2000-12-07 17:39:53.000000000 +0100
|
--- util-linux-2.13-pre2/hwclock/clock.h.audit 2000-12-07 17:39:53.000000000 +0100
|
||||||
+++ util-linux-2.13-pre1/hwclock/clock.h 2005-08-12 14:36:57.000000000 +0200
|
+++ util-linux-2.13-pre2/hwclock/clock.h 2005-08-30 11:06:38.000000000 +0200
|
||||||
@@ -24,7 +24,12 @@
|
@@ -24,7 +24,12 @@
|
||||||
extern char *progname;
|
extern char *progname;
|
||||||
extern int debug;
|
extern int debug;
|
||||||
@ -285,8 +291,8 @@
|
|||||||
|
|
||||||
/* cmos.c */
|
/* cmos.c */
|
||||||
extern void set_cmos_epoch(int ARCconsole, int SRM);
|
extern void set_cmos_epoch(int ARCconsole, int SRM);
|
||||||
--- util-linux-2.13-pre1/hwclock/rtc.c.audit 2005-07-31 22:15:45.000000000 +0200
|
--- util-linux-2.13-pre2/hwclock/rtc.c.audit 2005-07-31 22:15:45.000000000 +0200
|
||||||
+++ util-linux-2.13-pre1/hwclock/rtc.c 2005-08-12 14:36:57.000000000 +0200
|
+++ util-linux-2.13-pre2/hwclock/rtc.c 2005-08-30 11:06:38.000000000 +0200
|
||||||
@@ -8,6 +8,7 @@
|
@@ -8,6 +8,7 @@
|
||||||
|
|
||||||
#include "clock.h"
|
#include "clock.h"
|
||||||
|
@ -151,10 +151,13 @@ Patch205: util-linux-2.12p-execl.patch
|
|||||||
# deprecated the arch command (for compatibility only)
|
# deprecated the arch command (for compatibility only)
|
||||||
Patch206: util-linux-2.13-arch.patch
|
Patch206: util-linux-2.13-arch.patch
|
||||||
|
|
||||||
# upstream mistakes
|
# upstream build system mistakes
|
||||||
Patch207: util-linux-2.13-agetty-man.patch
|
Patch207: util-linux-2.13-agetty-man.patch
|
||||||
Patch208: util-linux-2.13-usrsbin.patch
|
Patch208: util-linux-2.13-usrsbin.patch
|
||||||
|
|
||||||
|
#159410 - mkswap(8) claims max swap area size is 2 GB
|
||||||
|
Patch209: util-linux-2.12p-mkswap-man.patch
|
||||||
|
|
||||||
# When adding patches, please make sure that it is easy to find out what bug # the
|
# When adding patches, please make sure that it is easy to find out what bug # the
|
||||||
# patch fixes.
|
# patch fixes.
|
||||||
########### END upstreamable
|
########### END upstreamable
|
||||||
@ -221,6 +224,7 @@ cp %{SOURCE8} %{SOURCE9} .
|
|||||||
%patch206 -p1
|
%patch206 -p1
|
||||||
%patch207 -p1
|
%patch207 -p1
|
||||||
%patch208 -p1
|
%patch208 -p1
|
||||||
|
%patch209 -p1
|
||||||
|
|
||||||
%build
|
%build
|
||||||
unset LINGUAS || :
|
unset LINGUAS || :
|
||||||
@ -642,6 +646,10 @@ fi
|
|||||||
/sbin/losetup
|
/sbin/losetup
|
||||||
|
|
||||||
%changelog
|
%changelog
|
||||||
|
* Tue Aug 30 2005 Karel Zak <kzak@redhat.com> 2.13-0.3.pre2
|
||||||
|
- fix #166923 - hwclock will not run on a non audit-enabled kernel
|
||||||
|
- fix #159410 - mkswap(8) claims max swap area size is 2 GB
|
||||||
|
|
||||||
* Tue Aug 16 2005 Karel Zak <kzak@redhat.com> 2.13-0.2.pre2
|
* Tue Aug 16 2005 Karel Zak <kzak@redhat.com> 2.13-0.2.pre2
|
||||||
- /usr/share/misc/getopt/* -move-> /usr/share/doc/util-linux-2.13/getopt-*
|
- /usr/share/misc/getopt/* -move-> /usr/share/doc/util-linux-2.13/getopt-*
|
||||||
- the arch command marked as deprecated
|
- the arch command marked as deprecated
|
||||||
|
Loading…
Reference in New Issue
Block a user