store xattrs for symlinks (#525992) - by Kamil Dudka, update tar(1) manpage
(#539787), fix memory leak in xheader (#518079)
This commit is contained in:
parent
5b40de24b4
commit
7b35b1d07b
File diff suppressed because it is too large
Load Diff
@ -1,13 +0,0 @@
|
|||||||
diff --git a/src/create.c b/src/create.c
|
|
||||||
index c7cf64c..f807a3d 100644
|
|
||||||
--- a/src/create.c
|
|
||||||
+++ b/src/create.c
|
|
||||||
@@ -1746,6 +1746,8 @@ dump_file0 (struct tar_stat_info *st, const char *p,
|
|
||||||
if (NAME_FIELD_SIZE - (archive_format == OLDGNU_FORMAT) < size)
|
|
||||||
write_long_link (st);
|
|
||||||
|
|
||||||
+ xattrs_selinux_get(st, p, -1);
|
|
||||||
+
|
|
||||||
block_ordinal = current_block_ordinal ();
|
|
||||||
st->stat.st_size = 0; /* force 0 size on symlink */
|
|
||||||
header = start_header (st);
|
|
11
tar-1.22-xheaderleak.patch
Normal file
11
tar-1.22-xheaderleak.patch
Normal file
@ -0,0 +1,11 @@
|
|||||||
|
diff -urNp tar-1.22-orig/src/xheader.c tar-1.22/src/xheader.c
|
||||||
|
--- tar-1.22-orig/src/xheader.c 2009-11-23 15:29:22.000000000 +0100
|
||||||
|
+++ tar-1.22/src/xheader.c 2009-11-23 15:30:55.000000000 +0100
|
||||||
|
@@ -722,7 +722,6 @@ xheader_read (struct xheader *xhdr, unio
|
||||||
|
{
|
||||||
|
size_t j = 0;
|
||||||
|
|
||||||
|
- xheader_init (xhdr);
|
||||||
|
size += BLOCKSIZE;
|
||||||
|
xhdr->size = size;
|
||||||
|
xhdr->buffer = xmalloc (size + 1);
|
27
tar.spec
27
tar.spec
@ -2,7 +2,7 @@ Summary: A GNU file archiving program
|
|||||||
Name: tar
|
Name: tar
|
||||||
Epoch: 2
|
Epoch: 2
|
||||||
Version: 1.22
|
Version: 1.22
|
||||||
Release: 9%{?dist}
|
Release: 10%{?dist}
|
||||||
License: GPLv3+
|
License: GPLv3+
|
||||||
Group: Applications/Archiving
|
Group: Applications/Archiving
|
||||||
URL: http://www.gnu.org/software/tar/
|
URL: http://www.gnu.org/software/tar/
|
||||||
@ -12,11 +12,11 @@ Source2: tar.1
|
|||||||
Patch1: tar-1.14-loneZeroWarning.patch
|
Patch1: tar-1.14-loneZeroWarning.patch
|
||||||
Patch2: tar-1.15.1-vfatTruncate.patch
|
Patch2: tar-1.15.1-vfatTruncate.patch
|
||||||
Patch3: tar-1.19-xattrs.patch
|
Patch3: tar-1.19-xattrs.patch
|
||||||
Patch4: tar-1.22-store-lnk-selinux.patch
|
Patch4: tar-1.17-wildcards.patch
|
||||||
Patch5: tar-1.17-wildcards.patch
|
Patch5: tar-1.22-atime-rofs.patch
|
||||||
Patch6: tar-1.22-atime-rofs.patch
|
Patch6: tar-1.22-shortreadbuffer.patch
|
||||||
Patch7: tar-1.22-shortreadbuffer.patch
|
Patch7: tar-1.22-fortifysourcessigabrt.patch
|
||||||
Patch8: tar-1.22-fortifysourcessigabrt.patch
|
Patch8: tar-1.22-xheaderleak.patch
|
||||||
Prereq: info
|
Prereq: info
|
||||||
BuildRequires: autoconf automake gzip texinfo gettext libacl-devel libselinux-devel gawk rsh
|
BuildRequires: autoconf automake gzip texinfo gettext libacl-devel libselinux-devel gawk rsh
|
||||||
Buildroot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
|
Buildroot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
|
||||||
@ -40,11 +40,11 @@ the rmt package.
|
|||||||
%patch1 -p1 -b .loneZeroWarning
|
%patch1 -p1 -b .loneZeroWarning
|
||||||
%patch2 -p1 -b .vfatTruncate
|
%patch2 -p1 -b .vfatTruncate
|
||||||
%patch3 -p1 -b .xattrs
|
%patch3 -p1 -b .xattrs
|
||||||
%patch4 -p1 -b .store-lnk-selinux
|
%patch4 -p1 -b .wildcards
|
||||||
%patch5 -p1 -b .wildcards
|
%patch5 -p1 -b .rofs
|
||||||
%patch6 -p1 -b .rofs
|
%patch6 -p1 -b .shortread
|
||||||
%patch7 -p1 -b .shortread
|
%patch7 -p1 -b .headerblackmagic
|
||||||
%patch8 -p1 -b .headerblackmagic
|
%patch8 -p1 -b .xheaderleak
|
||||||
|
|
||||||
%build
|
%build
|
||||||
autoreconf
|
autoreconf
|
||||||
@ -102,6 +102,11 @@ fi
|
|||||||
%{_infodir}/tar.info*
|
%{_infodir}/tar.info*
|
||||||
|
|
||||||
%changelog
|
%changelog
|
||||||
|
* Fri Nov 27 2009 Ondrej Vasik <ovasik@redhat.com> 2:1.22-10
|
||||||
|
- store xattrs for symlinks (#525992) - by Kamil Dudka
|
||||||
|
- update tar(1) manpage (#539787)
|
||||||
|
- fix memory leak in xheader (#518079)
|
||||||
|
|
||||||
* Wed Nov 18 2009 Kamil Dudka <kdudka@redhat.com> 2:1.22-9
|
* Wed Nov 18 2009 Kamil Dudka <kdudka@redhat.com> 2:1.22-9
|
||||||
- store SELinux context for symlinks (#525992)
|
- store SELinux context for symlinks (#525992)
|
||||||
|
|
||||||
|
Loading…
Reference in New Issue
Block a user