Resolves: rhbz2029924

reset sys/sdt.h asm operand constraints
This commit is contained in:
Stan Cox 2021-12-07 11:44:12 -05:00
parent 302b80039b
commit 8a6427b8ce
2 changed files with 19 additions and 8 deletions

View File

@ -116,6 +116,14 @@ index 4f2539c93..530a79175 100644
+ else + else
+ printf("FAIL: %s (%d/%d != 42/43)\n", $$name, $arg1, $arg2) + printf("FAIL: %s (%d/%d != 42/43)\n", $$name, $arg1, $arg2)
+} +}
commit 209b5a19c (HEAD -> master, origin/master, origin/HEAD)
Author: Stan Cox <scox@redhat.com>
Date: Tue Dec 7 09:55:01 2021 -0500
sys/sdt.h fp constraints: aarch64, s390
Remove float constraints as per commit 1d3653936 but for aarch64 and s390.
commit 1d3653936 (HEAD -> master, origin/master, origin/HEAD) commit 1d3653936 (HEAD -> master, origin/master, origin/HEAD)
Author: Frank Ch. Eigler <fche@redhat.com> Author: Frank Ch. Eigler <fche@redhat.com>
Date: Mon Dec 6 12:06:06 2021 -0500 Date: Mon Dec 6 12:06:06 2021 -0500
@ -131,16 +139,16 @@ Date: Mon Dec 6 12:06:06 2021 -0500
We may need to restore previous constraints broadly, forcing the We may need to restore previous constraints broadly, forcing the
compiler to plop floating point parameters into integer storage. compiler to plop floating point parameters into integer storage.
diff --git a/includes/sys/sdt.h b/includes/sys/sdt.h
index 24d5e01c3..3e1f00b6c 100644
--- a/includes/sys/sdt.h --- a/includes/sys/sdt.h
+++ b/includes/sys/sdt.h +++ b/includes/sys/sdt.h
@@ -101,7 +101,7 @@ @@ -102,9 +102,5 @@
# if defined __powerpc__
# define STAP_SDT_ARG_CONSTRAINT nZr # define STAP_SDT_ARG_CONSTRAINT nZr
# elif defined __x86_64__ # elif defined __x86_64__
-# define STAP_SDT_ARG_CONSTRAINT norfxy -# define STAP_SDT_ARG_CONSTRAINT norfxy
-# elif defined __aarch64__
-# define STAP_SDT_ARG_CONSTRAINT norw
-# elif defined __s390__ || defined __s390x__
-# define STAP_SDT_ARG_CONSTRAINT norf
+# define STAP_SDT_ARG_CONSTRAINT norx +# define STAP_SDT_ARG_CONSTRAINT norx
# elif defined __aarch64__ # else
# define STAP_SDT_ARG_CONSTRAINT norw # define STAP_SDT_ARG_CONSTRAINT nor
# elif defined __s390__ || defined __s390x__

View File

@ -118,7 +118,7 @@ m stapdev stapdev
Name: systemtap Name: systemtap
Version: 4.6 Version: 4.6
Release: 4%{?release_override}%{?dist} Release: 5%{?release_override}%{?dist}
# for version, see also configure.ac # for version, see also configure.ac
@ -1277,6 +1277,9 @@ exit 0
# PRERELEASE # PRERELEASE
%changelog %changelog
* Tue Dec 07 2021 Stan Cox <scox@redhat.com> - 4.6.5
- sys/sdt.h remove aarch64 and s390 float constraints
* Mon Dec 06 2021 Stan Cox <scox@redhat.com> - 4.6.4 * Mon Dec 06 2021 Stan Cox <scox@redhat.com> - 4.6.4
- sys/sdt.h remove float constraints that may cause gcc reload issues. - sys/sdt.h remove float constraints that may cause gcc reload issues.