Resolves: rhbz2025054
sys/sdt.h remove float constraints that may cause gcc reload issues.
This commit is contained in:
parent
2b5617f173
commit
302b80039b
@ -116,3 +116,31 @@ index 4f2539c93..530a79175 100644
|
||||
+ else
|
||||
+ printf("FAIL: %s (%d/%d != 42/43)\n", $$name, $arg1, $arg2)
|
||||
+}
|
||||
commit 1d3653936 (HEAD -> master, origin/master, origin/HEAD)
|
||||
Author: Frank Ch. Eigler <fche@redhat.com>
|
||||
Date: Mon Dec 6 12:06:06 2021 -0500
|
||||
|
||||
sys/sdt.h fp constraints cont'd, x86-64 edition
|
||||
|
||||
It appears that various versions of gcc continue to show signs of
|
||||
confusion at our newly offered asm-operand alternatives for floating
|
||||
point sdt.h marker parameters.
|
||||
|
||||
e.g., https://bugzilla.redhat.com/show_bug.cgi?id=2028798
|
||||
|
||||
We may need to restore previous constraints broadly, forcing the
|
||||
compiler to plop floating point parameters into integer storage.
|
||||
|
||||
diff --git a/includes/sys/sdt.h b/includes/sys/sdt.h
|
||||
index 24d5e01c3..3e1f00b6c 100644
|
||||
--- a/includes/sys/sdt.h
|
||||
+++ b/includes/sys/sdt.h
|
||||
@@ -101,7 +101,7 @@
|
||||
# if defined __powerpc__
|
||||
# define STAP_SDT_ARG_CONSTRAINT nZr
|
||||
# elif defined __x86_64__
|
||||
-# define STAP_SDT_ARG_CONSTRAINT norfxy
|
||||
+# define STAP_SDT_ARG_CONSTRAINT norx
|
||||
# elif defined __aarch64__
|
||||
# define STAP_SDT_ARG_CONSTRAINT norw
|
||||
# elif defined __s390__ || defined __s390x__
|
||||
|
@ -118,7 +118,7 @@ m stapdev stapdev
|
||||
|
||||
Name: systemtap
|
||||
Version: 4.6
|
||||
Release: 3%{?release_override}%{?dist}
|
||||
Release: 4%{?release_override}%{?dist}
|
||||
# for version, see also configure.ac
|
||||
|
||||
|
||||
@ -1277,6 +1277,9 @@ exit 0
|
||||
|
||||
# PRERELEASE
|
||||
%changelog
|
||||
* Mon Dec 06 2021 Stan Cox <scox@redhat.com> - 4.6.4
|
||||
- sys/sdt.h remove float constraints that may cause gcc reload issues.
|
||||
|
||||
* Thu Dec 02 2021 Frank Ch. Eigler <fche@redhat.com> - 4.6.3
|
||||
- rhbz2972798 - nfs tapset tweaks
|
||||
- sys/sdt.h fixes for glibc ftbfs
|
||||
|
Loading…
Reference in New Issue
Block a user