Update to new snapshot release
- Refresh patch for multilib support
This commit is contained in:
parent
ad275627df
commit
31d67c6d69
1
.gitignore
vendored
1
.gitignore
vendored
@ -1 +1,2 @@
|
||||
/sdl12-compat-cc5826a.tar.gz
|
||||
/sdl12-compat-efe9791.tar.gz
|
||||
|
@ -1,6 +1,6 @@
|
||||
From d5e9e51860f4e90f7ba0bb53b1c26740dc1ee7eb Mon Sep 17 00:00:00 2001
|
||||
From 3cfbf8e889b50d5d19795d6f81f66345c70ce4e0 Mon Sep 17 00:00:00 2001
|
||||
From: Neal Gompa <ngompa@fedoraproject.org>
|
||||
Date: Thu, 3 Jun 2021 08:31:58 -0400
|
||||
Date: Wed, 9 Jun 2021 06:57:51 -0400
|
||||
Subject: [PATCH] Remove libdir definition from sdl-config for multilib support
|
||||
|
||||
If we export the library directory, then the contents of sdl-config
|
||||
@ -9,44 +9,31 @@ not multilib-safe.
|
||||
|
||||
Thus, strip out the libdir stuff so that this isn't a problem.
|
||||
---
|
||||
CMakeLists.txt | 1 -
|
||||
sdl-config.in | 5 ++---
|
||||
2 files changed, 2 insertions(+), 4 deletions(-)
|
||||
sdl-config.in | 5 ++---
|
||||
1 file changed, 2 insertions(+), 3 deletions(-)
|
||||
|
||||
diff --git a/CMakeLists.txt b/CMakeLists.txt
|
||||
index 6256c3a..9163f9f 100644
|
||||
--- a/CMakeLists.txt
|
||||
+++ b/CMakeLists.txt
|
||||
@@ -182,7 +182,6 @@ if(SDL12DEVEL)
|
||||
set(SDL_STATIC_LIBS "-lm -ldl -lpthread")
|
||||
set(prefix ${CMAKE_INSTALL_PREFIX})
|
||||
set(exec_prefix "\${prefix}")
|
||||
- set(libdir "\${exec_prefix}/lib${LIB_SUFFIX}")
|
||||
set(bindir "\${exec_prefix}/bin")
|
||||
set(includedir "\${prefix}/include")
|
||||
configure_file("${CMAKE_SOURCE_DIR}/sdl-config.in" "${CMAKE_BINARY_DIR}/sdl-config" @ONLY)
|
||||
diff --git a/sdl-config.in b/sdl-config.in
|
||||
index f7895c2..e55633e 100755
|
||||
index 528a355..addabd8 100755
|
||||
--- a/sdl-config.in
|
||||
+++ b/sdl-config.in
|
||||
@@ -10,7 +10,6 @@
|
||||
prefix=@prefix@
|
||||
exec_prefix=@exec_prefix@
|
||||
prefix=@CMAKE_INSTALL_PREFIX@
|
||||
exec_prefix=${prefix}
|
||||
exec_prefix_set=no
|
||||
-libdir=@libdir@
|
||||
-libdir=@CMAKE_INSTALL_FULL_LIBDIR@
|
||||
includedir=@CMAKE_INSTALL_FULL_INCLUDEDIR@
|
||||
|
||||
@ENABLE_STATIC_FALSE@usage="\
|
||||
@ENABLE_STATIC_FALSE@Usage: $0 [--prefix[=DIR]] [--exec-prefix[=DIR]] [--version] [--cflags] [--libs]"
|
||||
@@ -52,11 +51,11 @@ while test $# -gt 0; do
|
||||
echo -I@includedir@/SDL2 @SDL_CFLAGS@
|
||||
@@ -53,11 +52,11 @@ while test $# -gt 0; do
|
||||
echo -I${includedir}/SDL @SDL_CFLAGS@
|
||||
;;
|
||||
@ENABLE_SHARED_TRUE@ --libs)
|
||||
-@ENABLE_SHARED_TRUE@ echo -L@libdir@ @SDL_RLD_FLAGS@ @SDL_LIBS@
|
||||
-@ENABLE_SHARED_TRUE@ echo -L${libdir} @SDL_RLD_FLAGS@ @SDL_LIBS@
|
||||
+@ENABLE_SHARED_TRUE@ echo @SDL_RLD_FLAGS@ @SDL_LIBS@
|
||||
@ENABLE_SHARED_TRUE@ ;;
|
||||
@ENABLE_STATIC_TRUE@@ENABLE_SHARED_TRUE@ --static-libs)
|
||||
@ENABLE_STATIC_TRUE@@ENABLE_SHARED_FALSE@ --libs|--static-libs)
|
||||
-@ENABLE_STATIC_TRUE@ echo -L@libdir@ @SDL_LIBS@ @SDL_STATIC_LIBS@
|
||||
-@ENABLE_STATIC_TRUE@ echo -L${libdir} @SDL_LIBS@ @SDL_STATIC_LIBS@
|
||||
+@ENABLE_STATIC_TRUE@ echo @SDL_LIBS@ @SDL_STATIC_LIBS@
|
||||
@ENABLE_STATIC_TRUE@ ;;
|
||||
*)
|
||||
|
@ -1,10 +1,10 @@
|
||||
%global commit cc5826a7553ad850de1dfc1264128d9df6d44fa2
|
||||
%global commit efe97912a54260f3e4c4b2ba5629986adbb9aff7
|
||||
%global shortcommit %(c=%{commit}; echo ${c:0:7})
|
||||
%global commitdate 20210602
|
||||
%global commitdate 20210609
|
||||
|
||||
Name: sdl12-compat
|
||||
Version: 0.0.1~git.%{commitdate}.%{shortcommit}
|
||||
Release: 3%{?dist}
|
||||
Release: 1%{?dist}
|
||||
Summary: SDL 1.2 runtime compatibility library using SDL 2.0
|
||||
|
||||
License: zlib
|
||||
@ -92,10 +92,15 @@ install -m644 %{SOURCE1} %{buildroot}/%{_includedir}/SDL/SDL_config.h
|
||||
%{_bindir}/sdl-config
|
||||
%{_includedir}/SDL/
|
||||
%{_libdir}/libSDL-1.2.so
|
||||
%{_libdir}/libSDL.so
|
||||
%{_libdir}/pkgconfig/sdl12_compat.pc
|
||||
|
||||
|
||||
%changelog
|
||||
* Wed Jun 09 2021 Neal Gompa <ngompa13@gmail.com> - 0.0.1~git.20210609.efe9791-1
|
||||
- Update to new snapshot release
|
||||
- Refresh patch for multilib support
|
||||
|
||||
* Thu Jun 03 2021 Neal Gompa <ngompa13@gmail.com> - 0.0.1~git.20210602.cc5826a-3
|
||||
- Fix for multilib support
|
||||
|
||||
|
2
sources
2
sources
@ -1 +1 @@
|
||||
SHA512 (sdl12-compat-cc5826a.tar.gz) = bc5b3299353f14b688ac39e8cef1a000d5c25f0fc1a0028197f06f2e316dd55daa2b6350d8a99bb84e7439d520d18822eab6984c3e857f8cbcf6f46083200f29
|
||||
SHA512 (sdl12-compat-efe9791.tar.gz) = 6f58f7ac4ca1328cee37eb0cc32564c03213d041192d22a2923655d0963dcedd7127b2da0ec5926c998ee17e96da16d3031bbe356c6eb6a8a7b072eeedabe259
|
||||
|
Loading…
Reference in New Issue
Block a user