Upgrade to Ruby 2.4.2.
Resolves: rhbz#1506785
This commit is contained in:
parent
4cb333ddd5
commit
89f3ea9d4a
@ -39,7 +39,7 @@ diff --git a/configure.in b/configure.in
|
|||||||
index 0e371e2..d4f1dcb 100644
|
index 0e371e2..d4f1dcb 100644
|
||||||
--- a/configure.in
|
--- a/configure.in
|
||||||
+++ b/configure.in
|
+++ b/configure.in
|
||||||
@@ -4536,6 +4536,13 @@ AC_SUBST(rubyarchhdrdir)dnl
|
@@ -4563,6 +4563,13 @@ AC_SUBST(rubyarchhdrdir)dnl
|
||||||
AC_SUBST(sitearchhdrdir)dnl
|
AC_SUBST(sitearchhdrdir)dnl
|
||||||
AC_SUBST(vendorarchhdrdir)dnl
|
AC_SUBST(vendorarchhdrdir)dnl
|
||||||
|
|
||||||
|
@ -11,7 +11,7 @@ diff --git a/configure.in b/configure.in
|
|||||||
index 37d9a62..553d4d0 100644
|
index 37d9a62..553d4d0 100644
|
||||||
--- a/configure.in
|
--- a/configure.in
|
||||||
+++ b/configure.in
|
+++ b/configure.in
|
||||||
@@ -3790,6 +3790,11 @@ if test ${multiarch+set}; then
|
@@ -3823,6 +3823,11 @@ if test ${multiarch+set}; then
|
||||||
fi
|
fi
|
||||||
|
|
||||||
archlibdir='${libdir}/${arch}'
|
archlibdir='${libdir}/${arch}'
|
||||||
|
@ -14,7 +14,7 @@ diff --git a/configure.in b/configure.in
|
|||||||
index db37cd6..ce8d149 100644
|
index db37cd6..ce8d149 100644
|
||||||
--- a/configure.in
|
--- a/configure.in
|
||||||
+++ b/configure.in
|
+++ b/configure.in
|
||||||
@@ -4390,7 +4390,8 @@ AS_CASE(["$ruby_version_dir_name"],
|
@@ -4417,7 +4417,8 @@ AS_CASE(["$ruby_version_dir_name"],
|
||||||
ruby_version_dir=/'${ruby_version_dir_name}'
|
ruby_version_dir=/'${ruby_version_dir_name}'
|
||||||
|
|
||||||
if test -z "${ruby_version_dir_name}"; then
|
if test -z "${ruby_version_dir_name}"; then
|
||||||
|
@ -11,7 +11,7 @@ diff --git a/configure.in b/configure.in
|
|||||||
index 553d4d0..03a4152 100644
|
index 553d4d0..03a4152 100644
|
||||||
--- a/configure.in
|
--- a/configure.in
|
||||||
+++ b/configure.in
|
+++ b/configure.in
|
||||||
@@ -4454,6 +4454,8 @@ AC_SUBST(vendorarchdir)dnl
|
@@ -4481,6 +4481,8 @@ AC_SUBST(vendorarchdir)dnl
|
||||||
AC_SUBST(CONFIGURE, "`echo $0 | sed 's|.*/||'`")dnl
|
AC_SUBST(CONFIGURE, "`echo $0 | sed 's|.*/||'`")dnl
|
||||||
AC_SUBST(configure_args, "`echo "${ac_configure_args}" | sed 's/\\$/$$/g'`")dnl
|
AC_SUBST(configure_args, "`echo "${ac_configure_args}" | sed 's/\\$/$$/g'`")dnl
|
||||||
|
|
||||||
|
@ -15,7 +15,7 @@ diff --git a/configure.in b/configure.in
|
|||||||
index 03a4152..0e371e2 100644
|
index 03a4152..0e371e2 100644
|
||||||
--- a/configure.in
|
--- a/configure.in
|
||||||
+++ b/configure.in
|
+++ b/configure.in
|
||||||
@@ -4426,6 +4426,10 @@ AC_ARG_WITH(vendorarchdir,
|
@@ -4453,6 +4453,10 @@ AC_ARG_WITH(vendorarchdir,
|
||||||
[vendorarchdir=$withval],
|
[vendorarchdir=$withval],
|
||||||
[vendorarchdir=${multiarch+'${rubysitearchprefix}/vendor_ruby'${ruby_version_dir}}${multiarch-'${vendorlibdir}/${sitearch}'}])
|
[vendorarchdir=${multiarch+'${rubysitearchprefix}/vendor_ruby'${ruby_version_dir}}${multiarch-'${vendorlibdir}/${sitearch}'}])
|
||||||
|
|
||||||
@ -26,7 +26,7 @@ index 03a4152..0e371e2 100644
|
|||||||
if test "${LOAD_RELATIVE+set}"; then
|
if test "${LOAD_RELATIVE+set}"; then
|
||||||
AC_DEFINE_UNQUOTED(LOAD_RELATIVE, $LOAD_RELATIVE)
|
AC_DEFINE_UNQUOTED(LOAD_RELATIVE, $LOAD_RELATIVE)
|
||||||
RUBY_EXEC_PREFIX=''
|
RUBY_EXEC_PREFIX=''
|
||||||
@@ -4450,6 +4454,7 @@ AC_SUBST(sitearchdir)dnl
|
@@ -4477,6 +4481,7 @@ AC_SUBST(sitearchdir)dnl
|
||||||
AC_SUBST(vendordir)dnl
|
AC_SUBST(vendordir)dnl
|
||||||
AC_SUBST(vendorlibdir)dnl
|
AC_SUBST(vendorlibdir)dnl
|
||||||
AC_SUBST(vendorarchdir)dnl
|
AC_SUBST(vendorarchdir)dnl
|
||||||
|
@ -20,7 +20,7 @@ diff --git a/configure.in b/configure.in
|
|||||||
index db37cd6..6e73fae 100644
|
index db37cd6..6e73fae 100644
|
||||||
--- a/configure.in
|
--- a/configure.in
|
||||||
+++ b/configure.in
|
+++ b/configure.in
|
||||||
@@ -4341,9 +4341,6 @@ AS_CASE(["$target_os"],
|
@@ -4368,9 +4368,6 @@ AS_CASE(["$target_os"],
|
||||||
rubyw_install_name='$(RUBYW_INSTALL_NAME)'
|
rubyw_install_name='$(RUBYW_INSTALL_NAME)'
|
||||||
])
|
])
|
||||||
|
|
||||||
@ -30,7 +30,7 @@ index db37cd6..6e73fae 100644
|
|||||||
rubyarchprefix=${multiarch+'${archlibdir}/${RUBY_BASE_NAME}'}${multiarch-'${rubylibprefix}/${arch}'}
|
rubyarchprefix=${multiarch+'${archlibdir}/${RUBY_BASE_NAME}'}${multiarch-'${rubylibprefix}/${arch}'}
|
||||||
AC_ARG_WITH(rubyarchprefix,
|
AC_ARG_WITH(rubyarchprefix,
|
||||||
AS_HELP_STRING([--with-rubyarchprefix=DIR],
|
AS_HELP_STRING([--with-rubyarchprefix=DIR],
|
||||||
@@ -4366,56 +4363,62 @@ AC_ARG_WITH(ridir,
|
@@ -4393,56 +4390,62 @@ AC_ARG_WITH(ridir,
|
||||||
AC_SUBST(ridir)
|
AC_SUBST(ridir)
|
||||||
AC_SUBST(RI_BASE_NAME)
|
AC_SUBST(RI_BASE_NAME)
|
||||||
|
|
||||||
@ -120,7 +120,7 @@ index db37cd6..6e73fae 100644
|
|||||||
|
|
||||||
if test "${LOAD_RELATIVE+set}"; then
|
if test "${LOAD_RELATIVE+set}"; then
|
||||||
AC_DEFINE_UNQUOTED(LOAD_RELATIVE, $LOAD_RELATIVE)
|
AC_DEFINE_UNQUOTED(LOAD_RELATIVE, $LOAD_RELATIVE)
|
||||||
@@ -4432,6 +4435,7 @@ AC_SUBST(sitearchincludedir)dnl
|
@@ -4459,6 +4462,7 @@ AC_SUBST(sitearchincludedir)dnl
|
||||||
AC_SUBST(arch)dnl
|
AC_SUBST(arch)dnl
|
||||||
AC_SUBST(sitearch)dnl
|
AC_SUBST(sitearch)dnl
|
||||||
AC_SUBST(ruby_version)dnl
|
AC_SUBST(ruby_version)dnl
|
||||||
@ -245,7 +245,7 @@ diff --git a/test/rubygems/test_gem.rb b/test/rubygems/test_gem.rb
|
|||||||
index 0428bea..b6e090e 100644
|
index 0428bea..b6e090e 100644
|
||||||
--- a/test/rubygems/test_gem.rb
|
--- a/test/rubygems/test_gem.rb
|
||||||
+++ b/test/rubygems/test_gem.rb
|
+++ b/test/rubygems/test_gem.rb
|
||||||
@@ -1101,7 +1101,8 @@ def test_self_use_paths
|
@@ -1124,7 +1124,8 @@ def test_self_use_paths
|
||||||
|
|
||||||
def test_self_user_dir
|
def test_self_user_dir
|
||||||
parts = [@userhome, '.gem', Gem.ruby_engine]
|
parts = [@userhome, '.gem', Gem.ruby_engine]
|
||||||
@ -255,7 +255,7 @@ index 0428bea..b6e090e 100644
|
|||||||
|
|
||||||
assert_equal File.join(parts), Gem.user_dir
|
assert_equal File.join(parts), Gem.user_dir
|
||||||
end
|
end
|
||||||
@@ -1228,7 +1229,7 @@ def test_self_user_home_user_drive_and_path
|
@@ -1251,7 +1252,7 @@ def test_self_user_home_user_drive_and_path
|
||||||
def test_self_vendor_dir
|
def test_self_vendor_dir
|
||||||
expected =
|
expected =
|
||||||
File.join RbConfig::CONFIG['vendordir'], 'gems',
|
File.join RbConfig::CONFIG['vendordir'], 'gems',
|
||||||
|
@ -1,36 +0,0 @@
|
|||||||
From ff3496b0116ed2ed589d000b7bfca3d8288b009c Mon Sep 17 00:00:00 2001
|
|
||||||
From: nobu <nobu@b2dd03c8-39d4-4d8f-98ff-823fe69b080e>
|
|
||||||
Date: Mon, 9 Jan 2017 02:55:39 +0000
|
|
||||||
Subject: [PATCH] vm_insnhelper.c: block argument at tailcall
|
|
||||||
|
|
||||||
* vm_insnhelper.c (vm_call_iseq_setup_tailcall): check interrupts
|
|
||||||
after set up the new frame, not the passed block to be clobbered
|
|
||||||
by invoked finalizers and so on. [ruby-core:78981] [Bug #13107]
|
|
||||||
|
|
||||||
git-svn-id: svn+ssh://ci.ruby-lang.org/ruby/trunk@57293 b2dd03c8-39d4-4d8f-98ff-823fe69b080e
|
|
||||||
---
|
|
||||||
vm_insnhelper.c | 4 ++--
|
|
||||||
1 file changed, 2 insertions(+), 2 deletions(-)
|
|
||||||
|
|
||||||
diff --git a/vm_insnhelper.c b/vm_insnhelper.c
|
|
||||||
index b580412..662a2d6 100644
|
|
||||||
--- a/vm_insnhelper.c
|
|
||||||
+++ b/vm_insnhelper.c
|
|
||||||
@@ -1538,8 +1538,6 @@ vm_call_iseq_setup_tailcall(rb_thread_t *th, rb_control_frame_t *cfp, struct rb_
|
|
||||||
vm_pop_frame(th, cfp, cfp->ep);
|
|
||||||
cfp = th->cfp;
|
|
||||||
|
|
||||||
- RUBY_VM_CHECK_INTS(th);
|
|
||||||
-
|
|
||||||
sp_orig = sp = cfp->sp;
|
|
||||||
|
|
||||||
/* push self */
|
|
||||||
@@ -1558,6 +1556,8 @@ vm_call_iseq_setup_tailcall(rb_thread_t *th, rb_control_frame_t *cfp, struct rb_
|
|
||||||
iseq->body->stack_max);
|
|
||||||
|
|
||||||
cfp->sp = sp_orig;
|
|
||||||
+ RUBY_VM_CHECK_INTS(th);
|
|
||||||
+
|
|
||||||
return Qundef;
|
|
||||||
}
|
|
||||||
|
|
43
ruby.spec
43
ruby.spec
@ -3,7 +3,7 @@
|
|||||||
|
|
||||||
%global major_version 2
|
%global major_version 2
|
||||||
%global minor_version 4
|
%global minor_version 4
|
||||||
%global teeny_version 0
|
%global teeny_version 2
|
||||||
%global major_minor_version %{major_version}.%{minor_version}
|
%global major_minor_version %{major_version}.%{minor_version}
|
||||||
|
|
||||||
%global ruby_version %{major_minor_version}.%{teeny_version}
|
%global ruby_version %{major_minor_version}.%{teeny_version}
|
||||||
@ -24,7 +24,7 @@
|
|||||||
%endif
|
%endif
|
||||||
|
|
||||||
|
|
||||||
%global release 75
|
%global release 86
|
||||||
%{!?release_string:%global release_string %{?development_release:0.}%{release}%{?development_release:.%{development_release}}%{?dist}}
|
%{!?release_string:%global release_string %{?development_release:0.}%{release}%{?development_release:.%{development_release}}%{?dist}}
|
||||||
|
|
||||||
# The RubyGems library has to stay out of Ruby directory three, since the
|
# The RubyGems library has to stay out of Ruby directory three, since the
|
||||||
@ -32,8 +32,8 @@
|
|||||||
%global rubygems_dir %{_datadir}/rubygems
|
%global rubygems_dir %{_datadir}/rubygems
|
||||||
|
|
||||||
# Bundled libraries versions
|
# Bundled libraries versions
|
||||||
%global rubygems_version 2.6.8
|
%global rubygems_version 2.6.13
|
||||||
%global molinillo_version 0.5.3
|
%global molinillo_version 0.5.7
|
||||||
|
|
||||||
# TODO: The IRB has strange versioning. Keep the Ruby's versioning ATM.
|
# TODO: The IRB has strange versioning. Keep the Ruby's versioning ATM.
|
||||||
# http://redmine.ruby-lang.org/issues/5313
|
# http://redmine.ruby-lang.org/issues/5313
|
||||||
@ -42,10 +42,10 @@
|
|||||||
%global bigdecimal_version 1.3.0
|
%global bigdecimal_version 1.3.0
|
||||||
%global did_you_mean_version 1.1.0
|
%global did_you_mean_version 1.1.0
|
||||||
%global io_console_version 0.4.6
|
%global io_console_version 0.4.6
|
||||||
%global json_version 2.0.2
|
%global json_version 2.0.4
|
||||||
%global minitest_version 5.10.1
|
%global minitest_version 5.10.1
|
||||||
%global net_telnet_version 0.1.1
|
%global net_telnet_version 0.1.1
|
||||||
%global openssl_version 2.0.2
|
%global openssl_version 2.0.5
|
||||||
%global power_assert_version 0.4.1
|
%global power_assert_version 0.4.1
|
||||||
%global psych_version 2.2.2
|
%global psych_version 2.2.2
|
||||||
%global rake_version 12.0.0
|
%global rake_version 12.0.0
|
||||||
@ -62,9 +62,13 @@
|
|||||||
%global _normalized_cpu %(echo %{_target_cpu} | sed 's/^ppc/powerpc/;s/i.86/i386/;s/sparcv./sparc/')
|
%global _normalized_cpu %(echo %{_target_cpu} | sed 's/^ppc/powerpc/;s/i.86/i386/;s/sparcv./sparc/')
|
||||||
|
|
||||||
%if 0%{?fedora} >= 19
|
%if 0%{?fedora} >= 19
|
||||||
%global with_rubypick 1
|
%bcond_without rubypick
|
||||||
%endif
|
%endif
|
||||||
|
|
||||||
|
%bcond_without systemtap
|
||||||
|
%bcond_without git
|
||||||
|
%bcond_without cmake
|
||||||
|
|
||||||
%if 0%{?fedora}
|
%if 0%{?fedora}
|
||||||
%global with_checksec 1
|
%global with_checksec 1
|
||||||
%endif
|
%endif
|
||||||
@ -136,9 +140,6 @@ Patch7: ruby-2.2.3-Generate-preludes-using-miniruby.patch
|
|||||||
# hardening features of glibc (rhbz#1361037).
|
# hardening features of glibc (rhbz#1361037).
|
||||||
# https://bugs.ruby-lang.org/issues/12666
|
# https://bugs.ruby-lang.org/issues/12666
|
||||||
Patch9: ruby-2.3.1-Rely-on-ldd-to-detect-glibc.patch
|
Patch9: ruby-2.3.1-Rely-on-ldd-to-detect-glibc.patch
|
||||||
# This fixed rubygem-mongo build failures and may be something else as well.
|
|
||||||
# https://bugs.ruby-lang.org/issues/13107
|
|
||||||
Patch10: ruby-2.4.0-vm_insnhelper.c-block-argument-at-tailcall.patch
|
|
||||||
|
|
||||||
Requires: %{?scl_prefix}%{pkg_name}-libs%{?_isa} = %{version}-%{release}
|
Requires: %{?scl_prefix}%{pkg_name}-libs%{?_isa} = %{version}-%{release}
|
||||||
Requires: %{?scl_prefix}ruby(rubygems) >= %{rubygems_version}
|
Requires: %{?scl_prefix}ruby(rubygems) >= %{rubygems_version}
|
||||||
@ -158,10 +159,10 @@ BuildRequires: libyaml-devel
|
|||||||
BuildRequires: readline-devel
|
BuildRequires: readline-devel
|
||||||
# Needed to pass test_set_program_name(TestRubyOptions)
|
# Needed to pass test_set_program_name(TestRubyOptions)
|
||||||
BuildRequires: procps
|
BuildRequires: procps
|
||||||
BuildRequires: %{?_root_bindir}%{!?_root_bindir:%{_bindir}}/dtrace
|
%{?with_systemtap:BuildRequires: %{?_root_bindir}%{!?_root_bindir:%{_bindir}}/dtrace}
|
||||||
# RubyGems test suite optional dependencies.
|
# RubyGems test suite optional dependencies.
|
||||||
BuildRequires: %{?_root_bindir}%{!?_root_bindir:%{_bindir}}/git
|
%{?with_git:BuildRequires: %{?_root_bindir}%{!?_root_bindir:%{_bindir}}/git}
|
||||||
BuildRequires: %{?_root_bindir}%{!?_root_bindir:%{_bindir}}/cmake
|
%{?with_cmake:BuildRequires: %{?_root_bindir}%{!?_root_bindir:%{_bindir}}/cmake}
|
||||||
# Required to test hardening.
|
# Required to test hardening.
|
||||||
%{?with_checksec:BuildRequires: %{?_root_bindir}%{!?_root_bindir:%{_bindir}}/checksec}
|
%{?with_checksec:BuildRequires: %{?_root_bindir}%{!?_root_bindir:%{_bindir}}/checksec}
|
||||||
|
|
||||||
@ -175,6 +176,7 @@ object-oriented programming. It has many features to process text
|
|||||||
files and to do system management tasks (as in Perl). It is simple,
|
files and to do system management tasks (as in Perl). It is simple,
|
||||||
straight-forward, and extensible.
|
straight-forward, and extensible.
|
||||||
|
|
||||||
|
|
||||||
%package devel
|
%package devel
|
||||||
Summary: A Ruby development environment
|
Summary: A Ruby development environment
|
||||||
Group: Development/Languages
|
Group: Development/Languages
|
||||||
@ -512,7 +514,6 @@ rm -rf ext/fiddle/libffi*
|
|||||||
%patch6 -p1
|
%patch6 -p1
|
||||||
%patch7 -p1
|
%patch7 -p1
|
||||||
%patch9 -p1
|
%patch9 -p1
|
||||||
%patch10 -p1
|
|
||||||
|
|
||||||
# Allow to use autoconf 2.63.
|
# Allow to use autoconf 2.63.
|
||||||
sed -i '/AC_PREREQ/ s/(.*)/(2.62)/' configure.in
|
sed -i '/AC_PREREQ/ s/(.*)/(2.62)/' configure.in
|
||||||
@ -732,7 +733,7 @@ touch abrt.rb
|
|||||||
make runruby TESTRUN_SCRIPT="--enable-gems %{SOURCE12}"
|
make runruby TESTRUN_SCRIPT="--enable-gems %{SOURCE12}"
|
||||||
|
|
||||||
# Check if systemtap is supported.
|
# Check if systemtap is supported.
|
||||||
make runruby TESTRUN_SCRIPT=%{SOURCE13}
|
%{?with_systemtap:make runruby TESTRUN_SCRIPT=%{SOURCE13}}
|
||||||
|
|
||||||
DISABLE_TESTS=""
|
DISABLE_TESTS=""
|
||||||
|
|
||||||
@ -929,7 +930,11 @@ make check TESTS="-v $DISABLE_TESTS"
|
|||||||
|
|
||||||
%files -n %{?scl_prefix}rubygems
|
%files -n %{?scl_prefix}rubygems
|
||||||
%{_bindir}/gem
|
%{_bindir}/gem
|
||||||
%{rubygems_dir}
|
%dir %{rubygems_dir}
|
||||||
|
%{rubygems_dir}/rbconfig
|
||||||
|
%{rubygems_dir}/rubygems
|
||||||
|
%{rubygems_dir}/rubygems.rb
|
||||||
|
%{rubygems_dir}/ubygems.rb
|
||||||
|
|
||||||
# Explicitly include only RubyGems directory strucure to avoid accidentally
|
# Explicitly include only RubyGems directory strucure to avoid accidentally
|
||||||
# packaged content.
|
# packaged content.
|
||||||
@ -1047,6 +1052,12 @@ make check TESTS="-v $DISABLE_TESTS"
|
|||||||
%{gem_dir}/specifications/xmlrpc-%{xmlrpc_version}.gemspec
|
%{gem_dir}/specifications/xmlrpc-%{xmlrpc_version}.gemspec
|
||||||
|
|
||||||
%changelog
|
%changelog
|
||||||
|
* Mon Oct 30 2017 Vít Ondruch <vondruch@redhat.com> - 2.4.2-86
|
||||||
|
- Upgrade to Ruby 2.4.2.
|
||||||
|
* Remove Patch10: ruby-2.4.0-vm_insnhelper.c-block-argument-at-tailcall.patch;
|
||||||
|
subsumed
|
||||||
|
Resolves: rhbz#1506785
|
||||||
|
|
||||||
* Tue Jan 17 2017 Vít Ondruch <vondruch@redhat.com> - 2.4.0-75
|
* Tue Jan 17 2017 Vít Ondruch <vondruch@redhat.com> - 2.4.0-75
|
||||||
- Apply patch fixing rubygem-mongo build failures.
|
- Apply patch fixing rubygem-mongo build failures.
|
||||||
|
|
||||||
|
Loading…
Reference in New Issue
Block a user