Apply patch fixing rubygem-mongo build failures.

This commit is contained in:
Vít Ondruch 2017-01-17 16:22:14 +01:00
parent 522e4d1ab7
commit 4cb333ddd5
2 changed files with 44 additions and 1 deletions

View File

@ -0,0 +1,36 @@
From ff3496b0116ed2ed589d000b7bfca3d8288b009c Mon Sep 17 00:00:00 2001
From: nobu <nobu@b2dd03c8-39d4-4d8f-98ff-823fe69b080e>
Date: Mon, 9 Jan 2017 02:55:39 +0000
Subject: [PATCH] vm_insnhelper.c: block argument at tailcall
* vm_insnhelper.c (vm_call_iseq_setup_tailcall): check interrupts
after set up the new frame, not the passed block to be clobbered
by invoked finalizers and so on. [ruby-core:78981] [Bug #13107]
git-svn-id: svn+ssh://ci.ruby-lang.org/ruby/trunk@57293 b2dd03c8-39d4-4d8f-98ff-823fe69b080e
---
vm_insnhelper.c | 4 ++--
1 file changed, 2 insertions(+), 2 deletions(-)
diff --git a/vm_insnhelper.c b/vm_insnhelper.c
index b580412..662a2d6 100644
--- a/vm_insnhelper.c
+++ b/vm_insnhelper.c
@@ -1538,8 +1538,6 @@ vm_call_iseq_setup_tailcall(rb_thread_t *th, rb_control_frame_t *cfp, struct rb_
vm_pop_frame(th, cfp, cfp->ep);
cfp = th->cfp;
- RUBY_VM_CHECK_INTS(th);
-
sp_orig = sp = cfp->sp;
/* push self */
@@ -1558,6 +1556,8 @@ vm_call_iseq_setup_tailcall(rb_thread_t *th, rb_control_frame_t *cfp, struct rb_
iseq->body->stack_max);
cfp->sp = sp_orig;
+ RUBY_VM_CHECK_INTS(th);
+
return Qundef;
}

View File

@ -24,7 +24,7 @@
%endif
%global release 73
%global release 75
%{!?release_string:%global release_string %{?development_release:0.}%{release}%{?development_release:.%{development_release}}%{?dist}}
# The RubyGems library has to stay out of Ruby directory three, since the
@ -136,6 +136,9 @@ Patch7: ruby-2.2.3-Generate-preludes-using-miniruby.patch
# hardening features of glibc (rhbz#1361037).
# https://bugs.ruby-lang.org/issues/12666
Patch9: ruby-2.3.1-Rely-on-ldd-to-detect-glibc.patch
# This fixed rubygem-mongo build failures and may be something else as well.
# https://bugs.ruby-lang.org/issues/13107
Patch10: ruby-2.4.0-vm_insnhelper.c-block-argument-at-tailcall.patch
Requires: %{?scl_prefix}%{pkg_name}-libs%{?_isa} = %{version}-%{release}
Requires: %{?scl_prefix}ruby(rubygems) >= %{rubygems_version}
@ -509,6 +512,7 @@ rm -rf ext/fiddle/libffi*
%patch6 -p1
%patch7 -p1
%patch9 -p1
%patch10 -p1
# Allow to use autoconf 2.63.
sed -i '/AC_PREREQ/ s/(.*)/(2.62)/' configure.in
@ -1043,6 +1047,9 @@ make check TESTS="-v $DISABLE_TESTS"
%{gem_dir}/specifications/xmlrpc-%{xmlrpc_version}.gemspec
%changelog
* Tue Jan 17 2017 Vít Ondruch <vondruch@redhat.com> - 2.4.0-75
- Apply patch fixing rubygem-mongo build failures.
* Mon Jan 09 2017 Vít Ondruch <vondruch@redhat.com> - 2.4.0-73
- Reshuffle the %%license macro to avoid %%postun scriptlet issues.
Resolves: rhbz#1411233