Update to 4.2.1
- Modernize spec
This commit is contained in:
parent
03ea7d97ab
commit
b29ffdb10c
1
.gitignore
vendored
1
.gitignore
vendored
@ -8,3 +8,4 @@ tornado-1.0.1.tar.gz
|
|||||||
/tornado-2.2.1.tar.gz
|
/tornado-2.2.1.tar.gz
|
||||||
/tornado-3.2.1.tar.gz
|
/tornado-3.2.1.tar.gz
|
||||||
/tornado-4.1.tar.gz
|
/tornado-4.1.tar.gz
|
||||||
|
/tornado-4.2.1.tar.gz
|
||||||
|
@ -1,7 +1,7 @@
|
|||||||
diff -up ./tornado/simple_httpclient.py.cert ./tornado/simple_httpclient.py
|
diff -up tornado-4.2.1/tornado/simple_httpclient.py.cert tornado-4.2.1/tornado/simple_httpclient.py
|
||||||
--- ./tornado/simple_httpclient.py.cert 2015-03-02 19:26:31.840455222 -0700
|
--- tornado-4.2.1/tornado/simple_httpclient.py.cert 2015-07-17 09:31:29.000000000 -0600
|
||||||
+++ ./tornado/simple_httpclient.py 2015-03-02 19:27:44.833403497 -0700
|
+++ tornado-4.2.1/tornado/simple_httpclient.py 2015-09-18 16:10:15.293077440 -0600
|
||||||
@@ -32,17 +32,8 @@ except ImportError:
|
@@ -33,17 +33,8 @@ except ImportError:
|
||||||
# ssl is not available on Google App Engine.
|
# ssl is not available on Google App Engine.
|
||||||
ssl = None
|
ssl = None
|
||||||
|
|
||||||
@ -20,23 +20,3 @@ diff -up ./tornado/simple_httpclient.py.cert ./tornado/simple_httpclient.py
|
|||||||
|
|
||||||
|
|
||||||
class SimpleAsyncHTTPClient(AsyncHTTPClient):
|
class SimpleAsyncHTTPClient(AsyncHTTPClient):
|
||||||
diff -up ./tornado/test/iostream_test.py.cert ./tornado/test/iostream_test.py
|
|
||||||
--- ./tornado/test/iostream_test.py.cert 2015-03-02 19:26:31.889456050 -0700
|
|
||||||
+++ ./tornado/test/iostream_test.py 2015-03-02 19:28:00.791674739 -0700
|
|
||||||
@@ -10,7 +10,6 @@ from tornado.stack_context import NullCo
|
|
||||||
from tornado.testing import AsyncHTTPTestCase, AsyncHTTPSTestCase, AsyncTestCase, bind_unused_port, ExpectLog, gen_test
|
|
||||||
from tornado.test.util import unittest, skipIfNonUnix, refusing_port
|
|
||||||
from tornado.web import RequestHandler, Application
|
|
||||||
-import certifi
|
|
||||||
import errno
|
|
||||||
import logging
|
|
||||||
import os
|
|
||||||
@@ -877,7 +876,7 @@ class TestIOStreamStartTLS(AsyncTestCase
|
|
||||||
def test_handshake_fail(self):
|
|
||||||
server_future = self.server_start_tls(_server_ssl_options())
|
|
||||||
client_future = self.client_start_tls(
|
|
||||||
- dict(cert_reqs=ssl.CERT_REQUIRED, ca_certs=certifi.where()))
|
|
||||||
+ dict(cert_reqs=ssl.CERT_REQUIRED, ca_certs='/etc/pki/tls/cert.pem'))
|
|
||||||
with ExpectLog(gen_log, "SSL Error"):
|
|
||||||
with self.assertRaises(ssl.SSLError):
|
|
||||||
yield client_future
|
|
||||||
|
@ -5,8 +5,8 @@
|
|||||||
%global pkgname tornado
|
%global pkgname tornado
|
||||||
|
|
||||||
Name: python-%{pkgname}
|
Name: python-%{pkgname}
|
||||||
Version: 4.1
|
Version: 4.2.1
|
||||||
Release: 3%{?dist}
|
Release: 1%{?dist}
|
||||||
Summary: Scalable, non-blocking web server and tools
|
Summary: Scalable, non-blocking web server and tools
|
||||||
|
|
||||||
Group: Development/Libraries
|
Group: Development/Libraries
|
||||||
@ -71,81 +71,58 @@ server and and tools. This package contains some example applications.
|
|||||||
%endif # with_python3
|
%endif # with_python3
|
||||||
|
|
||||||
%prep
|
%prep
|
||||||
%setup -qc
|
%setup -q -n %{pkgname}-%{version}
|
||||||
mv %{pkgname}-%{version} python2
|
|
||||||
pushd python2
|
|
||||||
%patch0 -p1 -b .cert
|
%patch0 -p1 -b .cert
|
||||||
# remove shebang from files
|
# remove shebang from files
|
||||||
%{__sed} -i.orig -e '/^#!\//, 1d' *py tornado/*.py tornado/*/*.py
|
%{__sed} -i.orig -e '/^#!\//, 1d' *py tornado/*.py tornado/*/*.py
|
||||||
popd
|
|
||||||
|
|
||||||
%if 0%{?with_python3}
|
|
||||||
cp -a python2 python3
|
|
||||||
find python3 -name '*.py' | xargs sed -i '1s|^#!.*python|#!%{__python3}|'
|
|
||||||
%endif # with_python3
|
|
||||||
|
|
||||||
%build
|
%build
|
||||||
%if 0%{?with_python3}
|
%if 0%{?with_python3}
|
||||||
pushd python3
|
%py3_build
|
||||||
%{__python3} setup.py build
|
|
||||||
popd
|
|
||||||
%endif # with_python3
|
%endif # with_python3
|
||||||
|
%py2_build
|
||||||
pushd python2
|
|
||||||
%{__python2} setup.py build
|
|
||||||
popd
|
|
||||||
|
|
||||||
|
|
||||||
%install
|
%install
|
||||||
%if 0%{?with_python3}
|
%if 0%{?with_python3}
|
||||||
pushd python3
|
%py3_install
|
||||||
PATH=$PATH:%{buildroot}%{python3_sitearch}/%{pkgname}
|
|
||||||
%{__python3} setup.py install --root=%{buildroot}
|
|
||||||
popd
|
|
||||||
%endif # with_python3
|
%endif # with_python3
|
||||||
|
%py2_install
|
||||||
pushd python2
|
|
||||||
PATH=$PATH:%{buildroot}%{python2_sitearch}/%{pkgname}
|
|
||||||
%{__python2} setup.py install --root=%{buildroot}
|
|
||||||
popd
|
|
||||||
|
|
||||||
|
|
||||||
%check
|
%check
|
||||||
%if "%{dist}" != ".el6"
|
%if 0%{?with_python3}
|
||||||
%if 0%{?with_python3}
|
PYTHONPATH=%{python3_sitearch} %{__python3} -m tornado.test.runtests --verbose
|
||||||
pushd python3
|
%endif # with_python3
|
||||||
PYTHONPATH=%{python3_sitearch} \
|
PYTHONPATH=%{python2_sitearch} %{__python2} -m tornado.test.runtests --verbose
|
||||||
%{__python3} -m tornado.test.runtests --verbose
|
|
||||||
popd
|
|
||||||
%endif # with_python3
|
|
||||||
pushd python2
|
|
||||||
PYTHONPATH=%{python2_sitearch} \
|
|
||||||
%{__python2} -m tornado.test.runtests --verbose
|
|
||||||
popd
|
|
||||||
%endif
|
|
||||||
|
|
||||||
%files
|
%files
|
||||||
%doc python2/README.rst python2/PKG-INFO
|
%doc README.rst
|
||||||
|
|
||||||
%{python2_sitearch}/%{pkgname}/
|
%{python2_sitearch}/%{pkgname}/
|
||||||
%{python2_sitearch}/%{pkgname}-%{version}-*.egg-info
|
%{python2_sitearch}/%{pkgname}-%{version}-*.egg-info
|
||||||
|
|
||||||
%files doc
|
%files doc
|
||||||
%doc python2/demos
|
%doc demos
|
||||||
|
|
||||||
%if 0%{?with_python3}
|
%if 0%{?with_python3}
|
||||||
%files -n python3-tornado
|
%files -n python3-tornado
|
||||||
%doc python3/README.rst python3/PKG-INFO
|
%doc README.rst
|
||||||
|
|
||||||
%{python3_sitearch}/%{pkgname}/
|
%{python3_sitearch}/%{pkgname}/
|
||||||
%{python3_sitearch}/%{pkgname}-%{version}-*.egg-info
|
%{python3_sitearch}/%{pkgname}-%{version}-*.egg-info
|
||||||
|
|
||||||
%files -n python3-tornado-doc
|
%files -n python3-tornado-doc
|
||||||
%doc python3/demos
|
%doc demos
|
||||||
%endif
|
%endif
|
||||||
|
|
||||||
|
|
||||||
%changelog
|
%changelog
|
||||||
|
* Fri Sep 19 2015 Orion Poplawski <orion@cora.nwra.com> - 4.2.1-1
|
||||||
|
- Update to 4.2.1
|
||||||
|
- Modernize spec
|
||||||
|
|
||||||
* Fri Jul 10 2015 Orion Poplawski <orion@cora.nwra.com> - 4.1-3
|
* Fri Jul 10 2015 Orion Poplawski <orion@cora.nwra.com> - 4.1-3
|
||||||
- Do not require python-backports-ssl_match_hostname for F22+ (bug #1231368)
|
- Do not require python-backports-ssl_match_hostname for F22+ (bug #1231368)
|
||||||
|
|
||||||
|
Loading…
Reference in New Issue
Block a user