Update to 4.5
This commit is contained in:
parent
cd171a6fa1
commit
6fb138a9ba
1
.gitignore
vendored
1
.gitignore
vendored
@ -12,3 +12,4 @@ tornado-1.0.1.tar.gz
|
|||||||
/tornado-4.3.tar.gz
|
/tornado-4.3.tar.gz
|
||||||
/tornado-4.4.1.tar.gz
|
/tornado-4.4.1.tar.gz
|
||||||
/tornado-4.4.2.tar.gz
|
/tornado-4.4.2.tar.gz
|
||||||
|
/tornado-4.5.tar.gz
|
||||||
|
@ -1,6 +1,6 @@
|
|||||||
diff -up tornado-4.4.2/setup.py.cert tornado-4.4.2/setup.py
|
diff -up tornado-4.5b2/setup.py.cert tornado-4.5b2/setup.py
|
||||||
--- tornado-4.4.2/setup.py.cert 2016-09-30 16:43:58.000000000 -0600
|
--- tornado-4.5b2/setup.py.cert 2017-04-10 20:42:50.000000000 -0600
|
||||||
+++ tornado-4.4.2/setup.py 2016-10-02 19:55:25.645685022 -0600
|
+++ tornado-4.5b2/setup.py 2017-04-11 13:30:36.653766615 -0600
|
||||||
@@ -133,10 +133,6 @@ if setuptools is not None:
|
@@ -133,10 +133,6 @@ if setuptools is not None:
|
||||||
install_requires.append('backports.ssl_match_hostname')
|
install_requires.append('backports.ssl_match_hostname')
|
||||||
if sys.version_info < (3, 4):
|
if sys.version_info < (3, 4):
|
||||||
@ -12,12 +12,12 @@ diff -up tornado-4.4.2/setup.py.cert tornado-4.4.2/setup.py
|
|||||||
if sys.version_info < (3, 5):
|
if sys.version_info < (3, 5):
|
||||||
install_requires.append('backports_abc>=0.4')
|
install_requires.append('backports_abc>=0.4')
|
||||||
kwargs['install_requires'] = install_requires
|
kwargs['install_requires'] = install_requires
|
||||||
diff -up tornado-4.4.2/tornado/simple_httpclient.py.cert tornado-4.4.2/tornado/simple_httpclient.py
|
diff -up tornado-4.5b2/tornado/simple_httpclient.py.cert tornado-4.5b2/tornado/simple_httpclient.py
|
||||||
--- tornado-4.4.2/tornado/simple_httpclient.py.cert 2016-09-30 16:41:19.000000000 -0600
|
--- tornado-4.5b2/tornado/simple_httpclient.py.cert 2017-04-09 21:05:09.000000000 -0600
|
||||||
+++ tornado-4.4.2/tornado/simple_httpclient.py 2016-10-02 19:55:25.646685029 -0600
|
+++ tornado-4.5b2/tornado/simple_httpclient.py 2017-04-11 13:31:06.580629181 -0600
|
||||||
@@ -1,4 +1,3 @@
|
@@ -1,4 +1,3 @@
|
||||||
-#!/usr/bin/env python
|
-#!/usr/bin/env python
|
||||||
from __future__ import absolute_import, division, print_function, with_statement
|
from __future__ import absolute_import, division, print_function
|
||||||
|
|
||||||
from tornado.escape import utf8, _unicode
|
from tornado.escape import utf8, _unicode
|
||||||
@@ -34,17 +33,8 @@ except ImportError:
|
@@ -34,17 +33,8 @@ except ImportError:
|
||||||
|
@ -5,8 +5,8 @@
|
|||||||
%global srcname tornado
|
%global srcname tornado
|
||||||
|
|
||||||
Name: python-%{srcname}
|
Name: python-%{srcname}
|
||||||
Version: 4.4.2
|
Version: 4.5
|
||||||
Release: 3%{?dist}
|
Release: 1%{?dist}
|
||||||
Summary: Scalable, non-blocking web server and tools
|
Summary: Scalable, non-blocking web server and tools
|
||||||
|
|
||||||
Group: Development/Libraries
|
Group: Development/Libraries
|
||||||
@ -15,12 +15,6 @@ URL: http://www.tornadoweb.org
|
|||||||
Source0: https://files.pythonhosted.org/packages/source/t/tornado/tornado-%{version}.tar.gz
|
Source0: https://files.pythonhosted.org/packages/source/t/tornado/tornado-%{version}.tar.gz
|
||||||
# Patch to use system CA certs instead of certifi
|
# Patch to use system CA certs instead of certifi
|
||||||
Patch0: python-tornado-cert.patch
|
Patch0: python-tornado-cert.patch
|
||||||
# Patch to run tests from project dir
|
|
||||||
# https://github.com/tornadoweb/tornado/pull/1781
|
|
||||||
Patch1: python-tornado-test.patch
|
|
||||||
# Patch to fix tests for Python 3.6
|
|
||||||
# https://github.com/tornadoweb/tornado/commit/a391e126e7f277244c691f5057d4cdb97c1ba2e7
|
|
||||||
Patch2: update-warning-config-to-fix-tests-on-python-3.6-nightly.patch
|
|
||||||
|
|
||||||
BuildRequires: python2-devel
|
BuildRequires: python2-devel
|
||||||
BuildRequires: python2-backports_abc
|
BuildRequires: python2-backports_abc
|
||||||
@ -29,11 +23,11 @@ BuildRequires: python-backports-ssl_match_hostname
|
|||||||
%endif
|
%endif
|
||||||
BuildRequires: python2-singledispatch
|
BuildRequires: python2-singledispatch
|
||||||
%if 0%{?with_python3}
|
%if 0%{?with_python3}
|
||||||
BuildRequires: python3-setuptools
|
BuildRequires: python%{python3_pkgversion}-setuptools
|
||||||
BuildRequires: python3-devel
|
BuildRequires: python%{python3_pkgversion}-devel
|
||||||
%if 0%{?fedora} < 24
|
%if 0%{?fedora} < 24
|
||||||
# Only needed for python < 3.5
|
# Only needed for python < 3.5
|
||||||
BuildRequires: python3-backports_abc
|
BuildRequires: python%{python3_pkgversion}-backports_abc
|
||||||
%endif
|
%endif
|
||||||
%endif
|
%endif
|
||||||
|
|
||||||
@ -71,24 +65,24 @@ ideal for real-time web services.
|
|||||||
%package doc
|
%package doc
|
||||||
Summary: Examples for python-tornado
|
Summary: Examples for python-tornado
|
||||||
Group: Documentation
|
Group: Documentation
|
||||||
Obsoletes: python3-%{srcname}-doc < 4.2.1-3
|
Obsoletes: python%{python3_pkgversion}-%{srcname}-doc < 4.2.1-3
|
||||||
Provides: python3-%{srcname}-doc = %{version}-%{release}
|
Provides: python%{python3_pkgversion}-%{srcname}-doc = %{version}-%{release}
|
||||||
|
|
||||||
%description doc
|
%description doc
|
||||||
Tornado is an open source version of the scalable, non-blocking web
|
Tornado is an open source version of the scalable, non-blocking web
|
||||||
server and and tools. This package contains some example applications.
|
server and and tools. This package contains some example applications.
|
||||||
|
|
||||||
%if 0%{?with_python3}
|
%if 0%{?with_python3}
|
||||||
%package -n python3-%{srcname}
|
%package -n python%{python3_pkgversion}-%{srcname}
|
||||||
Summary: Scalable, non-blocking web server and tools
|
Summary: Scalable, non-blocking web server and tools
|
||||||
%{?python_provide:%python_provide python3-%{srcname}}
|
%{?python_provide:%python_provide python%{python3_pkgversion}-%{srcname}}
|
||||||
Requires: python3-pycurl
|
Requires: python%{python3_pkgversion}-pycurl
|
||||||
%if 0%{?fedora} < 24
|
%if 0%{?fedora} < 24
|
||||||
# Only needed for python < 3.5
|
# Only needed for python < 3.5
|
||||||
Requires: python3-backports_abc
|
Requires: python%{python3_pkgversion}-backports_abc
|
||||||
%endif
|
%endif
|
||||||
|
|
||||||
%description -n python3-%{srcname}
|
%description -n python%{python3_pkgversion}-%{srcname}
|
||||||
Tornado is an open source version of the scalable, non-blocking web
|
Tornado is an open source version of the scalable, non-blocking web
|
||||||
server and tools.
|
server and tools.
|
||||||
|
|
||||||
@ -102,8 +96,6 @@ ideal for real-time web services.
|
|||||||
%prep
|
%prep
|
||||||
%setup -q -n %{srcname}-%{version}
|
%setup -q -n %{srcname}-%{version}
|
||||||
%patch0 -p1 -b .cert
|
%patch0 -p1 -b .cert
|
||||||
%patch1 -p1 -b .test
|
|
||||||
%patch2 -p1
|
|
||||||
# remove shebang from files
|
# remove shebang from files
|
||||||
%{__sed} -i.orig -e '/^#!\//, 1d' *py tornado/*.py tornado/*/*.py
|
%{__sed} -i.orig -e '/^#!\//, 1d' *py tornado/*.py tornado/*/*.py
|
||||||
|
|
||||||
@ -137,7 +129,7 @@ ideal for real-time web services.
|
|||||||
%doc demos
|
%doc demos
|
||||||
|
|
||||||
%if 0%{?with_python3}
|
%if 0%{?with_python3}
|
||||||
%files -n python3-%{srcname}
|
%files -n python%{python3_pkgversion}-%{srcname}
|
||||||
%doc README.rst
|
%doc README.rst
|
||||||
%{python3_sitearch}/%{srcname}/
|
%{python3_sitearch}/%{srcname}/
|
||||||
%{python3_sitearch}/%{srcname}-%{version}-*.egg-info
|
%{python3_sitearch}/%{srcname}-%{version}-*.egg-info
|
||||||
@ -145,6 +137,9 @@ ideal for real-time web services.
|
|||||||
|
|
||||||
|
|
||||||
%changelog
|
%changelog
|
||||||
|
* Mon Apr 17 2017 Orion Poplawski <orion@cora.nwra.com> - 4.5-1
|
||||||
|
- Update to 4.5
|
||||||
|
|
||||||
* Sat Feb 11 2017 Fedora Release Engineering <releng@fedoraproject.org> - 4.4.2-3
|
* Sat Feb 11 2017 Fedora Release Engineering <releng@fedoraproject.org> - 4.4.2-3
|
||||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_26_Mass_Rebuild
|
- Rebuilt for https://fedoraproject.org/wiki/Fedora_26_Mass_Rebuild
|
||||||
|
|
||||||
|
Loading…
Reference in New Issue
Block a user