Remove certifi from python2-tornado egg requires (bug #1372886)
This commit is contained in:
parent
7483ebcdf3
commit
3d0fa84cb7
@ -1,7 +1,26 @@
|
|||||||
diff -up tornado-4.2.1/tornado/simple_httpclient.py.cert tornado-4.2.1/tornado/simple_httpclient.py
|
diff -up tornado-4.3/setup.py.cert tornado-4.3/setup.py
|
||||||
--- tornado-4.2.1/tornado/simple_httpclient.py.cert 2015-07-17 09:31:29.000000000 -0600
|
--- tornado-4.3/setup.py.cert 2016-09-15 21:13:15.010093113 -0600
|
||||||
+++ tornado-4.2.1/tornado/simple_httpclient.py 2015-09-18 16:10:15.293077440 -0600
|
+++ tornado-4.3/setup.py 2016-09-15 21:23:11.709772545 -0600
|
||||||
@@ -33,17 +33,8 @@ except ImportError:
|
@@ -128,10 +128,6 @@ if setuptools is not None:
|
||||||
|
install_requires.append('backports.ssl_match_hostname')
|
||||||
|
if sys.version_info < (3, 4):
|
||||||
|
install_requires.append('singledispatch')
|
||||||
|
- # Certifi is also optional on 2.7.9+, although making our dependencies
|
||||||
|
- # conditional on micro version numbers seems like a bad idea
|
||||||
|
- # until we have more declarative metadata.
|
||||||
|
- install_requires.append('certifi')
|
||||||
|
if sys.version_info < (3, 5):
|
||||||
|
install_requires.append('backports_abc>=0.4')
|
||||||
|
kwargs['install_requires'] = install_requires
|
||||||
|
diff -up tornado-4.3/tornado/simple_httpclient.py.cert tornado-4.3/tornado/simple_httpclient.py
|
||||||
|
--- tornado-4.3/tornado/simple_httpclient.py.cert 2015-10-24 16:50:23.000000000 -0600
|
||||||
|
+++ tornado-4.3/tornado/simple_httpclient.py 2016-09-15 21:13:15.207107536 -0600
|
||||||
|
@@ -1,4 +1,3 @@
|
||||||
|
-#!/usr/bin/env python
|
||||||
|
from __future__ import absolute_import, division, print_function, with_statement
|
||||||
|
|
||||||
|
from tornado.escape import utf8, _unicode
|
||||||
|
@@ -33,17 +32,8 @@ except ImportError:
|
||||||
# ssl is not available on Google App Engine.
|
# ssl is not available on Google App Engine.
|
||||||
ssl = None
|
ssl = None
|
||||||
|
|
||||||
|
@ -6,7 +6,7 @@
|
|||||||
|
|
||||||
Name: python-%{srcname}
|
Name: python-%{srcname}
|
||||||
Version: 4.3
|
Version: 4.3
|
||||||
Release: 3%{?dist}
|
Release: 4%{?dist}
|
||||||
Summary: Scalable, non-blocking web server and tools
|
Summary: Scalable, non-blocking web server and tools
|
||||||
|
|
||||||
Group: Development/Libraries
|
Group: Development/Libraries
|
||||||
@ -137,6 +137,9 @@ ideal for real-time web services.
|
|||||||
|
|
||||||
|
|
||||||
%changelog
|
%changelog
|
||||||
|
* Thu Sep 15 2016 Orion Poplawski <orion@cora.nwra.com> - 4.3-4
|
||||||
|
- Remove certifi from python2-tornado egg requires (bug #1372886)
|
||||||
|
|
||||||
* Tue Jul 19 2016 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 4.3-3
|
* Tue Jul 19 2016 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 4.3-3
|
||||||
- https://fedoraproject.org/wiki/Changes/Automatic_Provides_for_Python_RPM_Packages
|
- https://fedoraproject.org/wiki/Changes/Automatic_Provides_for_Python_RPM_Packages
|
||||||
|
|
||||||
|
Loading…
Reference in New Issue
Block a user