Remove backports.ssl_match_hostname from python2-tornado egg requires (bug #1372887)
This commit is contained in:
parent
3d0fa84cb7
commit
3946c32701
12
python-tornado-requires.patch
Normal file
12
python-tornado-requires.patch
Normal file
@ -0,0 +1,12 @@
|
||||
diff -up tornado-4.3/setup.py.requires tornado-4.3/setup.py
|
||||
--- tornado-4.3/setup.py.requires 2016-09-15 21:31:05.188426632 -0600
|
||||
+++ tornado-4.3/setup.py 2016-09-15 21:49:19.093465027 -0600
|
||||
@@ -124,8 +124,6 @@ if setuptools is not None:
|
||||
if sys.version_info < (2, 7):
|
||||
# Only needed indirectly, for singledispatch.
|
||||
install_requires.append('ordereddict')
|
||||
- if sys.version_info < (3, 2):
|
||||
- install_requires.append('backports.ssl_match_hostname')
|
||||
if sys.version_info < (3, 4):
|
||||
install_requires.append('singledispatch')
|
||||
if sys.version_info < (3, 5):
|
@ -6,7 +6,7 @@
|
||||
|
||||
Name: python-%{srcname}
|
||||
Version: 4.3
|
||||
Release: 4%{?dist}
|
||||
Release: 5%{?dist}
|
||||
Summary: Scalable, non-blocking web server and tools
|
||||
|
||||
Group: Development/Libraries
|
||||
@ -15,6 +15,9 @@ URL: http://www.tornadoweb.org
|
||||
Source0: https://pypi.python.org/packages/source/t/tornado/tornado-%{version}.tar.gz
|
||||
# Patch to use system CA certs instead of certifi
|
||||
Patch0: python-tornado-cert.patch
|
||||
# Remove unnecessary requires (backports.ssl_match_hostname
|
||||
# https://bugzilla.redhat.com/show_bug.cgi?id=1372887
|
||||
Patch1: python-tornado-requires.patch
|
||||
|
||||
BuildRequires: python2-devel
|
||||
BuildRequires: python2-backports_abc
|
||||
@ -96,6 +99,7 @@ ideal for real-time web services.
|
||||
%prep
|
||||
%setup -q -n %{srcname}-%{version}
|
||||
%patch0 -p1 -b .cert
|
||||
%patch1 -p1 -b .requires
|
||||
# remove shebang from files
|
||||
%{__sed} -i.orig -e '/^#!\//, 1d' *py tornado/*.py tornado/*/*.py
|
||||
|
||||
@ -137,6 +141,9 @@ ideal for real-time web services.
|
||||
|
||||
|
||||
%changelog
|
||||
* Thu Sep 15 2016 Orion Poplawski <orion@cora.nwra.com> - 4.3-5
|
||||
- Remove backports.ssl_match_hostname from python2-tornado egg requires (bug #1372887)
|
||||
|
||||
* Thu Sep 15 2016 Orion Poplawski <orion@cora.nwra.com> - 4.3-4
|
||||
- Remove certifi from python2-tornado egg requires (bug #1372886)
|
||||
|
||||
|
Loading…
Reference in New Issue
Block a user