Add -D_GLIBCXX_ASSERTIONS
Resolves: #2044886 Signed-off-by: Robbie Harwood <rharwood@redhat.com>
This commit is contained in:
parent
2768dfdd8d
commit
f26bc9954b
@ -1,7 +1,7 @@
|
||||
From 05da4afd1908b0bd8303435aaa342f84a03dfa60 Mon Sep 17 00:00:00 2001
|
||||
From 0000000000000000000000000000000000000000 Mon Sep 17 00:00:00 2001
|
||||
From: Robbie Harwood <rharwood@redhat.com>
|
||||
Date: Wed, 9 Feb 2022 14:42:24 -0500
|
||||
Subject: [PATCH 4/6] Disable pragmas for warnings that are too old
|
||||
Subject: [PATCH] Disable pragmas for warnings that are too old
|
||||
|
||||
Signed-off-by: Robbie Harwood <rharwood@redhat.com>
|
||||
---
|
||||
@ -9,10 +9,10 @@ Signed-off-by: Robbie Harwood <rharwood@redhat.com>
|
||||
1 file changed, 5 deletions(-)
|
||||
|
||||
diff --git a/src/daemon.c b/src/daemon.c
|
||||
index c19eb80..01c612f 100644
|
||||
index ff88210..d66dd50 100644
|
||||
--- a/src/daemon.c
|
||||
+++ b/src/daemon.c
|
||||
@@ -916,10 +916,6 @@ do_shutdown(context *ctx, int nsockets, struct pollfd *pollfds)
|
||||
@@ -917,10 +917,6 @@ do_shutdown(context *ctx, int nsockets, struct pollfd *pollfds)
|
||||
free(pollfds);
|
||||
}
|
||||
|
||||
@ -23,7 +23,7 @@ index c19eb80..01c612f 100644
|
||||
static int
|
||||
handle_events(context *ctx)
|
||||
{
|
||||
@@ -998,7 +994,6 @@ shutdown:
|
||||
@@ -999,7 +995,6 @@ shutdown:
|
||||
}
|
||||
return 0;
|
||||
}
|
||||
@ -31,6 +31,3 @@ index c19eb80..01c612f 100644
|
||||
|
||||
static int
|
||||
get_uid_and_gid(context *ctx, char **homedir)
|
||||
--
|
||||
2.34.1
|
||||
|
||||
|
23
0003-Add-D_GLIBCXX_ASSERTIONS-to-CPPFLAGS.patch
Normal file
23
0003-Add-D_GLIBCXX_ASSERTIONS-to-CPPFLAGS.patch
Normal file
@ -0,0 +1,23 @@
|
||||
From 0000000000000000000000000000000000000000 Mon Sep 17 00:00:00 2001
|
||||
From: Robbie Harwood <rharwood@redhat.com>
|
||||
Date: Fri, 25 Mar 2022 15:01:54 -0400
|
||||
Subject: [PATCH] Add -D_GLIBCXX_ASSERTIONS to CPPFLAGS
|
||||
|
||||
Signed-off-by: Robbie Harwood <rharwood@redhat.com>
|
||||
---
|
||||
Make.defaults | 2 +-
|
||||
1 file changed, 1 insertion(+), 1 deletion(-)
|
||||
|
||||
diff --git a/Make.defaults b/Make.defaults
|
||||
index 130c1ee..4b0e77c 100644
|
||||
--- a/Make.defaults
|
||||
+++ b/Make.defaults
|
||||
@@ -79,7 +79,7 @@ ccldflags = $(cflags) $(CCLDFLAGS) $(LDFLAGS) \
|
||||
$(call pkg-config-ccldflags)
|
||||
efi_cflags = $(cflags)
|
||||
ASFLAGS ?= $(ARCH3264)
|
||||
-CPPFLAGS ?= -D_FORTIFY_SOURCE=2
|
||||
+CPPFLAGS ?= -D_FORTIFY_SOURCE=2 -D_GLIBCXX_ASSERTIONS
|
||||
RANLIBFLAGS ?= $(if $(filter $(CC),gcc),-D)
|
||||
ARFLAGS ?= $(if $(filter $(CC),gcc),-Dcvqs)$(if $(filter $(CC),clang),-cqvs)
|
||||
|
3
pesign.patches
Normal file
3
pesign.patches
Normal file
@ -0,0 +1,3 @@
|
||||
Patch0001: 0001-daemon-remove-always-true-comparison.patch
|
||||
Patch0002: 0002-Disable-pragmas-for-warnings-that-are-too-old.patch
|
||||
Patch0003: 0003-Add-D_GLIBCXX_ASSERTIONS-to-CPPFLAGS.patch
|
10
pesign.spec
10
pesign.spec
@ -3,7 +3,7 @@
|
||||
Name: pesign
|
||||
Summary: Signing utility for UEFI binaries
|
||||
Version: 115
|
||||
Release: 1%{?dist}
|
||||
Release: 2%{?dist}
|
||||
License: GPL-2.0-only
|
||||
URL: https://github.com/rhboot/pesign
|
||||
|
||||
@ -43,9 +43,9 @@ BuildRequires: rh-signing-tools >= 1.20-2
|
||||
Source0: https://github.com/rhboot/pesign/releases/download/%{version}/pesign-%{version}.tar.bz2
|
||||
Source1: certs.tar.xz
|
||||
Source2: pesign.py
|
||||
Source3: pesign.patches
|
||||
|
||||
Patch0001: 0001-daemon-remove-always-true-comparison.patch
|
||||
Patch0002: 0002-Disable-pragmas-for-warnings-that-are-too-old.patch
|
||||
%include %{SOURCE3}
|
||||
|
||||
%description
|
||||
This package contains the pesign utility for signing UEFI binaries as
|
||||
@ -162,6 +162,10 @@ certutil -d %{_sysconfdir}/pki/pesign/ -X -L > /dev/null
|
||||
%{python3_sitelib}/mockbuild/plugins/pesign.*
|
||||
|
||||
%changelog
|
||||
* Fri Mar 25 2022 Robbie Harwood <rharwood@redhat.com> - 115-2
|
||||
- Add -D_GLIBCXX_ASSERTIONS
|
||||
- Resolves: #2044886
|
||||
|
||||
* Tue Mar 08 2022 Robbie Harwood <rharwood@redhat.com> - 115-1
|
||||
- New upstream version (115)
|
||||
- Resolves: #2044886
|
||||
|
Loading…
Reference in New Issue
Block a user