perl-Test-Fatal/Test-Fatal-0.004-versions.patch
Paul Howarth ec3c903b60 Update to 0.004
- New upstream release 0.04:
  - success blocks now allow trailing blocks like finally, catch, etc.
- Remove remaining uses of macros for commands
- Re-order %install section to conventional position in spec
2011-04-26 16:28:53 +01:00

60 lines
1.7 KiB
Diff

There's no need to be as strict about versions as this.
diff -up Test-Fatal-0.004/lib/Test/Fatal.pm.orig Test-Fatal-0.004/lib/Test/Fatal.pm
--- Test-Fatal-0.004/lib/Test/Fatal.pm.orig 2011-04-25 16:58:02.000000000 +0100
+++ Test-Fatal-0.004/lib/Test/Fatal.pm 2011-04-26 14:53:19.759806309 +0100
@@ -10,7 +10,7 @@ BEGIN {
use Carp ();
use Try::Tiny 0.07;
-use Exporter 5.59 'import';
+use Exporter 5.57 'import';
our @EXPORT = qw(exception);
our @EXPORT_OK = qw(exception success);
diff -up Test-Fatal-0.004/Makefile.PL.orig Test-Fatal-0.004/Makefile.PL
--- Test-Fatal-0.004/Makefile.PL.orig 2011-04-25 16:58:02.000000000 +0100
+++ Test-Fatal-0.004/Makefile.PL 2011-04-26 14:54:06.471985150 +0100
@@ -4,7 +4,7 @@ use warnings;
-use ExtUtils::MakeMaker 6.31;
+use ExtUtils::MakeMaker 6.17;
@@ -12,11 +12,11 @@ my %WriteMakefileArgs = (
'ABSTRACT' => 'incredibly simple helpers for testing code with exceptions',
'AUTHOR' => 'Ricardo Signes <rjbs@cpan.org>',
'BUILD_REQUIRES' => {
- 'Test::More' => '0.96',
+ 'Test::More' => '0.47',
'overload' => '0'
},
'CONFIGURE_REQUIRES' => {
- 'ExtUtils::MakeMaker' => '6.31'
+ 'ExtUtils::MakeMaker' => '6.17'
},
'DISTNAME' => 'Test-Fatal',
'EXE_FILES' => [],
@@ -24,7 +24,7 @@ my %WriteMakefileArgs = (
'NAME' => 'Test::Fatal',
'PREREQ_PM' => {
'Carp' => '0',
- 'Exporter' => '5.59',
+ 'Exporter' => '5.57',
'Try::Tiny' => '0.07'
},
'VERSION' => '0.004',
@@ -50,6 +50,9 @@ unless ( eval { ExtUtils::MakeMaker->VER
delete $WriteMakefileArgs{CONFIGURE_REQUIRES}
unless eval { ExtUtils::MakeMaker->VERSION(6.52) };
+delete $WriteMakefileArgs{LICENSE}
+ unless eval { ExtUtils::MakeMaker->VERSION(6.31) };
+
WriteMakefile(%WriteMakefileArgs);