Update to 0.004

- New upstream release 0.04:
  - success blocks now allow trailing blocks like finally, catch, etc.
- Remove remaining uses of macros for commands
- Re-order %install section to conventional position in spec
This commit is contained in:
Paul Howarth 2011-04-26 16:28:53 +01:00
parent 39dbda498c
commit ec3c903b60
4 changed files with 27 additions and 21 deletions

2
.gitignore vendored
View File

@ -1 +1 @@
/Test-Fatal-0.003.tar.gz
/Test-Fatal-0.004.tar.gz

View File

@ -1,8 +1,8 @@
There's no need to be as strict about versions as this.
diff -up Test-Fatal-0.003/lib/Test/Fatal.pm.orig Test-Fatal-0.003/lib/Test/Fatal.pm
--- Test-Fatal-0.003/lib/Test/Fatal.pm.orig 2010-10-29 03:11:02.000000000 +0100
+++ Test-Fatal-0.003/lib/Test/Fatal.pm 2010-10-29 09:06:06.608473151 +0100
diff -up Test-Fatal-0.004/lib/Test/Fatal.pm.orig Test-Fatal-0.004/lib/Test/Fatal.pm
--- Test-Fatal-0.004/lib/Test/Fatal.pm.orig 2011-04-25 16:58:02.000000000 +0100
+++ Test-Fatal-0.004/lib/Test/Fatal.pm 2011-04-26 14:53:19.759806309 +0100
@@ -10,7 +10,7 @@ BEGIN {
use Carp ();
use Try::Tiny 0.07;
@ -12,9 +12,9 @@ diff -up Test-Fatal-0.003/lib/Test/Fatal.pm.orig Test-Fatal-0.003/lib/Test/Fatal
our @EXPORT = qw(exception);
our @EXPORT_OK = qw(exception success);
diff -up Test-Fatal-0.003/Makefile.PL.orig Test-Fatal-0.003/Makefile.PL
--- Test-Fatal-0.003/Makefile.PL.orig 2010-10-29 03:11:02.000000000 +0100
+++ Test-Fatal-0.003/Makefile.PL 2010-10-29 09:07:28.605285870 +0100
diff -up Test-Fatal-0.004/Makefile.PL.orig Test-Fatal-0.004/Makefile.PL
--- Test-Fatal-0.004/Makefile.PL.orig 2011-04-25 16:58:02.000000000 +0100
+++ Test-Fatal-0.004/Makefile.PL 2011-04-26 14:54:06.471985150 +0100
@@ -4,7 +4,7 @@ use warnings;
@ -46,7 +46,7 @@ diff -up Test-Fatal-0.003/Makefile.PL.orig Test-Fatal-0.003/Makefile.PL
+ 'Exporter' => '5.57',
'Try::Tiny' => '0.07'
},
'VERSION' => '0.003',
'VERSION' => '0.004',
@@ -50,6 +50,9 @@ unless ( eval { ExtUtils::MakeMaker->VER
delete $WriteMakefileArgs{CONFIGURE_REQUIRES}
unless eval { ExtUtils::MakeMaker->VERSION(6.52) };

View File

@ -1,20 +1,20 @@
Summary: Incredibly simple helpers for testing code with exceptions
Name: perl-Test-Fatal
Version: 0.003
Release: 2%{?dist}
Version: 0.004
Release: 1%{?dist}
License: GPL+ or Artistic
Group: Development/Libraries
Url: http://search.cpan.org/dist/Test-Fatal/
Source0: http://search.cpan.org/CPAN/authors/id/R/RJ/RJBS/Test-Fatal-%{version}.tar.gz
Patch0: Test-Fatal-0.003-versions.patch
BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
Patch0: Test-Fatal-0.004-versions.patch
BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(id -nu)
BuildArch: noarch
BuildRequires: perl(Exporter) >= 5.57
BuildRequires: perl(ExtUtils::MakeMaker)
BuildRequires: perl(Test::More)
BuildRequires: perl(Test::Pod)
BuildRequires: perl(Try::Tiny) >= 0.07
Requires: perl(:MODULE_COMPAT_%(eval "`%{__perl} -V:version`"; echo $version))
Requires: perl(:MODULE_COMPAT_%(eval "`perl -V:version`"; echo $version))
%description
Test::Fatal is an alternative to the popular Test::Exception. It does much
@ -33,12 +33,6 @@ It exports one routine by default: exception.
perl Makefile.PL INSTALLDIRS=vendor
make %{?_smp_mflags}
%check
make test RELEASE_TESTING=1
%clean
rm -rf %{buildroot}
%install
rm -rf %{buildroot}
make pure_install DESTDIR=%{buildroot}
@ -46,6 +40,12 @@ find %{buildroot} -type f -name .packlist -exec rm -f {} ';'
find %{buildroot} -depth -type d -exec rmdir {} ';' 2>/dev/null
%{_fixperms} %{buildroot}
%check
make test RELEASE_TESTING=1
%clean
rm -rf %{buildroot}
%files
%defattr(-,root,root,-)
%doc Changes LICENSE README
@ -53,7 +53,13 @@ find %{buildroot} -depth -type d -exec rmdir {} ';' 2>/dev/null
%{_mandir}/man3/Test::Fatal.3pm*
%changelog
* Wed Feb 09 2011 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.003-2
* Tue Apr 26 2011 Paul Howarth <paul@city-fan.org> 0.004-1
- Update to 0.004
- success blocks now allow trailing blocks like finally, catch, etc.
- Remove remaining uses of macros for commands
- Re-order %%install section to conventional position in spec
* Wed Feb 09 2011 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> 0.003-2
- Rebuilt for https://fedoraproject.org/wiki/Fedora_15_Mass_Rebuild
* Fri Oct 29 2010 Paul Howarth <paul@city-fan.org> 0.003-1

View File

@ -1 +1 @@
e73e90b65a5f07ff77f7e5f3bd336fcf Test-Fatal-0.003.tar.gz
aa4106ed8aaba14fb234d3f7d012f432 Test-Fatal-0.004.tar.gz