Update to 0.006

- New upstream release 0.006:
  - Crank back the Test::More and Exporter requirements (CPAN RT#62699)
  - Add lives_ok and dies_ok emulation (CPAN RT#67598)
- Versions patch replaced by workaround for old ExtUtils::MakeMaker
- BR: perl(Test::Builder::Tester)
This commit is contained in:
Paul Howarth 2011-06-02 10:21:36 +01:00
parent 3001da8796
commit f2c0251ccb
5 changed files with 45 additions and 64 deletions

2
.gitignore vendored
View File

@ -1 +1 @@
/Test-Fatal-0.005.tar.gz /Test-Fatal-[0-9.]*.tar.gz

View File

@ -1,57 +0,0 @@
There's no need to be as strict about versions as this.
--- Test-Fatal-0.005/lib/Test/Fatal.pm
+++ Test-Fatal-0.005/lib/Test/Fatal.pm
@@ -10,7 +10,7 @@ BEGIN {
use Carp ();
use Try::Tiny 0.07;
-use Exporter 5.59 'import';
+use Exporter 5.57 'import';
our @EXPORT = qw(exception);
our @EXPORT_OK = qw(exception success);
--- Test-Fatal-0.005/Makefile.PL
+++ Test-Fatal-0.005/Makefile.PL
@@ -4,7 +4,7 @@ use warnings;
-use ExtUtils::MakeMaker 6.31;
+use ExtUtils::MakeMaker 6.17;
@@ -12,11 +12,11 @@ my %WriteMakefileArgs = (
'ABSTRACT' => 'incredibly simple helpers for testing code with exceptions',
'AUTHOR' => 'Ricardo Signes <rjbs@cpan.org>',
'BUILD_REQUIRES' => {
- 'Test::More' => '0.96',
+ 'Test::More' => '0.47',
'overload' => '0'
},
'CONFIGURE_REQUIRES' => {
- 'ExtUtils::MakeMaker' => '6.31'
+ 'ExtUtils::MakeMaker' => '6.17'
},
'DISTNAME' => 'Test-Fatal',
'EXE_FILES' => [],
@@ -24,7 +24,7 @@ my %WriteMakefileArgs = (
'NAME' => 'Test::Fatal',
'PREREQ_PM' => {
'Carp' => '0',
- 'Exporter' => '5.59',
+ 'Exporter' => '5.57',
'Try::Tiny' => '0.07'
},
'VERSION' => '0.005',
@@ -50,6 +50,9 @@ unless ( eval { ExtUtils::MakeMaker->VER
delete $WriteMakefileArgs{CONFIGURE_REQUIRES}
unless eval { ExtUtils::MakeMaker->VERSION(6.52) };
+delete $WriteMakefileArgs{LICENSE}
+ unless eval { ExtUtils::MakeMaker->VERSION(6.31) };
+
WriteMakefile(%WriteMakefileArgs);

View File

@ -0,0 +1,30 @@
--- Test-Fatal/Makefile.PL
+++ Test-Fatal/Makefile.PL
@@ -4,7 +4,7 @@
-use ExtUtils::MakeMaker 6.30;
+use ExtUtils::MakeMaker;
@@ -17,7 +17,7 @@
'overload' => '0'
},
'CONFIGURE_REQUIRES' => {
- 'ExtUtils::MakeMaker' => '6.30'
+ 'ExtUtils::MakeMaker' => '0'
},
'DISTNAME' => 'Test-Fatal',
'EXE_FILES' => [],
@@ -52,6 +52,9 @@
delete $WriteMakefileArgs{CONFIGURE_REQUIRES}
unless eval { ExtUtils::MakeMaker->VERSION(6.52) };
+delete $WriteMakefileArgs{LICENSE}
+ unless eval { ExtUtils::MakeMaker->VERSION(6.31) };
+
WriteMakefile(%WriteMakefileArgs);

View File

@ -1,16 +1,17 @@
Summary: Incredibly simple helpers for testing code with exceptions Summary: Incredibly simple helpers for testing code with exceptions
Name: perl-Test-Fatal Name: perl-Test-Fatal
Version: 0.005 Version: 0.006
Release: 1%{?dist} Release: 1%{?dist}
License: GPL+ or Artistic License: GPL+ or Artistic
Group: Development/Libraries Group: Development/Libraries
Url: http://search.cpan.org/dist/Test-Fatal/ Url: http://search.cpan.org/dist/Test-Fatal/
Source0: http://search.cpan.org/CPAN/authors/id/R/RJ/RJBS/Test-Fatal-%{version}.tar.gz Source0: http://search.cpan.org/CPAN/authors/id/R/RJ/RJBS/Test-Fatal-%{version}.tar.gz
Patch0: Test-Fatal-0.005-versions.patch Patch0: Test-Fatal-0.006-old-EU::MM.patch
BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(id -nu) BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(id -nu)
BuildArch: noarch BuildArch: noarch
BuildRequires: perl(Exporter) >= 5.57 BuildRequires: perl(Exporter) >= 5.57
BuildRequires: perl(ExtUtils::MakeMaker) BuildRequires: perl(ExtUtils::MakeMaker)
BuildRequires: perl(Test::Builder::Tester)
BuildRequires: perl(Test::More) BuildRequires: perl(Test::More)
BuildRequires: perl(Test::Pod) BuildRequires: perl(Test::Pod)
BuildRequires: perl(Try::Tiny) >= 0.07 BuildRequires: perl(Try::Tiny) >= 0.07
@ -21,13 +22,13 @@ Test::Fatal is an alternative to the popular Test::Exception. It does much
less, but should allow greater flexibility in testing exception-throwing code less, but should allow greater flexibility in testing exception-throwing code
with about the same amount of typing. with about the same amount of typing.
It exports one routine by default: exception.
%prep %prep
%setup -q -n Test-Fatal-%{version} %setup -q -n Test-Fatal-%{version}
# No need to have bleeding edge versions of modules really # We don't really need ExtUtils::MakeMaker ≥ 6.30
%if "%{?rhel}" == "4"
%patch0 -p1 %patch0 -p1
%endif
%build %build
perl Makefile.PL INSTALLDIRS=vendor perl Makefile.PL INSTALLDIRS=vendor
@ -53,6 +54,13 @@ rm -rf %{buildroot}
%{_mandir}/man3/Test::Fatal.3pm* %{_mandir}/man3/Test::Fatal.3pm*
%changelog %changelog
* Thu Jun 2 2011 Paul Howarth <paul@city-fan.org> 0.006-1
- Update to 0.006
- Crank back the Test::More and Exporter requirements (CPAN RT#62699)
- Add lives_ok and dies_ok emulation (CPAN RT#67598)
- Versions patch replaced by workaround for old ExtUtils::MakeMaker
- BR: perl(Test::Builder::Tester)
* Tue Apr 26 2011 Paul Howarth <paul@city-fan.org> 0.005-1 * Tue Apr 26 2011 Paul Howarth <paul@city-fan.org> 0.005-1
- Update to 0.005 - Update to 0.005
- Fix the logic that picks tests for 5.13.1+ - Fix the logic that picks tests for 5.13.1+

View File

@ -1 +1 @@
8fd91391e82ea4290eb0cf8409393485 Test-Fatal-0.005.tar.gz a984aa4d4088892c0454cbfce35e54d9 Test-Fatal-0.006.tar.gz