perl-Test-Fatal/Test-Fatal-0.005-versions.patch
Paul Howarth 3001da8796 Update to 0.005
- New upstream release 0.005:
  - Fix the logic that picks tests for 5.13.1+
2011-04-26 18:10:45 +01:00

58 lines
1.4 KiB
Diff

There's no need to be as strict about versions as this.
--- Test-Fatal-0.005/lib/Test/Fatal.pm
+++ Test-Fatal-0.005/lib/Test/Fatal.pm
@@ -10,7 +10,7 @@ BEGIN {
use Carp ();
use Try::Tiny 0.07;
-use Exporter 5.59 'import';
+use Exporter 5.57 'import';
our @EXPORT = qw(exception);
our @EXPORT_OK = qw(exception success);
--- Test-Fatal-0.005/Makefile.PL
+++ Test-Fatal-0.005/Makefile.PL
@@ -4,7 +4,7 @@ use warnings;
-use ExtUtils::MakeMaker 6.31;
+use ExtUtils::MakeMaker 6.17;
@@ -12,11 +12,11 @@ my %WriteMakefileArgs = (
'ABSTRACT' => 'incredibly simple helpers for testing code with exceptions',
'AUTHOR' => 'Ricardo Signes <rjbs@cpan.org>',
'BUILD_REQUIRES' => {
- 'Test::More' => '0.96',
+ 'Test::More' => '0.47',
'overload' => '0'
},
'CONFIGURE_REQUIRES' => {
- 'ExtUtils::MakeMaker' => '6.31'
+ 'ExtUtils::MakeMaker' => '6.17'
},
'DISTNAME' => 'Test-Fatal',
'EXE_FILES' => [],
@@ -24,7 +24,7 @@ my %WriteMakefileArgs = (
'NAME' => 'Test::Fatal',
'PREREQ_PM' => {
'Carp' => '0',
- 'Exporter' => '5.59',
+ 'Exporter' => '5.57',
'Try::Tiny' => '0.07'
},
'VERSION' => '0.005',
@@ -50,6 +50,9 @@ unless ( eval { ExtUtils::MakeMaker->VER
delete $WriteMakefileArgs{CONFIGURE_REQUIRES}
unless eval { ExtUtils::MakeMaker->VERSION(6.52) };
+delete $WriteMakefileArgs{LICENSE}
+ unless eval { ExtUtils::MakeMaker->VERSION(6.31) };
+
WriteMakefile(%WriteMakefileArgs);