Update to 0.005
- New upstream release 0.005: - Fix the logic that picks tests for 5.13.1+
This commit is contained in:
parent
ec3c903b60
commit
3001da8796
2
.gitignore
vendored
2
.gitignore
vendored
@ -1 +1 @@
|
||||
/Test-Fatal-0.004.tar.gz
|
||||
/Test-Fatal-0.005.tar.gz
|
||||
|
@ -1,8 +1,7 @@
|
||||
There's no need to be as strict about versions as this.
|
||||
|
||||
diff -up Test-Fatal-0.004/lib/Test/Fatal.pm.orig Test-Fatal-0.004/lib/Test/Fatal.pm
|
||||
--- Test-Fatal-0.004/lib/Test/Fatal.pm.orig 2011-04-25 16:58:02.000000000 +0100
|
||||
+++ Test-Fatal-0.004/lib/Test/Fatal.pm 2011-04-26 14:53:19.759806309 +0100
|
||||
--- Test-Fatal-0.005/lib/Test/Fatal.pm
|
||||
+++ Test-Fatal-0.005/lib/Test/Fatal.pm
|
||||
@@ -10,7 +10,7 @@ BEGIN {
|
||||
use Carp ();
|
||||
use Try::Tiny 0.07;
|
||||
@ -12,9 +11,8 @@ diff -up Test-Fatal-0.004/lib/Test/Fatal.pm.orig Test-Fatal-0.004/lib/Test/Fatal
|
||||
|
||||
our @EXPORT = qw(exception);
|
||||
our @EXPORT_OK = qw(exception success);
|
||||
diff -up Test-Fatal-0.004/Makefile.PL.orig Test-Fatal-0.004/Makefile.PL
|
||||
--- Test-Fatal-0.004/Makefile.PL.orig 2011-04-25 16:58:02.000000000 +0100
|
||||
+++ Test-Fatal-0.004/Makefile.PL 2011-04-26 14:54:06.471985150 +0100
|
||||
--- Test-Fatal-0.005/Makefile.PL
|
||||
+++ Test-Fatal-0.005/Makefile.PL
|
||||
@@ -4,7 +4,7 @@ use warnings;
|
||||
|
||||
|
||||
@ -46,7 +44,7 @@ diff -up Test-Fatal-0.004/Makefile.PL.orig Test-Fatal-0.004/Makefile.PL
|
||||
+ 'Exporter' => '5.57',
|
||||
'Try::Tiny' => '0.07'
|
||||
},
|
||||
'VERSION' => '0.004',
|
||||
'VERSION' => '0.005',
|
||||
@@ -50,6 +50,9 @@ unless ( eval { ExtUtils::MakeMaker->VER
|
||||
delete $WriteMakefileArgs{CONFIGURE_REQUIRES}
|
||||
unless eval { ExtUtils::MakeMaker->VERSION(6.52) };
|
@ -1,12 +1,12 @@
|
||||
Summary: Incredibly simple helpers for testing code with exceptions
|
||||
Name: perl-Test-Fatal
|
||||
Version: 0.004
|
||||
Version: 0.005
|
||||
Release: 1%{?dist}
|
||||
License: GPL+ or Artistic
|
||||
Group: Development/Libraries
|
||||
Url: http://search.cpan.org/dist/Test-Fatal/
|
||||
Source0: http://search.cpan.org/CPAN/authors/id/R/RJ/RJBS/Test-Fatal-%{version}.tar.gz
|
||||
Patch0: Test-Fatal-0.004-versions.patch
|
||||
Patch0: Test-Fatal-0.005-versions.patch
|
||||
BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(id -nu)
|
||||
BuildArch: noarch
|
||||
BuildRequires: perl(Exporter) >= 5.57
|
||||
@ -53,6 +53,10 @@ rm -rf %{buildroot}
|
||||
%{_mandir}/man3/Test::Fatal.3pm*
|
||||
|
||||
%changelog
|
||||
* Tue Apr 26 2011 Paul Howarth <paul@city-fan.org> 0.005-1
|
||||
- Update to 0.005
|
||||
- Fix the logic that picks tests for 5.13.1+
|
||||
|
||||
* Tue Apr 26 2011 Paul Howarth <paul@city-fan.org> 0.004-1
|
||||
- Update to 0.004
|
||||
- success blocks now allow trailing blocks like finally, catch, etc.
|
||||
|
Loading…
Reference in New Issue
Block a user