New upstream release v2.02.132.
This commit is contained in:
parent
22e99add25
commit
34ebe8bfa5
1
.gitignore
vendored
1
.gitignore
vendored
@ -36,3 +36,4 @@
|
|||||||
/LVM2.2.02.129.tgz
|
/LVM2.2.02.129.tgz
|
||||||
/LVM2.2.02.130.tgz
|
/LVM2.2.02.130.tgz
|
||||||
/LVM2.2.02.131.tgz
|
/LVM2.2.02.131.tgz
|
||||||
|
/LVM2.2.02.132.tgz
|
||||||
|
@ -1,7 +0,0 @@
|
|||||||
-----BEGIN PGP SIGNATURE-----
|
|
||||||
Version: GnuPG v2.0.14 (GNU/Linux)
|
|
||||||
|
|
||||||
iEYEABECAAYFAlX4FrkACgkQIoGRwVZ+LBf4QACgwbVhaNwSJ4+uIkSJaxSd1aKY
|
|
||||||
a+8AniVvn4tKP2UGLayeIoTjeD/51uqy
|
|
||||||
=2+Au
|
|
||||||
-----END PGP SIGNATURE-----
|
|
7
LVM2.2.02.132.tgz.asc
Normal file
7
LVM2.2.02.132.tgz.asc
Normal file
@ -0,0 +1,7 @@
|
|||||||
|
-----BEGIN PGP SIGNATURE-----
|
||||||
|
Version: GnuPG v2.0.14 (GNU/Linux)
|
||||||
|
|
||||||
|
iEYEABECAAYFAlYBbckACgkQIoGRwVZ+LBedKgCgqN7CAWX44dfsi29q3qYLeqj2
|
||||||
|
oN8AoJraBuqA8lXTyVVK59K5qAKUgVT+
|
||||||
|
=XVPG
|
||||||
|
-----END PGP SIGNATURE-----
|
@ -1,28 +0,0 @@
|
|||||||
WHATS_NEW | 4 ++++
|
|
||||||
lib/format_text/format-text.c | 1 +
|
|
||||||
2 files changed, 5 insertions(+)
|
|
||||||
|
|
||||||
diff --git a/WHATS_NEW b/WHATS_NEW
|
|
||||||
index b15ae48..e50ffd2 100644
|
|
||||||
--- a/WHATS_NEW
|
|
||||||
+++ b/WHATS_NEW
|
|
||||||
@@ -1,3 +1,7 @@
|
|
||||||
+Version 2.02.132 -
|
|
||||||
+======================================
|
|
||||||
+ Fix PV label processing failure after pvcreate in lvm shell with lvmetad.
|
|
||||||
+
|
|
||||||
Version 2.02.131 - 15th September 2015
|
|
||||||
======================================
|
|
||||||
Rename 'make install_full_man' to install_all_man and add all_man target.
|
|
||||||
diff --git a/lib/format_text/format-text.c b/lib/format_text/format-text.c
|
|
||||||
index 4544f26..e0ec8ed 100644
|
|
||||||
--- a/lib/format_text/format-text.c
|
|
||||||
+++ b/lib/format_text/format-text.c
|
|
||||||
@@ -1339,6 +1339,7 @@ static int _text_pv_write(const struct format_type *fmt, struct physical_volume
|
|
||||||
|
|
||||||
label = lvmcache_get_label(info);
|
|
||||||
label->sector = pv->label_sector;
|
|
||||||
+ label->dev = pv->dev;
|
|
||||||
|
|
||||||
lvmcache_update_pv(info, pv, fmt);
|
|
||||||
|
|
20
lvm2.spec
20
lvm2.spec
@ -1,4 +1,4 @@
|
|||||||
%define device_mapper_version 1.02.108
|
%define device_mapper_version 1.02.109
|
||||||
|
|
||||||
%define enable_cache 1
|
%define enable_cache 1
|
||||||
%define enable_cluster 1
|
%define enable_cluster 1
|
||||||
@ -46,7 +46,7 @@
|
|||||||
|
|
||||||
Summary: Userland logical volume management tools
|
Summary: Userland logical volume management tools
|
||||||
Name: lvm2
|
Name: lvm2
|
||||||
Version: 2.02.131
|
Version: 2.02.132
|
||||||
Release: 1%{?dist}
|
Release: 1%{?dist}
|
||||||
License: GPLv2
|
License: GPLv2
|
||||||
Group: System Environment/Base
|
Group: System Environment/Base
|
||||||
@ -54,7 +54,6 @@ URL: http://sources.redhat.com/lvm2
|
|||||||
Source0: ftp://sources.redhat.com/pub/lvm2/releases/LVM2.%{version}.tgz
|
Source0: ftp://sources.redhat.com/pub/lvm2/releases/LVM2.%{version}.tgz
|
||||||
Patch0: lvm2-set-default-preferred_names.patch
|
Patch0: lvm2-set-default-preferred_names.patch
|
||||||
Patch1: lvm2-remove-mpath-device-handling-from-udev-rules.patch
|
Patch1: lvm2-remove-mpath-device-handling-from-udev-rules.patch
|
||||||
Patch2: lvm2-2_02_132-fix-pv-label-processing-failure-after-pvcreate-in-lvm-shell-with-lvmetad.patch
|
|
||||||
|
|
||||||
BuildRequires: libselinux-devel >= %{libselinux_version}, libsepol-devel
|
BuildRequires: libselinux-devel >= %{libselinux_version}, libsepol-devel
|
||||||
BuildRequires: libblkid-devel >= %{util_linux_version}
|
BuildRequires: libblkid-devel >= %{util_linux_version}
|
||||||
@ -104,7 +103,6 @@ or more physical volumes and creating one or more logical volumes
|
|||||||
%setup -q -n LVM2.%{version}
|
%setup -q -n LVM2.%{version}
|
||||||
%patch0 -p1 -b .preferred_names
|
%patch0 -p1 -b .preferred_names
|
||||||
%patch1 -p1 -b .udev_no_mpath
|
%patch1 -p1 -b .udev_no_mpath
|
||||||
%patch2 -p1 -b .pv_label_lvm_shell
|
|
||||||
|
|
||||||
%build
|
%build
|
||||||
%define _default_pid_dir /run
|
%define _default_pid_dir /run
|
||||||
@ -793,6 +791,20 @@ the device-mapper event library.
|
|||||||
%{_libdir}/pkgconfig/devmapper-event.pc
|
%{_libdir}/pkgconfig/devmapper-event.pc
|
||||||
|
|
||||||
%changelog
|
%changelog
|
||||||
|
* Wed Sep 23 2015 Peter Rajnoha <prajnoha@redhat.com> - 2.02.132-1
|
||||||
|
- Fix lvmconf to set locking_type=2 if external locking library is requested.
|
||||||
|
- Remove verbose message when rescanning an unchanged device. (2.02.119)
|
||||||
|
- Add origin_uuid, mirror_log_uuid, move_pv_uuid, convert_lv_uuid report fields.
|
||||||
|
- Add pool_lv_uuid, metadata_lv_uuid, data_lv_uuid reporting fields.
|
||||||
|
- Fix PV label processing failure after pvcreate in lvm shell with lvmetad.
|
||||||
|
- Update man pages for dmsetup and dmstats.
|
||||||
|
- Improve help text for dmsetup.
|
||||||
|
- Use --noflush and --nolockfs when removing device with --force.
|
||||||
|
- Parse new Overflow status string for snapshot target.
|
||||||
|
- Check dir path components are valid if using dm_create_dir, error out if not.
|
||||||
|
- Fix /dev/mapper handling to remove dangling entries if symlinks are found.
|
||||||
|
- Make it possible to use blank value as selection for string list report field.
|
||||||
|
|
||||||
* Wed Sep 16 2015 Peter Rajnoha <prajnoha@redhat.com> - 2.02.131-1
|
* Wed Sep 16 2015 Peter Rajnoha <prajnoha@redhat.com> - 2.02.131-1
|
||||||
- Fix PV label processing failure after pvcreate in lvm shell with lvmetad.
|
- Fix PV label processing failure after pvcreate in lvm shell with lvmetad.
|
||||||
- Rename 'make install_full_man' to install_all_man and add all_man target.
|
- Rename 'make install_full_man' to install_all_man and add all_man target.
|
||||||
|
2
sources
2
sources
@ -1 +1 @@
|
|||||||
ae0d8004b9753b87054ae5178b22f57c LVM2.2.02.131.tgz
|
80af5af726949bbbb2aceb15b24b7d20 LVM2.2.02.132.tgz
|
||||||
|
Loading…
Reference in New Issue
Block a user