New upstream release v2.02.131.
This commit is contained in:
parent
e92381c596
commit
22e99add25
1
.gitignore
vendored
1
.gitignore
vendored
@ -35,3 +35,4 @@
|
||||
/LVM2.2.02.128.tgz
|
||||
/LVM2.2.02.129.tgz
|
||||
/LVM2.2.02.130.tgz
|
||||
/LVM2.2.02.131.tgz
|
||||
|
@ -1,7 +0,0 @@
|
||||
-----BEGIN PGP SIGNATURE-----
|
||||
Version: GnuPG v2.0.14 (GNU/Linux)
|
||||
|
||||
iEYEABECAAYFAlXrcTMACgkQIoGRwVZ+LBcl+wCg3DR2zgS1YLLMnFlquVIJciwU
|
||||
ofMAoPMn5LyU3DgnzvWzJvocGzcBCCZM
|
||||
=N8MY
|
||||
-----END PGP SIGNATURE-----
|
7
LVM2.2.02.131.tgz.asc
Normal file
7
LVM2.2.02.131.tgz.asc
Normal file
@ -0,0 +1,7 @@
|
||||
-----BEGIN PGP SIGNATURE-----
|
||||
Version: GnuPG v2.0.14 (GNU/Linux)
|
||||
|
||||
iEYEABECAAYFAlX4FrkACgkQIoGRwVZ+LBf4QACgwbVhaNwSJ4+uIkSJaxSd1aKY
|
||||
a+8AniVvn4tKP2UGLayeIoTjeD/51uqy
|
||||
=2+Au
|
||||
-----END PGP SIGNATURE-----
|
@ -0,0 +1,28 @@
|
||||
WHATS_NEW | 4 ++++
|
||||
lib/format_text/format-text.c | 1 +
|
||||
2 files changed, 5 insertions(+)
|
||||
|
||||
diff --git a/WHATS_NEW b/WHATS_NEW
|
||||
index b15ae48..e50ffd2 100644
|
||||
--- a/WHATS_NEW
|
||||
+++ b/WHATS_NEW
|
||||
@@ -1,3 +1,7 @@
|
||||
+Version 2.02.132 -
|
||||
+======================================
|
||||
+ Fix PV label processing failure after pvcreate in lvm shell with lvmetad.
|
||||
+
|
||||
Version 2.02.131 - 15th September 2015
|
||||
======================================
|
||||
Rename 'make install_full_man' to install_all_man and add all_man target.
|
||||
diff --git a/lib/format_text/format-text.c b/lib/format_text/format-text.c
|
||||
index 4544f26..e0ec8ed 100644
|
||||
--- a/lib/format_text/format-text.c
|
||||
+++ b/lib/format_text/format-text.c
|
||||
@@ -1339,6 +1339,7 @@ static int _text_pv_write(const struct format_type *fmt, struct physical_volume
|
||||
|
||||
label = lvmcache_get_label(info);
|
||||
label->sector = pv->label_sector;
|
||||
+ label->dev = pv->dev;
|
||||
|
||||
lvmcache_update_pv(info, pv, fmt);
|
||||
|
22
lvm2.spec
22
lvm2.spec
@ -1,4 +1,4 @@
|
||||
%define device_mapper_version 1.02.107
|
||||
%define device_mapper_version 1.02.108
|
||||
|
||||
%define enable_cache 1
|
||||
%define enable_cluster 1
|
||||
@ -46,7 +46,7 @@
|
||||
|
||||
Summary: Userland logical volume management tools
|
||||
Name: lvm2
|
||||
Version: 2.02.130
|
||||
Version: 2.02.131
|
||||
Release: 1%{?dist}
|
||||
License: GPLv2
|
||||
Group: System Environment/Base
|
||||
@ -54,6 +54,7 @@ URL: http://sources.redhat.com/lvm2
|
||||
Source0: ftp://sources.redhat.com/pub/lvm2/releases/LVM2.%{version}.tgz
|
||||
Patch0: lvm2-set-default-preferred_names.patch
|
||||
Patch1: lvm2-remove-mpath-device-handling-from-udev-rules.patch
|
||||
Patch2: lvm2-2_02_132-fix-pv-label-processing-failure-after-pvcreate-in-lvm-shell-with-lvmetad.patch
|
||||
|
||||
BuildRequires: libselinux-devel >= %{libselinux_version}, libsepol-devel
|
||||
BuildRequires: libblkid-devel >= %{util_linux_version}
|
||||
@ -103,6 +104,7 @@ or more physical volumes and creating one or more logical volumes
|
||||
%setup -q -n LVM2.%{version}
|
||||
%patch0 -p1 -b .preferred_names
|
||||
%patch1 -p1 -b .udev_no_mpath
|
||||
%patch2 -p1 -b .pv_label_lvm_shell
|
||||
|
||||
%build
|
||||
%define _default_pid_dir /run
|
||||
@ -791,6 +793,22 @@ the device-mapper event library.
|
||||
%{_libdir}/pkgconfig/devmapper-event.pc
|
||||
|
||||
%changelog
|
||||
* Wed Sep 16 2015 Peter Rajnoha <prajnoha@redhat.com> - 2.02.131-1
|
||||
- Fix PV label processing failure after pvcreate in lvm shell with lvmetad.
|
||||
- Rename 'make install_full_man' to install_all_man and add all_man target.
|
||||
- Fix vgimportclone cache_dir path name (2.02.115).
|
||||
- Swapping of LV identifiers handles more complex LVs.
|
||||
- Use passed list of PVS when allocating space in lvconvert --thinpool.
|
||||
- Disallow usage of --stripe and --stripesize when creating cache pool.
|
||||
- Warn user when caching raid or thin pool data LV.
|
||||
- When layering LV, move LV flags with segments.
|
||||
- Ignore persistent cache if configuration changed. (2.02.127)
|
||||
- Fix devices/filter to be applied before disk-accessing filters. (2.02.112)
|
||||
- Make tags only when requested via 'make tags'.
|
||||
- Configure supports --disable-dependency-tracking for one-time builds.
|
||||
- Fix usage of configure.h when building in srcdir != builddir.
|
||||
- Do not check for full thin pool when activating without messages (1.02.107).
|
||||
|
||||
* Mon Sep 07 2015 Peter Rajnoha <prajnoha@redhat.com> - 2.02.130-1
|
||||
- Fix use of uninitialized device status if reading outdated .cache record.
|
||||
- Restore support for --monitor option in lvcreate (2.02.112).
|
||||
|
2
sources
2
sources
@ -1 +1 @@
|
||||
e7ae07e413120713549cc6dd2a558c75 LVM2.2.02.130.tgz
|
||||
ae0d8004b9753b87054ae5178b22f57c LVM2.2.02.131.tgz
|
||||
|
Loading…
Reference in New Issue
Block a user