Update to 2.42.4

Signed-off-by: Igor Gnatenko <ignatenkobrain@fedoraproject.org>
This commit is contained in:
Igor Gnatenko 2018-05-08 15:56:33 +02:00
parent f77de3169f
commit 8da4f790bb
No known key found for this signature in database
GPG Key ID: 695714BD1BBC5F4C
5 changed files with 76 additions and 47 deletions

1
.gitignore vendored
View File

@ -35,3 +35,4 @@ librsvg-2.31.0.tar.bz2
/librsvg-2.42.1.tar.xz
/librsvg-2.42.2.tar.xz
/librsvg-2.42.3.tar.xz
/librsvg-2.42.4.tar.xz

View File

@ -0,0 +1,61 @@
From 3a1325cc73ee4abb64ce254098fb9a1d8f486ce0 Mon Sep 17 00:00:00 2001
From: Igor Gnatenko <ignatenko@src.gnome.org>
Date: Tue, 8 May 2018 16:10:26 +0200
Subject: [PATCH] deps: update gtk-rs stack
Signed-off-by: Igor Gnatenko <ignatenko@src.gnome.org>
---
rsvg_internals/Cargo.toml | 14 +++++++-------
1 file changed, 7 insertions(+), 7 deletions(-)
diff --git a/rsvg_internals/Cargo.toml b/rsvg_internals/Cargo.toml
index 92c7704f..92e16a95 100644
--- a/rsvg_internals/Cargo.toml
+++ b/rsvg_internals/Cargo.toml
@@ -24,16 +24,16 @@ libc = "0.2"
downcast-rs = "^1.0.0"
regex = "^0.2.1"
itertools = "0.7.4"
-pango = "0.3.0"
-pangocairo = "0.4.1"
-pango-sys = "0.5.0"
+pango = "0.4"
+pangocairo = "0.5"
+pango-sys = "0.6"
cssparser = "0.23"
lazy_static = "1.0.0"
phf = "0.7.21"
float-cmp = "0.4.0"
[dependencies.cairo-sys-rs]
-version = "0.5.0"
+version = "0.6"
#git = "https://github.com/gtk-rs/cairo.git"
#branch = "master"
#git = "https://github.com/federicomenaquintero/cairo.git"
@@ -42,19 +42,19 @@ version = "0.5.0"
#features = ["png"]
[dependencies.cairo-rs]
-version = "0.3.0"
+version = "0.4"
#git = "https://github.com/gtk-rs/cairo.git"
#branch = "master"
#git = "file:///home/federico/src/gtk-rs/cairo"
#features = ["png"]
[dependencies.glib]
-version = "0.4.0"
+version = "0.5"
#git = "https://github.com/gtk-rs/glib.git"
#branch = "master"
[dependencies.glib-sys]
-version = "0.5.0"
+version = "0.6"
#git = "https://github.com/gtk-rs/sys"
#branch = "master"
--
2.17.0

View File

@ -1,43 +0,0 @@
--- librsvg-2.42.3/rsvg_internals/Cargo.toml.orig 2018-02-24 08:11:59.000000000 -0800
+++ librsvg-2.42.3/rsvg_internals/Cargo.toml 2018-03-22 16:07:55.041261092 -0700
@@ -13,14 +13,14 @@ libc = "0.2"
downcast-rs = "^1.0.0"
regex = "^0.2.1"
itertools = "0.7.4"
-pango = "0.3.0"
-pango-sys = "0.5.0"
+pango = "0.4.0"
+pango-sys = "0.6.0"
cssparser = "0.23"
lazy_static = "1.0.0"
phf = "0.7.21"
[dependencies.cairo-sys-rs]
-version = "0.5.0"
+version = "0.6.0"
#git = "https://github.com/gtk-rs/cairo.git"
#branch = "master"
#git = "https://github.com/federicomenaquintero/cairo.git"
@@ -29,19 +29,19 @@ version = "0.5.0"
#features = ["png"]
[dependencies.cairo-rs]
-version = "0.3.0"
+version = "0.4.0"
#git = "https://github.com/gtk-rs/cairo.git"
#branch = "master"
#git = "file:///home/federico/src/gtk-rs/cairo"
#features = ["png"]
[dependencies.glib]
-version = "0.4.0"
+version = "0.5.0"
#git = "https://github.com/gtk-rs/glib.git"
#branch = "master"
[dependencies.glib-sys]
-version = "0.5.0"
+version = "0.6.0"
#git = "https://github.com/gtk-rs/sys"
#branch = "master"

View File

@ -6,13 +6,14 @@
Name: librsvg2
Summary: An SVG library based on cairo
Version: 2.42.3
Release: 2%{?dist}
Version: 2.42.4
Release: 1%{?dist}
License: LGPLv2+
URL: https://wiki.gnome.org/Projects/LibRsvg
Source: http://download.gnome.org/sources/librsvg/2.42/librsvg-%{version}.tar.xz
Patch0: librsvg-2.42.3-update-rust-deps.diff
# https://gitlab.gnome.org/GNOME/librsvg/merge_requests/60
Patch0: 0001-deps-update-gtk-rs-stack.patch
BuildRequires: gcc
BuildRequires: pkgconfig(gdk-pixbuf-2.0) >= 2.20
@ -37,13 +38,19 @@ BuildRequires: (crate(cairo-rs) >= 0.4.0 with crate(cairo-rs) < 0.5.0)
BuildRequires: (crate(cairo-sys-rs) >= 0.6.0 with crate(cairo-sys-rs) < 0.7.0)
BuildRequires: (crate(cssparser) >= 0.23.0 with crate(cssparser) < 0.24.0)
BuildRequires: (crate(downcast-rs) >= 1.0.0 with crate(downcast-rs) < 2.0.0)
BuildRequires: (crate(float-cmp) >= 0.4.0 with crate(float-cmp) < 0.5.0)
BuildRequires: (crate(glib) >= 0.5.0 with crate(glib) < 0.6.0)
BuildRequires: (crate(glib-sys) >= 0.6.0 with crate(glib-sys) < 0.7.0)
BuildRequires: (crate(itertools) >= 0.7.4 with crate(itertools) < 0.8.0)
BuildRequires: (crate(lazy_static) >= 1.0.0 with crate(lazy_static) < 2.0.0)
BuildRequires: (crate(libc) >= 0.2.0 with crate(libc) < 0.3.0)
BuildRequires: (crate(pango) >= 0.4.0 with crate(pango) < 0.5.0)
BuildRequires: (crate(pango-sys) >= 0.6.0 with crate(pango-sys) < 0.7.0)
BuildRequires: (crate(pangocairo) >= 0.5.0 with crate(pangocairo) < 0.6.0)
BuildRequires: (crate(phf) >= 0.7.21 with crate(phf) < 0.8.0)
BuildRequires: (crate(regex) >= 0.2.1 with crate(regex) < 0.3.0)
# [build-dependencies]
BuildRequires: (crate(phf_codegen) >= 0.7.21 with crate(phf_codegen) < 0.8.0)
# for file triggers
Requires: gdk-pixbuf2%{?_isa} >= 2.31.5-2.fc24
@ -122,6 +129,9 @@ rm -vrf %{buildroot}%{_datadir}/doc
%{_mandir}/man1/rsvg-convert.1*
%changelog
* Tue May 08 2018 Igor Gnatenko <ignatenkobrain@fedoraproject.org> - 2.42.4-1
- Update to 2.42.4
* Thu May 03 2018 Josh Stone <jistone@redhat.com> - 2.42.3-2
- Update rust dependencies.

View File

@ -1 +1 @@
SHA512 (librsvg-2.42.3.tar.xz) = 21bbfea6236a602d41e9ba3f7cc7e25c49a499c791f54feb9bcb72717de0887a0d8554e2e798cc91583bdf4e5266ec4a53a9ea380bc5f4b40adac8b2e502de2e
SHA512 (librsvg-2.42.4.tar.xz) = d2fe14e7ae4b22774d6bbc4af630e9ae07742e45b5d17e8e6d4f0d3de94086d4108a15cfb8769eead8161bd024617d57c29bf5353cede252d2ed41d7a0f76744