Update rust dependencies.

This commit is contained in:
Josh Stone 2018-05-03 22:02:26 -07:00
parent 9d54ba2cbd
commit f77de3169f
2 changed files with 54 additions and 7 deletions

View File

@ -0,0 +1,43 @@
--- librsvg-2.42.3/rsvg_internals/Cargo.toml.orig 2018-02-24 08:11:59.000000000 -0800
+++ librsvg-2.42.3/rsvg_internals/Cargo.toml 2018-03-22 16:07:55.041261092 -0700
@@ -13,14 +13,14 @@ libc = "0.2"
downcast-rs = "^1.0.0"
regex = "^0.2.1"
itertools = "0.7.4"
-pango = "0.3.0"
-pango-sys = "0.5.0"
+pango = "0.4.0"
+pango-sys = "0.6.0"
cssparser = "0.23"
lazy_static = "1.0.0"
phf = "0.7.21"
[dependencies.cairo-sys-rs]
-version = "0.5.0"
+version = "0.6.0"
#git = "https://github.com/gtk-rs/cairo.git"
#branch = "master"
#git = "https://github.com/federicomenaquintero/cairo.git"
@@ -29,19 +29,19 @@ version = "0.5.0"
#features = ["png"]
[dependencies.cairo-rs]
-version = "0.3.0"
+version = "0.4.0"
#git = "https://github.com/gtk-rs/cairo.git"
#branch = "master"
#git = "file:///home/federico/src/gtk-rs/cairo"
#features = ["png"]
[dependencies.glib]
-version = "0.4.0"
+version = "0.5.0"
#git = "https://github.com/gtk-rs/glib.git"
#branch = "master"
[dependencies.glib-sys]
-version = "0.5.0"
+version = "0.6.0"
#git = "https://github.com/gtk-rs/sys"
#branch = "master"

View File

@ -7,11 +7,12 @@
Name: librsvg2
Summary: An SVG library based on cairo
Version: 2.42.3
Release: 1%{?dist}
Release: 2%{?dist}
License: LGPLv2+
URL: https://wiki.gnome.org/Projects/LibRsvg
Source: http://download.gnome.org/sources/librsvg/2.42/librsvg-%{version}.tar.xz
Patch0: librsvg-2.42.3-update-rust-deps.diff
BuildRequires: gcc
BuildRequires: pkgconfig(gdk-pixbuf-2.0) >= 2.20
@ -32,16 +33,16 @@ BuildRequires: pkgconfig(fontconfig)
BuildRequires: chrpath
BuildRequires: rust-packaging
# [dependencies]
BuildRequires: (crate(cairo-rs) >= 0.3.0 with crate(cairo-rs) < 0.4.0)
BuildRequires: (crate(cairo-sys-rs) >= 0.5.0 with crate(cairo-sys-rs) < 0.6.0)
BuildRequires: (crate(cairo-rs) >= 0.4.0 with crate(cairo-rs) < 0.5.0)
BuildRequires: (crate(cairo-sys-rs) >= 0.6.0 with crate(cairo-sys-rs) < 0.7.0)
BuildRequires: (crate(cssparser) >= 0.23.0 with crate(cssparser) < 0.24.0)
BuildRequires: (crate(downcast-rs) >= 1.0.0 with crate(downcast-rs) < 2.0.0)
BuildRequires: (crate(glib) >= 0.4.0 with crate(glib) < 0.5.0)
BuildRequires: (crate(glib-sys) >= 0.5.0 with crate(glib-sys) < 0.6.0)
BuildRequires: (crate(glib) >= 0.5.0 with crate(glib) < 0.6.0)
BuildRequires: (crate(glib-sys) >= 0.6.0 with crate(glib-sys) < 0.7.0)
BuildRequires: (crate(itertools) >= 0.7.4 with crate(itertools) < 0.8.0)
BuildRequires: (crate(libc) >= 0.2.0 with crate(libc) < 0.3.0)
BuildRequires: (crate(pango) >= 0.3.0 with crate(pango) < 0.4.0)
BuildRequires: (crate(pango-sys) >= 0.5.0 with crate(pango-sys) < 0.6.0)
BuildRequires: (crate(pango) >= 0.4.0 with crate(pango) < 0.5.0)
BuildRequires: (crate(pango-sys) >= 0.6.0 with crate(pango-sys) < 0.7.0)
BuildRequires: (crate(regex) >= 0.2.1 with crate(regex) < 0.3.0)
# for file triggers
@ -121,6 +122,9 @@ rm -vrf %{buildroot}%{_datadir}/doc
%{_mandir}/man1/rsvg-convert.1*
%changelog
* Thu May 03 2018 Josh Stone <jistone@redhat.com> - 2.42.3-2
- Update rust dependencies.
* Mon Mar 05 2018 Kalev Lember <klember@redhat.com> - 2.42.3-1
- Update to 2.42.3