New upstream version 1.13.22.

- Remove 3x upstream patches.
- Renumber the two remaining non-upstream patches as patch0, patch1.
This commit is contained in:
Richard W.M. Jones 2011-10-19 18:02:01 +01:00
parent 8eb92c2b78
commit 1a7ac3f9c8
6 changed files with 13 additions and 149 deletions

1
.gitignore vendored
View File

@ -108,3 +108,4 @@ libguestfs-1.5.3.tar.gz
/libguestfs-1.13.19.tar.gz
/libguestfs-1.13.20.tar.gz
/libguestfs-1.13.21.tar.gz
/libguestfs-1.13.22.tar.gz

View File

@ -1,45 +0,0 @@
From cf4cc1143393d607a7fb4cdbee1434544237d5d4 Mon Sep 17 00:00:00 2001
From: "Richard W.M. Jones" <rjones@redhat.com>
Date: Mon, 17 Oct 2011 09:59:43 +0100
Subject: [PATCH] Skip guestmount and virt-sysprep tests if no /dev/fuse.
---
clone/test-virt-sysprep.sh | 5 +++++
fuse/test-fuse.sh | 5 +++++
2 files changed, 10 insertions(+), 0 deletions(-)
diff --git a/clone/test-virt-sysprep.sh b/clone/test-virt-sysprep.sh
index 632d366..097f416 100755
--- a/clone/test-virt-sysprep.sh
+++ b/clone/test-virt-sysprep.sh
@@ -19,6 +19,11 @@
export LANG=C
set -e
+if [ ! -w /dev/fuse ]; then
+ echo "SKIPPING virt-sysprep test, because there is no /dev/fuse."
+ exit 0
+fi
+
rm -f test.img guestfish
qemu-img create -f qcow2 -o backing_file=../images/fedora.img test.img
diff --git a/fuse/test-fuse.sh b/fuse/test-fuse.sh
index cfa277a..7de5211 100755
--- a/fuse/test-fuse.sh
+++ b/fuse/test-fuse.sh
@@ -20,6 +20,11 @@ unset CDPATH
set -e
#set -v
+if [ ! -w /dev/fuse ]; then
+ echo "SKIPPING guestmount test, because there is no /dev/fuse."
+ exit 0
+fi
+
if [ -z "$top_builddir" ]; then
echo "$0: error: environment variable \$top_builddir must be set"
exit 1
--
1.7.6

View File

@ -1,27 +0,0 @@
From af0c123be8cc62acf9e1368b1d00acccdd6d91e9 Mon Sep 17 00:00:00 2001
From: "Richard W.M. Jones" <rjones@redhat.com>
Date: Fri, 14 Oct 2011 22:08:20 +0100
Subject: [PATCH] appliance: Fedora cryptsetup-luks renamed to cryptsetup.
Therefore we need both names to be listed in the file.
---
appliance/packagelist.in | 3 ++-
1 files changed, 2 insertions(+), 1 deletions(-)
diff --git a/appliance/packagelist.in b/appliance/packagelist.in
index 731ee7d..f8f2642 100644
--- a/appliance/packagelist.in
+++ b/appliance/packagelist.in
@@ -21,7 +21,8 @@
#ifdef REDHAT
augeas-libs
btrfs-progs
- cryptsetup-luks
+ cryptsetup
+ cryptsetup-luks /* old name used before Fedora 17 */
diffutils
e2fsprogs
/* e4fsprogs only exists on RHEL 5, will be ignored everywhere else. */
--
1.7.6

View File

@ -1,58 +0,0 @@
From 8cf06ddcddf1fda3a189667dbaaa4560ba49df3c Mon Sep 17 00:00:00 2001
From: "Richard W.M. Jones" <rjones@redhat.com>
Date: Sat, 15 Oct 2011 17:51:16 +0100
Subject: [PATCH] virt-sysprep: Fix test to use guestmount and virt-inspector
binaries that have been built.
---
Makefile.am | 2 +-
clone/test-virt-sysprep.sh | 17 +++++++++++++----
2 files changed, 14 insertions(+), 5 deletions(-)
diff --git a/Makefile.am b/Makefile.am
index 5170ec8..388cdeb 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -85,7 +85,7 @@ if HAVE_FUSE
SUBDIRS += fuse
endif
-# virt-tools in shell. This uses guestmount.
+# virt-tools in shell. This uses guestmount and virt-inspector.
if HAVE_FUSE
SUBDIRS += clone
endif
diff --git a/clone/test-virt-sysprep.sh b/clone/test-virt-sysprep.sh
index 897afb7..632d366 100755
--- a/clone/test-virt-sysprep.sh
+++ b/clone/test-virt-sysprep.sh
@@ -23,13 +23,22 @@ rm -f test.img guestfish
qemu-img create -f qcow2 -o backing_file=../images/fedora.img test.img
-cat <<'EOF' > guestfish
+# Provide alternate 'virt-inspector' and 'guestmount' binaries
+# that run the just-built programs.
+
+cat <<'EOF' > virt-inspector
+#!/bin/sh -
+../run ../inspector/virt-inspector "$@"
+EOF
+chmod +x virt-inspector
+cat <<'EOF' > guestmount
#!/bin/sh -
-../run ../fish/guestfish "$@"
+../run ../fuse/guestmount "$@"
EOF
-chmod +x guestfish
+chmod +x guestmount
+
PATH=.:$PATH
./virt-sysprep -a test.img
-rm -f test.img guestfish
+rm -f test.img virt-inspector guestmount
--
1.7.6

View File

@ -29,8 +29,8 @@
Summary: Access and modify virtual machine disk images
Name: libguestfs
Epoch: 1
Version: 1.13.21
Release: 4%{?dist}
Version: 1.13.22
Release: 1%{?dist}
License: LGPLv2+
Group: Development/Libraries
URL: http://libguestfs.org/
@ -38,22 +38,13 @@ Source0: http://libguestfs.org/download/1.13-development/%{name}-%{version
BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
# Force qemu-kvm test to run with -machine accel=tcg flag.
Patch2: libguestfs-1.12.0-configure-force-machine-accel-tcg.patch
Patch0: libguestfs-1.12.0-configure-force-machine-accel-tcg.patch
# Non-upstream patch to fix -machine option. This is not upstream
# because qemu have reverted the behaviour. However the reverted
# version is not yet in Rawhide so we have to keep this patch for a
# while.
Patch3: 0001-Fix-qemu-machine-option-for-latest-qemu-thanks-Marku.patch
# Upstream patch to rename cryptsetup-luks to cryptsetup.
Patch4: 0001-appliance-Fedora-cryptsetup-luks-renamed-to-cryptset.patch
# Upstream patch to fix virt-sysprep test.
Patch5: 0001-virt-sysprep-Fix-test-to-use-guestmount-and-virt-ins.patch
# Upstream patch to skip FUSE tests if no /dev/fuse.
Patch6: 0001-Skip-guestmount-and-virt-sysprep-tests-if-no-dev-fus.patch
Patch1: 0001-Fix-qemu-machine-option-for-latest-qemu-thanks-Marku.patch
# Basic build requirements:
BuildRequires: /usr/bin/pod2man
@ -528,11 +519,8 @@ for %{name}.
%prep
%setup -q
%patch2 -p1
%patch3 -p1
%patch4 -p1
%patch5 -p1
%patch6 -p1
%patch0 -p1
%patch1 -p1
mkdir -p daemon/m4
@ -909,6 +897,11 @@ rm -rf $RPM_BUILD_ROOT
%changelog
* Wed Oct 19 2011 Richard W.M. Jones <rjones@redhat.com> - 1:1.13.22-1
- New upstream version 1.13.22.
- Remove 3x upstream patches.
- Renumber the two remaining non-upstream patches as patch0, patch1.
* Mon Oct 17 2011 Richard W.M. Jones <rjones@redhat.com> - 1:1.13.21-4
- Add upstream patch to skip FUSE tests if there is no /dev/fuse.
This allows us also to remove the Fedora-specific patch which

View File

@ -1 +1 @@
b7b16824fc6a40a718299a498e4ead6e libguestfs-1.13.21.tar.gz
745217ec6046d483b5b610506252ff45 libguestfs-1.13.22.tar.gz