- Add upstream patch to skip FUSE tests if there is no /dev/fuse.
This allows us also to remove the Fedora-specific patch which disabled these tests before.
This commit is contained in:
parent
67cb874897
commit
8eb92c2b78
@ -0,0 +1,45 @@
|
||||
From cf4cc1143393d607a7fb4cdbee1434544237d5d4 Mon Sep 17 00:00:00 2001
|
||||
From: "Richard W.M. Jones" <rjones@redhat.com>
|
||||
Date: Mon, 17 Oct 2011 09:59:43 +0100
|
||||
Subject: [PATCH] Skip guestmount and virt-sysprep tests if no /dev/fuse.
|
||||
|
||||
---
|
||||
clone/test-virt-sysprep.sh | 5 +++++
|
||||
fuse/test-fuse.sh | 5 +++++
|
||||
2 files changed, 10 insertions(+), 0 deletions(-)
|
||||
|
||||
diff --git a/clone/test-virt-sysprep.sh b/clone/test-virt-sysprep.sh
|
||||
index 632d366..097f416 100755
|
||||
--- a/clone/test-virt-sysprep.sh
|
||||
+++ b/clone/test-virt-sysprep.sh
|
||||
@@ -19,6 +19,11 @@
|
||||
export LANG=C
|
||||
set -e
|
||||
|
||||
+if [ ! -w /dev/fuse ]; then
|
||||
+ echo "SKIPPING virt-sysprep test, because there is no /dev/fuse."
|
||||
+ exit 0
|
||||
+fi
|
||||
+
|
||||
rm -f test.img guestfish
|
||||
|
||||
qemu-img create -f qcow2 -o backing_file=../images/fedora.img test.img
|
||||
diff --git a/fuse/test-fuse.sh b/fuse/test-fuse.sh
|
||||
index cfa277a..7de5211 100755
|
||||
--- a/fuse/test-fuse.sh
|
||||
+++ b/fuse/test-fuse.sh
|
||||
@@ -20,6 +20,11 @@ unset CDPATH
|
||||
set -e
|
||||
#set -v
|
||||
|
||||
+if [ ! -w /dev/fuse ]; then
|
||||
+ echo "SKIPPING guestmount test, because there is no /dev/fuse."
|
||||
+ exit 0
|
||||
+fi
|
||||
+
|
||||
if [ -z "$top_builddir" ]; then
|
||||
echo "$0: error: environment variable \$top_builddir must be set"
|
||||
exit 1
|
||||
--
|
||||
1.7.6
|
||||
|
@ -1,33 +0,0 @@
|
||||
diff -ur libguestfs-1.7.13.old/fuse/Makefile.am libguestfs-1.7.13/fuse/Makefile.am
|
||||
--- libguestfs-1.7.13.old/fuse/Makefile.am 2010-11-24 20:12:08.000000000 +0000
|
||||
+++ libguestfs-1.7.13/fuse/Makefile.am 2010-11-24 22:31:13.522116969 +0000
|
||||
@@ -77,8 +77,8 @@
|
||||
|
||||
# Tests.
|
||||
|
||||
-TESTS = test-fuse.sh
|
||||
-TESTS_ENVIRONMENT = \
|
||||
- top_builddir=..
|
||||
+#TESTS = test-fuse.sh
|
||||
+#TESTS_ENVIRONMENT = \
|
||||
+# top_builddir=..
|
||||
|
||||
endif
|
||||
Only in libguestfs-1.7.13/fuse: Makefile.am.orig
|
||||
diff -ur libguestfs-1.7.13.old/fuse/Makefile.in libguestfs-1.7.13/fuse/Makefile.in
|
||||
--- libguestfs-1.7.13.old/fuse/Makefile.in 2010-11-24 20:17:24.000000000 +0000
|
||||
+++ libguestfs-1.7.13/fuse/Makefile.in 2010-11-24 22:31:13.524116997 +0000
|
||||
@@ -1055,9 +1055,9 @@
|
||||
@HAVE_FUSE_TRUE@noinst_DATA = $(top_builddir)/html/guestmount.1.html
|
||||
|
||||
# Tests.
|
||||
-@HAVE_FUSE_TRUE@TESTS = test-fuse.sh
|
||||
-@HAVE_FUSE_TRUE@TESTS_ENVIRONMENT = \
|
||||
-@HAVE_FUSE_TRUE@ top_builddir=..
|
||||
+#@HAVE_FUSE_TRUE@TESTS = test-fuse.sh
|
||||
+#@HAVE_FUSE_TRUE@TESTS_ENVIRONMENT = \
|
||||
+#@HAVE_FUSE_TRUE@ top_builddir=..
|
||||
|
||||
all: all-am
|
||||
|
||||
Only in libguestfs-1.7.13/fuse: Makefile.in.orig
|
@ -30,16 +30,13 @@ Summary: Access and modify virtual machine disk images
|
||||
Name: libguestfs
|
||||
Epoch: 1
|
||||
Version: 1.13.21
|
||||
Release: 3%{?dist}
|
||||
Release: 4%{?dist}
|
||||
License: LGPLv2+
|
||||
Group: Development/Libraries
|
||||
URL: http://libguestfs.org/
|
||||
Source0: http://libguestfs.org/download/1.13-development/%{name}-%{version}.tar.gz
|
||||
BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
|
||||
|
||||
# Disable FUSE tests, not supported in Koji at the moment.
|
||||
Patch0: libguestfs-1.7.13-no-fuse-test.patch
|
||||
|
||||
# Force qemu-kvm test to run with -machine accel=tcg flag.
|
||||
Patch2: libguestfs-1.12.0-configure-force-machine-accel-tcg.patch
|
||||
|
||||
@ -55,6 +52,9 @@ Patch4: 0001-appliance-Fedora-cryptsetup-luks-renamed-to-cryptset.patch
|
||||
# Upstream patch to fix virt-sysprep test.
|
||||
Patch5: 0001-virt-sysprep-Fix-test-to-use-guestmount-and-virt-ins.patch
|
||||
|
||||
# Upstream patch to skip FUSE tests if no /dev/fuse.
|
||||
Patch6: 0001-Skip-guestmount-and-virt-sysprep-tests-if-no-dev-fus.patch
|
||||
|
||||
# Basic build requirements:
|
||||
BuildRequires: /usr/bin/pod2man
|
||||
BuildRequires: /usr/bin/pod2text
|
||||
@ -528,11 +528,11 @@ for %{name}.
|
||||
%prep
|
||||
%setup -q
|
||||
|
||||
%patch0 -p1
|
||||
%patch2 -p1
|
||||
%patch3 -p1
|
||||
%patch4 -p1
|
||||
%patch5 -p1
|
||||
%patch6 -p1
|
||||
|
||||
mkdir -p daemon/m4
|
||||
|
||||
@ -909,6 +909,11 @@ rm -rf $RPM_BUILD_ROOT
|
||||
|
||||
|
||||
%changelog
|
||||
* Mon Oct 17 2011 Richard W.M. Jones <rjones@redhat.com> - 1:1.13.21-4
|
||||
- Add upstream patch to skip FUSE tests if there is no /dev/fuse.
|
||||
This allows us also to remove the Fedora-specific patch which
|
||||
disabled these tests before.
|
||||
|
||||
* Sat Oct 15 2011 Richard W.M. Jones <rjones@redhat.com> - 1:1.13.21-3
|
||||
- Add upstream patch to fix virt-sysprep test.
|
||||
|
||||
|
Loading…
Reference in New Issue
Block a user