Fix MakerNote handling
This commit is contained in:
parent
7817eb926e
commit
f18224aa48
11
libexif-0.6.12-odd.patch
Normal file
11
libexif-0.6.12-odd.patch
Normal file
@ -0,0 +1,11 @@
|
||||
--- libexif-0.6.12/libexif/exif-data.c.odd 2005-04-24 22:39:24.611317000 -0400
|
||||
+++ libexif-0.6.12/libexif/exif-data.c 2005-04-24 22:39:49.290613000 -0400
|
||||
@@ -231,7 +231,7 @@
|
||||
* the offset must be an even number. If we need to introduce
|
||||
* a padding byte, we set it to 0.
|
||||
*/
|
||||
- if (s & 1) *ds++;
|
||||
+ if (s & 1) (*ds)++;
|
||||
*d = exif_mem_realloc (data->priv->mem, *d, *ds);
|
||||
if (!*d) {
|
||||
EXIF_LOG_NO_MEMORY (data->priv->log, "ExifData", *ds);
|
10
libexif.spec
10
libexif.spec
@ -1,7 +1,7 @@
|
||||
Summary: Library for extracting extra information from image files
|
||||
Name: libexif
|
||||
Version: 0.6.12
|
||||
Release: 1
|
||||
Release: 2
|
||||
Group: System Environment/Libraries
|
||||
License: LGPL
|
||||
URL: http://libexif.sourceforge.net/
|
||||
@ -9,6 +9,8 @@ Source0: http://umn.dl.sourceforge.net/sourceforge/libexif/%{name}-%{version}.ta
|
||||
BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-buildroot
|
||||
|
||||
Patch0: libexif-0.6.12-gcc4.patch
|
||||
# fixed in libexif CVS
|
||||
Patch1: libexif-0.6.12-odd.patch
|
||||
|
||||
%description
|
||||
Most digital cameras produce EXIF files, which are JPEG files with
|
||||
@ -26,7 +28,8 @@ for writing programs that use libexif.
|
||||
|
||||
%prep
|
||||
%setup -q
|
||||
%patch -p1 -b .gcc4
|
||||
%patch0 -p1 -b .gcc4
|
||||
%patch1 -p1 -b .odd
|
||||
|
||||
%build
|
||||
%configure
|
||||
@ -58,6 +61,9 @@ rm -rf $RPM_BUILD_ROOT
|
||||
%{_libdir}/pkgconfig/libexif.pc
|
||||
|
||||
%changelog
|
||||
* Sun Apr 24 2005 Matthias Clasen <mclasen@redhat.com>
|
||||
- Fix MakerNote handling (#153282)
|
||||
|
||||
* Mon Mar 28 2005 Matthias Clasen <mclasen@redhat.com>
|
||||
- Update to 0.6.12
|
||||
|
||||
|
Loading…
Reference in New Issue
Block a user