Switch to updated and fixed tarball
This commit is contained in:
parent
832188f112
commit
b925f95385
@ -1,34 +0,0 @@
|
|||||||
From f467e0f7c02be955a74d6e2844de0c846f40a6f1 Mon Sep 17 00:00:00 2001
|
|
||||||
From: Neal Gompa <ngompa13@gmail.com>
|
|
||||||
Date: Fri, 10 Jul 2020 14:02:34 -0400
|
|
||||||
Subject: [PATCH] CMake: Install version file
|
|
||||||
|
|
||||||
---
|
|
||||||
lib/CMakeLists.txt | 6 +++++-
|
|
||||||
1 file changed, 5 insertions(+), 1 deletion(-)
|
|
||||||
|
|
||||||
diff --git a/lib/CMakeLists.txt b/lib/CMakeLists.txt
|
|
||||||
index ec3baf3..3553d2d 100644
|
|
||||||
--- a/lib/CMakeLists.txt
|
|
||||||
+++ b/lib/CMakeLists.txt
|
|
||||||
@@ -57,12 +57,16 @@ configure_package_config_file(${PROJECT_SOURCE_DIR}/cmake/libeconfConfig.cmake.i
|
|
||||||
NO_SET_AND_CHECK_MACRO
|
|
||||||
NO_CHECK_REQUIRED_COMPONENTS_MACRO
|
|
||||||
)
|
|
||||||
+install(FILES
|
|
||||||
+ ${CMAKE_BINARY_DIR}/libeconfConfig.cmake
|
|
||||||
+ DESTINATION ${CMAKE_INSTALL_LIBDIR}/cmake/libeconf
|
|
||||||
+)
|
|
||||||
write_basic_package_version_file(
|
|
||||||
${CMAKE_BINARY_DIR}/libeconfConfigVersion.cmake
|
|
||||||
VERSION ${PROJECT_VERSION}
|
|
||||||
COMPATIBILITY SameMinorVersion
|
|
||||||
)
|
|
||||||
install(FILES
|
|
||||||
- ${CMAKE_BINARY_DIR}/libeconfConfig.cmake
|
|
||||||
+ ${CMAKE_BINARY_DIR}/libeconfConfigVersion.cmake
|
|
||||||
DESTINATION ${CMAKE_INSTALL_LIBDIR}/cmake/libeconf
|
|
||||||
)
|
|
||||||
--
|
|
||||||
2.26.2
|
|
||||||
|
|
@ -5,16 +5,13 @@
|
|||||||
|
|
||||||
Name: libeconf
|
Name: libeconf
|
||||||
Version: 0.3.8
|
Version: 0.3.8
|
||||||
Release: 1%{?dist}
|
Release: 2%{?dist}
|
||||||
Summary: Enhanced config file parser library
|
Summary: Enhanced config file parser library
|
||||||
|
|
||||||
License: MIT
|
License: MIT
|
||||||
URL: https://github.com/openSUSE/libeconf
|
URL: https://github.com/openSUSE/libeconf
|
||||||
Source0: %{url}/archive/v%{version}/%{name}-%{version}.tar.gz
|
Source0: %{url}/archive/v%{version}/%{name}-%{version}.tar.gz
|
||||||
|
|
||||||
# From: https://github.com/openSUSE/libeconf/pull/127
|
|
||||||
Patch0001: 0001-CMake-Install-version-file.patch
|
|
||||||
|
|
||||||
BuildRequires: cmake >= 3.12
|
BuildRequires: cmake >= 3.12
|
||||||
BuildRequires: gcc
|
BuildRequires: gcc
|
||||||
BuildRequires: make
|
BuildRequires: make
|
||||||
@ -37,9 +34,6 @@ developing applications that use %{name}.
|
|||||||
%prep
|
%prep
|
||||||
%autosetup -p1
|
%autosetup -p1
|
||||||
|
|
||||||
# Set the version correctly
|
|
||||||
sed -e "s/project(libeconf VERSION .*/project(libeconf VERSION %{version}/" -i CMakeLists.txt
|
|
||||||
|
|
||||||
|
|
||||||
%build
|
%build
|
||||||
%cmake
|
%cmake
|
||||||
@ -68,6 +62,9 @@ sed -e "s/project(libeconf VERSION .*/project(libeconf VERSION %{version}/" -i C
|
|||||||
|
|
||||||
|
|
||||||
%changelog
|
%changelog
|
||||||
|
* Sun Jul 12 2020 Neal Gompa <ngompa13@gmail.com> - 0.3.8-2
|
||||||
|
- Switch to updated and fixed tarball
|
||||||
|
|
||||||
* Fri Jul 10 2020 Neal Gompa <ngompa13@gmail.com> - 0.3.8-1
|
* Fri Jul 10 2020 Neal Gompa <ngompa13@gmail.com> - 0.3.8-1
|
||||||
- Update to 0.3.8 (RH#1844005)
|
- Update to 0.3.8 (RH#1844005)
|
||||||
|
|
||||||
|
2
sources
2
sources
@ -1 +1 @@
|
|||||||
SHA512 (libeconf-0.3.8.tar.gz) = 748c9fe5a87ded94b466a78d617716c6f9255b7687889732f277762f9621d2c0368ee9eac48f8f7b056f7eb4264dc4c66e9a7f043ac04f724425d88eba51ec98
|
SHA512 (libeconf-0.3.8.tar.gz) = 78b2a27748c1dfa9d4a73e99112e2632142136f7d1f842a9a18b1afd26e4238731415c5a103925a8d03941a5cc041288aa5893d5bc86144a1500dad95c362c34
|
||||||
|
Loading…
Reference in New Issue
Block a user