- Update to 0.5.2 (RH#1980774)
- Fix CVE-2023-22652 (RH#2212464) - Fix CVE-2023-30079 (RH#2235236) Signed-off-by: Iker Pedrosa <ipedrosa@redhat.com>
This commit is contained in:
parent
93f16cdd8b
commit
4f8679c2b0
1
.gitignore
vendored
1
.gitignore
vendored
@ -5,3 +5,4 @@
|
||||
/libeconf-0.3.5.tar.xz
|
||||
/libeconf-0.3.8.tar.gz
|
||||
/libeconf-0.4.0.tar.gz
|
||||
/libeconf-0.5.2.tar.gz
|
||||
|
@ -1,25 +0,0 @@
|
||||
From 82bd1d76a50c0f7557578b18d601c69c10e50950 Mon Sep 17 00:00:00 2001
|
||||
From: Neal Gompa <ngompa13@gmail.com>
|
||||
Date: Thu, 8 Jul 2021 05:42:04 -0400
|
||||
Subject: [PATCH 1/2] cmake: Install econftool
|
||||
|
||||
This was missed in bce4976bd6bd933ca415f3bf765d80a887b832a4.
|
||||
---
|
||||
util/CMakeLists.txt | 4 ++++
|
||||
1 file changed, 4 insertions(+)
|
||||
|
||||
diff --git a/util/CMakeLists.txt b/util/CMakeLists.txt
|
||||
index ce3fca8..08cc5f0 100644
|
||||
--- a/util/CMakeLists.txt
|
||||
+++ b/util/CMakeLists.txt
|
||||
@@ -1,3 +1,7 @@
|
||||
# Create the binary/executable
|
||||
add_executable(econftool econftool.c)
|
||||
target_link_libraries(econftool PRIVATE econf)
|
||||
+
|
||||
+install(TARGETS econftool
|
||||
+ RUNTIME DESTINATION ${CMAKE_INSTALL_BINDIR}
|
||||
+)
|
||||
--
|
||||
2.31.1
|
||||
|
13
0001-cmake-no-install-html.patch
Normal file
13
0001-cmake-no-install-html.patch
Normal file
@ -0,0 +1,13 @@
|
||||
diff --git a/doc/CMakeLists.txt b/doc/CMakeLists.txt
|
||||
index f1a43c6..3b58d80 100644
|
||||
--- a/doc/CMakeLists.txt
|
||||
+++ b/doc/CMakeLists.txt
|
||||
@@ -17,8 +17,6 @@ if(BUILD_DOCUMENTATION)
|
||||
WORKING_DIRECTORY ${CMAKE_CURRENT_BINARY_DIR}
|
||||
COMMENT "Generating API documentation with Doxygen"
|
||||
VERBATIM)
|
||||
-
|
||||
- install(DIRECTORY ${CMAKE_CURRENT_BINARY_DIR}/../html DESTINATION share/doc)
|
||||
endif()
|
||||
|
||||
install(FILES ${CMAKE_CURRENT_SOURCE_DIR}/man/libeconf.3 DESTINATION ${CMAKE_INSTALL_MANDIR}/man3)
|
@ -1,23 +0,0 @@
|
||||
From 5fbe0aed4622d4c94c4e541c6b013be7ae4616a3 Mon Sep 17 00:00:00 2001
|
||||
From: Neal Gompa <ngompa13@gmail.com>
|
||||
Date: Thu, 8 Jul 2021 05:49:41 -0400
|
||||
Subject: [PATCH 2/2] cmake: Install man pages
|
||||
|
||||
---
|
||||
doc/CMakeLists.txt | 3 +++
|
||||
1 file changed, 3 insertions(+)
|
||||
|
||||
diff --git a/doc/CMakeLists.txt b/doc/CMakeLists.txt
|
||||
index 0e47ccc..726183a 100644
|
||||
--- a/doc/CMakeLists.txt
|
||||
+++ b/doc/CMakeLists.txt
|
||||
@@ -20,3 +20,6 @@ if(BUILD_DOCUMENTATION)
|
||||
|
||||
install(DIRECTORY ${CMAKE_CURRENT_BINARY_DIR}/html DESTINATION share/doc)
|
||||
endif()
|
||||
+
|
||||
+install(FILES ${CMAKE_CURRENT_SOURCE_DIR}/man/libeconf.3 DESTINATION ${CMAKE_INSTALL_MANDIR}/man3)
|
||||
+install(FILES ${CMAKE_CURRENT_SOURCE_DIR}/man/econftool.8 DESTINATION ${CMAKE_INSTALL_MANDIR}/man8)
|
||||
--
|
||||
2.31.1
|
||||
|
@ -4,17 +4,18 @@
|
||||
%global somajor 0
|
||||
|
||||
Name: libeconf
|
||||
Version: 0.4.0
|
||||
Release: 6%{?dist}
|
||||
Version: 0.5.2
|
||||
Release: 1%{?dist}
|
||||
Summary: Enhanced config file parser library
|
||||
|
||||
License: MIT
|
||||
URL: https://github.com/openSUSE/libeconf
|
||||
Source0: %{url}/archive/%{version}/%{name}-%{version}.tar.gz
|
||||
|
||||
# Proposed upstream: https://github.com/openSUSE/libeconf/pull/151
|
||||
Patch0101: 0001-cmake-Install-econftool.patch
|
||||
Patch0102: 0002-cmake-Install-man-pages.patch
|
||||
### Patches ###
|
||||
# This should be a temporary workaround. I don't have enough time to check what's happening, but since we aren't shipping the html documentation it's fine to stop installing it
|
||||
Patch0101: 0001-cmake-no-install-html.patch
|
||||
|
||||
|
||||
BuildRequires: cmake >= 3.12
|
||||
BuildRequires: gcc
|
||||
@ -79,6 +80,11 @@ configuration files from applications that use %{name}.
|
||||
%{_mandir}/man8/econftool.8*
|
||||
|
||||
%changelog
|
||||
* Mon Aug 28 2023 Iker Pedrosa <ipedrosa@redhat.com> - 0.5.2-1
|
||||
- Update to 0.5.2 (RH#1980774)
|
||||
- Fix CVE-2023-22652 (RH#2212464)
|
||||
- Fix CVE-2023-30079 (RH#2235236)
|
||||
|
||||
* Thu Jul 20 2023 Fedora Release Engineering <releng@fedoraproject.org> - 0.4.0-6
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_39_Mass_Rebuild
|
||||
|
||||
|
2
sources
2
sources
@ -1 +1 @@
|
||||
SHA512 (libeconf-0.4.0.tar.gz) = 6ea93aa73ca632e5372125d463825f4d599cd22dc0c7bc9dec5c73f90d71faa411ab7676d156da2b5efb4fd2fd63fc864855eb3d6b70854920d95d4e71f0a995
|
||||
SHA512 (libeconf-0.5.2.tar.gz) = 4ab8b77df06d92309db0a1be427d953f2db164566d0b5b28f0579514cb94be7491cf9a892f06162c97406b2ead78ce8c9ca3ed17fb0a28bdf309c28d5273031f
|
||||
|
Loading…
Reference in New Issue
Block a user