Updating for Keylime release v6.3.1
This commit is contained in:
parent
2e877b5368
commit
07fa712c02
1
.gitignore
vendored
1
.gitignore
vendored
@ -12,3 +12,4 @@
|
|||||||
/6.0.1.tar.gz
|
/6.0.1.tar.gz
|
||||||
/6.1.0.tar.gz
|
/6.1.0.tar.gz
|
||||||
/v6.3.0.tar.gz
|
/v6.3.0.tar.gz
|
||||||
|
/v6.3.1.tar.gz
|
||||||
|
@ -1,32 +0,0 @@
|
|||||||
From 5adb1f336dc88c081eaed13fc454e9601b34bc1e Mon Sep 17 00:00:00 2001
|
|
||||||
From: Thore Sommer <mail@thson.de>
|
|
||||||
Date: Thu, 27 Jan 2022 18:43:33 +0100
|
|
||||||
Subject: [PATCH] revocation_notifier: fix socket path permission check
|
|
||||||
|
|
||||||
If the path was already there, we checked if the socket has the right
|
|
||||||
permissions not the directory. This fails because the file does not exists
|
|
||||||
at that point.
|
|
||||||
|
|
||||||
Signed-off-by: Thore Sommer <mail@thson.de>
|
|
||||||
---
|
|
||||||
keylime/revocation_notifier.py | 4 ++--
|
|
||||||
1 file changed, 2 insertions(+), 2 deletions(-)
|
|
||||||
|
|
||||||
diff --git a/keylime/revocation_notifier.py b/keylime/revocation_notifier.py
|
|
||||||
index e9e3b3f..1b74001 100644
|
|
||||||
--- a/keylime/revocation_notifier.py
|
|
||||||
+++ b/keylime/revocation_notifier.py
|
|
||||||
@@ -32,8 +32,8 @@ def start_broker():
|
|
||||||
if not os.path.exists(dir_name):
|
|
||||||
os.makedirs(dir_name, 0o700)
|
|
||||||
else:
|
|
||||||
- if os.stat(_SOCKET_PATH).st_mode & 0o777 != 0o700:
|
|
||||||
- msg = f"{_SOCKET_PATH} present with wrong permissions"
|
|
||||||
+ if os.stat(dir_name).st_mode & 0o777 != 0o700:
|
|
||||||
+ msg = f"{dir_name} present with wrong permissions"
|
|
||||||
logger.error(msg)
|
|
||||||
raise Exception(msg)
|
|
||||||
|
|
||||||
--
|
|
||||||
2.33.1
|
|
||||||
|
|
21
keylime.spec
21
keylime.spec
@ -1,8 +1,8 @@
|
|||||||
%global srcname keylime
|
%global srcname keylime
|
||||||
|
|
||||||
Name: keylime
|
Name: keylime
|
||||||
Version: 6.3.0
|
Version: 6.3.1
|
||||||
Release: 4%{?dist}
|
Release: 1%{?dist}
|
||||||
Summary: Open source TPM software for Bootstrapping and Maintaining Trust
|
Summary: Open source TPM software for Bootstrapping and Maintaining Trust
|
||||||
|
|
||||||
BuildArch: noarch
|
BuildArch: noarch
|
||||||
@ -10,8 +10,6 @@ BuildArch: noarch
|
|||||||
URL: https://github.com/keylime/keylime
|
URL: https://github.com/keylime/keylime
|
||||||
Source0: https://github.com/keylime/keylime/archive/refs/tags/v%{version}.tar.gz
|
Source0: https://github.com/keylime/keylime/archive/refs/tags/v%{version}.tar.gz
|
||||||
|
|
||||||
Patch: 0001-revocation_notifier-fix-socket-path-permission-check.patch
|
|
||||||
|
|
||||||
# Main program: BSD
|
# Main program: BSD
|
||||||
# Icons: MIT
|
# Icons: MIT
|
||||||
License: ASL 2.0 and MIT
|
License: ASL 2.0 and MIT
|
||||||
@ -224,21 +222,20 @@ The keylime tools package includes tools like the IMA emulator.
|
|||||||
|
|
||||||
%install
|
%install
|
||||||
%py3_install
|
%py3_install
|
||||||
mkdir -p %{buildroot}%{_unitdir}
|
|
||||||
mkdir -p %{buildroot}/%{_sharedstatedir}/%{srcname}
|
mkdir -p %{buildroot}/%{_sharedstatedir}/%{srcname}
|
||||||
mkdir -p --mode=0700 %{buildroot}/%{_rundir}/%{srcname}
|
mkdir -p --mode=0700 %{buildroot}/%{_rundir}/%{srcname}
|
||||||
mkdir -p --mode=0700 %{buildroot}/%{_localstatedir}/log/%{srcname}
|
mkdir -p --mode=0700 %{buildroot}/%{_localstatedir}/log/%{srcname}
|
||||||
|
|
||||||
install -pm 644 %{srcname}.conf \
|
install -Dpm 600 %{srcname}.conf \
|
||||||
%{buildroot}%{_sysconfdir}/%{srcname}.conf
|
%{buildroot}%{_sysconfdir}/%{srcname}.conf
|
||||||
|
|
||||||
install -pm 644 ./services/%{srcname}_agent.service \
|
install -Dpm 644 ./services/%{srcname}_agent.service \
|
||||||
%{buildroot}%{_unitdir}/%{srcname}_agent.service
|
%{buildroot}%{_unitdir}/%{srcname}_agent.service
|
||||||
|
|
||||||
install -pm 644 ./services/%{srcname}_verifier.service \
|
install -Dpm 644 ./services/%{srcname}_verifier.service \
|
||||||
%{buildroot}%{_unitdir}/%{srcname}_verifier.service
|
%{buildroot}%{_unitdir}/%{srcname}_verifier.service
|
||||||
|
|
||||||
install -pm 644 ./services/%{srcname}_registrar.service \
|
install -Dpm 644 ./services/%{srcname}_registrar.service \
|
||||||
%{buildroot}%{_unitdir}/%{srcname}_registrar.service
|
%{buildroot}%{_unitdir}/%{srcname}_registrar.service
|
||||||
|
|
||||||
cp -r ./tpm_cert_store %{buildroot}%{_sharedstatedir}/keylime/
|
cp -r ./tpm_cert_store %{buildroot}%{_sharedstatedir}/keylime/
|
||||||
@ -291,7 +288,6 @@ exit 0
|
|||||||
%files registrar
|
%files registrar
|
||||||
%license LICENSE
|
%license LICENSE
|
||||||
%{_bindir}/%{srcname}_registrar
|
%{_bindir}/%{srcname}_registrar
|
||||||
%{_bindir}/%{srcname}_provider_registrar
|
|
||||||
%{_unitdir}/keylime_registrar.service
|
%{_unitdir}/keylime_registrar.service
|
||||||
|
|
||||||
%files -n python3-%{srcname}-agent
|
%files -n python3-%{srcname}-agent
|
||||||
@ -315,8 +311,6 @@ exit 0
|
|||||||
|
|
||||||
%files tools
|
%files tools
|
||||||
%license LICENSE
|
%license LICENSE
|
||||||
%{_bindir}/%{srcname}_provider_platform_init
|
|
||||||
%{_bindir}/%{srcname}_provider_vtpm_add
|
|
||||||
%{_bindir}/%{srcname}_userdata_encrypt
|
%{_bindir}/%{srcname}_userdata_encrypt
|
||||||
|
|
||||||
%files base
|
%files base
|
||||||
@ -332,6 +326,9 @@ exit 0
|
|||||||
%license LICENSE
|
%license LICENSE
|
||||||
|
|
||||||
%changelog
|
%changelog
|
||||||
|
* Mon Feb 14 2022 Sergio Correia <scorreia@redhat.com> - 6.3.1-1
|
||||||
|
- Updating for Keylime release v6.3.1
|
||||||
|
|
||||||
* Tue Feb 08 2022 Sergio Correia <scorreia@redhat.com> - 6.0.3-4
|
* Tue Feb 08 2022 Sergio Correia <scorreia@redhat.com> - 6.0.3-4
|
||||||
- Add Conflicts clauses for the subpackages
|
- Add Conflicts clauses for the subpackages
|
||||||
|
|
||||||
|
2
sources
2
sources
@ -1 +1 @@
|
|||||||
SHA512 (v6.3.0.tar.gz) = be52720d37456982e9d4fb0947774db8f46e2303899bfba1c6b1601945c550336eba1ec29d129df373ecd0ae0c887258d2558c226029fc3766d87152d17e0e02
|
SHA512 (v6.3.1.tar.gz) = 0c0d5f2bbc68eae6608c3e7b8f06149c4f6ad27174fd84a05a7beecf69fba3340f961955da843a5c3bce2849bb79f065c5e2002d477d19c0fe8d6b81c5cb9109
|
||||||
|
Loading…
Reference in New Issue
Block a user