Linux v4.5-9406-g46e595a17dcf
- xtensa, mailbox, vhost, all the armsoc merges
This commit is contained in:
parent
8bfaf21554
commit
f20b3e7657
@ -1,101 +0,0 @@
|
|||||||
From patchwork Wed Jan 27 15:08:19 2016
|
|
||||||
Content-Type: text/plain; charset="utf-8"
|
|
||||||
MIME-Version: 1.0
|
|
||||||
Content-Transfer-Encoding: 7bit
|
|
||||||
Subject: [1/2] ARM: mvebu: change order of ethernet DT nodes on Armada 38x
|
|
||||||
From: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
|
|
||||||
X-Patchwork-Id: 8134751
|
|
||||||
Message-Id: <1453907300-28283-2-git-send-email-thomas.petazzoni@free-electrons.com>
|
|
||||||
To: Jason Cooper <jason@lakedaemon.net>, Andrew Lunn <andrew@lunn.ch>,
|
|
||||||
Sebastian Hesselbarth <sebastian.hesselbarth@gmail.com>,
|
|
||||||
Gregory Clement <gregory.clement@free-electrons.com>
|
|
||||||
Cc: Nadav Haklai <nadavh@marvell.com>, Lior Amsalem <alior@marvell.com>,
|
|
||||||
Thomas Petazzoni <thomas.petazzoni@free-electrons.com>,
|
|
||||||
linux-arm-kernel@lists.infradead.org
|
|
||||||
Date: Wed, 27 Jan 2016 16:08:19 +0100
|
|
||||||
|
|
||||||
On Armada 38x, the available network interfaces are:
|
|
||||||
|
|
||||||
- port 0, at 0x70000
|
|
||||||
- port 1, at 0x30000
|
|
||||||
- port 2, at 0x34000
|
|
||||||
|
|
||||||
Due to the rule saying that DT nodes should be ordered by register
|
|
||||||
addresses, the network interfaces are probed in this order:
|
|
||||||
|
|
||||||
- port 1, at 0x30000, which gets named eth0
|
|
||||||
- port 2, at 0x34000, which gets named eth1
|
|
||||||
- port 0, at 0x70000, which gets named eth2
|
|
||||||
|
|
||||||
(if all three ports are enabled at the board level)
|
|
||||||
|
|
||||||
Unfortunately, the network subsystem doesn't provide any way to rename
|
|
||||||
network interfaces from the kernel (it can only be done from
|
|
||||||
userspace). So, the default naming of the network interfaces is very
|
|
||||||
confusing as it doesn't match the datasheet, nor the naming of the
|
|
||||||
interfaces in the bootloader, nor the naming of the interfaces on
|
|
||||||
labels printed on the board.
|
|
||||||
|
|
||||||
For example, on the Armada 388 GP, the board has two ports, labelled
|
|
||||||
GE0 and GE1. One has to know that GE0 is eth1 and GE1 is eth0, which
|
|
||||||
isn't really obvious.
|
|
||||||
|
|
||||||
In order to solve this, this patch proposes to exceptionaly violate
|
|
||||||
the rule of "order DT nodes by register address", and put the 0x70000
|
|
||||||
node before the 0x30000 node, so that network interfaces get named in
|
|
||||||
a more natural way.
|
|
||||||
|
|
||||||
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
|
|
||||||
|
|
||||||
---
|
|
||||||
arch/arm/boot/dts/armada-38x.dtsi | 30 +++++++++++++++++++++---------
|
|
||||||
1 file changed, 21 insertions(+), 9 deletions(-)
|
|
||||||
|
|
||||||
diff --git a/arch/arm/boot/dts/armada-38x.dtsi b/arch/arm/boot/dts/armada-38x.dtsi
|
|
||||||
index e8b7f67..b50784d 100644
|
|
||||||
--- a/arch/arm/boot/dts/armada-38x.dtsi
|
|
||||||
+++ b/arch/arm/boot/dts/armada-38x.dtsi
|
|
||||||
@@ -429,6 +429,27 @@
|
|
||||||
reg = <0x22000 0x1000>;
|
|
||||||
};
|
|
||||||
|
|
||||||
+ /*
|
|
||||||
+ * As a special exception to the "order by
|
|
||||||
+ * register address" rule, the eth0 node is
|
|
||||||
+ * placed here to ensure that it gets
|
|
||||||
+ * registered as the first interface, since
|
|
||||||
+ * the network subsystem doesn't allow naming
|
|
||||||
+ * interfaces using DT aliases. Without this,
|
|
||||||
+ * the ordering of interfaces is different
|
|
||||||
+ * from the one used in U-Boot and the
|
|
||||||
+ * labeling of interfaces on the boards, which
|
|
||||||
+ * is very confusing for users.
|
|
||||||
+ */
|
|
||||||
+ eth0: ethernet@70000 {
|
|
||||||
+ compatible = "marvell,armada-370-neta";
|
|
||||||
+ reg = <0x70000 0x4000>;
|
|
||||||
+ interrupts-extended = <&mpic 8>;
|
|
||||||
+ clocks = <&gateclk 4>;
|
|
||||||
+ tx-csum-limit = <9800>;
|
|
||||||
+ status = "disabled";
|
|
||||||
+ };
|
|
||||||
+
|
|
||||||
eth1: ethernet@30000 {
|
|
||||||
compatible = "marvell,armada-370-neta";
|
|
||||||
reg = <0x30000 0x4000>;
|
|
||||||
@@ -493,15 +514,6 @@
|
|
||||||
};
|
|
||||||
};
|
|
||||||
|
|
||||||
- eth0: ethernet@70000 {
|
|
||||||
- compatible = "marvell,armada-370-neta";
|
|
||||||
- reg = <0x70000 0x4000>;
|
|
||||||
- interrupts-extended = <&mpic 8>;
|
|
||||||
- clocks = <&gateclk 4>;
|
|
||||||
- tx-csum-limit = <9800>;
|
|
||||||
- status = "disabled";
|
|
||||||
- };
|
|
||||||
-
|
|
||||||
mdio: mdio@72004 {
|
|
||||||
#address-cells = <1>;
|
|
||||||
#size-cells = <0>;
|
|
@ -36,7 +36,7 @@ index bb9b0faa..8b39d2b 100644
|
|||||||
--- a/Documentation/devicetree/bindings/arm/sunxi.txt
|
--- a/Documentation/devicetree/bindings/arm/sunxi.txt
|
||||||
+++ b/Documentation/devicetree/bindings/arm/sunxi.txt
|
+++ b/Documentation/devicetree/bindings/arm/sunxi.txt
|
||||||
@@ -13,3 +13,4 @@ using one of the following compatible strings:
|
@@ -13,3 +13,4 @@ using one of the following compatible strings:
|
||||||
allwinner,sun8i-a33
|
allwinner,sun8i-a83t
|
||||||
allwinner,sun8i-h3
|
allwinner,sun8i-h3
|
||||||
allwinner,sun9i-a80
|
allwinner,sun9i-a80
|
||||||
+ allwinner,sun50i-a64
|
+ allwinner,sun50i-a64
|
||||||
@ -164,11 +164,11 @@ diff --git a/arch/arm64/boot/dts/Makefile b/arch/arm64/boot/dts/Makefile
|
|||||||
index f832b8a..3b7428a 100644
|
index f832b8a..3b7428a 100644
|
||||||
--- a/arch/arm64/boot/dts/Makefile
|
--- a/arch/arm64/boot/dts/Makefile
|
||||||
+++ b/arch/arm64/boot/dts/Makefile
|
+++ b/arch/arm64/boot/dts/Makefile
|
||||||
@@ -1,3 +1,4 @@
|
@@ -2,3 +2,4 @@
|
||||||
|
dts-dirs += al
|
||||||
+dts-dirs += allwinner
|
+dts-dirs += allwinner
|
||||||
dts-dirs += altera
|
dts-dirs += altera
|
||||||
dts-dirs += amd
|
dts-dirs += amd
|
||||||
dts-dirs += apm
|
|
||||||
diff --git a/arch/arm64/boot/dts/allwinner/Makefile b/arch/arm64/boot/dts/allwinner/Makefile
|
diff --git a/arch/arm64/boot/dts/allwinner/Makefile b/arch/arm64/boot/dts/allwinner/Makefile
|
||||||
new file mode 100644
|
new file mode 100644
|
||||||
index 0000000..1e29a5a
|
index 0000000..1e29a5a
|
||||||
|
@ -133,6 +133,7 @@ CONFIG_CRYPTO_DEV_ROCKCHIP=m
|
|||||||
CONFIG_ROCKCHIP_EFUSE=m
|
CONFIG_ROCKCHIP_EFUSE=m
|
||||||
CONFIG_PHY_ROCKCHIP_EMMC=m
|
CONFIG_PHY_ROCKCHIP_EMMC=m
|
||||||
CONFIG_PHY_ROCKCHIP_DP=m
|
CONFIG_PHY_ROCKCHIP_DP=m
|
||||||
|
CONFIG_ROCKCHIP_MBOX=y
|
||||||
|
|
||||||
# Tegra
|
# Tegra
|
||||||
CONFIG_ARM_TEGRA_CPUFREQ=y
|
CONFIG_ARM_TEGRA_CPUFREQ=y
|
||||||
|
@ -12,17 +12,21 @@ CONFIG_ARCH_SEATTLE=y
|
|||||||
CONFIG_ARCH_SUNXI=y
|
CONFIG_ARCH_SUNXI=y
|
||||||
CONFIG_ARCH_TEGRA=y
|
CONFIG_ARCH_TEGRA=y
|
||||||
CONFIG_ARCH_XGENE=y
|
CONFIG_ARCH_XGENE=y
|
||||||
|
# CONFIG_ARCH_ALPINE is not set
|
||||||
# CONFIG_ARCH_BCM_IPROC is not set
|
# CONFIG_ARCH_BCM_IPROC is not set
|
||||||
# CONFIG_ARCH_BERLIN is not set
|
# CONFIG_ARCH_BERLIN is not set
|
||||||
# CONFIG_ARCH_EXYNOS7 is not set
|
# CONFIG_ARCH_EXYNOS is not set
|
||||||
# CONFIG_ARCH_FSL_LS2085A is not set
|
# CONFIG_ARCH_FSL_LS2085A is not set
|
||||||
# CONFIG_ARCH_LAYERSCAPE is not set
|
# CONFIG_ARCH_LAYERSCAPE is not set
|
||||||
# CONFIG_ARCH_MEDIATEK is not set
|
# CONFIG_ARCH_MEDIATEK is not set
|
||||||
|
# CONFIG_ARCH_MESON is not set
|
||||||
|
# CONFIG_ARCH_MVEBU is not set
|
||||||
# CONFIG_ARCH_QCOM is not set
|
# CONFIG_ARCH_QCOM is not set
|
||||||
# CONFIG_ARCH_RENESAS is not set
|
# CONFIG_ARCH_RENESAS is not set
|
||||||
# CONFIG_ARCH_SPRD is not set
|
# CONFIG_ARCH_SPRD is not set
|
||||||
# CONFIG_ARCH_STRATIX10 is not set
|
# CONFIG_ARCH_STRATIX10 is not set
|
||||||
# CONFIG_ARCH_THUNDER is not set
|
# CONFIG_ARCH_THUNDER is not set
|
||||||
|
# CONFIG_ARCH_VULCAN is not set
|
||||||
# CONFIG_ARCH_ZYNQMP is not set
|
# CONFIG_ARCH_ZYNQMP is not set
|
||||||
# CONFIG_ARCH_UNIPHIER is not set
|
# CONFIG_ARCH_UNIPHIER is not set
|
||||||
|
|
||||||
@ -135,6 +139,7 @@ CONFIG_EDAC_XGENE=m
|
|||||||
CONFIG_PCI_XGENE=y
|
CONFIG_PCI_XGENE=y
|
||||||
CONFIG_PCI_XGENE_MSI=y
|
CONFIG_PCI_XGENE_MSI=y
|
||||||
CONFIG_I2C_XGENE_SLIMPRO=m
|
CONFIG_I2C_XGENE_SLIMPRO=m
|
||||||
|
CONFIG_XGENE_SLIMPRO_MBOX=m
|
||||||
|
|
||||||
# AMD Seattle
|
# AMD Seattle
|
||||||
CONFIG_NET_SB1000=y
|
CONFIG_NET_SB1000=y
|
||||||
@ -152,6 +157,7 @@ CONFIG_HISI_THERMAL=m
|
|||||||
CONFIG_STUB_CLK_HI6220=y
|
CONFIG_STUB_CLK_HI6220=y
|
||||||
CONFIG_PHY_HI6220_USB=m
|
CONFIG_PHY_HI6220_USB=m
|
||||||
CONFIG_COMMON_RESET_HI6220=m
|
CONFIG_COMMON_RESET_HI6220=m
|
||||||
|
CONFIG_HI6220_MBOX=m
|
||||||
|
|
||||||
# Tegra
|
# Tegra
|
||||||
CONFIG_ARCH_TEGRA_132_SOC=y
|
CONFIG_ARCH_TEGRA_132_SOC=y
|
||||||
|
@ -59,6 +59,7 @@ CONFIG_ARCH_SUNXI=y
|
|||||||
CONFIG_ARCH_TEGRA=y
|
CONFIG_ARCH_TEGRA=y
|
||||||
CONFIG_ARCH_VEXPRESS_CORTEX_A5_A9_ERRATA=y
|
CONFIG_ARCH_VEXPRESS_CORTEX_A5_A9_ERRATA=y
|
||||||
CONFIG_ARCH_VIRT=y
|
CONFIG_ARCH_VIRT=y
|
||||||
|
# CONFIG_ARCH_ARTPEC is not set
|
||||||
# CONFIG_ARCH_BCM is not set
|
# CONFIG_ARCH_BCM is not set
|
||||||
# CONFIG_ARCH_BERLIN is not set
|
# CONFIG_ARCH_BERLIN is not set
|
||||||
# CONFIG_ARCH_HI3xxx is not set
|
# CONFIG_ARCH_HI3xxx is not set
|
||||||
|
2
gitrev
2
gitrev
@ -1 +1 @@
|
|||||||
1e75a9f34a5ed5902707fb74b468356c55142b71
|
46e595a17dcf11404f713845ecb5b06b92a94e43
|
||||||
|
@ -69,7 +69,7 @@ Summary: The Linux kernel
|
|||||||
# The rc snapshot level
|
# The rc snapshot level
|
||||||
%define rcrev 0
|
%define rcrev 0
|
||||||
# The git snapshot level
|
# The git snapshot level
|
||||||
%define gitrev 14
|
%define gitrev 15
|
||||||
# Set rpm version accordingly
|
# Set rpm version accordingly
|
||||||
%define rpmversion 4.%{upstream_sublevel}.0
|
%define rpmversion 4.%{upstream_sublevel}.0
|
||||||
%endif
|
%endif
|
||||||
@ -510,8 +510,6 @@ Patch456: arm64-acpi-drop-expert-patch.patch
|
|||||||
# http://patchwork.ozlabs.org/patch/587554/
|
# http://patchwork.ozlabs.org/patch/587554/
|
||||||
Patch457: ARM-tegra-usb-no-reset.patch
|
Patch457: ARM-tegra-usb-no-reset.patch
|
||||||
|
|
||||||
Patch458: ARM-mvebu-change-order-of-ethernet-DT-nodes-on-Armada-38x.patch
|
|
||||||
|
|
||||||
# http://www.spinics.net/lists/arm-kernel/msg490981.html
|
# http://www.spinics.net/lists/arm-kernel/msg490981.html
|
||||||
Patch459: geekbox-v4-device-tree-support.patch
|
Patch459: geekbox-v4-device-tree-support.patch
|
||||||
|
|
||||||
@ -2153,6 +2151,10 @@ fi
|
|||||||
#
|
#
|
||||||
#
|
#
|
||||||
%changelog
|
%changelog
|
||||||
|
* Mon Mar 21 2016 Josh Boyer <jwboyer@fedoraproject.org> - 4.6.0-0.rc0.git15.1
|
||||||
|
- Linux v4.5-9406-g46e595a17dcf
|
||||||
|
- xtensa, mailbox, vhost, all the armsoc merges
|
||||||
|
|
||||||
* Mon Mar 21 2016 Peter Robinson <pbrobinson@fedoraproject.org>
|
* Mon Mar 21 2016 Peter Robinson <pbrobinson@fedoraproject.org>
|
||||||
- Minor aarch64 cleanups
|
- Minor aarch64 cleanups
|
||||||
|
|
||||||
|
2
sources
2
sources
@ -1,3 +1,3 @@
|
|||||||
a60d48eee08ec0536d5efb17ca819aef linux-4.5.tar.xz
|
a60d48eee08ec0536d5efb17ca819aef linux-4.5.tar.xz
|
||||||
6f557fe90b800b615c85c2ca04da6154 perf-man-4.5.tar.gz
|
6f557fe90b800b615c85c2ca04da6154 perf-man-4.5.tar.gz
|
||||||
ef7eff3ee0ad581ed63c76552b70c09f patch-4.5-git14.xz
|
1034b54b04263544264016c73c6ba561 patch-4.5-git15.xz
|
||||||
|
Loading…
Reference in New Issue
Block a user