Enable bcm283x VEC composite output
This commit is contained in:
parent
860e040971
commit
c59b0760c7
58
bcm283x-VEC.patch
Normal file
58
bcm283x-VEC.patch
Normal file
@ -0,0 +1,58 @@
|
|||||||
|
From 7713257febc1cdecdc55e1372ecef7263c58c03c Mon Sep 17 00:00:00 2001
|
||||||
|
From: Boris Brezillon <boris.brezillon@free-electrons.com>
|
||||||
|
Date: Fri, 2 Dec 2016 14:48:12 +0100
|
||||||
|
Subject: [PATCH] ARM: bcm/dt: Add VEC node in bcm283x.dtsi
|
||||||
|
|
||||||
|
Add the VEC (Video EnCoder) node definition in bcm283x.dtsi.
|
||||||
|
|
||||||
|
Signed-off-by: Boris Brezillon <boris.brezillon@free-electrons.com>
|
||||||
|
Signed-off-by: Eric Anholt <eric@anholt.net>
|
||||||
|
---
|
||||||
|
arch/arm/boot/dts/bcm283x.dtsi | 8 ++++++++
|
||||||
|
1 file changed, 8 insertions(+)
|
||||||
|
|
||||||
|
diff --git a/arch/arm/boot/dts/bcm283x.dtsi b/arch/arm/boot/dts/bcm283x.dtsi
|
||||||
|
index 9a44da1..a3106aa 100644
|
||||||
|
--- a/arch/arm/boot/dts/bcm283x.dtsi
|
||||||
|
+++ b/arch/arm/boot/dts/bcm283x.dtsi
|
||||||
|
@@ -476,6 +476,14 @@
|
||||||
|
status = "disabled";
|
||||||
|
};
|
||||||
|
|
||||||
|
+ vec: vec@7e806000 {
|
||||||
|
+ compatible = "brcm,bcm2835-vec";
|
||||||
|
+ reg = <0x7e806000 0x1000>;
|
||||||
|
+ clocks = <&clocks BCM2835_CLOCK_VEC>;
|
||||||
|
+ interrupts = <2 27>;
|
||||||
|
+ status = "disabled";
|
||||||
|
+ };
|
||||||
|
+
|
||||||
|
pixelvalve@7e807000 {
|
||||||
|
compatible = "brcm,bcm2835-pixelvalve2";
|
||||||
|
reg = <0x7e807000 0x100>;
|
||||||
|
From 38742ca2b8b21bfc2a2cc24278b58485ff781644 Mon Sep 17 00:00:00 2001
|
||||||
|
From: Boris Brezillon <boris.brezillon@free-electrons.com>
|
||||||
|
Date: Fri, 2 Dec 2016 14:48:13 +0100
|
||||||
|
Subject: [PATCH] ARM: bcm/dt: Enable the VEC IP on all RaspberryPi boards
|
||||||
|
|
||||||
|
Enable the VEC IP on all RaspberryPi boards.
|
||||||
|
|
||||||
|
Signed-off-by: Boris Brezillon <boris.brezillon@free-electrons.com>
|
||||||
|
Signed-off-by: Eric Anholt <eric@anholt.net>
|
||||||
|
---
|
||||||
|
arch/arm/boot/dts/bcm2835-rpi.dtsi | 5 +++++
|
||||||
|
1 file changed, 5 insertions(+)
|
||||||
|
|
||||||
|
diff --git a/arch/arm/boot/dts/bcm2835-rpi.dtsi b/arch/arm/boot/dts/bcm2835-rpi.dtsi
|
||||||
|
index 6ddf7dfe..38e6050 100644
|
||||||
|
--- a/arch/arm/boot/dts/bcm2835-rpi.dtsi
|
||||||
|
+++ b/arch/arm/boot/dts/bcm2835-rpi.dtsi
|
||||||
|
@@ -87,3 +87,8 @@
|
||||||
|
power-domains = <&power RPI_POWER_DOMAIN_HDMI>;
|
||||||
|
status = "okay";
|
||||||
|
};
|
||||||
|
+
|
||||||
|
+&vec {
|
||||||
|
+ power-domains = <&power RPI_POWER_DOMAIN_VEC>;
|
||||||
|
+ status = "okay";
|
||||||
|
+};
|
23
kernel.spec
23
kernel.spec
@ -497,30 +497,32 @@ Source5005: kbuild-AFTER_LINK.patch
|
|||||||
# Standalone patches
|
# Standalone patches
|
||||||
|
|
||||||
# a tempory patch for QCOM hardware enablement. Will be gone by end of 2016/F-26 GA
|
# a tempory patch for QCOM hardware enablement. Will be gone by end of 2016/F-26 GA
|
||||||
Patch421: qcom-QDF2432-tmp-errata.patch
|
Patch420: qcom-QDF2432-tmp-errata.patch
|
||||||
|
|
||||||
# http://www.spinics.net/lists/arm-kernel/msg490981.html
|
# http://www.spinics.net/lists/arm-kernel/msg490981.html
|
||||||
Patch422: geekbox-v4-device-tree-support.patch
|
Patch421: geekbox-v4-device-tree-support.patch
|
||||||
|
|
||||||
# http://www.spinics.net/lists/linux-tegra/msg26029.html
|
# http://www.spinics.net/lists/linux-tegra/msg26029.html
|
||||||
Patch426: usb-phy-tegra-Add-38.4MHz-clock-table-entry.patch
|
Patch422: usb-phy-tegra-Add-38.4MHz-clock-table-entry.patch
|
||||||
|
|
||||||
# Fix OMAP4 (pandaboard)
|
# Fix OMAP4 (pandaboard)
|
||||||
Patch427: arm-revert-mmc-omap_hsmmc-Use-dma_request_chan-for-reque.patch
|
Patch423: arm-revert-mmc-omap_hsmmc-Use-dma_request_chan-for-reque.patch
|
||||||
|
|
||||||
# Not particularly happy we don't yet have a proper upstream resolution this is the right direction
|
# Not particularly happy we don't yet have a proper upstream resolution this is the right direction
|
||||||
# https://www.spinics.net/lists/arm-kernel/msg535191.html
|
# https://www.spinics.net/lists/arm-kernel/msg535191.html
|
||||||
Patch429: arm64-mm-Fix-memmap-to-be-initialized-for-the-entire-section.patch
|
Patch424: arm64-mm-Fix-memmap-to-be-initialized-for-the-entire-section.patch
|
||||||
|
|
||||||
# http://patchwork.ozlabs.org/patch/587554/
|
# http://patchwork.ozlabs.org/patch/587554/
|
||||||
Patch430: ARM-tegra-usb-no-reset.patch
|
Patch425: ARM-tegra-usb-no-reset.patch
|
||||||
|
|
||||||
Patch431: bcm2837-initial-support.patch
|
Patch426: AllWinner-net-emac.patch
|
||||||
|
|
||||||
|
Patch430: bcm2837-initial-support.patch
|
||||||
|
|
||||||
# http://www.spinics.net/lists/linux-mmc/msg41151.html
|
# http://www.spinics.net/lists/linux-mmc/msg41151.html
|
||||||
Patch432: bcm283x-mmc-imp-speed.patch
|
Patch431: bcm283x-mmc-imp-speed.patch
|
||||||
|
|
||||||
Patch433: AllWinner-net-emac.patch
|
Patch432: bcm283x-VEC.patch
|
||||||
|
|
||||||
Patch460: lib-cpumask-Make-CPUMASK_OFFSTACK-usable-without-deb.patch
|
Patch460: lib-cpumask-Make-CPUMASK_OFFSTACK-usable-without-deb.patch
|
||||||
|
|
||||||
@ -2152,6 +2154,9 @@ fi
|
|||||||
#
|
#
|
||||||
#
|
#
|
||||||
%changelog
|
%changelog
|
||||||
|
* Wed Jan 18 2017 Peter Robinson <pbrobinson@fedoraproject.org>
|
||||||
|
- Enable bcm283x VEC composite output
|
||||||
|
|
||||||
* Tue Jan 17 2017 Justin M. Forbes <jforbes@fedoraproject.org> - 4.10.0-0.rc4.git1.1
|
* Tue Jan 17 2017 Justin M. Forbes <jforbes@fedoraproject.org> - 4.10.0-0.rc4.git1.1
|
||||||
- Linux v4.10-rc4-78-g4b19a9e
|
- Linux v4.10-rc4-78-g4b19a9e
|
||||||
|
|
||||||
|
Loading…
Reference in New Issue
Block a user