Linux v4.17-rc6
This commit is contained in:
parent
ae3a573424
commit
3c2b399004
@ -1,70 +0,0 @@
|
|||||||
From f43194c1447c9536efb0859c2f3f46f6bf2b9154 Mon Sep 17 00:00:00 2001
|
|
||||||
From: Maxime Chevallier <maxime.chevallier@bootlin.com>
|
|
||||||
Date: Wed, 25 Apr 2018 20:19:47 +0200
|
|
||||||
Subject: ARM64: dts: marvell: armada-cp110: Add mg_core_clk for ethernet node
|
|
||||||
|
|
||||||
Marvell PPv2.2 controller present on CP-110 need the extra "mg_core_clk"
|
|
||||||
clock to avoid system hangs when powering some network interfaces up.
|
|
||||||
|
|
||||||
This issue appeared after a recent clock rework on Armada 7K/8K platforms.
|
|
||||||
|
|
||||||
This commit adds the new clock and updates the documentation accordingly.
|
|
||||||
|
|
||||||
[gregory.clement: use the real first commit to fix and add the cc:stable
|
|
||||||
flag]
|
|
||||||
Fixes: e3af9f7c6ece ("RM64: dts: marvell: armada-cp110: Fix clock resources for various node")
|
|
||||||
Cc: <stable@vger.kernel.org>
|
|
||||||
Signed-off-by: Maxime Chevallier <maxime.chevallier@bootlin.com>
|
|
||||||
Signed-off-by: Gregory CLEMENT <gregory.clement@bootlin.com>
|
|
||||||
---
|
|
||||||
Documentation/devicetree/bindings/net/marvell-pp2.txt | 9 +++++----
|
|
||||||
arch/arm64/boot/dts/marvell/armada-cp110.dtsi | 5 +++--
|
|
||||||
2 files changed, 8 insertions(+), 6 deletions(-)
|
|
||||||
|
|
||||||
diff --git a/Documentation/devicetree/bindings/net/marvell-pp2.txt b/Documentation/devicetree/bindings/net/marvell-pp2.txt
|
|
||||||
index 1814fa1..fc019df 100644
|
|
||||||
--- a/Documentation/devicetree/bindings/net/marvell-pp2.txt
|
|
||||||
+++ b/Documentation/devicetree/bindings/net/marvell-pp2.txt
|
|
||||||
@@ -21,9 +21,10 @@ Required properties:
|
|
||||||
- main controller clock (for both armada-375-pp2 and armada-7k-pp2)
|
|
||||||
- GOP clock (for both armada-375-pp2 and armada-7k-pp2)
|
|
||||||
- MG clock (only for armada-7k-pp2)
|
|
||||||
+ - MG Core clock (only for armada-7k-pp2)
|
|
||||||
- AXI clock (only for armada-7k-pp2)
|
|
||||||
-- clock-names: names of used clocks, must be "pp_clk", "gop_clk", "mg_clk"
|
|
||||||
- and "axi_clk" (the 2 latter only for armada-7k-pp2).
|
|
||||||
+- clock-names: names of used clocks, must be "pp_clk", "gop_clk", "mg_clk",
|
|
||||||
+ "mg_core_clk" and "axi_clk" (the 3 latter only for armada-7k-pp2).
|
|
||||||
|
|
||||||
The ethernet ports are represented by subnodes. At least one port is
|
|
||||||
required.
|
|
||||||
@@ -80,8 +81,8 @@ cpm_ethernet: ethernet@0 {
|
|
||||||
compatible = "marvell,armada-7k-pp22";
|
|
||||||
reg = <0x0 0x100000>, <0x129000 0xb000>;
|
|
||||||
clocks = <&cpm_syscon0 1 3>, <&cpm_syscon0 1 9>,
|
|
||||||
- <&cpm_syscon0 1 5>, <&cpm_syscon0 1 18>;
|
|
||||||
- clock-names = "pp_clk", "gop_clk", "gp_clk", "axi_clk";
|
|
||||||
+ <&cpm_syscon0 1 5>, <&cpm_syscon0 1 6>, <&cpm_syscon0 1 18>;
|
|
||||||
+ clock-names = "pp_clk", "gop_clk", "mg_clk", "mg_core_clk", "axi_clk";
|
|
||||||
|
|
||||||
eth0: eth0 {
|
|
||||||
interrupts = <ICU_GRP_NSR 39 IRQ_TYPE_LEVEL_HIGH>,
|
|
||||||
diff --git a/arch/arm64/boot/dts/marvell/armada-cp110.dtsi b/arch/arm64/boot/dts/marvell/armada-cp110.dtsi
|
|
||||||
index ca22f9d..ed2f123 100644
|
|
||||||
--- a/arch/arm64/boot/dts/marvell/armada-cp110.dtsi
|
|
||||||
+++ b/arch/arm64/boot/dts/marvell/armada-cp110.dtsi
|
|
||||||
@@ -38,9 +38,10 @@
|
|
||||||
compatible = "marvell,armada-7k-pp22";
|
|
||||||
reg = <0x0 0x100000>, <0x129000 0xb000>;
|
|
||||||
clocks = <&CP110_LABEL(clk) 1 3>, <&CP110_LABEL(clk) 1 9>,
|
|
||||||
- <&CP110_LABEL(clk) 1 5>, <&CP110_LABEL(clk) 1 18>;
|
|
||||||
+ <&CP110_LABEL(clk) 1 5>, <&CP110_LABEL(clk) 1 6>,
|
|
||||||
+ <&CP110_LABEL(clk) 1 18>;
|
|
||||||
clock-names = "pp_clk", "gop_clk",
|
|
||||||
- "mg_clk", "axi_clk";
|
|
||||||
+ "mg_clk", "mg_core_clk", "axi_clk";
|
|
||||||
marvell,system-controller = <&CP110_LABEL(syscon0)>;
|
|
||||||
status = "disabled";
|
|
||||||
dma-coherent;
|
|
||||||
--
|
|
||||||
cgit v1.1
|
|
2
gitrev
2
gitrev
@ -1 +1 @@
|
|||||||
2c71d338bef2cc8a2e5f8ebe70788eeff246fcd8
|
771c577c23bac90597c685971d7297ea00f99d11
|
||||||
|
13
kernel.spec
13
kernel.spec
@ -67,9 +67,9 @@ Summary: The Linux kernel
|
|||||||
# The next upstream release sublevel (base_sublevel+1)
|
# The next upstream release sublevel (base_sublevel+1)
|
||||||
%define upstream_sublevel %(echo $((%{base_sublevel} + 1)))
|
%define upstream_sublevel %(echo $((%{base_sublevel} + 1)))
|
||||||
# The rc snapshot level
|
# The rc snapshot level
|
||||||
%global rcrev 5
|
%global rcrev 6
|
||||||
# The git snapshot level
|
# The git snapshot level
|
||||||
%define gitrev 3
|
%define gitrev 0
|
||||||
# Set rpm version accordingly
|
# Set rpm version accordingly
|
||||||
%define rpmversion 4.%{upstream_sublevel}.0
|
%define rpmversion 4.%{upstream_sublevel}.0
|
||||||
%endif
|
%endif
|
||||||
@ -122,7 +122,7 @@ Summary: The Linux kernel
|
|||||||
# Set debugbuildsenabled to 1 for production (build separate debug kernels)
|
# Set debugbuildsenabled to 1 for production (build separate debug kernels)
|
||||||
# and 0 for rawhide (all kernels are debug kernels).
|
# and 0 for rawhide (all kernels are debug kernels).
|
||||||
# See also 'make debug' and 'make release'.
|
# See also 'make debug' and 'make release'.
|
||||||
%define debugbuildsenabled 0
|
%define debugbuildsenabled 1
|
||||||
|
|
||||||
%if %{with_verbose}
|
%if %{with_verbose}
|
||||||
%define make_opts V=1
|
%define make_opts V=1
|
||||||
@ -592,9 +592,6 @@ Patch310: arm-dts-Add-am335x-pocketbeagle.patch
|
|||||||
# https://www.spinics.net/lists/linux-tegra/msg32920.html
|
# https://www.spinics.net/lists/linux-tegra/msg32920.html
|
||||||
Patch311: arm-tegra-USB-driver-dependency-fix.patch
|
Patch311: arm-tegra-USB-driver-dependency-fix.patch
|
||||||
|
|
||||||
# In linux-next, due in stable
|
|
||||||
Patch312: arm64-dts-marvell-armada-cp110-fix-hang.patch
|
|
||||||
|
|
||||||
# https://patchwork.kernel.org/patch/10354521/
|
# https://patchwork.kernel.org/patch/10354521/
|
||||||
# https://patchwork.kernel.org/patch/10354187/
|
# https://patchwork.kernel.org/patch/10354187/
|
||||||
# https://patchwork.kernel.org/patch/10306793/
|
# https://patchwork.kernel.org/patch/10306793/
|
||||||
@ -1856,6 +1853,10 @@ fi
|
|||||||
#
|
#
|
||||||
#
|
#
|
||||||
%changelog
|
%changelog
|
||||||
|
* Mon May 21 2018 Justin M. Forbes <jforbes@fedoraproject.org> - 4.17.0-0.rc6.git0.1
|
||||||
|
- Linux v4.17-rc6
|
||||||
|
- Disable debugging options.
|
||||||
|
|
||||||
* Sun May 20 2018 Hans de Goede <hdegoede@redhat.com>
|
* Sun May 20 2018 Hans de Goede <hdegoede@redhat.com>
|
||||||
- Enable GPIO_AMDPT, PINCTRL_AMD and X86_AMD_PLATFORM_DEVICE Kconfig options
|
- Enable GPIO_AMDPT, PINCTRL_AMD and X86_AMD_PLATFORM_DEVICE Kconfig options
|
||||||
to fix i2c and GPIOs not working on AMD based laptops (rhbz#1510649)
|
to fix i2c and GPIOs not working on AMD based laptops (rhbz#1510649)
|
||||||
|
3
sources
3
sources
@ -1,3 +1,2 @@
|
|||||||
SHA512 (linux-4.16.tar.xz) = ab47849314b177d0eec9dbf261f33972b0d89fb92fb0650130ffa7abc2f36c0fab2d06317dc1683c51a472a9a631573a9b1e7258d6281a2ee189897827f14662
|
SHA512 (linux-4.16.tar.xz) = ab47849314b177d0eec9dbf261f33972b0d89fb92fb0650130ffa7abc2f36c0fab2d06317dc1683c51a472a9a631573a9b1e7258d6281a2ee189897827f14662
|
||||||
SHA512 (patch-4.17-rc5.xz) = 00599599b13efa89ac7d2f33a5b4eb09c4226add9944ae10cc08fa8c98d08a9a7a58e234bbafd4ccfe00cc808979ce98018d9fc1cf8245ad74574233cffb9883
|
SHA512 (patch-4.17-rc6.xz) = d8d67897e741b5ba91dbb3c6660e9289364938755f2f03031264206e85dd9b2a5101e36b4736ced9b58d092573ef5943c0cfd8d929da85143be2215b10478c55
|
||||||
SHA512 (patch-4.17-rc5-git3.xz) = c6fddc1df98cb801afbaf67e8e50e6f371bbd4f9062971ea9d861560a5ed4ef85b77f08d77bd552fee8e9253873e6d79ecc387c38d8126d5dcd153c12036db21
|
|
||||||
|
Loading…
Reference in New Issue
Block a user