3.10.0 bump

- Drop the SHAREDIR patch and revert to upstream ways (#966445)
- Fix an XFRM regression with FORTIFY_SOURCE
This commit is contained in:
Petr Šabata 2013-07-17 14:54:29 +02:00
parent a6699c9016
commit bf1ab7bc70
8 changed files with 62 additions and 88 deletions

1
.gitignore vendored
View File

@ -14,3 +14,4 @@ iproute2-2.6.35.tar.bz2
/iproute2-3.7.0.tar.gz
/iproute2-3.8.0.tar.gz
/iproute2-3.9.0.tar.gz
/iproute2-3.10.0.tar.gz

View File

@ -1,7 +1,7 @@
%global cbq_version v0.7.3
Summary: Advanced IP routing and network device configuration tools
Name: iproute
Version: 3.9.0
Version: 3.10.0
Release: 1%{?dist}
Group: Applications/System
URL: http://kernel.org/pub/linux/utils/net/%{name}2/
@ -11,13 +11,13 @@ Source2: avpkt
Patch0: man-pages.patch
Patch1: iproute2-3.4.0-kernel.patch
Patch2: iproute2-3.8.0-optflags.patch
Patch3: iproute2-3.4.0-sharepath.patch
Patch4: iproute2-3.9.0-IPPROTO_IP_for_SA.patch
Patch5: iproute2-example-cbq-service.patch
Patch6: iproute2-2.6.35-print-route.patch
Patch7: iproute2-2.6.39-create-peer-veth-without-a-name.patch
Patch8: iproute2-2.6.39-lnstat-dump-to-stdout.patch
Patch9: iproute2-3.8.0-unused-result.patch
Patch3: iproute2-3.9.0-IPPROTO_IP_for_SA.patch
Patch4: iproute2-example-cbq-service.patch
Patch5: iproute2-2.6.35-print-route.patch
Patch6: iproute2-2.6.39-create-peer-veth-without-a-name.patch
Patch7: iproute2-2.6.39-lnstat-dump-to-stdout.patch
Patch8: iproute2-3.8.0-unused-result.patch
Patch9: iproute2-3.9.0-xfrm-state-overflow.patch
License: GPLv2+ and Public Domain
BuildRequires: bison
BuildRequires: flex
@ -66,13 +66,14 @@ The libnetlink static library.
sed -i "s/_VERSION_/%{version}/" man/man8/ss.8
%patch1 -p1 -b .kernel
%patch2 -p1 -b .opt_flags
%patch3 -p1 -b .share
%patch4 -p1 -b .ipproto
%patch5 -p1 -b .fix_cbq
%patch6 -p1 -b .print-route
%patch7 -p1 -b .peer-veth-without-name
%patch8 -p1 -b .lnstat-dump-to-stdout
%patch9 -p1 -b .unused-result
%patch3 -p1 -b .ipproto
%patch4 -p1 -b .fix_cbq
%patch5 -p1 -b .print-route
%patch6 -p1 -b .peer-veth-without-name
%patch7 -p1 -b .lnstat-dump-to-stdout
%patch8 -p1 -b .unused-result
%patch9 -p1 -b .xfrm-state
sed -i 's/^LIBDIR=/LIBDIR?=/' Makefile
%build
export LIBDIR=/%{_libdir}
@ -88,7 +89,6 @@ mkdir -p \
%{buildroot}%{_mandir}/man3 \
%{buildroot}%{_mandir}/man7 \
%{buildroot}%{_mandir}/man8 \
%{buildroot}%{_datadir}/tc \
%{buildroot}%{_libdir}/tc \
%{buildroot}%{_sysconfdir}/iproute2 \
%{buildroot}%{_sysconfdir}/sysconfig/cbq
@ -119,6 +119,7 @@ cd %{buildroot}%{_sbindir}
cd -
# Libs
install -m644 netem/*.dist %{buildroot}%{_libdir}/tc
%if 0%{?fedora}
install -m755 tc/q_atm.so %{buildroot}%{_libdir}/tc
%endif
@ -138,14 +139,6 @@ install -m644 man/man3/*.3 %{buildroot}%{_mandir}/man3
install -m644 man/man7/*.7 %{buildroot}%{_mandir}/man7
install -m644 man/man8/*.8 %{buildroot}%{_mandir}/man8
# Share files
for shared in \
netem/normal.dist \
netem/pareto.dist \
netem/paretonormal.dist
do install -m644 ${shared} %{buildroot}%{_datadir}/tc
done
# Config files
install -m644 etc/iproute2/* %{buildroot}%{_sysconfdir}/iproute2
for config in \
@ -162,8 +155,6 @@ done
%{_mandir}/man8/*
%attr(644,root,root) %config(noreplace) %{_sysconfdir}/iproute2/*
%{_sbindir}/*
%dir %{_datadir}/tc
%{_datadir}/tc/*
%dir %{_libdir}/tc/
%{_libdir}/tc/*
%dir %{_sysconfdir}/sysconfig/cbq
@ -181,6 +172,11 @@ done
%{_includedir}/libnetlink.h
%changelog
* Wed Jul 17 2013 Petr Šabata <contyk@redhat.com> - 3.10.0-1
- 3.10.0 bump
- Drop the SHAREDIR patch and revert to upstream ways (#966445)
- Fix an XFRM regression with FORTIFY_SOURCE
* Tue Apr 30 2013 Petr Šabata <contyk@redhat.com> - 3.9.0-1
- 3.9.0 bump

View File

@ -1,21 +0,0 @@
diff -up iproute2-2.6.29/iproute2-2.6.29/ip/xfrm_state.c.seg iproute2-2.6.29/iproute2-2.6.29/ip/xfrm_state.c
--- iproute2-2.6.29/ip/xfrm_state.c.seg 2008-07-21 17:23:12.000000000 +0200
+++ iproute2-2.6.29/ip/xfrm_state.c 2008-07-22 09:27:12.000000000 +0200
@@ -158,12 +158,16 @@ static int xfrm_algo_parse(struct xfrm_a
buf[j] = val;
}
} else {
+ int i;
len = slen;
if (len > 0) {
if (len > max)
invarg("\"ALGOKEY\" makes buffer overflow\n", key);
- strncpy(buf, key, len);
+ for (i = 0 ; i < len && key[i] != '\0'; i++)
+ buf[i] = key[i];
+ for ( ; i < len; i++)
+ buf[i] = '\0';
}
}

View File

@ -1,12 +0,0 @@
diff -up iproute2-2.6.31/Makefile.old iproute2-2.6.31/Makefile
--- iproute2-2.6.31/Makefile.old 2010-01-04 12:46:47.000000000 +0100
+++ iproute2-2.6.31/Makefile 2010-01-04 12:50:17.396384644 +0100
@@ -13,7 +13,7 @@ DBM_INCLUDE:=$(ROOTDIR)/usr/include
SHARED_LIBS = y
-DEFINES= -DRESOLVE_HOSTNAMES -DLIBDIR=\"$(LIBDIR)\"
+DEFINES= -DRESOLVE_HOSTNAMES -DLIBDIR=\"$(LIBDIR)\" -DIPT_LIB_DIR=\"$(IPT_LIB_DIR)\"
ifneq ($(SHARED_LIBS),y)
DEFINES+= -DNO_SHARED_LIBS
endif

View File

@ -1,7 +1,3 @@
diff --git a/ip/.link_veth.c.swp b/ip/.link_veth.c.swp
deleted file mode 100644
index e3b5480..0000000
Binary files a/ip/.link_veth.c.swp and /dev/null differ
diff --git a/ip/link_veth.c b/ip/link_veth.c
index 3d19b01..eb0f41e 100644
--- a/ip/link_veth.c

View File

@ -1,24 +0,0 @@
diff --git a/tc/tc_util.c b/tc/tc_util.c
index 926ed08..33f6974 100644
--- a/tc/tc_util.c
+++ b/tc/tc_util.c
@@ -24,8 +24,8 @@
#include "utils.h"
#include "tc_util.h"
-#ifndef LIBDIR
-#define LIBDIR "/usr/lib"
+#ifndef SHAREDIR
+#define SHAREDIR "/usr/share"
#endif
const char *get_tc_lib(void)
@@ -34,7 +34,7 @@ const char *get_tc_lib(void)
lib_dir = getenv("TC_LIB_DIR");
if (!lib_dir)
- lib_dir = LIBDIR "/tc/";
+ lib_dir = SHAREDIR "/tc/";
return lib_dir;
}

View File

@ -0,0 +1,38 @@
From 9d0e33ed670f222208a0fc09b367b8adc3a3a9c5 Mon Sep 17 00:00:00 2001
From: =?UTF-8?q?Petr=20=C5=A0abata?= <contyk@redhat.com>
Date: Thu, 11 Jul 2013 17:09:07 +0200
Subject: [PATCH] Avoid overflow segfault with FORTIFY_SOURCE
MIME-Version: 1.0
Content-Type: text/plain; charset=UTF-8
Content-Transfer-Encoding: 8bit
Signed-off-by: Petr Šabata <contyk@redhat.com>
---
ip/xfrm_state.c | 5 +++++
1 file changed, 5 insertions(+)
diff --git a/ip/xfrm_state.c b/ip/xfrm_state.c
index 61a8f02..b3780c5 100644
--- a/ip/xfrm_state.c
+++ b/ip/xfrm_state.c
@@ -155,12 +155,17 @@ static int xfrm_algo_parse(struct xfrm_algo *alg, enum xfrm_attr_type_t type,
buf[j] = val;
}
} else {
+ int i;
len = slen;
if (len > 0) {
if (len > max)
invarg("ALGO-KEYMAT value makes buffer overflow\n", key);
strncpy(buf, key, len);
+ for (i = 0 ; i < len && key[i] != '\0'; i++)
+ buf[i] = key[i];
+ for ( ; i < len; i++)
+ buf[i] = '\0';
}
}
--
1.8.3.1

View File

@ -1 +1 @@
4777718bde8796347d17497ad9033105 iproute2-3.9.0.tar.gz
0b15432159e222ba7f0451d1b59258e4 iproute2-3.10.0.tar.gz