3.9.0 bump
This commit is contained in:
parent
4f1b4def61
commit
a6699c9016
1
.gitignore
vendored
1
.gitignore
vendored
@ -13,3 +13,4 @@ iproute2-2.6.35.tar.bz2
|
||||
/iproute2-3.6.0.tar.gz
|
||||
/iproute2-3.7.0.tar.gz
|
||||
/iproute2-3.8.0.tar.gz
|
||||
/iproute2-3.9.0.tar.gz
|
||||
|
11
iproute.spec
11
iproute.spec
@ -1,8 +1,8 @@
|
||||
%global cbq_version v0.7.3
|
||||
Summary: Advanced IP routing and network device configuration tools
|
||||
Name: iproute
|
||||
Version: 3.8.0
|
||||
Release: 4%{?dist}
|
||||
Version: 3.9.0
|
||||
Release: 1%{?dist}
|
||||
Group: Applications/System
|
||||
URL: http://kernel.org/pub/linux/utils/net/%{name}2/
|
||||
Source0: http://kernel.org/pub/linux/utils/net/%{name}2/%{name}2-%{version}.tar.gz
|
||||
@ -12,13 +12,12 @@ Patch0: man-pages.patch
|
||||
Patch1: iproute2-3.4.0-kernel.patch
|
||||
Patch2: iproute2-3.8.0-optflags.patch
|
||||
Patch3: iproute2-3.4.0-sharepath.patch
|
||||
Patch4: iproute2-2.6.29-IPPROTO_IP_for_SA.patch
|
||||
Patch4: iproute2-3.9.0-IPPROTO_IP_for_SA.patch
|
||||
Patch5: iproute2-example-cbq-service.patch
|
||||
Patch6: iproute2-2.6.35-print-route.patch
|
||||
Patch7: iproute2-2.6.39-create-peer-veth-without-a-name.patch
|
||||
Patch8: iproute2-2.6.39-lnstat-dump-to-stdout.patch
|
||||
Patch9: iproute2-3.8.0-unused-result.patch
|
||||
Patch10: iproute2-3.8.0-up.patch
|
||||
License: GPLv2+ and Public Domain
|
||||
BuildRequires: bison
|
||||
BuildRequires: flex
|
||||
@ -74,7 +73,6 @@ sed -i "s/_VERSION_/%{version}/" man/man8/ss.8
|
||||
%patch7 -p1 -b .peer-veth-without-name
|
||||
%patch8 -p1 -b .lnstat-dump-to-stdout
|
||||
%patch9 -p1 -b .unused-result
|
||||
%patch10 -p1 -b .up
|
||||
|
||||
%build
|
||||
export LIBDIR=/%{_libdir}
|
||||
@ -183,6 +181,9 @@ done
|
||||
%{_includedir}/libnetlink.h
|
||||
|
||||
%changelog
|
||||
* Tue Apr 30 2013 Petr Šabata <contyk@redhat.com> - 3.9.0-1
|
||||
- 3.9.0 bump
|
||||
|
||||
* Thu Apr 25 2013 Petr Šabata <contyk@redhat.com> - 3.8.0-4
|
||||
- ATM is available in Fedora only
|
||||
|
||||
|
@ -1,11 +0,0 @@
|
||||
diff -up iproute2-2.6.29/ip/ipxfrm.c.old iproute2-2.6.29/ip/ipxfrm.c
|
||||
--- iproute2-2.6.29/ip/ipxfrm.c.old 2009-03-24 23:15:14.000000000 +0100
|
||||
+++ iproute2-2.6.29/ip/ipxfrm.c 2009-04-24 09:35:58.203735119 +0200
|
||||
@@ -1156,6 +1156,7 @@ static int xfrm_selector_upspec_parse(st
|
||||
case IPPROTO_UDP:
|
||||
case IPPROTO_SCTP:
|
||||
case IPPROTO_DCCP:
|
||||
+ case IPPROTO_IP: /* to allow shared SA for different protocols */
|
||||
break;
|
||||
default:
|
||||
fprintf(stderr, "\"sport\" and \"dport\" are invalid with proto=%s\n", strxf_proto(sel->proto));
|
@ -1,41 +0,0 @@
|
||||
diff --git a/ip/ipaddress.c b/ip/ipaddress.c
|
||||
index cff503f..54c394b 100644
|
||||
--- a/ip/ipaddress.c
|
||||
+++ b/ip/ipaddress.c
|
||||
@@ -71,7 +71,7 @@ static void usage(void)
|
||||
fprintf(stderr, " [ CONFFLAG-LIST ]\n");
|
||||
fprintf(stderr, " ip addr del IFADDR dev STRING\n");
|
||||
fprintf(stderr, " ip addr {show|save|flush} [ dev STRING ] [ scope SCOPE-ID ]\n");
|
||||
- fprintf(stderr, " [ to PREFIX ] [ FLAG-LIST ] [ label PATTERN ]\n");
|
||||
+ fprintf(stderr, " [ to PREFIX ] [ FLAG-LIST ] [ label PATTERN ] [up]\n");
|
||||
fprintf(stderr, " ip addr {showdump|restore}\n");
|
||||
fprintf(stderr, "IFADDR := PREFIX | ADDR peer PREFIX\n");
|
||||
fprintf(stderr, " [ broadcast ADDR ] [ anycast ADDR ]\n");
|
||||
diff --git a/ip/iplink.c b/ip/iplink.c
|
||||
index ad33611..5c7b43c 100644
|
||||
--- a/ip/iplink.c
|
||||
+++ b/ip/iplink.c
|
||||
@@ -79,7 +79,7 @@ void iplink_usage(void)
|
||||
fprintf(stderr, " [ spoofchk { on | off} ] ] \n");
|
||||
fprintf(stderr, " [ master DEVICE ]\n");
|
||||
fprintf(stderr, " [ nomaster ]\n");
|
||||
- fprintf(stderr, " ip link show [ DEVICE | group GROUP ]\n");
|
||||
+ fprintf(stderr, " ip link show [ DEVICE | group GROUP ] [up]\n");
|
||||
|
||||
if (iplink_have_newlink()) {
|
||||
fprintf(stderr, "\n");
|
||||
diff --git a/man/man8/ip-address.8.in b/man/man8/ip-address.8.in
|
||||
index 63bf9cb..b9c996d 100644
|
||||
--- a/man/man8/ip-address.8.in
|
||||
+++ b/man/man8/ip-address.8.in
|
||||
@@ -163,6 +163,10 @@ only list addresses with labels matching the
|
||||
is a usual shell style pattern.
|
||||
|
||||
.TP
|
||||
+.B up
|
||||
+only display running interfaces.
|
||||
+
|
||||
+.TP
|
||||
.BR dynamic " and " permanent
|
||||
(IPv6 only) only list addresses installed due to stateless
|
||||
address configuration or only list permanent (not dynamic)
|
12
iproute2-3.9.0-IPPROTO_IP_for_SA.patch
Normal file
12
iproute2-3.9.0-IPPROTO_IP_for_SA.patch
Normal file
@ -0,0 +1,12 @@
|
||||
diff --git a/ip/ipxfrm.c b/ip/ipxfrm.c
|
||||
index 0495ff4..b1d4c6e 100644
|
||||
--- a/ip/ipxfrm.c
|
||||
+++ b/ip/ipxfrm.c
|
||||
@@ -1275,6 +1275,7 @@ static int xfrm_selector_upspec_parse(struct xfrm_selector *sel,
|
||||
case IPPROTO_UDP:
|
||||
case IPPROTO_SCTP:
|
||||
case IPPROTO_DCCP:
|
||||
+ case IPPROTO_IP: /* to allow shared SA for different protocols */
|
||||
break;
|
||||
default:
|
||||
fprintf(stderr, "\"sport\" and \"dport\" are invalid with PROTO value \"%s\"\n", strxf_proto(sel->proto));
|
Loading…
Reference in New Issue
Block a user