- new iptables (xtables) bring problems to tc, when ipt is used.

rhbz#497344 still broken. tc_modules.patch brings correct paths to
    xtables, but that doesn't fix whole issue.
- 497355 ip should allow creation of an IPsec SA with 'proto any' and
    specified sport and dport as selectors
This commit is contained in:
Marcela Mašláňová 2009-04-24 07:49:30 +00:00
parent 55e4f70cc1
commit a0a99ccd80
11 changed files with 71 additions and 24 deletions

View File

@ -1,6 +1,6 @@
diff -up iproute2-2.6.29/iproute2-2.6.29/man/man8/ip.8.mm iproute2-2.6.29/iproute2-2.6.29/man/man8/ip.8
--- iproute2-2.6.29/iproute2-2.6.29/man/man8/ip.8.mm 2008-07-25 22:46:07.000000000 +0200
+++ iproute2-2.6.29/iproute2-2.6.29/man/man8/ip.8 2008-08-12 14:24:01.000000000 +0200
--- iproute2-2.6.29/man/man8/ip.8.mm 2008-07-25 22:46:07.000000000 +0200
+++ iproute2-2.6.29/man/man8/ip.8 2008-08-12 14:24:01.000000000 +0200
@@ -190,6 +190,8 @@ replace " | " monitor " } "
.IR NUMBER " ] [ "
.B cwnd

View File

@ -4,7 +4,7 @@
Summary: Advanced IP routing and network device configuration tools
Name: iproute
Version: 2.6.29
Release: 2%{?dist}
Release: 3%{?dist}
Group: Applications/System
Source: http://developer.osdl.org/dev/iproute2/download/iproute2-%{version}.tar.bz2
#Source1: iproute-doc-2.6.22.tar.gz
@ -17,19 +17,31 @@ Patch5: iproute2-sharepath.patch
Patch6: iproute2-2.6.29-fix_headers_for_gre.patch
Patch7: iproute2-missing-arpd-directory.patch
Patch8: iproute2-display_ip4ip6tunnels.patch
Patch9: iproute2-2.6.29-tc_modules.patch
Patch10: iproute2-2.6.29-IPPROTO_IP_for_SA.patch
License: GPLv2+
BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
BuildRequires: tetex-latex tetex-dvips linuxdoc-tools
BuildRequires: flex linux-atm-libs-devel psutils db4-devel bison
# introduction new iptables (xtables) which broke ipt
Requires: iptables >= 1.4.1
%description
The iproute package contains networking utilities (ip and rtmon, for
example) which are designed to use the advanced networking
capabilities of the Linux 2.4.x and 2.6.x kernel.
%package doc
Summary: ip and tc documentation with examples
Group: Applications/System
License: GPLv2+
%description doc
The iproute documentation contains howtos and examples of settings.
%prep
%setup -q -c iproute-%{version}
%setup -q -n iproute2-%{version}
%patch1 -p1 -b .kernel
%patch2 -p1 -b .opt_flags
%patch3 -p1
@ -38,11 +50,13 @@ capabilities of the Linux 2.4.x and 2.6.x kernel.
%patch6 -p1 -b .hdrs
%patch7 -p1 -b .arpd
%patch8 -p1 -b .ip4ip6
%patch9 -p1 -b .ipt
%patch10 -p1 -b .ipproto
%build
export LIBDIR=%{_libdir}
export LIBDIR=/%{_libdir}
export IPT_LIB_DIR=/%{_lib}/xtables
cd iproute2-%{version}
make %{?_smp_mflags}
make -C doc
@ -56,7 +70,6 @@ mkdir -p $RPM_BUILD_ROOT/sbin \
$RPM_BUILD_ROOT%{_datadir}/tc \
$RPM_BUILD_ROOT%{_libdir}/tc
cd iproute2-%{version}
install -m 755 ip/ip ip/ifcfg ip/rtmon tc/tc $RPM_BUILD_ROOT/sbin
install -m 755 misc/ss misc/nstat misc/rtacct misc/lnstat misc/arpd $RPM_BUILD_ROOT%{_sbindir}
#netem is static
@ -98,9 +111,7 @@ EOF
%files
%defattr(-,root,root,-)
%dir %{_sysconfdir}/iproute2
%doc iproute2-%{version}/README.decnet iproute2-%{version}/README.iproute2+tc iproute2-%{version}/RELNOTES iproute2-%{version}/examples/README.cbq
%doc iproute2-%{version}/doc/*.ps
%doc iproute2-%{version}/examples
%doc README README.decnet README.iproute2+tc README.distribution README.lnstat
/sbin/*
%{_mandir}/man8/*
%attr(644,root,root) %config(noreplace) %{_sysconfdir}/iproute2/*
@ -112,7 +123,20 @@ EOF
%dir %{_sysconfdir}/sysconfig/cbq
%config(noreplace) %{_sysconfdir}/sysconfig/cbq/*
%files doc
%defattr(-,root,root,-)
%doc doc/*.ps
%doc examples
%doc RELNOTES
%changelog
* Thu Apr 23 2009 Marcela Mašláňová <mmaslano@redhat.com> - 2.6.29-3
- new iptables (xtables) bring problems to tc, when ipt is used.
rhbz#497344 still broken. tc_modules.patch brings correct paths to
xtables, but that doesn't fix whole issue.
- 497355 ip should allow creation of an IPsec SA with 'proto any'
and specified sport and dport as selectors
* Tue Apr 14 2009 Marcela Mašláňová <mmaslano@redhat.com> - 2.6.29-2
- c3651bf4763d7247e3edd4e20526a85de459041b ip6tunnel: Fix no default
display of ip4ip6 tunnels

View File

@ -1,6 +1,6 @@
diff -up iproute2-2.6.29/iproute2-2.6.29/ip/xfrm_state.c.seg iproute2-2.6.29/iproute2-2.6.29/ip/xfrm_state.c
--- iproute2-2.6.29/iproute2-2.6.29/ip/xfrm_state.c.seg 2008-07-21 17:23:12.000000000 +0200
+++ iproute2-2.6.29/iproute2-2.6.29/ip/xfrm_state.c 2008-07-22 09:27:12.000000000 +0200
--- iproute2-2.6.29/ip/xfrm_state.c.seg 2008-07-21 17:23:12.000000000 +0200
+++ iproute2-2.6.29/ip/xfrm_state.c 2008-07-22 09:27:12.000000000 +0200
@@ -158,12 +158,16 @@ static int xfrm_algo_parse(struct xfrm_a
buf[j] = val;
}

View File

@ -0,0 +1,11 @@
diff -up iproute2-2.6.29/ip/ipxfrm.c.old iproute2-2.6.29/ip/ipxfrm.c
--- iproute2-2.6.29/ip/ipxfrm.c.old 2009-03-24 23:15:14.000000000 +0100
+++ iproute2-2.6.29/ip/ipxfrm.c 2009-04-24 09:35:58.203735119 +0200
@@ -1156,6 +1156,7 @@ static int xfrm_selector_upspec_parse(st
case IPPROTO_UDP:
case IPPROTO_SCTP:
case IPPROTO_DCCP:
+ case IPPROTO_IP: /* to allow shared SA for different protocols */
break;
default:
fprintf(stderr, "\"sport\" and \"dport\" are invalid with proto=%s\n", strxf_proto(sel->proto));

View File

@ -10,8 +10,8 @@ Need to get right headers or build breaks.
diff --git a/ip/link_gre.c b/ip/link_gre.c
index 9109312..9f8bde6 100644
--- iproute-2.6.29/iproute2-2.6.29/ip/link_gre.c.old
+++ iproute-2.6.29/iproute2-2.6.29/ip/link_gre.c
--- iproute2-2.6.29/ip/link_gre.c.old
+++ iproute2-2.6.29/ip/link_gre.c
@@ -12,11 +12,12 @@
#include <string.h>

View File

@ -0,0 +1,12 @@
diff -up iproute2-2.6.29/Makefile.ipt iproute2-2.6.29/Makefile
--- iproute2-2.6.29/Makefile.ipt 2009-04-23 15:19:19.000000000 +0200
+++ iproute2-2.6.29/Makefile 2009-04-23 15:27:19.802477954 +0200
@@ -10,7 +10,7 @@ ARPDDIR=/var/lib/arpd
# Path to db_185.h include
DBM_INCLUDE:=/usr/include
-DEFINES= -DRESOLVE_HOSTNAMES -DLIBDIR=\"$(LIBDIR)\"
+DEFINES= -DRESOLVE_HOSTNAMES -DLIBDIR=\"$(LIBDIR)\" -DIPT_LIB_DIR=\"$(IPT_LIB_DIR)\"
#options if you have a bind>=4.9.4 libresolv (or, maybe, glibc)
LDLIBS=-lresolv

View File

@ -1,6 +1,6 @@
diff -up iproute2-2.6.29/iproute2-2.6.29/Makefile.kernel iproute2-2.6.29/iproute2-2.6.29/Makefile
--- iproute2-2.6.29/iproute2-2.6.29/Makefile.kernel 2008-07-25 22:46:07.000000000 +0200
+++ iproute2-2.6.29/iproute2-2.6.29/Makefile 2008-08-12 14:19:58.000000000 +0200
--- iproute2-2.6.29/Makefile.kernel 2008-07-25 22:46:07.000000000 +0200
+++ iproute2-2.6.29/Makefile 2008-08-12 14:19:58.000000000 +0200
@@ -3,6 +3,7 @@ SBINDIR=/sbin
CONFDIR=/etc/iproute2
DOCDIR=/share/doc/iproute2

View File

@ -13,8 +13,8 @@ This is because the default tunnel proto is initialized to IPPROTO_IPV6 in ip6_t
diff --git a/ip/ip6tunnel.c b/ip/ip6tunnel.c
index 8421983..8852a67 100644
--- iproute2-2.6.29/iproute2-2.6.29/ip/ip6tunnel.c.old
+++ iproute2-2.6.29/iproute2-2.6.29/ip/ip6tunnel.c
--- iproute2-2.6.29/ip/ip6tunnel.c.old
+++ iproute2-2.6.29/ip/ip6tunnel.c
@@ -335,6 +335,7 @@ static int do_show(int argc, char **argv)
struct ip6_tnl_parm p;

View File

@ -10,8 +10,8 @@ see attached patch, which lets iproute create this directroy during install.
1 files changed, 2 insertions(+), 0 deletions(-)
diff -up iproute-2.6.29/iproute2-2.6.29/Makefile.arpd iproute-2.6.29/iproute2-2.6.29/Makefile
--- iproute-2.6.29/iproute2-2.6.29/Makefile.arpd 2009-04-14 12:57:23.743114366 +0200
+++ iproute-2.6.29/iproute2-2.6.29/Makefile 2009-04-14 12:58:38.754111501 +0200
--- iproute2-2.6.29/Makefile.arpd 2009-04-14 12:57:23.743114366 +0200
+++ iproute2-2.6.29/Makefile 2009-04-14 12:58:38.754111501 +0200
@@ -5,6 +5,7 @@ CONFDIR=/etc/iproute2
DOCDIR=/share/doc/iproute2
MANDIR=/share/man

View File

@ -1,6 +1,6 @@
diff -up iproute-2.6.29/iproute2-2.6.29/tc/tc_util.c.movelib iproute-2.6.29/iproute2-2.6.29/tc/tc_util.c
--- iproute-2.6.29/iproute2-2.6.29/tc/tc_util.c.movelib 2009-01-15 21:25:04.000000000 +0100
+++ iproute-2.6.29/iproute2-2.6.29/tc/tc_util.c 2009-02-04 08:58:36.000000000 +0100
--- iproute2-2.6.29/tc/tc_util.c.movelib 2009-01-15 21:25:04.000000000 +0100
+++ iproute2-2.6.29/tc/tc_util.c 2009-02-04 08:58:36.000000000 +0100
@@ -24,8 +24,8 @@
#include "utils.h"
#include "tc_util.h"

View File

@ -1,6 +1,6 @@
diff -up iproute2-2.6.29/iproute2-2.6.29/Makefile.opt iproute2-2.6.29/iproute2-2.6.29/Makefile
--- iproute2-2.6.29/iproute2-2.6.29/Makefile.opt 2008-08-12 14:19:58.000000000 +0200
+++ iproute2-2.6.29/iproute2-2.6.29/Makefile 2008-08-12 14:21:42.000000000 +0200
--- iproute2-2.6.29/Makefile.opt 2008-08-12 14:19:58.000000000 +0200
+++ iproute2-2.6.29/Makefile 2008-08-12 14:21:42.000000000 +0200
@@ -22,7 +22,7 @@ ADDLIB+=ipx_ntop.o ipx_pton.o
CC = gcc