- c3651bf4763d7247e3edd4e20526a85de459041b ip6tunnel: Fix no default
display of ip4ip6 tunnels - e48f73d6a5e90d2f883e15ccedf4f53d26bb6e74 missing arpd directory
This commit is contained in:
parent
4f568ae584
commit
55e4f70cc1
11
iproute.spec
11
iproute.spec
@ -4,7 +4,7 @@
|
||||
Summary: Advanced IP routing and network device configuration tools
|
||||
Name: iproute
|
||||
Version: 2.6.29
|
||||
Release: 1%{?dist}
|
||||
Release: 2%{?dist}
|
||||
Group: Applications/System
|
||||
Source: http://developer.osdl.org/dev/iproute2/download/iproute2-%{version}.tar.bz2
|
||||
#Source1: iproute-doc-2.6.22.tar.gz
|
||||
@ -15,6 +15,8 @@ Patch3: iproute-ip-man.patch
|
||||
Patch4: iproute2-2.6.25-segfault.patch
|
||||
Patch5: iproute2-sharepath.patch
|
||||
Patch6: iproute2-2.6.29-fix_headers_for_gre.patch
|
||||
Patch7: iproute2-missing-arpd-directory.patch
|
||||
Patch8: iproute2-display_ip4ip6tunnels.patch
|
||||
|
||||
License: GPLv2+
|
||||
BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
|
||||
@ -34,6 +36,8 @@ capabilities of the Linux 2.4.x and 2.6.x kernel.
|
||||
%patch4 -p1 -b .seg
|
||||
%patch5 -p1 -b .share
|
||||
%patch6 -p1 -b .hdrs
|
||||
%patch7 -p1 -b .arpd
|
||||
%patch8 -p1 -b .ip4ip6
|
||||
|
||||
%build
|
||||
export LIBDIR=%{_libdir}
|
||||
@ -109,6 +113,11 @@ EOF
|
||||
%config(noreplace) %{_sysconfdir}/sysconfig/cbq/*
|
||||
|
||||
%changelog
|
||||
* Tue Apr 14 2009 Marcela Mašláňová <mmaslano@redhat.com> - 2.6.29-2
|
||||
- c3651bf4763d7247e3edd4e20526a85de459041b ip6tunnel: Fix no default
|
||||
display of ip4ip6 tunnels
|
||||
- e48f73d6a5e90d2f883e15ccedf4f53d26bb6e74 missing arpd directory
|
||||
|
||||
* Wed Mar 25 2009 Marcela Mašláňová <mmaslano@redhat.com> - 2.6.29-1
|
||||
- update to 2.6.29
|
||||
- remove DDR patch which became part of sourc
|
||||
|
28
iproute2-display_ip4ip6tunnels.patch
Normal file
28
iproute2-display_ip4ip6tunnels.patch
Normal file
@ -0,0 +1,28 @@
|
||||
From c3651bf4763d7247e3edd4e20526a85de459041b Mon Sep 17 00:00:00 2001
|
||||
From: Srivats P <srivats.p@conexant.com>
|
||||
Date: Fri, 27 Mar 2009 11:17:26 -0700
|
||||
Subject: [PATCH] ip6tunnel: Fix no default display of ip4ip6 tunnels
|
||||
|
||||
"ip -6 tunnel show" displays only ip6ip6 tunnels not ip4ip6 tunnels
|
||||
- it should display all irrespective of proto.
|
||||
|
||||
This is because the default tunnel proto is initialized to IPPROTO_IPV6 in ip6_tnl_parm_init() which is fine for a 'add' command but not for 'show'. This patch overrides proto with 0 signifying 'mode any' as the default in case of a 'show'.
|
||||
---
|
||||
ip/ip6tunnel.c | 1 +
|
||||
1 files changed, 1 insertions(+), 0 deletions(-)
|
||||
|
||||
diff --git a/ip/ip6tunnel.c b/ip/ip6tunnel.c
|
||||
index 8421983..8852a67 100644
|
||||
--- iproute2-2.6.29/iproute2-2.6.29/ip/ip6tunnel.c.old
|
||||
+++ iproute2-2.6.29/iproute2-2.6.29/ip/ip6tunnel.c
|
||||
@@ -335,6 +335,7 @@ static int do_show(int argc, char **argv)
|
||||
struct ip6_tnl_parm p;
|
||||
|
||||
ip6_tnl_parm_init(&p, 0);
|
||||
+ p.proto = 0; /* default to any */
|
||||
|
||||
if (parse_args(argc, argv, &p) < 0)
|
||||
return -1;
|
||||
--
|
||||
1.6.2.2
|
||||
|
30
iproute2-missing-arpd-directory.patch
Normal file
30
iproute2-missing-arpd-directory.patch
Normal file
@ -0,0 +1,30 @@
|
||||
From e48f73d6a5e90d2f883e15ccedf4f53d26bb6e74 Mon Sep 17 00:00:00 2001
|
||||
From: Olaf Rempel <razzor@kopf-tisch.de>
|
||||
Date: Wed, 9 Nov 2005 15:25:40 +0100
|
||||
Subject: [PATCH] iproute2-2.6.14-051107: missing arpd directory
|
||||
|
||||
arpd requires a directory (/var/lib/arpd/) to run.
|
||||
see attached patch, which lets iproute create this directroy during install.
|
||||
---
|
||||
Makefile | 2 ++
|
||||
1 files changed, 2 insertions(+), 0 deletions(-)
|
||||
|
||||
diff -up iproute-2.6.29/iproute2-2.6.29/Makefile.arpd iproute-2.6.29/iproute2-2.6.29/Makefile
|
||||
--- iproute-2.6.29/iproute2-2.6.29/Makefile.arpd 2009-04-14 12:57:23.743114366 +0200
|
||||
+++ iproute-2.6.29/iproute2-2.6.29/Makefile 2009-04-14 12:58:38.754111501 +0200
|
||||
@@ -5,6 +5,7 @@ CONFDIR=/etc/iproute2
|
||||
DOCDIR=/share/doc/iproute2
|
||||
MANDIR=/share/man
|
||||
KERNEL_INCLUDE=/usr/include
|
||||
+ARPDDIR=/var/lib/arpd
|
||||
|
||||
# Path to db_185.h include
|
||||
DBM_INCLUDE:=/usr/include
|
||||
@@ -44,6 +45,7 @@ Config:
|
||||
install: all
|
||||
install -m 0755 -d $(DESTDIR)$(SBINDIR)
|
||||
install -m 0755 -d $(DESTDIR)$(CONFDIR)
|
||||
+ install -m 0755 -d $(DESTDIR)$(ARPDDIR)
|
||||
install -m 0755 -d $(DESTDIR)$(DOCDIR)/examples
|
||||
install -m 0755 -d $(DESTDIR)$(DOCDIR)/examples/diffserv
|
||||
install -m 0644 README.iproute2+tc $(shell find examples -maxdepth 1 -type f) \
|
Loading…
Reference in New Issue
Block a user