- update to 2.6.29
- remove DDR patch which became part of sourc - add patch with correct headers 1957a322c9932e1a1d2ca1fd37ce4b335ceb7113
This commit is contained in:
parent
4574a42a19
commit
4f568ae584
@ -1 +1 @@
|
||||
iproute2-2.6.28.tar.bz2
|
||||
iproute2-2.6.29.tar.bz2
|
||||
|
@ -1,6 +1,6 @@
|
||||
diff -up iproute2-2.6.28/iproute2-2.6.28/man/man8/ip.8.mm iproute2-2.6.28/iproute2-2.6.28/man/man8/ip.8
|
||||
--- iproute2-2.6.28/iproute2-2.6.28/man/man8/ip.8.mm 2008-07-25 22:46:07.000000000 +0200
|
||||
+++ iproute2-2.6.28/iproute2-2.6.28/man/man8/ip.8 2008-08-12 14:24:01.000000000 +0200
|
||||
diff -up iproute2-2.6.29/iproute2-2.6.29/man/man8/ip.8.mm iproute2-2.6.29/iproute2-2.6.29/man/man8/ip.8
|
||||
--- iproute2-2.6.29/iproute2-2.6.29/man/man8/ip.8.mm 2008-07-25 22:46:07.000000000 +0200
|
||||
+++ iproute2-2.6.29/iproute2-2.6.29/man/man8/ip.8 2008-08-12 14:24:01.000000000 +0200
|
||||
@@ -190,6 +190,8 @@ replace " | " monitor " } "
|
||||
.IR NUMBER " ] [ "
|
||||
.B cwnd
|
||||
|
13
iproute.spec
13
iproute.spec
@ -3,8 +3,8 @@
|
||||
|
||||
Summary: Advanced IP routing and network device configuration tools
|
||||
Name: iproute
|
||||
Version: 2.6.28
|
||||
Release: 3%{?dist}
|
||||
Version: 2.6.29
|
||||
Release: 1%{?dist}
|
||||
Group: Applications/System
|
||||
Source: http://developer.osdl.org/dev/iproute2/download/iproute2-%{version}.tar.bz2
|
||||
#Source1: iproute-doc-2.6.22.tar.gz
|
||||
@ -14,7 +14,7 @@ Patch2: iproute2-ss050901-opt_flags.patch
|
||||
Patch3: iproute-ip-man.patch
|
||||
Patch4: iproute2-2.6.25-segfault.patch
|
||||
Patch5: iproute2-sharepath.patch
|
||||
Patch6: iproute2-ddr_support.patch
|
||||
Patch6: iproute2-2.6.29-fix_headers_for_gre.patch
|
||||
|
||||
License: GPLv2+
|
||||
BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
|
||||
@ -33,7 +33,7 @@ capabilities of the Linux 2.4.x and 2.6.x kernel.
|
||||
%patch3 -p1
|
||||
%patch4 -p1 -b .seg
|
||||
%patch5 -p1 -b .share
|
||||
%patch6 -p1 -b .ddr
|
||||
%patch6 -p1 -b .hdrs
|
||||
|
||||
%build
|
||||
export LIBDIR=%{_libdir}
|
||||
@ -109,6 +109,11 @@ EOF
|
||||
%config(noreplace) %{_sysconfdir}/sysconfig/cbq/*
|
||||
|
||||
%changelog
|
||||
* Wed Mar 25 2009 Marcela Mašláňová <mmaslano@redhat.com> - 2.6.29-1
|
||||
- update to 2.6.29
|
||||
- remove DDR patch which became part of sourc
|
||||
- add patch with correct headers 1957a322c9932e1a1d2ca1fd37ce4b335ceb7113
|
||||
|
||||
* Wed Feb 25 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 2.6.28-3
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_11_Mass_Rebuild
|
||||
|
||||
|
@ -1,6 +1,6 @@
|
||||
diff -up iproute2-2.6.28/iproute2-2.6.28/ip/xfrm_state.c.seg iproute2-2.6.28/iproute2-2.6.28/ip/xfrm_state.c
|
||||
--- iproute2-2.6.28/iproute2-2.6.28/ip/xfrm_state.c.seg 2008-07-21 17:23:12.000000000 +0200
|
||||
+++ iproute2-2.6.28/iproute2-2.6.28/ip/xfrm_state.c 2008-07-22 09:27:12.000000000 +0200
|
||||
diff -up iproute2-2.6.29/iproute2-2.6.29/ip/xfrm_state.c.seg iproute2-2.6.29/iproute2-2.6.29/ip/xfrm_state.c
|
||||
--- iproute2-2.6.29/iproute2-2.6.29/ip/xfrm_state.c.seg 2008-07-21 17:23:12.000000000 +0200
|
||||
+++ iproute2-2.6.29/iproute2-2.6.29/ip/xfrm_state.c 2008-07-22 09:27:12.000000000 +0200
|
||||
@@ -158,12 +158,16 @@ static int xfrm_algo_parse(struct xfrm_a
|
||||
buf[j] = val;
|
||||
}
|
||||
|
31
iproute2-2.6.29-fix_headers_for_gre.patch
Normal file
31
iproute2-2.6.29-fix_headers_for_gre.patch
Normal file
@ -0,0 +1,31 @@
|
||||
From 1957a322c9932e1a1d2ca1fd37ce4b335ceb7113 Mon Sep 17 00:00:00 2001
|
||||
From: Stephen Hemminger <stephen.hemminger@vyatta.com>
|
||||
Date: Tue, 24 Mar 2009 15:40:54 -0700
|
||||
Subject: [PATCH] Fix headers needed for gre
|
||||
|
||||
Need to get right headers or build breaks.
|
||||
---
|
||||
ip/link_gre.c | 3 ++-
|
||||
1 files changed, 2 insertions(+), 1 deletions(-)
|
||||
|
||||
diff --git a/ip/link_gre.c b/ip/link_gre.c
|
||||
index 9109312..9f8bde6 100644
|
||||
--- iproute-2.6.29/iproute2-2.6.29/ip/link_gre.c.old
|
||||
+++ iproute-2.6.29/iproute2-2.6.29/ip/link_gre.c
|
||||
@@ -12,11 +12,12 @@
|
||||
|
||||
#include <string.h>
|
||||
#include <net/if.h>
|
||||
-#include <linux/if_tunnel.h>
|
||||
#include <sys/types.h>
|
||||
#include <sys/socket.h>
|
||||
#include <arpa/inet.h>
|
||||
|
||||
+#include <linux/ip.h>
|
||||
+#include <linux/if_tunnel.h>
|
||||
#include "rt_names.h"
|
||||
#include "utils.h"
|
||||
#include "ip_common.h"
|
||||
--
|
||||
1.6.0.6
|
||||
|
@ -1,6 +1,6 @@
|
||||
diff -up iproute2-2.6.28/iproute2-2.6.28/Makefile.kernel iproute2-2.6.28/iproute2-2.6.28/Makefile
|
||||
--- iproute2-2.6.28/iproute2-2.6.28/Makefile.kernel 2008-07-25 22:46:07.000000000 +0200
|
||||
+++ iproute2-2.6.28/iproute2-2.6.28/Makefile 2008-08-12 14:19:58.000000000 +0200
|
||||
diff -up iproute2-2.6.29/iproute2-2.6.29/Makefile.kernel iproute2-2.6.29/iproute2-2.6.29/Makefile
|
||||
--- iproute2-2.6.29/iproute2-2.6.29/Makefile.kernel 2008-07-25 22:46:07.000000000 +0200
|
||||
+++ iproute2-2.6.29/iproute2-2.6.29/Makefile 2008-08-12 14:19:58.000000000 +0200
|
||||
@@ -3,6 +3,7 @@ SBINDIR=/sbin
|
||||
CONFDIR=/etc/iproute2
|
||||
DOCDIR=/share/doc/iproute2
|
||||
|
@ -1,188 +0,0 @@
|
||||
From c86f34942a0ce9f8203c0c38f9fe9604f96be706 Mon Sep 17 00:00:00 2001
|
||||
From: Patrick McHardy <kaber@trash.net>
|
||||
Date: Wed, 19 Nov 2008 16:08:05 +0100
|
||||
Subject: [PATCH] iproute: add DRR support
|
||||
|
||||
add DRR support
|
||||
|
||||
This patch adds support for the DRR scheduler I just sent
|
||||
to iproute.
|
||||
|
||||
Signed-off-by: Patrick McHardy <kaber@trash.net>
|
||||
---
|
||||
include/linux/pkt_sched.h | 16 ++++++
|
||||
tc/Makefile | 1 +
|
||||
tc/q_drr.c | 124 +++++++++++++++++++++++++++++++++++++++++++++
|
||||
3 files changed, 141 insertions(+), 0 deletions(-)
|
||||
create mode 100644 tc/q_drr.c
|
||||
|
||||
diff --git a/include/linux/pkt_sched.h b/include/linux/pkt_sched.h
|
||||
index 5d921fa..8495053 100644
|
||||
--- iproute-2.6.28/iproute2-2.6.28/include/linux/pkt_sched.h.old
|
||||
+++ iproute-2.6.28/iproute2-2.6.28/include/linux/pkt_sched.h
|
||||
@@ -500,4 +500,20 @@ struct tc_netem_corrupt
|
||||
|
||||
#define NETEM_DIST_SCALE 8192
|
||||
|
||||
+/* DRR */
|
||||
+
|
||||
+enum
|
||||
+{
|
||||
+ TCA_DRR_UNSPEC,
|
||||
+ TCA_DRR_QUANTUM,
|
||||
+ __TCA_DRR_MAX
|
||||
+};
|
||||
+
|
||||
+#define TCA_DRR_MAX (__TCA_DRR_MAX - 1)
|
||||
+
|
||||
+struct tc_drr_stats
|
||||
+{
|
||||
+ __u32 deficit;
|
||||
+};
|
||||
+
|
||||
#endif
|
||||
diff --git a/tc/Makefile b/tc/Makefile
|
||||
index bd9b833..eb67ede 100644
|
||||
--- iproute-2.6.28/iproute2-2.6.28/tc/Makefile.old
|
||||
+++ iproute-2.6.28/iproute2-2.6.28/tc/Makefile
|
||||
@@ -26,6 +26,7 @@ TCMODULES += f_tcindex.o
|
||||
TCMODULES += q_ingress.o
|
||||
TCMODULES += q_hfsc.o
|
||||
TCMODULES += q_htb.o
|
||||
+TCMODULES += q_drr.o
|
||||
TCMODULES += m_gact.o
|
||||
TCMODULES += m_mirred.o
|
||||
TCMODULES += m_ipt.o
|
||||
diff --git a/tc/q_drr.c b/tc/q_drr.c
|
||||
new file mode 100644
|
||||
index 0000000..7d2d874
|
||||
--- /dev/null
|
||||
+++ iproute-2.6.28/iproute2-2.6.28/tc/q_drr.c
|
||||
@@ -0,0 +1,124 @@
|
||||
+/*
|
||||
+ * q_drr.c DRR.
|
||||
+ *
|
||||
+ * This program is free software; you can redistribute it and/or
|
||||
+ * modify it under the terms of the GNU General Public License
|
||||
+ * as published by the Free Software Foundation; either version
|
||||
+ * 2 of the License, or (at your option) any later version.
|
||||
+ *
|
||||
+ * Authors: Patrick McHardy <kaber@trash.net>
|
||||
+ *
|
||||
+ */
|
||||
+
|
||||
+#include <stdio.h>
|
||||
+#include <stdlib.h>
|
||||
+#include <unistd.h>
|
||||
+#include <syslog.h>
|
||||
+#include <fcntl.h>
|
||||
+#include <sys/socket.h>
|
||||
+#include <netinet/in.h>
|
||||
+#include <arpa/inet.h>
|
||||
+#include <string.h>
|
||||
+
|
||||
+#include "utils.h"
|
||||
+#include "tc_util.h"
|
||||
+
|
||||
+static void explain(void)
|
||||
+{
|
||||
+ fprintf(stderr, "Usage: ... drr\n");
|
||||
+}
|
||||
+
|
||||
+static void explain2(void)
|
||||
+{
|
||||
+ fprintf(stderr, "Usage: ... drr quantum SIZE\n");
|
||||
+}
|
||||
+
|
||||
+#define usage() return(-1)
|
||||
+
|
||||
+static int drr_parse_opt(struct qdisc_util *qu, int argc, char **argv, struct nlmsghdr *n)
|
||||
+{
|
||||
+ while (argc > 0) {
|
||||
+ if (strcmp(*argv, "help") == 0) {
|
||||
+ explain();
|
||||
+ return -1;
|
||||
+ } else {
|
||||
+ fprintf(stderr, "What is \"%s\"?\n", *argv);
|
||||
+ explain();
|
||||
+ return -1;
|
||||
+ }
|
||||
+ argc--; argv++;
|
||||
+ }
|
||||
+ return 0;
|
||||
+}
|
||||
+
|
||||
+static int drr_parse_class_opt(struct qdisc_util *qu, int argc, char **argv,
|
||||
+ struct nlmsghdr *n)
|
||||
+{
|
||||
+ struct rtattr *tail;
|
||||
+ __u32 tmp;
|
||||
+
|
||||
+ tail = NLMSG_TAIL(n);
|
||||
+ addattr_l(n, 1024, TCA_OPTIONS, NULL, 0);
|
||||
+
|
||||
+ while (argc > 0) {
|
||||
+ if (strcmp(*argv, "quantum") == 0) {
|
||||
+ NEXT_ARG();
|
||||
+ if (get_size(&tmp, *argv)) {
|
||||
+ fprintf(stderr, "Illegal \"quantum\"\n");
|
||||
+ return -1;
|
||||
+ }
|
||||
+ addattr_l(n, 1024, TCA_DRR_QUANTUM, &tmp, sizeof(tmp));
|
||||
+ } else if (strcmp(*argv, "help") == 0) {
|
||||
+ explain2();
|
||||
+ return -1;
|
||||
+ } else {
|
||||
+ fprintf(stderr, "What is \"%s\"?\n", *argv);
|
||||
+ explain2();
|
||||
+ return -1;
|
||||
+ }
|
||||
+ argc--; argv++;
|
||||
+ }
|
||||
+
|
||||
+ tail->rta_len = (void *) NLMSG_TAIL(n) - (void *)tail;
|
||||
+ return 0;
|
||||
+}
|
||||
+
|
||||
+static int drr_print_opt(struct qdisc_util *qu, FILE *f, struct rtattr *opt)
|
||||
+{
|
||||
+ struct rtattr *tb[TCA_DRR_MAX + 1];
|
||||
+ SPRINT_BUF(b1);
|
||||
+
|
||||
+ if (opt == NULL)
|
||||
+ return 0;
|
||||
+
|
||||
+ parse_rtattr_nested(tb, TCA_DRR_MAX, opt);
|
||||
+
|
||||
+ if (tb[TCA_DRR_QUANTUM])
|
||||
+ fprintf(f, "quantum %s ",
|
||||
+ sprint_size(*(__u32 *)RTA_DATA(tb[TCA_DRR_QUANTUM]), b1));
|
||||
+ return 0;
|
||||
+}
|
||||
+
|
||||
+static int drr_print_xstats(struct qdisc_util *qu, FILE *f, struct rtattr *xstats)
|
||||
+{
|
||||
+ struct tc_drr_stats *x;
|
||||
+ SPRINT_BUF(b1);
|
||||
+
|
||||
+ if (xstats == NULL)
|
||||
+ return 0;
|
||||
+ if (RTA_PAYLOAD(xstats) < sizeof(*x))
|
||||
+ return -1;
|
||||
+ x = RTA_DATA(xstats);
|
||||
+
|
||||
+ fprintf(f, " deficit %s ", sprint_size(x->deficit, b1));
|
||||
+ return 0;
|
||||
+}
|
||||
+
|
||||
+struct qdisc_util drr_qdisc_util = {
|
||||
+ .id = "drr",
|
||||
+ .parse_qopt = drr_parse_opt,
|
||||
+ .print_qopt = drr_print_opt,
|
||||
+ .print_xstats = drr_print_xstats,
|
||||
+ .parse_copt = drr_parse_class_opt,
|
||||
+ .print_copt = drr_print_opt,
|
||||
+};
|
||||
--
|
||||
1.6.0.6
|
||||
|
@ -1,6 +1,6 @@
|
||||
diff -up iproute-2.6.28/iproute2-2.6.28/tc/tc_util.c.movelib iproute-2.6.28/iproute2-2.6.28/tc/tc_util.c
|
||||
--- iproute-2.6.28/iproute2-2.6.28/tc/tc_util.c.movelib 2009-01-15 21:25:04.000000000 +0100
|
||||
+++ iproute-2.6.28/iproute2-2.6.28/tc/tc_util.c 2009-02-04 08:58:36.000000000 +0100
|
||||
diff -up iproute-2.6.29/iproute2-2.6.29/tc/tc_util.c.movelib iproute-2.6.29/iproute2-2.6.29/tc/tc_util.c
|
||||
--- iproute-2.6.29/iproute2-2.6.29/tc/tc_util.c.movelib 2009-01-15 21:25:04.000000000 +0100
|
||||
+++ iproute-2.6.29/iproute2-2.6.29/tc/tc_util.c 2009-02-04 08:58:36.000000000 +0100
|
||||
@@ -24,8 +24,8 @@
|
||||
#include "utils.h"
|
||||
#include "tc_util.h"
|
||||
|
@ -1,6 +1,6 @@
|
||||
diff -up iproute2-2.6.28/iproute2-2.6.28/Makefile.opt iproute2-2.6.28/iproute2-2.6.28/Makefile
|
||||
--- iproute2-2.6.28/iproute2-2.6.28/Makefile.opt 2008-08-12 14:19:58.000000000 +0200
|
||||
+++ iproute2-2.6.28/iproute2-2.6.28/Makefile 2008-08-12 14:21:42.000000000 +0200
|
||||
diff -up iproute2-2.6.29/iproute2-2.6.29/Makefile.opt iproute2-2.6.29/iproute2-2.6.29/Makefile
|
||||
--- iproute2-2.6.29/iproute2-2.6.29/Makefile.opt 2008-08-12 14:19:58.000000000 +0200
|
||||
+++ iproute2-2.6.29/iproute2-2.6.29/Makefile 2008-08-12 14:21:42.000000000 +0200
|
||||
@@ -22,7 +22,7 @@ ADDLIB+=ipx_ntop.o ipx_pton.o
|
||||
|
||||
CC = gcc
|
||||
|
Loading…
Reference in New Issue
Block a user