Add patch to fix FTBFS # 631415

This commit is contained in:
Peter Robinson 2010-12-26 20:10:25 +00:00
parent cdb158ce7a
commit cc00f3a62f
2 changed files with 42 additions and 19 deletions

27
gupnp-igd-gcc.patch Normal file
View File

@ -0,0 +1,27 @@
From 251a7c4bf1817a98140ab1ca80a0c636945d65bb Mon Sep 17 00:00:00 2001
From: =?utf-8?q?Olivier=20Cr=C3=AAte?= <olivier.crete@collabora.co.uk>
Date: Mon, 20 Dec 2010 16:27:12 +0530
Subject: [PATCH] simpleigdthread: Add typecast to make newer GCC happy
Report by Peter Robinson
http://bugzilla.openedhand.com/show_bug.cgi?id=2209
---
libgupnp-igd/gupnp-simple-igd-thread.c | 2 +-
1 files changed, 1 insertions(+), 1 deletions(-)
diff --git a/libgupnp-igd/gupnp-simple-igd-thread.c b/libgupnp-igd/gupnp-simple-igd-thread.c
index bd4476e..905880d 100644
--- a/libgupnp-igd/gupnp-simple-igd-thread.c
+++ b/libgupnp-igd/gupnp-simple-igd-thread.c
@@ -214,7 +214,7 @@ gupnp_simple_igd_thread_dispose (GObject *object)
{
GSource *src = g_idle_source_new ();
- g_source_set_callback (src, stop_loop, self, NULL);
+ g_source_set_callback (src, (GSourceFunc) stop_loop, self, NULL);
g_source_attach (src, self->priv->context);
g_source_unref (src);
--
1.6.1

View File

@ -1,23 +1,20 @@
%{!?python_sitearch: %global python_sitearch %(%{__python} -c "from distutils.sysconfig import get_python_lib; print get_python_lib(1)")}
%define gupnp_ver 0.13.2
%define glib2_ver 2.16
Name: gupnp-igd
Version: 0.1.7
Release: 3%{?dist}
Summary: Library to handle UPnP IGD port mapping
Release: 4%{?dist}
Summary: Library to handle UPnP IGD port mapping
Group: System Environment/Libraries
License: LGPLv2+
License: LGPLv2+
URL: http://www.gupnp.org/
Source0: http://www.gupnp.org/sources/%{name}/%{name}-%{version}.tar.gz
Patch0: %{name}-0.1.7-make.patch
BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
Patch1: gupnp-igd-gcc.patch
BuildRequires: glib2-devel >= %{glib2_ver}
BuildRequires: gupnp-devel >= %{gupnp_ver}
BuildRequires: pygtk2-devel
BuildRequires: glib2-devel
BuildRequires: gupnp-devel
BuildRequires: pygtk2-devel
%description
@ -25,9 +22,9 @@ BuildRequires: pygtk2-devel
%package python
Summary: Python bindings for %{name}
Summary: Python bindings for %{name}
Group: Development/Libraries
Requires: %{name} = %{version}-%{release}
Requires: %{name} = %{version}-%{release}
%description python
The %{name}-python package contains the Python bindings for
@ -38,8 +35,8 @@ The %{name}-python package contains the Python bindings for
Summary: Development files for %{name}
Group: Development/Libraries
Requires: %{name} = %{version}-%{release}
Requires: %{name}-python = %{version}-%{release}
Requires: pkgconfig
Requires: %{name}-python = %{version}-%{release}
Requires: pkgconfig
%description devel
@ -50,6 +47,7 @@ developing applications that use %{name}.
%prep
%setup -q
%patch0 -p1 -b .make
%patch1 -p1 -b .gcc
%build
@ -60,15 +58,10 @@ make %{?_smp_mflags}
%install
rm -rf $RPM_BUILD_ROOT
make install DESTDIR=$RPM_BUILD_ROOT INSTALL="install -p"
find $RPM_BUILD_ROOT -name '*.la' -exec rm -f {} ';'
%clean
rm -rf $RPM_BUILD_ROOT
%post -p /sbin/ldconfig
@ -97,6 +90,9 @@ rm -rf $RPM_BUILD_ROOT
%changelog
* Sun Dec 26 2010 Peter Robinson <pbrobinson@gmail.com> - 0.1.7-4
- Add patch to fix FTBFS # 631415
* Thu Dec 23 2010 Dan Horák <dan[at]danny.cz> - 0.1.7-3
- workaround make 3.82 issue in python/Makefile