Update to 0.4.0

Resolves: #1991593
This commit is contained in:
Ondrej Holy 2021-08-10 10:28:26 +02:00
parent 20c82a6a47
commit d0d8fbce3b
6 changed files with 208 additions and 11 deletions

1
.gitignore vendored
View File

@ -9,3 +9,4 @@
/gnome-autoar-0.3.1.tar.xz
/gnome-autoar-0.3.2.tar.xz
/gnome-autoar-0.3.3.tar.xz
/gnome-autoar-0.4.0.tar.xz

View File

@ -0,0 +1,90 @@
From ac21bd0c50584a1905a0da65d4bf9a6926ecd483 Mon Sep 17 00:00:00 2001
From: Felipe Borges <felipeborges@gnome.org>
Date: Wed, 11 Aug 2021 14:32:53 +0200
Subject: [PATCH] build: Downgrade meson dependency
Format strings got added in meson 0.58. This allows the meson
dependency to be downgraded to 0.56.
See https://mesonbuild.com/Syntax.html#string-formatting
---
gnome-autoar/meson.build | 12 ++++++------
meson.build | 4 ++--
2 files changed, 8 insertions(+), 8 deletions(-)
diff --git a/gnome-autoar/meson.build b/gnome-autoar/meson.build
index 30533a1..8852da8 100644
--- a/gnome-autoar/meson.build
+++ b/gnome-autoar/meson.build
@@ -3,7 +3,7 @@
src_inc = include_directories('.')
-libname = f'@gnome_autoar_name@-@gnome_autoar_api_version@'
+libname= '@0@-@1@'.format(gnome_autoar_name, gnome_autoar_api_version)
headers = files(
'autoar-compressor.h',
@@ -31,8 +31,8 @@ enum_types = 'autoar-enum-types'
enum_sources = gnome.mkenums(
enum_types,
sources: headers,
- h_template: f'@enum_types@.h.template',
- c_template: f'@enum_types@.c.template',
+ h_template: '@0@.h.template'.format(enum_types),
+ c_template: '@0@.c.template'.format(enum_types),
install_header: true,
install_dir: gnome_autoar_includedir / libname / gnome_autoar_name,
)
@@ -86,7 +86,7 @@ if enable_introspection
namespace: api_ns,
nsversion: gnome_autoar_api_ns_version,
identifier_prefix: gnome_autoar_api_prefix,
- export_packages: f'@api_ns@-@gnome_autoar_api_ns_version@',
+ export_packages: '@0@-@1@'.format(api_ns, gnome_autoar_api_ns_version),
install: true,
)
@@ -104,7 +104,7 @@ if not enable_gtk
subdir_done()
endif
-libname_gtk = f'@gnome_autoar_name@-gtk-@gnome_autoar_api_version@'
+libname_gtk = '@0@-gtk-@1@'.format(gnome_autoar_name, gnome_autoar_api_version)
headers = files(
'autoar-gtk-chooser.h',
@@ -161,7 +161,7 @@ if enable_introspection
namespace: api_ns,
nsversion: gnome_autoar_api_ns_version,
identifier_prefix: 'AutoarGtk',
- export_packages: f'@api_ns@-@gnome_autoar_api_ns_version@',
+ export_packages: '@0@-@1@'.format(api_ns, gnome_autoar_api_ns_version),
install: true,
)
diff --git a/meson.build b/meson.build
index 2c26cde..fe9afd5 100644
--- a/meson.build
+++ b/meson.build
@@ -6,7 +6,7 @@ project(
version: '0.4.0',
license: 'LGPL2.1+',
default_options: 'buildtype=debugoptimized',
- meson_version: '>= 0.58.0',
+ meson_version: '>= 0.56.0',
)
gnome_autoar_name = meson.project_name()
@@ -96,7 +96,7 @@ gtk_dep = dependency(
'gtk+-3.0',
version: gtk_req_version,
required: get_option('gtk'),
- not_found_message: f'GTK+ support requested but gtk+-3.0 @gtk_req_version@ could not be found',
+ not_found_message: 'GTK+ support requested but gtk+-3.0 @0@ could not be found'.format(gtk_req_version),
)
enable_gtk = gtk_dep.found()
--
2.31.1

View File

@ -0,0 +1,63 @@
From aacd9f21cad19be623eec4b2ae64dbd8f6a011cf Mon Sep 17 00:00:00 2001
From: Ondrej Holy <oholy@redhat.com>
Date: Wed, 11 Aug 2021 16:21:49 +0200
Subject: [PATCH] build: Really downgrade meson dependency
This is follow up for commit ac21bd0c50584a1905a0da65d4bf9a6926ecd483
as not all the build.meson files was actually rewritten.
---
docs/reference/meson.build | 4 ++--
docs/reference/xml/meson.build | 4 ++--
tests/meson.build | 2 +-
3 files changed, 5 insertions(+), 5 deletions(-)
diff --git a/docs/reference/meson.build b/docs/reference/meson.build
index 0e9831a..58cb9f5 100644
--- a/docs/reference/meson.build
+++ b/docs/reference/meson.build
@@ -11,11 +11,11 @@ private_headers = [
gnome.gtkdoc(
gnome_autoar_name,
- main_xml: f'@gnome_autoar_name@-docs.xml',
+ main_xml: '@0@-docs.xml'.format(gnome_autoar_name),
src_dir: src_inc,
dependencies: libgnome_autoar_dep,
scan_args: '--rebuild-types',
- gobject_typesfile: f'@gnome_autoar_name@.types',
+ gobject_typesfile: '@0@.types'.format(gnome_autoar_name),
ignore_headers: private_headers,
fixxref_args: '--html-dir=' + (gnome_autoar_prefix / gnome.gtkdoc_html_dir(gnome_autoar_name)),
install: true,
diff --git a/docs/reference/xml/meson.build b/docs/reference/xml/meson.build
index fb9dfce..90ba402 100644
--- a/docs/reference/xml/meson.build
+++ b/docs/reference/xml/meson.build
@@ -3,9 +3,9 @@
ent_conf = {
'PACKAGE': gnome_autoar_name,
- 'PACKAGE_BUGREPORT': f'https://gitlab.gnome.org/GNOME/@gnome_autoar_name@',
+ 'PACKAGE_BUGREPORT': 'https://gitlab.gnome.org/GNOME/@0@'.format(gnome_autoar_name),
'PACKAGE_NAME': gnome_autoar_name,
- 'PACKAGE_STRING': f'@gnome_autoar_name@ @gnome_autoar_version@',
+ 'PACKAGE_STRING': '@0@ @1@'.format(gnome_autoar_name, gnome_autoar_version),
'PACKAGE_TARNAME': gnome_autoar_name,
'PACKAGE_URL': '',
'PACKAGE_VERSION': gnome_autoar_version,
diff --git a/tests/meson.build b/tests/meson.build
index b50f221..8fff91c 100644
--- a/tests/meson.build
+++ b/tests/meson.build
@@ -23,7 +23,7 @@ foreach test_unit: test_units
test(
test_unit[0],
exe,
- env : [f'G_TEST_SRCDIR=@source_root@']
+ env : ['G_TEST_SRCDIR=@0@'.format(source_root)]
)
endif
endforeach
--
2.31.1

View File

@ -0,0 +1,32 @@
From 2d90da6174c03aad546802234a3d77fa0b714e6b Mon Sep 17 00:00:00 2001
From: Felipe Borges <felipeborges@gnome.org>
Date: Wed, 11 Aug 2021 15:35:52 +0200
Subject: [PATCH] build: Remove leftover referencing schema file
In commit bcf17c9fc095fefead731a2883d293b97b2c0dd0 the schema got
removed because it wasn't used. The meson.build file was still
referencing it.
---
meson.build | 6 ------
1 file changed, 6 deletions(-)
diff --git a/meson.build b/meson.build
index 00a92d0..2c26cde 100644
--- a/meson.build
+++ b/meson.build
@@ -105,12 +105,6 @@ enable_introspection = dependency('gobject-introspection-1.0', version: '>= 1.30
enable_vapi = get_option('vapi')
assert(not enable_vapi or enable_introspection, 'GObject introspection support must be enabled to build VALA bindings')
-gio_schemasdir = gio_dep.get_variable(
- 'schemasdir',
- pkgconfig_define: ['datadir', gnome_autoar_datadir],
- default_value: gnome_autoar_datadir / 'glib-2.0/schemas',
-)
-
subdir('gnome-autoar')
enable_tests = get_option('tests')
--
2.31.1

View File

@ -1,14 +1,19 @@
Name: gnome-autoar
Version: 0.3.3
Release: 2%{?dist}
Version: 0.4.0
Release: 1%{?dist}
Summary: Archive library
License: LGPLv2+
URL: https://git.gnome.org/browse/gnome-autoar
Source0: https://download.gnome.org/sources/gnome-autoar/0.3/gnome-autoar-%{version}.tar.xz
Source0: https://download.gnome.org/sources/gnome-autoar/0.4/gnome-autoar-%{version}.tar.xz
Patch0: build-Remove-leftover-referencing-schema-file.patch
Patch1: build-Downgrade-meson-dependency.patch
Patch2: build-Really-downgrade-meson-dependency.patch
BuildRequires: gcc
BuildRequires: make
BuildRequires: meson
BuildRequires: gtk-doc
BuildRequires: pkgconfig(gio-2.0)
BuildRequires: pkgconfig(glib-2.0)
BuildRequires: pkgconfig(gobject-2.0)
@ -31,21 +36,22 @@ developing applications that use %{name}.
%prep
%autosetup
%autosetup -p1
%build
%configure --disable-static
%make_build
%meson -Dvapi=true \
-Dgtk_doc=true \
%{nil}
%meson_build
%install
%make_install
find $RPM_BUILD_ROOT -name '*.la' -delete
%meson_install
%check
make check
%meson_test
%files
@ -69,9 +75,14 @@ make check
%dir %{_datadir}/vala/vapi
%{_datadir}/vala/vapi/gnome-autoar-0.vapi
%{_datadir}/vala/vapi/gnome-autoar-gtk-0.vapi
%{_datadir}/vala/vapi/gnome-autoar-0.deps
%{_datadir}/vala/vapi/gnome-autoar-gtk-0.deps
%changelog
* Tue Aug 10 2021 Ondrej Holy <oholy@redhat.com> - 0.4.0-1
- Update to 0.4.0
* Mon Aug 09 2021 Mohan Boddu <mboddu@redhat.com> - 0.3.3-2
- Rebuilt for IMA sigs, glibc 2.34, aarch64 flags
Related: rhbz#1991688

View File

@ -1 +1 @@
SHA512 (gnome-autoar-0.3.3.tar.xz) = 41cda2670506e9b3f79c4995d2fdfbd5024777d8f8b3f85a2010af4e5f4303743d26ad9cad787c995362f83b65617ed5773d972c8aa2c7bdcd358d873cb86ec4
SHA512 (gnome-autoar-0.4.0.tar.xz) = ab4ef47ef65e4fa0dc652b19a9eb94cc307013e4c7ced6980cedc7ced20fb77d53e1807c20b14a69c1ddc536c4ed0007062481e258d36c07e3be837537916b7f