gnome-autoar/build-Really-downgrade-meson-dependency.patch
Ondrej Holy d0d8fbce3b Update to 0.4.0
Resolves: #1991593
2021-08-11 16:36:52 +02:00

64 lines
2.2 KiB
Diff

From aacd9f21cad19be623eec4b2ae64dbd8f6a011cf Mon Sep 17 00:00:00 2001
From: Ondrej Holy <oholy@redhat.com>
Date: Wed, 11 Aug 2021 16:21:49 +0200
Subject: [PATCH] build: Really downgrade meson dependency
This is follow up for commit ac21bd0c50584a1905a0da65d4bf9a6926ecd483
as not all the build.meson files was actually rewritten.
---
docs/reference/meson.build | 4 ++--
docs/reference/xml/meson.build | 4 ++--
tests/meson.build | 2 +-
3 files changed, 5 insertions(+), 5 deletions(-)
diff --git a/docs/reference/meson.build b/docs/reference/meson.build
index 0e9831a..58cb9f5 100644
--- a/docs/reference/meson.build
+++ b/docs/reference/meson.build
@@ -11,11 +11,11 @@ private_headers = [
gnome.gtkdoc(
gnome_autoar_name,
- main_xml: f'@gnome_autoar_name@-docs.xml',
+ main_xml: '@0@-docs.xml'.format(gnome_autoar_name),
src_dir: src_inc,
dependencies: libgnome_autoar_dep,
scan_args: '--rebuild-types',
- gobject_typesfile: f'@gnome_autoar_name@.types',
+ gobject_typesfile: '@0@.types'.format(gnome_autoar_name),
ignore_headers: private_headers,
fixxref_args: '--html-dir=' + (gnome_autoar_prefix / gnome.gtkdoc_html_dir(gnome_autoar_name)),
install: true,
diff --git a/docs/reference/xml/meson.build b/docs/reference/xml/meson.build
index fb9dfce..90ba402 100644
--- a/docs/reference/xml/meson.build
+++ b/docs/reference/xml/meson.build
@@ -3,9 +3,9 @@
ent_conf = {
'PACKAGE': gnome_autoar_name,
- 'PACKAGE_BUGREPORT': f'https://gitlab.gnome.org/GNOME/@gnome_autoar_name@',
+ 'PACKAGE_BUGREPORT': 'https://gitlab.gnome.org/GNOME/@0@'.format(gnome_autoar_name),
'PACKAGE_NAME': gnome_autoar_name,
- 'PACKAGE_STRING': f'@gnome_autoar_name@ @gnome_autoar_version@',
+ 'PACKAGE_STRING': '@0@ @1@'.format(gnome_autoar_name, gnome_autoar_version),
'PACKAGE_TARNAME': gnome_autoar_name,
'PACKAGE_URL': '',
'PACKAGE_VERSION': gnome_autoar_version,
diff --git a/tests/meson.build b/tests/meson.build
index b50f221..8fff91c 100644
--- a/tests/meson.build
+++ b/tests/meson.build
@@ -23,7 +23,7 @@ foreach test_unit: test_units
test(
test_unit[0],
exe,
- env : [f'G_TEST_SRCDIR=@source_root@']
+ env : ['G_TEST_SRCDIR=@0@'.format(source_root)]
)
endif
endforeach
--
2.31.1